Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
etc-update not found
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 919

PostPosted: Tue Nov 14, 2023 4:07 pm    Post subject: etc-update not found Reply with quote

hi all ...

atfer upgrade portage I tryed to ru a word upgrade , but obtain this:


Code:
Total: 645 packages (541 upgrades, 24 new, 17 in new slots, 63 reinstalls, 1 uninstall), Size of downloads: 5,546,688 KiB
Conflict: 4 blocks (all satisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.38.0-r1:0/5.38::gentoo, ebuild scheduled for merge) USE="gdbm -berkdb -debug -doc -ithreads -minimal -quadmath" ABI_X86="(64)" pulled in by
    =dev-lang/perl-5.38* required by (virtual/perl-Storable-3.320.0:0/0::gentoo, ebuild scheduled for merge) USE="" ABI_X86="(64)"
    ^              ^^^^^                                                                                                                                                                                   
    (and 40 more with the same problem)

  (dev-lang/perl-5.36.1-r3:0/5.36::gentoo, ebuild scheduled for merge) USE="gdbm -berkdb -debug -doc -ithreads -minimal -quadmath" ABI_X86="(64)" pulled in by
    dev-lang/perl:0/5.36= required by (virtual/perl-Exporter-5.770.0-r1:0/0::gentoo, installed) USE="" ABI_X86="(64)"
                 ^^^^^^^^                                                                                                                                                   
    (and 113 more with the same problem)

dev-libs/boost:0

  (dev-libs/boost-1.83.0-r2:0/1.83.0::gentoo, ebuild scheduled for merge) USE="bzip2 context icu nls stacktrace zlib -debug -doc -lzma -mpi -numpy -python -tools -zstd" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python3_10 python3_11 -python3_12" pulled in by
    dev-libs/boost:=[stacktrace(-)] required by (media-gfx/inkscape-1.3:0/0::gentoo, ebuild scheduled for merge) USE="X cdr exif jpeg openmp readline spell -dia -graphicsmagick -imagemagick -inkjar -postscript -sourceview -svg2 -test -visio -wpg" ABI_X86="(64)" PYTHON_SINGLE_TARGET="python3_11 -python3_10"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                               

  (dev-libs/boost-1.82.0-r1:0/1.82.0::gentoo, ebuild scheduled for merge) USE="bzip2 icu nls zlib -context -debug -doc -lzma -mpi -numpy -python -tools -zstd" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python3_10 python3_11" pulled in by
    dev-libs/boost:0/1.82.0=[icu,nls] required by (media-sound/ncmpcpp-0.9.2-r3:0/0::gentoo, installed) USE="userland_GNU -clock -lto -outputs -taglib -visualizer" ABI_X86="(64)"
                  ^^^^^^^^^^                                                                                                                                                                                                                                                                                                                               

dev-lang/ghc:0

  (dev-lang/ghc-9.2.8:0/9.2.8::gentoo, ebuild scheduled for merge) USE="gmp (-big-endian) -binary -doc -elfutils -ghcbootstrap -ghcmakebinary -llvm -numa -profile -test -unregisterised" ABI_X86="(64)" pulled in by
    >=dev-lang/ghc-9.2.4:= required by (dev-haskell/cabal-3.6.3.0:0/3.6.3.0::gentoo, ebuild scheduled for merge) USE="-doc -hscolour -profile" ABI_X86="(64)"
    ^^             ^^^^^                                                                                                                                                                                                                                                                                           

  (dev-lang/ghc-9.0.2-r4:0/9.0.2::gentoo, ebuild scheduled for merge) USE="gmp (-big-endian) -binary -doc -elfutils -ghcbootstrap -ghcmakebinary -llvm -numa -profile -test -unregisterised" ABI_X86="(64)" pulled in by
    >=dev-lang/ghc-7.4.1:0/9.0.2= required by (dev-haskell/extensible-exceptions-0.1.1.4:0/0.1.1.4::gentoo, installed) USE="userland_GNU -doc -hscolour -profile" ABI_X86="(64)"
                        ^^^^^^^^^                                                                                                                                                                                                                                                                                 
    (and 4 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by dev-python/PyQt6-WebEngine-6.6.0::gentoo[widgets]
# required by www-client/qutebrowser-3.0.2::gentoo[qt6,python_single_target_python3_11]
# required by @selected
# required by @world (argument)
>=dev-python/PyQt6-6.6.0 qml webchannel

Would you like to add these changes to your config files? [Yes/No]

Autounmask changes successfully written.

 * IMPORTANT: 2 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
 * sections of the emerge man page to learn how to update config files.

 * In order to avoid wasting time, backtracking has terminated early
 * due to the above autounmask change(s). The --autounmask-backtrack=y
 * option can be used to force further backtracking, but there is no
 * guarantee that it will produce a solution.

Arch7820X / # etc-updates
bash: etc-update: command not found



whyy???
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 21023

PostPosted: Tue Nov 14, 2023 5:35 pm    Post subject: Reply with quote

That looks like you have a transcription error somewhere. Your shown shell command is etc-updates (plural), which never exists; but then your shell error says etc-update (singular), which should exist. Please check that both of those are what was shown, and there were no transcription errors when you posted the text on the forum.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 919

PostPosted: Thu Nov 16, 2023 11:39 am    Post subject: Reply with quote

Arch7820X / # etc-updates
bash: etc-updates: command not found
Arch7820X / # etc-updates
bash: etc-updates: command not found
Arch7820X / # etc-update
bash: etc-update: command not found
Arch7820X / #
Back to top
View user's profile Send private message
freke
l33t
l33t


Joined: 23 Jan 2003
Posts: 890
Location: Somewhere in Denmark

PostPosted: Thu Nov 16, 2023 12:25 pm    Post subject: Reply with quote

Did an emerge of sys-apps/portage fail in some horrible way?
Code:
ns ~ # which etc-update
/usr/sbin/etc-update
ns ~ # equery b /usr/sbin/etc-update
 * Searching for /usr/sbin/etc-update ...
sys-apps/portage-3.0.54-r1 (/usr/sbin/etc-update)

If you don't have /usr/sbin/etc-update - can you try re-emerging sys-apps/portage? ie.
Code:
emerge -va1 sys-apps/portage
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 919

PostPosted: Thu Nov 16, 2023 12:35 pm    Post subject: Reply with quote

Code:
>>> Original instance of package unmerged safely.
>>> sys-apps/portage-3.0.55 merged.

>>> Completed (1 of 1) sys-apps/portage-3.0.55::gentoo

 * GNU info directory index is up-to-date.

 * IMPORTANT: 8 config files in '/etc' need updating.
 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
 * sections of the emerge man page to learn how to update config files.
Arch7820X / # etc-update
bash: etc-update: command not found


8O 8O 8O
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 919

PostPosted: Thu Nov 16, 2023 12:37 pm    Post subject: Reply with quote

Code:
>>> Original instance of package unmerged safely.
>>> sys-apps/portage-3.0.55 merged.

>>> Completed (1 of 1) sys-apps/portage-3.0.55::gentoo

 * GNU info directory index is up-to-date.

 * IMPORTANT: 8 config files in '/etc' need updating.
 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
 * sections of the emerge man page to learn how to update config files.
Arch7820X / #

looks ok
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 919

PostPosted: Thu Nov 16, 2023 12:43 pm    Post subject: Reply with quote

Code:
>>> Original instance of package unmerged safely.
>>> sys-apps/portage-3.0.55 merged.

>>> Completed (1 of 1) sys-apps/portage-3.0.55::gentoo

 * GNU info directory index is up-to-date.

 * IMPORTANT: 8 config files in '/etc' need updating.
 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
 * sections of the emerge man page to learn how to update config files.
Arch7820X / #

looks ok
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 919

PostPosted: Thu Nov 16, 2023 12:48 pm    Post subject: Reply with quote

I think I have something to do with python ....


Code:

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-util/meson:0

  (dev-util/meson-1.2.3:0/0::gentoo, ebuild scheduled for merge) USE="(-test) -verify-sig" ABI_X86="(64)" PYTHON_TARGETS="python3_11 -pypy3 -python3_10 -python3_12" conflicts with
    >=dev-util/meson-0.63.0[python_targets_python3_10(-),python_targets_python3_11(-)] required by (dev-python/meson-python-0.15.0:0/0::gentoo, ebuild scheduled for merge) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python3_10 python3_11 -pypy3 -python3_12"
                                                                                     


The following packages are causing rebuilds:
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 919

PostPosted: Thu Nov 16, 2023 12:53 pm    Post subject: Reply with quote

my
/etc/portage/package.use/python
is

Code:
*/* PYTHON_TARGETS: -* python3_11
*/* PYTHON_SINGLE_TARGET: -* python3_11


but I ve installed py 3.12 as well ...
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 21023

PostPosted: Thu Nov 16, 2023 2:20 pm    Post subject: Reply with quote

What is the output of declare -p PATH ; namei -l /usr/sbin/etc-update ; equery check sys-apps/portage ; cat -n /var/db/pkg/sys-apps/portage-*/CONTENTS?
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 919

PostPosted: Fri Nov 17, 2023 4:15 pm    Post subject: Reply with quote

Code:
 marco@Arch7820X  ~  declare -p PATH ; namei -l /usr/sbin/etc-update ; equery check sys-apps/portage ; cat -n /var/db/pkg/sys-apps/portage-*/CONTENTS
export -T PATH path=( /usr/local/bin /usr/bin /bin /usr/local/sbin /usr/lib/jvm/default/bin /usr/bin/site_perl /usr/bin/vendor_perl /usr/bin/core_perl )
f: /usr/sbin/etc-update
drwxr-xr-x root root /
drwxr-xr-x root root usr
lrwxrwxrwx root root sbin -> bin
drwxr-xr-x root root   bin
                      etc-update - No such file or directory
zsh: command not found: equery
zsh: no matches found: /var/db/pkg/sys-apps/portage-*/CONTENTS
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 21023

PostPosted: Fri Nov 17, 2023 4:54 pm    Post subject: Reply with quote

Are you running this on an otherwise functional Gentoo machine? The absence of equery is unusual, but not strictly impossible. Most people tend to have it installed, because its package contains a number of nice utilities. The absence of a /var/db/pkg entry for Portage is very unusual. What is the output of ls -l /var/db/pkg/?
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 919

PostPosted: Mon Nov 20, 2023 11:39 am    Post subject: Reply with quote

Code:
ls -l /var/db/pkg/
total 384
drwxr-xr-x  37 root root  4096 Nov 16 15:59 acct-group
drwxr-xr-x  18 root root  4096 Nov 16 16:01 acct-user
drwxr-xr-x   3 root root  4096 Jun  6 06:09 app-accessibility
drwxr-xr-x   8 root root  4096 Nov 17 18:32 app-admin
drwxr-xr-x  12 root root  4096 Nov 17 17:38 app-alternatives
drwxr-xr-x  20 root root  4096 Nov 17 17:34 app-arch
drwxr-xr-x   3 root root  4096 Jun  6 04:06 app-backup
drwxr-xr-x   3 root root  4096 Apr  9  2022 app-cdr
drwxr-xr-x   7 root root  4096 Nov 17 17:34 app-containers
drwxr-xr-x  13 root root  4096 Jun 29 12:57 app-crypt
drwxr-xr-x   3 root root  4096 Jun  6 10:17 app-doc
drwxr-xr-x   9 root root  4096 Nov 17 18:02 app-editors
drwxr-xr-x   4 root root  4096 Nov 17 17:35 app-emacs
drwxr-xr-x   6 root root  4096 Nov 17 18:21 app-emulation
drwxr-xr-x  18 root root  4096 Jun 29 07:41 app-eselect
drwxr-xr-x   4 root root  4096 Jul 27  2021 app-i18n
drwxr-xr-x  18 root root  4096 Nov 17 18:11 app-misc
drwxr-xr-x  11 root root  4096 Nov 14 16:49 app-portage
drwxr-xr-x   7 root root  4096 Nov 17 17:36 app-shells
drwxr-xr-x  52 root root  4096 Nov 17 19:13 app-text
drwxr-xr-x   4 root root  4096 Jul 10 20:31 app-vim
drwxr-xr-x  12 root root  4096 Jun 29 06:19 dev-cpp
drwxr-xr-x   4 root root  4096 Nov 17 17:50 dev-db
drwxr-xr-x   3 root root  4096 Apr 15  2023 dev-go
drwxr-xr-x  16 root root  4096 Jun 29 07:29 dev-haskell
drwxr-xr-x   6 root root  4096 Jun 29 17:04 dev-java
drwxr-xr-x  23 root root  4096 Nov 17 19:07 dev-lang
drwxr-xr-x 111 root root  4096 Nov 17 19:12 dev-libs
drwxr-xr-x   5 root root  4096 Nov 17 18:21 dev-lua
drwxr-xr-x 110 root root  4096 Nov 17 19:13 dev-perl
drwxr-xr-x 201 root root 12288 Nov 16 15:48 dev-python
drwxr-xr-x  32 root root  4096 Jul 10 19:19 dev-qt
drwxr-xr-x   5 root root  4096 Jun  6 19:14 dev-tex
drwxr-xr-x  19 root root  4096 Sep 17  2022 dev-texlive
drwxr-xr-x  30 root root  4096 Nov 17 17:38 dev-util
drwxr-xr-x   3 root root  4096 Jun  6 11:00 dev-vcs
drwxr-xr-x   4 root root  4096 May  5  2023 games-misc
drwxr-xr-x  10 root root  4096 Jun 29 07:22 gnome-base
drwxr-xr-x   5 root root  4096 Jul 10 19:55 gnome-extra
drwxr-xr-x   7 root root  4096 Jun 13 17:09 gui-libs
drwxr-xr-x   5 root root  4096 Apr 27  2023 lxde-base
drwxr-xr-x   4 root root  4096 Nov 17 18:32 mail-client
drwxr-xr-x   3 root root  4096 Jun 16  2022 mail-mta
drwxr-xr-x   3 root root  4096 Nov 16 15:54 mate-base
drwxr-xr-x  45 root root  4096 Nov 17 17:59 media-fonts
drwxr-xr-x  19 root root  4096 Jul 10 19:50 media-gfx
drwxr-xr-x  87 root root  4096 Nov 17 18:21 media-libs
drwxr-xr-x  21 root root  4096 Jul 10 20:15 media-plugins
drwxr-xr-x  15 root root  4096 Nov 17 18:14 media-sound
drwxr-xr-x   3 root root  4096 Apr 27  2023 media-tv
drwxr-xr-x  11 root root  4096 Jul 10 20:23 media-video
drwxr-xr-x   3 root root  4096 May  5  2023 net-analyzer
drwxr-xr-x   4 root root  4096 Jun 13 17:57 net-dialup
drwxr-xr-x   5 root root  4096 Nov 16 15:47 net-dns
drwxr-xr-x   3 root root  4096 Nov 17 17:52 net-firewall
drwxr-xr-x   3 root root  4096 Jul 10 19:00 net-im
drwxr-xr-x   3 root root  4096 May  6  2023 net-irc
drwxr-xr-x  26 root root  4096 Nov 17 18:32 net-libs
drwxr-xr-x   3 root root  4096 Jun 16  2022 net-mail
drwxr-xr-x  15 root root  4096 Nov 17 19:10 net-misc
drwxr-xr-x   3 root root  4096 May  7  2023 net-p2p
drwxr-xr-x   4 root root  4096 Jun 29 16:27 net-print
drwxr-xr-x   6 root root  4096 Apr 27  2023 net-vpn
drwxr-xr-x   6 root root  4096 Nov 16 15:57 net-wireless
drwxr-xr-x   5 root root  4096 Nov 17 19:07 perl-core
drwxr-xr-x  17 root root  4096 Nov 17 19:10 sci-libs
drwxr-xr-x   4 root root  4096 Jun  6 10:48 sci-mathematics
drwxr-xr-x   5 root root  4096 Jun 14 21:49 sci-visualization
drwxr-xr-x   3 root root  4096 Apr 15  2023 sec-keys
drwxr-xr-x  51 root root  4096 Nov 17 19:13 sys-apps
drwxr-xr-x   6 root root  4096 Nov 17 18:38 sys-auth
drwxr-xr-x   4 root root  4096 Jun 29 06:20 sys-block
drwxr-xr-x   5 root root  4096 Apr 27  2023 sys-boot
drwxr-xr-x   3 root root  4096 May 17  2023 sys-cluster
drwxr-xr-x  38 root root  4096 Nov 17 17:48 sys-devel
drwxr-xr-x  16 root root  4096 Nov 17 19:11 sys-fs
drwxr-xr-x   9 root root  4096 Nov 17 18:15 sys-kernel
drwxr-xr-x  28 root root  4096 Nov 17 18:21 sys-libs
drwxr-xr-x   4 root root  4096 Jun 29 06:10 sys-power
drwxr-xr-x  11 root root  4096 Nov 17 18:39 sys-process
drwxr-xr-x  89 root root  4096 Nov 17 19:10 virtual
drwxr-xr-x   6 root root  4096 Jul 10 19:52 www-client
drwxr-xr-x   3 root root  4096 Nov 17 17:32 www-plugins
drwxr-xr-x   2 root root  4096 Nov 10  2022 www-servers
drwxr-xr-x  27 root root  4096 Jun 29 06:09 x11-apps
drwxr-xr-x   7 root root  4096 Jun 29 13:45 x11-base
drwxr-xr-x   4 root root  4096 Jul 22 16:07 x11-drivers
drwxr-xr-x  61 root root  4096 Jun 29 13:54 x11-libs
drwxr-xr-x  36 root root  4096 Aug 26 07:33 x11-misc
drwxr-xr-x  11 root root  4096 Nov 17 17:35 x11-terms
drwxr-xr-x  14 root root  4096 Jun  7 07:35 x11-themes
drwxr-xr-x   4 root root  4096 Aug 26 03:48 x11-wm
drwxr-xr-x  19 root root  4096 Jun  6 11:10 xfce-base
drwxr-xr-x   4 root root  4096 Jun 14 00:58 xfce-extra
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 919

PostPosted: Mon Nov 20, 2023 11:50 am    Post subject: Reply with quote

but I was running an emerge world...
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 21023

PostPosted: Mon Nov 20, 2023 4:15 pm    Post subject: Reply with quote

Your vdb seems plausible. Please install app-portage/gentoolkit so that you have equery, then show the output of equery check sys-apps/portage ; equery files sys-apps/portage. Also, show the output of ls -l /var/db/pkg/sys-apps/ /var/db/pkg/sys-apps/portage*/.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 919

PostPosted: Wed Nov 22, 2023 6:24 pm    Post subject: Reply with quote

Code:
equery check sys-apps/portage ;
* Checking sys-apps/portage-3.0.55 ...
   5976 out of 5976 files passed
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 919

PostPosted: Thu Nov 23, 2023 3:54 am    Post subject: Reply with quote

the second one is too big to be pasted using wgetpaste (splitted in 30 files) is too big .. how can i do?
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 919

PostPosted: Thu Nov 23, 2023 6:06 am    Post subject: Reply with quote

Code:
ls -l /var/db/pkg/sys-apps/ /var/db/pkg/sys-apps/portage*/

/var/db/pkg/sys-apps/:
totale 196
drwxr-xr-x 2 root root 4096 27 apr  2023 accountsservice-23.13.9
drwxr-xr-x 2 root root 4096 10 mag  2023 acl-2.3.1-r2
drwxr-xr-x 2 root root 4096 17 set  2022 attr-2.5.1-r2
drwxr-xr-x 2 root root 4096 16 nov 15.45 baselayout-2.14-r1
drwxr-xr-x 2 root root 4096 23 nov 00.05 baselayout-java-0.1.0-r2
drwxr-xr-x 2 root root 4096 27 apr  2023 bubblewrap-0.8.0
drwxr-xr-x 2 root root 4096 17 nov 18.29 coreutils-9.4
drwxr-xr-x 2 root root 4096 13 giu 16.37 dbus-1.15.6
drwxr-xr-x 2 root root 4096 17 nov 17.51 debianutils-5.14
drwxr-xr-x 2 root root 4096  6 giu 01.06 diffutils-3.10
drwxr-xr-x 2 root root 4096 16 nov 15.59 dmidecode-3.5-r3
drwxr-xr-x 2 root root 4096 15 apr  2023 ed-1.19-r1
drwxr-xr-x 2 root root 4096 17 nov 17.51 file-5.45-r3
drwxr-xr-x 2 root root 4096 15 apr  2023 findutils-4.9.0-r2
drwxr-xr-x 2 root root 4096 22 nov 21.50 gawk-5.3.0
drwxr-xr-x 2 root root 4096 15 apr  2023 gentoo-functions-0.19
drwxr-xr-x 2 root root 4096 22 nov 22.34 gptfdisk-1.0.9-r3
drwxr-xr-x 2 root root 4096 15 mag  2023 grep-3.11
drwxr-xr-x 2 root root 4096 23 nov 00.20 groff-1.23.0
drwxr-xr-x 2 root root 4096 15 apr  2023 help2man-1.49.3
drwxr-xr-x 2 root root 4096 16 nov 15.53 hwdata-0.376
drwxr-xr-x 2 root root 4096 17 mag  2023 hwloc-2.9.1
drwxr-xr-x 2 root root 4096 15 apr  2023 install-xattr-0.8-r1
drwxr-xr-x 2 root root 4096 17 nov 18.12 iproute2-6.6.0
drwxr-xr-x 2 root root 4096 17 nov 18.38 kbd-2.6.3-r1
drwxr-xr-x 2 root root 4096 17 nov 17.12 keyutils-1.6.3
drwxr-xr-x 2 root root 4096 17 nov 17.50 kmod-31
drwxr-xr-x 2 root root 4096 17 nov 17.53 less-643
drwxr-xr-x 2 root root 4096 25 mag 05.20 lm-sensors-3.6.0-r1
drwxr-xr-x 2 root root 4096  5 giu 21.18 locale-gen-2.23-r1
drwxr-xr-x 2 root root 4096 17 set  2022 lsb-release-3.2
drwxr-xr-x 2 root root 4096 27 apr  2023 lshw-02.19.2b_p20220831
drwxr-xr-x 2 root root 4096 23 nov 00.24 man-db-2.12.0
drwxr-xr-x 2 root root 4096 23 nov 00.25 man-pages-6.05.01
drwxr-xr-x 2 root root 4096 13 apr  2020 mlocate-0.26-r3
drwxr-xr-x 2 root root 4096  5 feb  2021 net-tools-2.10
drwxr-xr-x 2 root root 4096 23 nov 01.27 openrc-0.51
drwxr-xr-x 2 root root 4096  2 mag  2023 pciutils-3.10.0
drwxr-xr-x 2 root root 4096 16 nov 13.34 portage-3.0.55
drwxr-xr-x 2 root root 4096 16 nov 15.59 pv-1.8.0
drwxr-xr-x 2 root root 4096 17 nov 17.31 sandbox-2.38
drwxr-xr-x 2 root root 4096 15 apr  2023 sed-4.9
drwxr-xr-x 2 root root 4096 23 nov 01.08 shadow-4.14.2
drwxr-xr-x 2 root root 4096 22 nov 22.13 systemd-utils-254.6
drwxr-xr-x 2 root root 4096 23 nov 00.08 sysvinit-3.08
drwxr-xr-x 2 root root 4096 24 apr  2023 tcp-wrappers-7.6.31
drwxr-xr-x 2 root root 4096 20 nov 12.57 texinfo-7.1
drwxr-xr-x 2 root root 4096 17 nov 19.13 util-linux-2.39.2
drwxr-xr-x 2 root root 4096 19 ago  2019 which-2.21

/var/db/pkg/sys-apps/portage-3.0.55/:
totale 944
-rw-r--r-- 1 root root    184 16 nov 13.34 BDEPEND
-rw-r--r-- 1 root root     11 16 nov 13.34 BUILD_TIME
-rw-r--r-- 1 root root      9 16 nov 13.34 CATEGORY
-rw-r--r-- 1 root root     20 16 nov 13.34 CBUILD
-rw-r--r-- 1 root root     24 16 nov 13.34 CFLAGS
-rw-r--r-- 1 root root     20 16 nov 13.34 CHOST
-rw-r--r-- 1 root root 793036 16 nov 13.34 CONTENTS
-rw-r--r-- 1 root root      5 16 nov 13.34 COUNTER
-rw-r--r-- 1 root root     24 16 nov 13.34 CXXFLAGS
-rw-r--r-- 1 root root     70 16 nov 13.34 DEFINED_PHASES
-rw-r--r-- 1 root root    222 16 nov 13.34 DEPEND
-rw-r--r-- 1 root root     58 16 nov 13.34 DESCRIPTION
-rw-r--r-- 1 root root      2 16 nov 13.34 EAPI
-rw-r--r-- 1 root root  28551 16 nov 13.34 environment.bz2
-rw-r--r-- 1 root root    417 16 nov 13.34 FEATURES
-rw-r--r-- 1 root root     45 16 nov 13.34 HOMEPAGE
-rw-r--r-- 1 root root    148 16 nov 13.34 INHERITED
-rw-r--r-- 1 root root    184 16 nov 13.34 IUSE
-rw-r--r-- 1 root root    495 16 nov 13.34 IUSE_EFFECTIVE
-rw-r--r-- 1 root root     94 16 nov 13.34 KEYWORDS
-rw-r--r-- 1 root root     24 16 nov 13.34 LDFLAGS
-rw-r--r-- 1 root root      6 16 nov 13.34 LICENSE
-rw-r--r-- 1 root root    614 16 nov 13.34 NEEDED
-rw-r--r-- 1 root root    956 16 nov 13.34 NEEDED.ELF.2
-rw-r--r-- 1 root root     72 16 nov 13.34 PDEPEND
-rw-r--r-- 1 root root     15 16 nov 13.34 PF
-rw-r--r-- 1 root root     51 16 nov 13.34 PKGUSE
-rw-r--r-- 1 root root   6712 16 nov 13.34 portage-3.0.55.ebuild
-rw-r--r-- 1 root root    260 16 nov 13.34 PROVIDES
-rw-r--r-- 1 root root    682 16 nov 13.34 RDEPEND
-rw-r--r-- 1 root root      7 16 nov 13.34 repository
-rw-r--r-- 1 root root     18 16 nov 13.34 REQUIRES
-rw-r--r-- 1 root root      5 16 nov 13.34 RESTRICT
-rw-r--r-- 1 root root      9 16 nov 13.34 SIZE
-rw-r--r-- 1 root root      2 16 nov 13.34 SLOT
-rw-r--r-- 1 root root    135 16 nov 13.34 USE


tnx for your support
Back to top
View user's profile Send private message
logrusx
l33t
l33t


Joined: 22 Feb 2018
Posts: 989

PostPosted: Thu Nov 23, 2023 8:23 am    Post subject: Reply with quote

drudox wrote:
Code:
equery check sys-apps/portage ;
* Checking sys-apps/portage-3.0.55 ...
   5976 out of 5976 files passed


This is very suspicious. How do you elevate to root? Su or sudo?

Best Regards,
Georgi
Back to top
View user's profile Send private message
Genone
Retired Dev
Retired Dev


Joined: 14 Mar 2003
Posts: 9466
Location: beyond the rim

PostPosted: Thu Nov 23, 2023 9:05 am    Post subject: Reply with quote

Something here doesn't add up: First zsh says that it can't find the vdb package contents for portage, but later it clearly exists according to your ls output. Did you run all these commands in the same environment? What does
Code:
grep etc-update /var/db/pkg/sys-apps/*/CONTENTS
ls -ld /usr/*/etc-update

say? If it fails with a "file not found" error again, can you try running it with bash instead of zsh?
Back to top
View user's profile Send private message
logrusx
l33t
l33t


Joined: 22 Feb 2018
Posts: 989

PostPosted: Thu Nov 23, 2023 11:05 am    Post subject: Reply with quote

Genone wrote:
Something here doesn't add up: First zsh says that it can't find the vdb package contents for portage, but later it clearly exists according to your ls output. Did you run all these commands in the same environment?


It doesn't look like it. If you check the posted output above, it may even be on different hosts.

Best Regards,
Georgi
Back to top
View user's profile Send private message
pingtoo
l33t
l33t


Joined: 10 Sep 2021
Posts: 786
Location: Richmond Hill, Canada

PostPosted: Thu Nov 23, 2023 12:13 pm    Post subject: Reply with quote

Wild guess :D could it be some sort of mix static link binary and dynamic link binary? Those command successful ran because they were able to either find the dynamic libraries or static linked, where as those command not found, could it be because dynamic link library not found (or the interpreter not found, or interpreter dynamic library not found) I seen this error message when I have mess up the root file system with different architecture or different libc.
Back to top
View user's profile Send private message
Genone
Retired Dev
Retired Dev


Joined: 14 Mar 2003
Posts: 9466
Location: beyond the rim

PostPosted: Thu Nov 23, 2023 1:30 pm    Post subject: Reply with quote

pingtoo wrote:
Wild guess :D could it be some sort of mix static link binary and dynamic link binary? Those command successful ran because they were able to either find the dynamic libraries or static linked, where as those command not found, could it be because dynamic link library not found (or the interpreter not found, or interpreter dynamic library not found) I seen this error message when I have mess up the root file system with different architecture or different libc.

Unlikely as etc-update is a script, not a binary. And if the interpreter would be missing or non-functional the error would refer to that, not to etc-update.
But yeah, linker problems can sometimes cause very misleading error messages.
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 919

PostPosted: Tue Nov 28, 2023 1:14 pm    Post subject: Reply with quote

logrusx wrote:
drudox wrote:
Code:
equery check sys-apps/portage ;
* Checking sys-apps/portage-3.0.55 ...
   5976 out of 5976 files passed


This is very suspicious. How do you elevate to root? Su or sudo?

Best Regards,
Georgi


root
Back to top
View user's profile Send private message
drudox
l33t
l33t


Joined: 28 Jan 2016
Posts: 919

PostPosted: Tue Nov 28, 2023 1:19 pm    Post subject: Reply with quote

pingtoo wrote:
Wild guess :D could it be some sort of mix static link binary and dynamic link binary? Those command successful ran because they were able to either find the dynamic libraries or static linked, where as those command not found, could it be because dynamic link library not found (or the interpreter not found, or interpreter dynamic library not found) I seen this error message when I have mess up the root file system with different architecture or different libc.


what do u mean ?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum