Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
installing bobwya's wine-staging
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
ExecutorElassus
Veteran
Veteran


Joined: 11 Mar 2004
Posts: 1361
Location: Berlin, Germany

PostPosted: Fri Nov 04, 2022 9:31 am    Post subject: installing bobwya's wine-staging Reply with quote

the bobwya overlay includes a version of wine-staging with vkd3d support in a USE flag. gentoo's wine-staging does not, so I'm trying to install it. I'm running into this problem:

Code:
# emerge -pv =app-emulation/wine-staging-9999_p1

 * IMPORTANT: config file '/etc/portage/package.use' needs updating.
 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
 * sections of the emerge man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "x11-libs/libva:=[drm,X?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_s390_32(-)?,abi_s390_64(-)?]".
(dependency required by "app-emulation/wine-staging-9999_p1::bobwya" [ebuild])
(dependency required by "=app-emulation/wine-staging-9999_p1" [argument])

but:
Code:
 # emerge -pv libva

 * IMPORTANT: config file '/etc/portage/package.use' needs updating.
 * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS
 * sections of the emerge man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] media-libs/libva-2.16.0:0/2::gentoo  USE="X opengl -wayland" ABI_X86="32 (64) (-x32)" 0 KiB


What does this error mean?

And how do you get vkd3d (ie, DX12) support enabled on wine? I'm trying to enable it on EVE Online.

Relatedly, EVE now enables Resource Cache by default, which causes significant memory leakage. Is there a way to disable this in the wine emulator?

Cheers,

EE
Back to top
View user's profile Send private message
fedeliallalinea
Administrator
Administrator


Joined: 08 Mar 2003
Posts: 29090
Location: here

PostPosted: Fri Nov 04, 2022 9:41 am    Post subject: Reply with quote

The problem is that media-libs/libva has dropped drm use flag but app-emulation/wine-staging "needs" this use flag if you enable vaapi use flag.
You can try to change the app-emulation/wine-staging ebuild or downgrade libva to 2.15.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ExecutorElassus
Veteran
Veteran


Joined: 11 Mar 2004
Posts: 1361
Location: Berlin, Germany

PostPosted: Fri Nov 04, 2022 9:56 am    Post subject: Reply with quote

I downgraded to libva-2.15.0, with drm enabled. Same error.

Cheers,

EE
Back to top
View user's profile Send private message
fedeliallalinea
Administrator
Administrator


Joined: 08 Mar 2003
Posts: 29090
Location: here

PostPosted: Fri Nov 04, 2022 9:57 am    Post subject: Reply with quote

ExecutorElassus wrote:
I downgraded to libva-2.15.0, with drm enabled. Same error.

And abi_x86_32 is enable for this version of package?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ExecutorElassus
Veteran
Veteran


Joined: 11 Mar 2004
Posts: 1361
Location: Berlin, Germany

PostPosted: Fri Nov 04, 2022 9:59 am    Post subject: Reply with quote

Code:
 # USE="drm" emerge -pv =media-libs/libva-2.15.0

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] media-libs/libva-2.15.0:0/2::gentoo  USE="X drm opengl -wayland" ABI_X86="32 (64) (-x32)" 0 KiB


Seems so?
Back to top
View user's profile Send private message
fedeliallalinea
Administrator
Administrator


Joined: 08 Mar 2003
Posts: 29090
Location: here

PostPosted: Fri Nov 04, 2022 10:07 am    Post subject: Reply with quote

If the error is exactly the same probably you should mask libva-2.16 version.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ExecutorElassus
Veteran
Veteran


Joined: 11 Mar 2004
Posts: 1361
Location: Berlin, Germany

PostPosted: Fri Nov 04, 2022 10:11 am    Post subject: Reply with quote

masked it. Same error :(
Back to top
View user's profile Send private message
fedeliallalinea
Administrator
Administrator


Joined: 08 Mar 2003
Posts: 29090
Location: here

PostPosted: Fri Nov 04, 2022 12:06 pm    Post subject: Reply with quote

ExecutorElassus wrote:
masked it. Same error :(

Can you post the emerge error?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ExecutorElassus
Veteran
Veteran


Joined: 11 Mar 2004
Posts: 1361
Location: Berlin, Germany

PostPosted: Sun Nov 20, 2022 4:00 pm    Post subject: Reply with quote

With libva-2.16 masked, and libva-2.15 emerged with drm enabled, this is the error I get when I try to emerge wine-staging::bobwya:

Code:
# emerge wine-staging::bobwya

 * IMPORTANT: 26 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "x11-libs/libva:=[drm,X?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_s390_32(-)?,abi_s390_64(-)?]".
(dependency required by "app-emulation/wine-staging-9999_p1::bobwya" [ebuild])
(dependency required by "wine-staging::bobwya" [argument])


Notably, eselect-wine is also badly out of date, so I have eselect-wine::bobwya installed, which is not compatible with the ::gentoo versions of wine. So how do I fix this?

EE
Back to top
View user's profile Send private message
Ionen
Developer
Developer


Joined: 06 Dec 2018
Posts: 2407

PostPosted: Sun Nov 20, 2022 4:49 pm    Post subject: Reply with quote

vkd3d USE is useless by the way, wine bundles vkd3d since wine-7.1x or around there and it's always enabled assuming you got USE=vulkan support, it's built with mingw if possible (PE files) and so the system's ELF libraries can't be used anymore.

The same happened with e.g. faudio, and recently removed USE=ldap along with openldap dep in -9999 ebuild for the same reason, but faudio/ldap support is /not/ gone.

Haven't looked at it, but still having these likely just means this overlay ebuild is poorly maintained.

Edit: on a side-note, optionally ::gentoo also has app-emulation/vkd3d-proton which you can use instead of wine's default vkd3d, may or may not work better for some games and typically is better for performance (works like dxvk with a setup script that symlink/copy the .dll to wanted wine prefixes, vkd3d-proton-2.7 does need bit more modern vulkan support like dxvk-2.0 though).


Last edited by Ionen on Sun Nov 20, 2022 10:01 pm; edited 2 times in total
Back to top
View user's profile Send private message
Ionen
Developer
Developer


Joined: 06 Dec 2018
Posts: 2407

PostPosted: Sun Nov 20, 2022 5:04 pm    Post subject: Reply with quote

...and about eselect-wine, we're about to roll out eselect-wine-2 which is completely different (rewritten from scratch and hosted by gentoo.org now), using some overlay's eselect-wine when it gets keyworded could have all sort of unexpected consequence
Back to top
View user's profile Send private message
ExecutorElassus
Veteran
Veteran


Joined: 11 Mar 2004
Posts: 1361
Location: Berlin, Germany

PostPosted: Tue Nov 22, 2022 7:24 pm    Post subject: Reply with quote

OK, I've removed the bobwya overlay, and am now installing the latest ::gentoo version of wine-staging, after that wine-proton. I'll see if that does any better.

My biggest problem right now is that EVE Online made Resource Cache enabled, which causes significant memory leaks over time. I'm going to try wine-proton and see if that helps.

I'll report back in a bit.

EE
Back to top
View user's profile Send private message
ExecutorElassus
Veteran
Veteran


Joined: 11 Mar 2004
Posts: 1361
Location: Berlin, Germany

PostPosted: Wed Nov 23, 2022 9:39 am    Post subject: Reply with quote

UPDATE: So, it turns out that switching to wine-proton has solved all my problems. No more lag, dropping framerates, memory leaks, etc.

I look forward to eselect-wine-2, but I guess I won't need to be doing anything fancy with wine so long as wine-proton holds up. Wine-staging, for reasons I don't understand, won't run EVE on any version I've tried since wine-staging-7.17. I guess I'll be sticking with proton.

Cheers,

EE
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum