Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Cannot update -- python related?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
mgnut57
Apprentice
Apprentice


Joined: 12 Jan 2008
Posts: 268

PostPosted: Sat Aug 06, 2022 12:41 am    Post subject: Cannot update -- python related? Reply with quote

emerge is complaining and I don't know how to fix it.

Note that I don't have PYTHON_TARGETS or PYTHON_SINGLE TARGET set anywhere:
Code:

# emerge -uD --ask @world

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-python/zipp:0

  (dev-python/zipp-3.8.0:0/0::gentoo, installed) USE="-doc -test" ABI_X86="(64)" PYTHON_TARGETS="python3_8 python3_9 (-pypy3) -python3_10 (-python3_11)" pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-python/zipp-3.8.0:0/0::gentoo, ebuild scheduled for merge) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python3_10 python3_8 python3_9 (-pypy3) (-python3_11)" pulled in by
    dev-python/zipp[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?,python_targets_python3_11(-)?] required by (dev-python/importlib_metadata-4.12.0:0/0::gentoo, ebuild scheduled for merge) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python3_10 python3_8 python3_9 (-pypy3) (-python3_11)"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                     

x11-base/xorg-server:0

  (x11-base/xorg-server-21.1.4:0/21.1.4::gentoo, ebuild scheduled for merge) USE="elogind udev xorg -debug -minimal (-selinux) -suid -systemd -test -unwind -xcsecurity -xephyr -xnest -xvfb" ABI_X86="(64)" pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-base/xorg-server-21.1.3-r3:0/21.1.3::gentoo, ebuild scheduled for merge) USE="elogind udev xorg -debug -minimal (-selinux) -suid -systemd -test -unwind -xcsecurity -xephyr -xnest -xvfb" ABI_X86="(64)" pulled in by
    x11-base/xorg-server:0/21.1.3= required by (x11-drivers/xf86-input-evdev-2.10.6:0/0::gentoo, installed) USE="" ABI_X86="(64)"
                        ^^^^^^^^^^                                                                                                                                                     
    (and 3 more with the same problem)

net-libs/gnutls:0

  (net-libs/gnutls-3.7.6:0/30.30::gentoo, ebuild scheduled for merge) USE="cxx idn nls openssl seccomp tls-heartbeat zlib -brotli -dane -doc -examples -guile -pkcs11 -sslv2 -sslv3 -static-libs -test (-test-full) -tools -valgrind -verify-sig -zstd" ABI_X86="32 (64) (-x32)" pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (net-libs/gnutls-3.7.3-r1:0/30::gentoo, installed) USE="cxx idn nls openssl seccomp tls-heartbeat -dane -doc -examples -guile -pkcs11 -sslv2 -sslv3 -static-libs -test (-test-full) -tools -valgrind" ABI_X86="32 (64) (-x32)" pulled in by
    >=net-libs/gnutls-3.2.0:0/30= required by (net-misc/rdesktop-1.9.0:0/0::gentoo, installed) USE="alsa ipv6 pulseaudio -ao -kerberos -oss -pcsc-lite -xrandr" ABI_X86="(64)"
                           ^^^^^^                                                                                                                                                                                                                                                                                                                                                           

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! The ebuild selected to satisfy ">=dev-libs/libpeas-1.14.1:=" has unmet requirements.
- dev-libs/libpeas-1.32.0::gentoo USE="gtk python -glade -gtk-doc -lua -test -vala" ABI_X86="(64)" LUA_SINGLE_TARGET="lua5-1 -luajit" PYTHON_SINGLE_TARGET="python3_10 python3_9 (-python3_11) -python3_8"

  The following REQUIRED_USE flag constraints are unsatisfied:
    python? ( exactly-one-of ( python_single_target_python3_8 python_single_target_python3_9 python_single_target_python3_10 python_single_target_python3_11 ) )

  The above constraints are a subset of the following complete expression:
    lua? ( exactly-one-of ( lua_single_target_luajit lua_single_target_lua5-1 ) ) python? ( exactly-one-of ( python_single_target_python3_8 python_single_target_python3_9 python_single_target_python3_10 python_single_target_python3_11 ) )

(dependency required by "media-gfx/eog-plugins-42.1::gentoo" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


Last edited by mgnut57 on Sat Aug 06, 2022 2:26 am; edited 1 time in total
Back to top
View user's profile Send private message
Ionen
Developer
Developer


Joined: 06 Dec 2018
Posts: 2310

PostPosted: Sat Aug 06, 2022 1:04 am    Post subject: Reply with quote

If really no PYTHON_SINGLE_TARGET, you could potentially have the the expanded form (e.g. python_single_target_python3_9), may want to grep in case:

grep -rsin python_single_target /etc/portage
Back to top
View user's profile Send private message
mgnut57
Apprentice
Apprentice


Joined: 12 Jan 2008
Posts: 268

PostPosted: Sat Aug 06, 2022 1:10 am    Post subject: Reply with quote

Ionen wrote:
If really no PYTHON_SINGLE_TARGET, you could potentially have the the expanded form (e.g. python_single_target_python3_9), may want to grep in case:

grep -rsin python_single_target /etc/portage


I did find some examples of this:
Code:
grep -rsin python_single_target /etc/portage | grep -v :#
/etc/portage/package.use:462:media-video/openshot python_single_target_python3_6
/etc/portage/package.use:537:>=media-libs/libopenshot-0.1.1 python_single_target_python3_6
/etc/portage/package.use:1547:>=dev-libs/libpeas-1.32.0 python_single_target_python3_9


Also, if I search for "python_target", I get a lot of lines that match:
Code:

grep -rsin python_target /etc/portage | grep -v :#
/etc/portage/package.use:956:>=dev-libs/libxml2-2.9.10-r4 python_targets_python3_7
/etc/portage/package.use:963:>=dev-python/pycairo-1.20.0 python_targets_python3_7
/etc/portage/package.use:972:>=dev-python/setuptools-50.3.0 python_targets_python3_7
/etc/portage/package.use:978:>=dev-python/certifi-10001-r1 python_targets_python3_7
/etc/portage/package.use:984:>=dev-python/setuptools_scm-4.1.2-r1 python_targets_python3_7
/etc/portage/package.use:991:>=dev-python/pbr-5.5.1 python_targets_python3_7
/etc/portage/package.use:997:>=dev-python/pygments-2.7.2 python_targets_python3_7
/etc/portage/package.use:1004:>=dev-python/numpy-1.19.4 python_targets_python3_7
/etc/portage/package.use:1012:>=dev-python/cython-0.29.21-r1 python_targets_python3_7
/etc/portage/package.use:1016:>=sys-apps/portage-3.0.9 python_targets_python3_7
/etc/portage/package.use:1022:>=dev-python/urllib3-1.25.11 python_targets_python3_7
/etc/portage/package.use:1028:>=dev-python/cryptography-3.2.1 python_targets_python3_7
/etc/portage/package.use:1033:>=app-portage/gemato-16.2 python_targets_python3_7
/etc/portage/package.use:1038:>=dev-python/requests-2.24.0-r1 python_targets_python3_7
/etc/portage/package.use:1043:>=dev-python/chardet-3.0.4-r1 python_targets_python3_7
/etc/portage/package.use:1048:>=dev-python/idna-2.10-r1 python_targets_python3_7
/etc/portage/package.use:1055:>=dev-python/six-1.15.0-r1 python_targets_python3_7
/etc/portage/package.use:1062:>=dev-python/cffi-1.14.0-r3 python_targets_python3_7
/etc/portage/package.use:1070:>=dev-python/pycparser-2.20-r1 python_targets_python3_7
/etc/portage/package.use:1074:>=dev-python/ply-3.11-r1 python_targets_python3_7
/etc/portage/package.use:1080:>=dev-python/PySocks-1.7.1-r1 python_targets_python3_7
/etc/portage/package.use:1086:>=dev-python/pyopenssl-19.1.0-r1 python_targets_python3_7
/etc/portage/package.use:1091:>=dev-python/pygobject-3.36.1-r1 python_targets_python3_7
/etc/portage/package.use:1098:>=dev-python/pycairo-1.20.0 python_targets_python3_6
/etc/portage/package.use:1104:>=dev-python/setuptools-50.3.0 python_targets_python3_6
/etc/portage/package.use:1110:>=dev-python/certifi-10001-r1 python_targets_python3_6
/etc/portage/package.use:1116:>=dev-python/setuptools_scm-4.1.2-r1 python_targets_python3_6
/etc/portage/package.use:1127:>=dev-python/toml-0.10.2 python_targets_python3_7
/etc/portage/package.use:1134:>=dev-libs/libxml2-2.9.12-r3 python_targets_python3_8
/etc/portage/package.use:1142:>=dev-python/pygments-2.9.0 python_targets_python3_8
/etc/portage/package.use:1150:>=dev-python/lxml-4.6.3-r1 python_targets_python3_8
/etc/portage/package.use:1158:>=dev-python/cython-0.29.23 python_targets_python3_8
/etc/portage/package.use:1165:>=dev-python/setuptools-56.0.0 python_targets_python3_8
/etc/portage/package.use:1169:>=sys-apps/portage-3.0.20-r6 python_targets_python3_8
/etc/portage/package.use:1173:>=dev-python/argcomplete-1.12.3 python_targets_python3_8
/etc/portage/package.use:1177:>=dev-python/libvirt-python-7.3.0 python_targets_python3_8
/etc/portage/package.use:1185:>=dev-python/jinja-3.0.1 python_targets_python3_8
/etc/portage/package.use:1194:>=dev-python/six-1.16.0 python_targets_python3_8
/etc/portage/package.use:1201:>=dev-python/markupsafe-2.0.1 python_targets_python3_8
/etc/portage/package.use:1205:>=app-portage/gemato-16.2 python_targets_python3_8
/etc/portage/package.use:1211:>=dev-python/certifi-10001-r1 python_targets_python3_8
/etc/portage/package.use:1220:>=dev-python/setuptools_scm-6.0.1-r1 python_targets_python3_8
/etc/portage/package.use:1230:>=dev-python/toml-0.10.2 python_targets_python3_8
/etc/portage/package.use:1238:>=dev-python/requests-2.25.1-r2 python_targets_python3_8
/etc/portage/package.use:1244:>=dev-python/chardet-4.0.0 python_targets_python3_8
/etc/portage/package.use:1250:>=dev-python/idna-3.1 python_targets_python3_8
/etc/portage/package.use:1256:>=dev-python/urllib3-1.26.4 python_targets_python3_8
/etc/portage/package.use:1263:>=dev-python/PySocks-1.7.1-r1 python_targets_python3_8
/etc/portage/package.use:1267:>=dev-python/pygobject-3.40.1 python_targets_python3_8
/etc/portage/package.use:1272:>=dev-python/pycairo-1.20.0 python_targets_python3_8
/etc/portage/package.use:1279:>=dev-python/numpy-1.20.3-r1 python_targets_python3_8
/etc/portage/package.use:1292:>=dev-python/packaging-21.0 python_targets_python3_8
/etc/portage/package.use:1300:>=dev-python/tomli-1.2.1 python_targets_python3_8
/etc/portage/package.use:1306:>=dev-python/pyparsing-2.4.7-r1 python_targets_python3_8
/etc/portage/package.use:1312:>=dev-python/charset_normalizer-2.0.6 python_targets_python3_8
/etc/portage/package.use:1328:>=dev-python/appdirs-1.4.4-r2 python_targets_python3_8
/etc/portage/package.use:1334:>=dev-python/jaraco-text-3.7.0-r2 python_targets_python3_8
/etc/portage/package.use:1340:>=dev-python/more-itertools-8.12.0-r1 python_targets_python3_8
/etc/portage/package.use:1346:>=dev-python/ordered-set-4.1.0 python_targets_python3_8
/etc/portage/package.use:1352:>=dev-python/importlib_metadata-4.11.2 python_targets_python3_8
/etc/portage/package.use:1358:>=dev-python/importlib_resources-5.4.0-r3 python_targets_python3_8
/etc/portage/package.use:1364:>=dev-python/wheel-0.37.1-r1 python_targets_python3_8
/etc/portage/package.use:1371:>=dev-python/installer-0.5.0 python_targets_python3_8
/etc/portage/package.use:1379:>=dev-python/flit_core-3.7.1 python_targets_python3_8
/etc/portage/package.use:1387:>=dev-python/zipp-3.7.0-r1 python_targets_python3_8
/etc/portage/package.use:1394:>=dev-python/jaraco-context-4.1.1-r2 python_targets_python3_8
/etc/portage/package.use:1401:>=dev-python/jaraco-functools-3.5.0-r2 python_targets_python3_8
/etc/portage/package.use:1407:>=dev-python/nspektr-0.3.0 python_targets_python3_8
/etc/portage/package.use:1414:>=dev-python/gpep517-3 python_targets_python3_8
/etc/portage/package.use:1420:=dev-python/certifi-3021.3.16-r2 python_targets_python3_8 python_targets_python3_9
/etc/portage/package.use:1428:>=dev-python/typing-extensions-4.3.0 python_targets_python3_8
/etc/portage/package.use:1439:>=dev-python/tomli-2.0.1-r1 python_targets_python3_9
/etc/portage/package.use:1443:>=dev-python/pexpect-4.8.0-r3 python_targets_python3_9
/etc/portage/package.use:1447:>=dev-python/pygobject-3.42.1 python_targets_python3_9
/etc/portage/package.use:1451:>=dev-python/pyxdg-0.28 python_targets_python3_9
/etc/portage/package.use:1459:>=dev-python/gpep517-8 python_targets_python3_9
/etc/portage/package.use:1466:>=dev-python/setuptools-62.6.0 python_targets_python3_9
/etc/portage/package.use:1474:>=dev-python/wheel-0.37.1-r1 python_targets_python3_9
/etc/portage/package.use:1480:>=dev-python/pycairo-1.21.0 python_targets_python3_9
/etc/portage/package.use:1485:>=dev-python/ptyprocess-0.7.0-r1 python_targets_python3_9
/etc/portage/package.use:1491:>=dev-python/flit_core-3.7.1 python_targets_python3_9
/etc/portage/package.use:1497:>=dev-python/pygments-2.12.0-r1 python_targets_python3_9
/etc/portage/package.use:1504:>=dev-libs/libxml2-2.9.14-r1 python_targets_python3_9
/etc/portage/package.use:1509:>=dev-python/requests-2.28.1 python_targets_python3_9
/etc/portage/package.use:1515:>=dev-python/charset_normalizer-2.1.0 python_targets_python3_9
/etc/portage/package.use:1521:>=dev-python/idna-3.3-r1 python_targets_python3_9
/etc/portage/package.use:1527:>=dev-python/urllib3-1.26.10 python_targets_python3_9
/etc/portage/package.use:1534:>=dev-python/PySocks-1.7.1-r2 python_targets_python3_9
/etc/portage/package.use:1541:>=dev-python/six-1.16.0-r1 python_targets_python3_9
/etc/portage/package.use:1545:>=dev-python/pycryptodome-3.15.0 python_targets_python3_9
/etc/portage/package.use:1554:>=dev-python/packaging-21.3-r2 python_targets_python3_9
/etc/portage/package.use:1561:>=dev-python/pyparsing-3.0.9 python_targets_python3_9
/etc/portage/package.use:1568:>=dev-python/appdirs-1.4.4-r2 python_targets_python3_9
/etc/portage/package.use:1575:>=dev-python/jaraco-text-3.8.0 python_targets_python3_9
/etc/portage/package.use:1583:>=dev-python/more-itertools-8.13.0 python_targets_python3_9
/etc/portage/package.use:1590:>=dev-python/nspektr-0.4.0 python_targets_python3_9
/etc/portage/package.use:1597:>=dev-python/ordered-set-4.1.0 python_targets_python3_9
/etc/portage/package.use:1605:>=dev-python/importlib_metadata-4.12.0 python_targets_python3_9
/etc/portage/package.use:1612:>=dev-python/setuptools_scm-7.0.5 python_targets_python3_9
/etc/portage/package.use:1620:>=dev-python/typing-extensions-4.3.0 python_targets_python3_9
/etc/portage/package.use:1629:>=dev-python/zipp-3.8.0 python_targets_python3_9
/etc/portage/package.use:1637:>=dev-python/jaraco-context-4.1.1-r2 python_targets_python3_9
/etc/portage/package.use:1645:>=dev-python/jaraco-functools-3.5.0-r2 python_targets_python3_9
/etc/portage/package.use:1652:>=dev-python/installer-0.5.1-r1 python_targets_python3_9
Back to top
View user's profile Send private message
Ionen
Developer
Developer


Joined: 06 Dec 2018
Posts: 2310

PostPosted: Sat Aug 06, 2022 1:16 am    Post subject: Reply with quote

The 3_9 libpeas one is what is causing this particular issue, but I suggest removing all of these.

Can address any issues after that if still anything.
Back to top
View user's profile Send private message
Ionen
Developer
Developer


Joined: 06 Dec 2018
Posts: 2310

PostPosted: Sat Aug 06, 2022 1:17 am    Post subject: Reply with quote

Oh, also, use emerge -uUD rather than -uD (aka --changed-use).
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 19147

PostPosted: Sat Aug 06, 2022 2:15 am    Post subject: Reply with quote

Also, per Guidelines (READ BEFORE POSTING) item #5, please choose a better thread title. As is, readers must open the thread to determine whether they may be able to help you.
Back to top
View user's profile Send private message
mgnut57
Apprentice
Apprentice


Joined: 12 Jan 2008
Posts: 268

PostPosted: Sat Aug 06, 2022 2:32 am    Post subject: Reply with quote

Ionen wrote:
Oh, also, use emerge -uUD rather than -uD (aka --changed-use).


Didn't help.

Commenting out the python_single_target for libpeas, along with the other command has got emerge running.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum