Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
PulseAudio with HSP supported headset not working
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Dragonlord
Guru
Guru


Joined: 22 Aug 2004
Posts: 433
Location: Switzerland

PostPosted: Fri May 13, 2022 9:31 am    Post subject: PulseAudio with HSP supported headset not working Reply with quote

I'm trying to get a Sony WH-CH700N (supports HSP and HSF) working on a Cambridge Silicon Radio, Ltd Bluetooth Dongle (CSR8510 A10). In the office I have the same dongle but a different head-set (and it's Ubuntu). There HSP is working (microphone works). On GenToo it is not working.

I've build pulseaudio with the native-headset use flag.
Code:
media-sound/pulseaudio-15.0-r2::gentoo  USE="X alsa alsa-plugin asyncns bluetooth (daemon) dbus elogind gdbm glib gtk ipv6 jack native-headset orc sox ssl udev webrtc-aec -doc -equalizer -gstreamer -lirc -ofono-headset (-oss) (-selinux) (-system-wide) -systemd -tcpd -test -zeroconf" ABI_X86="32 (64) (-x32)"


Code:
pactl list
...
Card #5
        Name: bluez_card.38_18_4C_AD_8D_3B
        Driver: module-bluez5-device.c
        Owner Module: 34
        Properties:
                device.description = "WH-CH700N"
                device.string = "38:18:4C:AD:8D:3B"
                device.api = "bluez"
                device.class = "sound"
                device.bus = "bluetooth"
                device.form_factor = "headset"
                bluez.path = "/org/bluez/hci0/dev_38_18_4C_AD_8D_3B"
                bluez.class = "0x240404"
                bluez.alias = "WH-CH700N"
                device.icon_name = "audio-headset-bluetooth"
                device.intended_roles = "phone"
                bluetooth.codec = "sbc"
        Profiles:
                headset_head_unit: Headset Head Unit (HSP) (sinks: 1, sources: 1, priority: 30, available: no)
                a2dp_sink: High Fidelity Playback (A2DP Sink) (sinks: 1, sources: 0, priority: 40, available: yes)
                handsfree_head_unit: Handsfree Head Unit (HFP) (sinks: 1, sources: 1, priority: 30, available: no)
                off: Off (sinks: 0, sources: 0, priority: 0, available: yes)
        Active Profile: a2dp_sink
        Ports:
                headset-output: Headset (type: Headset, priority: 0, latency offset: 0 usec, availability unknown)
                        Part of profile(s): headset_head_unit, a2dp_sink, handsfree_head_unit
                headset-input: Headset (type: Headset, priority: 0, latency offset: 0 usec, not available)
                        Part of profile(s): headset_head_unit, handsfree_head_unit


As you can see headset_head_unit has available: no which is wrong. I've tried anything I could find on the internet but it is not working. Is this a GenToo bug since on the other computer (Ubuntu) pulseaudio works (version 13.99.1).
_________________
DragonDreams: Leader and Head Programmer
Back to top
View user's profile Send private message
garrison
Apprentice
Apprentice


Joined: 18 Mar 2003
Posts: 151

PostPosted: Sat May 14, 2022 6:56 am    Post subject: Reply with quote

Double-check you have RFCOMM listed in grep RFCOMM /proc/net/protocols

If RFCOMM is there, make sure you are not using any other bluetooth audio implementation (e.g. bluealsa or ofono) and show your 'pa-info' also check bluetoothd log for any reported issues.
Back to top
View user's profile Send private message
garrison
Apprentice
Apprentice


Joined: 18 Mar 2003
Posts: 151

PostPosted: Sat May 14, 2022 7:17 am    Post subject: Reply with quote

Looks like this is reported to pulseaudio tracker https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/issues/1359

My understanding is this could be a problem with timidity running it's own pulseaudio daemon which takes over some bluetooth connections; suggestion is to run timidity as user daemon instead.
Back to top
View user's profile Send private message
Dragonlord
Guru
Guru


Joined: 22 Aug 2004
Posts: 433
Location: Switzerland

PostPosted: Sat May 14, 2022 7:51 pm    Post subject: Reply with quote

garrison wrote:
Double-check you have RFCOMM listed in grep RFCOMM /proc/net/protocols

If RFCOMM is there, make sure you are not using any other bluetooth audio implementation (e.g. bluealsa or ofono) and show your 'pa-info' also check bluetoothd log for any reported issues.

RFCOMM is not listed in the proc file but I'm sure it is compiled into the kernel since CONFIG_BT_RFCOMM is enabled.
_________________
DragonDreams: Leader and Head Programmer
Back to top
View user's profile Send private message
Dragonlord
Guru
Guru


Joined: 22 Aug 2004
Posts: 433
Location: Switzerland

PostPosted: Sat May 14, 2022 7:56 pm    Post subject: Reply with quote

garrison wrote:
Looks like this is reported to pulseaudio tracker https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/issues/1359

My understanding is this could be a problem with timidity running it's own pulseaudio daemon which takes over some bluetooth connections; suggestion is to run timidity as user daemon instead.

I stopped and disabled timidity (I don't use it actively only for some testing). The result is the same.
_________________
DragonDreams: Leader and Head Programmer
Back to top
View user's profile Send private message
garrison
Apprentice
Apprentice


Joined: 18 Mar 2003
Posts: 151

PostPosted: Sat May 14, 2022 7:57 pm    Post subject: Reply with quote

Dragonlord wrote:
garrison wrote:
Double-check you have RFCOMM listed in grep RFCOMM /proc/net/protocols

If RFCOMM is there, make sure you are not using any other bluetooth audio implementation (e.g. bluealsa or ofono) and show your 'pa-info' also check bluetoothd log for any reported issues.

RFCOMM is not listed in the proc file but I'm sure it is compiled into the kernel since CONFIG_BT_RFCOMM is enabled.

RFCOMM is absolutely required to handle HFP/HSP profiles, if you have it as a module try modprobe rfcomm though it is usually loaded automatically.
Back to top
View user's profile Send private message
Dragonlord
Guru
Guru


Joined: 22 Aug 2004
Posts: 433
Location: Switzerland

PostPosted: Sat May 14, 2022 7:59 pm    Post subject: Reply with quote

garrison wrote:
Dragonlord wrote:
garrison wrote:
Double-check you have RFCOMM listed in grep RFCOMM /proc/net/protocols

If RFCOMM is there, make sure you are not using any other bluetooth audio implementation (e.g. bluealsa or ofono) and show your 'pa-info' also check bluetoothd log for any reported issues.

RFCOMM is not listed in the proc file but I'm sure it is compiled into the kernel since CONFIG_BT_RFCOMM is enabled.

RFCOMM is absolutely required to handle HFP/HSP profiles, if you have it as a module try modprobe rfcomm though it is usually loaded automatically.

I have CONFIG_BT_RFCOMM compiled into the kernel. Does it work only as module?
_________________
DragonDreams: Leader and Head Programmer
Back to top
View user's profile Send private message
garrison
Apprentice
Apprentice


Joined: 18 Mar 2003
Posts: 151

PostPosted: Sat May 14, 2022 8:28 pm    Post subject: Reply with quote

Dragonlord wrote:
I have CONFIG_BT_RFCOMM compiled into the kernel. Does it work only as module?

Well it should work as built-in, though https://wiki.gentoo.org/wiki/Bluetooth#Kernel has a warning so probably try as a module instead.
Back to top
View user's profile Send private message
Dragonlord
Guru
Guru


Joined: 22 Aug 2004
Posts: 433
Location: Switzerland

PostPosted: Sun May 15, 2022 7:04 pm    Post subject: Reply with quote

garrison wrote:
Dragonlord wrote:
I have CONFIG_BT_RFCOMM compiled into the kernel. Does it work only as module?

Well it should work as built-in, though https://wiki.gentoo.org/wiki/Bluetooth#Kernel has a warning so probably try as a module instead.

Okay... summary of what I tried so far:

  • RFCOMM not build in but as module: Shows up in the protocols listing but HSP is still not working
  • timidity service is not running but HSP is still not working

_________________
DragonDreams: Leader and Head Programmer
Back to top
View user's profile Send private message
garrison
Apprentice
Apprentice


Joined: 18 Mar 2003
Posts: 151

PostPosted: Sun May 15, 2022 7:23 pm    Post subject: Reply with quote

Dragonlord wrote:


  • RFCOMM not build in but as module: Shows up in the protocols listing but HSP is still not working
  • timidity service is not running but HSP is still not working

There are basically 2 options left
1. something is interfering with pulseaudio HSP/HFP handling, see if you have bluealsa configured or ofono running, or maybe pipewire though that was not listed in your latest upload.
2. headset has HFP profile support and kernel driver or pulseaudio backend-native is broken. start looking at 'bluetoothctl info' with headset connected, check if headset has UUID: Handsfree

Please upload updated pa-info output to pulseaudio tracker, also check bluetoothd log for any errors.
If headset has HFP try appending enable_msbc=false to module-bluetooth-discover in /etc/pulse/default.pa and if that helps I'd be interested in more detailed logging in that pulseaudio issue ticket.
Back to top
View user's profile Send private message
garrison
Apprentice
Apprentice


Joined: 18 Mar 2003
Posts: 151

PostPosted: Sun May 15, 2022 7:28 pm    Post subject: Reply with quote

Need to add that WH-CH700N was verified to work in HFP mode with pulseaudio last year so I'm sure yours can be made to work too https://gitlab.freedesktop.org/pulseaudio/pulseaudio/-/merge_requests/507#note_826371
Back to top
View user's profile Send private message
Dragonlord
Guru
Guru


Joined: 22 Aug 2004
Posts: 433
Location: Switzerland

PostPosted: Mon May 16, 2022 12:09 am    Post subject: Reply with quote

garrison wrote:
Dragonlord wrote:


  • RFCOMM not build in but as module: Shows up in the protocols listing but HSP is still not working
  • timidity service is not running but HSP is still not working

There are basically 2 options left
1. something is interfering with pulseaudio HSP/HFP handling, see if you have bluealsa configured or ofono running, or maybe pipewire though that was not listed in your latest upload.
2. headset has HFP profile support and kernel driver or pulseaudio backend-native is broken. start looking at 'bluetoothctl info' with headset connected, check if headset has UUID: Handsfree

Please upload updated pa-info output to pulseaudio tracker, also check bluetoothd log for any errors.
If headset has HFP try appending enable_msbc=false to module-bluetooth-discover in /etc/pulse/default.pa and if that helps I'd be interested in more detailed logging in that pulseaudio issue ticket.

I have nighter bluealsa, ofono nor pipewire running nor installed.

Output of bluetoothctl info
Code:
bluetoothctl info
Device 38:18:4C:AD:8D:3B (public)
        Name: WH-CH700N
        Alias: WH-CH700N
        Class: 0x00240404
        Icon: audio-headset
        Paired: yes
        Trusted: yes
        Blocked: no
        Connected: yes
        LegacyPairing: no
        UUID: Vendor specific           (00000000-deca-fade-deca-deafdecacaff)
        UUID: Headset                   (00001108-0000-1000-8000-00805f9b34fb)
        UUID: Audio Sink                (0000110b-0000-1000-8000-00805f9b34fb)
        UUID: A/V Remote Control Target (0000110c-0000-1000-8000-00805f9b34fb)
        UUID: A/V Remote Control        (0000110e-0000-1000-8000-00805f9b34fb)
        UUID: Handsfree                 (0000111e-0000-1000-8000-00805f9b34fb)
        UUID: PnP Information           (00001200-0000-1000-8000-00805f9b34fb)
        UUID: Vendor specific           (7b265b0e-2232-4d45-bef4-bb8ae62f813d)
        UUID: Vendor specific           (81c2e72a-0591-443e-a1ff-05f988593351)
        UUID: Vendor specific           (931c7e8a-540f-4686-b798-e8df0a2ad9f7)
        UUID: Vendor specific           (96cc203e-5068-46ad-b32d-e316f5e069ba)
        UUID: Vendor specific           (b9b213ce-eeab-49e4-8fd9-aa478ed1b26b)
        UUID: Vendor specific           (f8d1fbe4-7966-4334-8024-ff96c9330e15)
        Modalias: usb:v054Cp0C7Fd0420


Handsfree is listed.
_________________
DragonDreams: Leader and Head Programmer


Last edited by Dragonlord on Mon May 16, 2022 12:25 am; edited 2 times in total
Back to top
View user's profile Send private message
Dragonlord
Guru
Guru


Joined: 22 Aug 2004
Posts: 433
Location: Switzerland

PostPosted: Mon May 16, 2022 12:24 am    Post subject: Reply with quote

I tried with enable_msbc=false. This is the result:
  • HSF become available and headset can be switched in pavucontrol.
  • Audio is not working
  • Recording is working but is totally broken

Basically HSF is unusable while HSP remains unavailable.

The kernel is 5.15.32-gentoo-r1
_________________
DragonDreams: Leader and Head Programmer
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum