Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
python-exec [RISOLTO]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
dylanmc
Tux's lil' helper
Tux's lil' helper


Joined: 18 Apr 2014
Posts: 146
Location: Modena, Italy

PostPosted: Mon Jan 10, 2022 11:37 pm    Post subject: python-exec [RISOLTO] Reply with quote

Ciao a tutti,

non chiedetemi come ho fatto ma per errore, ho rimosso python-exec

Sono riuscito reinstallarlo con

Code:
/usr/lib64/python-exec/python3.9/emerge -av1 dev-lang/python-exec


però adesso ho questo problema :-(

Code:
snoopx /home/luca # emerge -a -uvDU @world --newuse --update

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-python/PySocks:0

  (dev-python/PySocks-1.7.1-r1:0/0::gentoo, ebuild scheduled for merge) USE="" ABI_X86="(64)" PYTHON_TARGETS="python3_9 (-pypy3) -python3_10 -python3_8" pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-python/PySocks-1.7.1-r1:0/0::gentoo, installed) USE="" ABI_X86="(64)" PYTHON_TARGETS="python3_7 python3_8 python3_9 (-pypy3)" pulled in by
    <dev-python/PySocks-2.0[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?] required by (dev-python/urllib3-1.26.7:0/0::gentoo, installed) USE="-brotli -test" ABI_X86="(64)" PYTHON_TARGETS="python3_8 python3_9 (-pypy3) -python3_10"
                                                                                                                                                                                                                                                                                                                                                                                                                                                               
    >=dev-python/PySocks-1.5.8[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?] required by (dev-python/urllib3-1.26.7:0/0::gentoo, installed) USE="-brotli -test" ABI_X86="(64)" PYTHON_TARGETS="python3_8 python3_9 (-pypy3) -python3_10"
                                    emerge: there are no ebuilds to satisfy ">=dev-lang/python-exec-2:2/2=[python_targets_python3_7(-),python_targets_python3_8(-),python_targets_python3_9(-),-python_single_target_pypy3(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)]".
(dependency required by "dev-python/PySocks-1.7.1-r1::gentoo" [installed])
(dependency required by "dev-python/urllib3-1.26.7::gentoo" [installed])
(dependency required by "app-admin/system-config-printer-1.5.15::gentoo[python_single_target_python3_9]" [ebuild])
(dependency required by "kde-apps/print-manager-21.08.3::gentoo[gtk]" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
                                                                                                                                                                                 

 


Praticamente non riesco ad aggiornare e credo sia per un problema di python-exec

Questo è il mio make.conf, i target python ci sono e c'erano anche prima

Code:
snoopx /home/luca # cat /etc/portage/make.conf
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
#CPU_FLAGS_X86="mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3"
CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3"
#CFLAGS="-O2 -march=native -pipe"
CFLAGS="-O2 -march=znver1"
#CFLAGS="-O2 -march=haswell"
CXXFLAGS="${CFLAGS}"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
PORTAGE_ELOG_CLASSES="warn error log"
PORTAGE_ELOG_SYSTEM="save"

USE="udev nls mp3 gtk alsa dvd cdr it bluetooth v4l dvb X opengl steamruntime udisks policykit dbus x86_64 opencl"

PORTDIR="/usr/portage"
DISTDIR="${PORTDIR}/distfiles"
PKGDIR="${PORTDIR}/packages"
MAKEOPTS="-j13"
LINGUAS="it"
L10N="it en"
EMERGE_DEFAULT_OPTS="--keep-going -v --with-bdeps=y --autounmask y --autounmask-write y -q"
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
#PORTDIR_OVERLAY=/var/lib/layman/steam
PORTAGE_TMPDIR="/var/tmp/portage"
#SYNC="rsync://rsync10.de.gentoo.org/gentoo-portage"
GENTOO_MIRRORS="http://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/ http://de-mirror.org/gentoo/ http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/"
PYTHON_TARGETS="python3_9"
PYTHON_SINGLE_TARGETS="python3_9"
VIDEO_CARDS="amdgpu radeonsi"
FEATURES="preserve-libs"
PORT_LOGDIR="/var/log/portage"
QEMU_SOFTMMU_TARGETS="arm x86_64 sparc"
QEMU_USER_TARGETS="x86_64"
ALSA_CARDS="hda-intel"
DOTNET_TARGETS="net45 net40"
RUBY_TARGETS="ruby25 ruby26 ruby27 ruby30"
ABI_X86="32 64"



Non mi era mai capitato in tanti anni... qualcuno può aiutarmi?


Last edited by dylanmc on Tue Jan 11, 2022 1:51 pm; edited 1 time in total
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4721
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Mon Jan 10, 2022 11:53 pm    Post subject: Reply with quote

se ti fidi, questo è il pacchetto che ti manca.
Code:

cloc3@cloc3 ~/prova/python-exec $ md5sum python-exec-2.4.8.tbz2
4fa3ee500dcafc035d156040dcd22bba  python-exec-2.4.8.tbz2

prova a scompattarlo, trasferire i file a mano e poi reinstallare il pacchetto originale.
se non ti fidi, ricava la lista dei file mancanti e prelevali da un cd di installazione.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
dylanmc
Tux's lil' helper
Tux's lil' helper


Joined: 18 Apr 2014
Posts: 146
Location: Modena, Italy

PostPosted: Mon Jan 10, 2022 11:58 pm    Post subject: Reply with quote

Code:
snoopx /home/luca # emerge -pv python-exec
[ebuild   R   ] dev-lang/python-exec-2.4.8  USE="(native-symlinks) -test" PYTHON_TARGETS="(pypy3) (python3_8) (python3_9) (python3_10)"



questo l'ho già scaricato, quindi c'è...

Il problema temo sia altro.. la sua configurazione credo, quando l'ho emerso ho sovrascritto la configurazione
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4721
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Tue Jan 11, 2022 12:36 am    Post subject: Reply with quote

dylanmc wrote:


Il problema temo sia altro.. la sua configurazione credo, quando l'ho emerso ho sovrascritto la configurazione

la configurazione si modifica con eselect.
credo che tocchi questo file:
Code:

cloc3 ~ # cat /etc/python-exec/python-exec.conf
#/etc/python-exec/python-exec.conf
# python-exec global preference configuration
#
# This file specifies global Python preference for python-exec. It
# determines which implementations will be used when wrapped Python
# scripts or generic Python wrappers (such as /usr/bin/python) are
# started with no implementation override (EPYTHON).
#
# The global configuration can be overriden for each wrapped script
# in /etc/python-exec/<script-name>.conf. If this override exists,
# the global configuration is not used at all.
#
# The preference file should list Python implementations, one per line,
# in EPYTHON-format (e.g. python3.5), in order of preference. The most
# preferred implementation should be listed first. The program will use
# the most preferred implementation that is supported by it.
#
# If none of the listed implementations are supported, python-exec will
# attempt to use the remaining supported implementations in default
# order.
#
# A specific implementation can be disabled by preceding it with
# a hyphen (-). In this case, the implementation will never be used.
# If no other implementation is supported by the program, it will fail
# to start.
#
# Note: this file can be modified by calls to 'eselect python'.
python3.9

_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
fedeliallalinea
Administrator
Administrator


Joined: 08 Mar 2003
Posts: 27749
Location: here

PostPosted: Tue Jan 11, 2022 6:21 am    Post subject: Reply with quote

Il problema è il pacchetto dev-python/PySocks che è installato con il supporto a python3_7 non più supportato.
Non hai qualche voce che abilita questo supporto in /etc/portage/package.use (grep -ri python3_7 /etc/portage/)?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
dylanmc
Tux's lil' helper
Tux's lil' helper


Joined: 18 Apr 2014
Posts: 146
Location: Modena, Italy

PostPosted: Tue Jan 11, 2022 7:59 am    Post subject: Reply with quote

Code:
noopx /home/luca # grep -ri python3_7 /etc/portage/
/etc/portage/make.conf:PYTHON_SINGLE_TARGETS="python3_7 python3_8 python3_9 python3_10"
/etc/portage/package.use:>=dev-python/setuptools-56.0.0 python_targets_python3_7 python_targets_python3_8
/etc/portage/package.use:>=dev-python/setuptools_scm-6.0.1-r1 python_targets_python3_7 python_targets_python3_8
/etc/portage/package.use:>=dev-python/toml-0.10.2 python_targets_python3_7 python_targets_python3_8




No, punta ad altri pacchetti non python 3.7, ma il problema è sopraggiunto quando ho fatto l'errore di togliere pyton-exec che conflittava con qualcosa che ora non ricordo.
Pensavo di riuscire reinstallando.. e invece no.

Sto provando anche solo con dev-python/PySocks da solo ma niente, da lo stesso errore.
Dovrei provare a reinstallarlo senza supporto 3.7 a sapere come fare

Ho provato con

Code:

snoopx /home/luca # USE="PYTHON_TARGET=python3_9" emerge -pv dev-python/PySocks
[ebuild   R   ] dev-python/PySocks-1.7.1-r1  PYTHON_TARGETS="python3_9 (-pypy3) -python3_8* -python3_10% (-python3_7%*)"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-python/PySocks:0

  (dev-python/PySocks-1.7.1-r1:0/0::gentoo, ebuild scheduled for merge) USE="" ABI_X86="(64)" PYTHON_TARGETS="python3_9 (-pypy3) -python3_10 -python3_8" pulled in by
    dev-python/PySocks (Argument)

  (dev-python/PySocks-1.7.1-r1:0/0::gentoo, installed) USE="" ABI_X86="(64)" PYTHON_TARGETS="python3_7 python3_8 python3_9 (-pypy3)" pulled in by
    >=dev-python/PySocks-1.5.8[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?] required by (dev-python/urllib3-1.26.7:0/0::gentoo, installed) USE="-brotli -test" ABI_X86="(64)" PYTHON_TARGETS="python3_8 python3_9 (-pypy3) -python3_10"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                 
    <dev-python/PySocks-2.0[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?] required by (dev-python/urllib3-1.26.7:0/0::gentoo, installed) USE="-brotli -test" ABI_X86="(64)" PYTHON_TARGETS="python3_8 python3_9 (-pypy3) -python3_10"
                                                                                       




però non capisco, sembra che voglia installare la versione 2.0, che in portage non c'è.

Ho tolto pure il supporto a python 3.7 dai targets ma niente
Back to top
View user's profile Send private message
fedeliallalinea
Administrator
Administrator


Joined: 08 Mar 2003
Posts: 27749
Location: here

PostPosted: Tue Jan 11, 2022 8:06 am    Post subject: Reply with quote

Code:
noopx /home/luca # grep -ri python3_7 /etc/portage/
/etc/portage/make.conf:PYTHON_SINGLE_TARGETS="python3_7 python3_8 python3_9 python3_10"
/etc/portage/package.use:>=dev-python/setuptools-56.0.0 python_targets_python3_7 python_targets_python3_8
/etc/portage/package.use:>=dev-python/setuptools_scm-6.0.1-r1 python_targets_python3_7 python_targets_python3_8
/etc/portage/package.use:>=dev-python/toml-0.10.2 python_targets_python3_7 python_targets_python3_8

Commenta tutte queste voci e lancia un emerge -uUDa @world, di default ora portage abilita solo python3_9.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
dylanmc
Tux's lil' helper
Tux's lil' helper


Joined: 18 Apr 2014
Posts: 146
Location: Modena, Italy

PostPosted: Tue Jan 11, 2022 8:15 am    Post subject: Reply with quote

Code:
snoopx /home/luca # emerge -uUDa @world

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-python/PySocks:0

  (dev-python/PySocks-1.7.1-r1:0/0::gentoo, ebuild scheduled for merge) USE="" ABI_X86="(64)" PYTHON_TARGETS="python3_9 (-pypy3) -python3_10 -python3_8" pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-python/PySocks-1.7.1-r1:0/0::gentoo, installed) USE="" ABI_X86="(64)" PYTHON_TARGETS="python3_7 python3_8 python3_9 (-pypy3)" pulled in by
    >=dev-python/PySocks-1.5.8[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?] required by (dev-python/urllib3-1.26.7:0/0::gentoo, installed) USE="-brotli -test" ABI_X86="(64)" PYTHON_TARGETS="python3_8 python3_9 (-pypy3) -python3_10"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                 
    <dev-python/PySocks-2.0[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?] required by (dev-python/urllib3-1.26.7:0/0::gentoo, installed) USE="-brotli -test" ABI_X86="(64)" PYTHON_TARGETS="python3_8 python3_9 (-pypy3) -python3_10"
                                                                                                                                                                                                                                                                                                                                                                                                                                                               


!!! Enabling --newuse and --update might solve this conflict.
!!! If not, it might help emerge to give a more specific suggestion.


The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by dev-python/cython-0.29.25::gentoo
# required by dev-python/lxml-4.6.5::gentoo
# required by media-libs/lv2-1.18.2::gentoo[python_single_target_python3_9]
# required by media-libs/lilv-0.24.12::gentoo
# required by media-sound/audacity-2.4.2-r2::gentoo[lv2]
# required by @selected
# required by @world (argument)
>=dev-python/setuptools-59.8.0 python_targets_python3_8

Would you like to add these changes to your config files? [Yes/No]


Mi chiede questo.

Ho provato a farlo, ma il problema resta, ho un sacco di pacchetti che portano a python 3.8 che mi pare di capire sia supportato.
Devo passare solo a python 3.9 come PYTHON_TARGETS ?
Back to top
View user's profile Send private message
fedeliallalinea
Administrator
Administrator


Joined: 08 Mar 2003
Posts: 27749
Location: here

PostPosted: Tue Jan 11, 2022 8:33 am    Post subject: Reply with quote

Devi eliminare la voce PYTHON_SINGLE_TARGETS="python3_7 python3_8 python3_9 python3_10" in /etc/portage/make.conf.
I target python sono gestiti dal profilo e tu non dovresti fare nulla se non hai delle necessità particolari.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
dylanmc
Tux's lil' helper
Tux's lil' helper


Joined: 18 Apr 2014
Posts: 146
Location: Modena, Italy

PostPosted: Tue Jan 11, 2022 8:50 am    Post subject: Reply with quote

Code:
snoopx /home/luca # emerge -pv dev-python/PySocks
[ebuild   R   ] dev-python/PySocks-1.7.1-r1  PYTHON_TARGETS="python3_9 (-pypy3) -python3_8* -python3_10% (-python3_7%*)"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-python/PySocks:0

  (dev-python/PySocks-1.7.1-r1:0/0::gentoo, ebuild scheduled for merge) USE="" ABI_X86="(64)" PYTHON_TARGETS="python3_9 (-pypy3) -python3_10 -python3_8" pulled in by
    dev-python/PySocks (Argument)

  (dev-python/PySocks-1.7.1-r1:0/0::gentoo, installed) USE="" ABI_X86="(64)" PYTHON_TARGETS="python3_7 python3_8 python3_9 (-pypy3)" pulled in by
    >=dev-python/PySocks-1.5.8[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?] required by (dev-python/urllib3-1.26.7:0/0::gentoo, installed) USE="-brotli -test" ABI_X86="(64)" PYTHON_TARGETS="python3_8 python3_9 (-pypy3) -python3_10"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                 
    [b]<dev-python/PySocks-2.0[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?] required by (dev-python/urllib3-1.26.7:0/0::gentoo, installed) USE="-brotli -test" ABI_X86="(64)" PYTHON_TARGETS="python3_8 python3_9 (-pypy3) -python3_10"[/b]



Niente da lo stesso errore.

Però c'è questo pacchetto che richiede una versione 2.0 che non c'è.
Se provassi a toglierlo?

E' che ho pausa di entrare in un loop dopo, visto che ha delle dipendenze anche quel pacchetto logicamente
Back to top
View user's profile Send private message
fedeliallalinea
Administrator
Administrator


Joined: 08 Mar 2003
Posts: 27749
Location: here

PostPosted: Tue Jan 11, 2022 9:04 am    Post subject: Reply with quote

Se hai tolto il supporto a python3_8 non puoi usare solo emerge -pv dev-python/PySocks ma devi lanciare emerge -uUD @world (l'opzione -U è importante e significa ricompila tutti i pacchetti che hanno cambiato use flag).
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
dylanmc
Tux's lil' helper
Tux's lil' helper


Joined: 18 Apr 2014
Posts: 146
Location: Modena, Italy

PostPosted: Tue Jan 11, 2022 9:16 am    Post subject: Reply with quote

Ho commentato tutti i pacchetti che richiedevano python 3.8 in package.use

Code:
snoopx /home/luca # emerge -uUD @world

emerge: there are no ebuilds to satisfy ">=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),-python_single_target_python2_7(-)]".
(dependency required by "dev-python/enum34-1.1.6-r1::gentoo" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])



quello che mi preoccupa è quello che riguarda emerge no ebuilds
Back to top
View user's profile Send private message
dylanmc
Tux's lil' helper
Tux's lil' helper


Joined: 18 Apr 2014
Posts: 146
Location: Modena, Italy

PostPosted: Tue Jan 11, 2022 9:22 am    Post subject: Reply with quote

Risolto (o almeno credo)

Ho eliminato il pacchetto dev-python/enum34-1.1.6-r1::gentoo che non è più in portage, adesso con


Code:
emerge -uUD @world
sta ricompilando un centinaio di pacchetti.[/quote]

Intanto grazie.

Purtroppo non sono ferratissimo, e dire che la uso da anni.
Ma togliere quel python-exec ... adesso almeno so cos'è :P
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum