Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Tor browser 11.0.1 ya no funciona en gentoo (solucionado)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
cameta
Veteran
Veteran


Joined: 04 Aug 2004
Posts: 1277

PostPosted: Wed Nov 17, 2021 11:15 am    Post subject: Tor browser 11.0.1 ya no funciona en gentoo (solucionado) Reply with quote

El otro día al actualizar tor browser a la versión 11.0.1 en gentoo este dejo de funcionar.
Este es el error que aparece
Code:
XPCOMGlueLoad error for file /home/mestres/tor-browser_en-US.bak/Browser/libxul.so:
/home/mestres/tor-browser_en-US.bak/Browser/libxul.so: undefined symbol: gdk_wayland_display_get_wl_compositor
Couldn't load XPCOM.


https://www.linuxquestions.org/questions/slackware-14/tor-browser-doesn%27t-work-in-slackware64-14-2-anymore-4175703351/
https://gitlab.torproject.org/tpo/applications/tor-browser/-/issues/40693

De momento aconsejo a todos los usuarios de tor desactivar las actualizaciones automáticas.
¿Alguna idea de como hacer funcionar wayland en gentoo? Se que hay una use wayland pero desconozco si con ello sera suficiente.
_________________
Si algo falla LEE el jodido manual, Si sigue fallando LEE BIEN el jodido manual.


Last edited by cameta on Thu Nov 25, 2021 9:28 pm; edited 2 times in total
Back to top
View user's profile Send private message
chrootman
n00b
n00b


Joined: 18 Aug 2020
Posts: 47

PostPosted: Sun Nov 21, 2021 9:55 pm    Post subject: Reply with quote

Cuál es la ventaja de usar tor-browser y no tor configurado con un browser?

En archlinux tengo ambos, torbrowser y firefox configurado con tor de esta forma https://wiki.gentoo.org/wiki/Tor
https://wiki.archlinux.org/title/tor
, así que no tengo que esperar que se conecte como con toR browser., llego y lanzó firefox que lo compile y ya, tal como en gentoo también con el daemon corriendo siempre, se configura igual en /etc/tor/torrc
ExcludeExitNodes {au}, {ca}, {gb}, {nz}, {us}
La otra opción es usar
https://wiki.gentoo.org/wiki/Flatpak
https://flathub.org/apps/details/com.github.micahflee.torbrowser-launcher
https://clearlinux.org/software/flathub/tor-browser-launcher

Code:
com.github.micahflee.torbrowser-launcher
Looking for matches…
Required runtime for com.github.micahflee.torbrowser-launcher/x86_64/stable (runtime/org.kde.Platform/x86_64/5.15) found in remote flathub
Do you want to install it? [Y/n]: Y

com.github.micahflee.torbrowser-launcher permissions:
    ipc       network              pulseaudio           x11
    dri       file access [1]      dbus access [2]

    [1] xdg-config/kdeglobals:ro, xdg-download
    [2] com.canonical.AppMenu.Registrar

No sé si todavía está vigente esto, es que no estoy en gentoo en este momento.
Code:
# eix -e torbrowser
* www-client/torbrowser [1]
     Available versions:  (~)60.7.0_p853 {hardened}
     Homepage:            https://www.torproject.org/projects/torbrowser.html https://gitweb.torproject.org/tor-browser.git
     Description:         The Tor Browser

[1] "torbrowser" /var/lib/layman/torbrowser

Me aleje de wayland así que no sé de eso, lo último que recuerdo es que agregué -wayland.
Back to top
View user's profile Send private message
spyderco
n00b
n00b


Joined: 13 May 2013
Posts: 25

PostPosted: Thu Nov 25, 2021 7:25 am    Post subject: Re: Tor browser 11.0.1 ya no funciona en gentoo Reply with quote

cameta wrote:
El otro día al actualizar tor browser a la versión 11.0.1 en gentoo este dejo de funcionar.
Este es el error que aparece
Code:
XPCOMGlueLoad error for file /home/mestres/tor-browser_en-US.bak/Browser/libxul.so:
/home/mestres/tor-browser_en-US.bak/Browser/libxul.so: undefined symbol: gdk_wayland_display_get_wl_compositor
Couldn't load XPCOM.


https://www.linuxquestions.org/questions/slackware-14/tor-browser-doesn%27t-work-in-slackware64-14-2-anymore-4175703351/
https://gitlab.torproject.org/tpo/applications/tor-browser/-/issues/40693

De momento aconsejo a todos los usuarios de tor desactivar las actualizaciones automáticas.
¿Alguna idea de como hacer funcionar wayland en gentoo? Se que hay una use wayland pero desconozco si con ello sera suficiente.




Hola Cameta.

A mi me va perfecto, y sin ningún problema, lo que pasa es que hay que instalar wayland.

Tiene ahora esa dependencia instala wayland y problema resuelto.
Back to top
View user's profile Send private message
cameta
Veteran
Veteran


Joined: 04 Aug 2004
Posts: 1277

PostPosted: Thu Nov 25, 2021 10:07 am    Post subject: Reply with quote

Pues ya lo probaré.
_________________
Si algo falla LEE el jodido manual, Si sigue fallando LEE BIEN el jodido manual.
Back to top
View user's profile Send private message
cameta
Veteran
Veteran


Joined: 04 Aug 2004
Posts: 1277

PostPosted: Thu Nov 25, 2021 9:32 pm    Post subject: Reply with quote

Solucionado, al añadir las uses wayland y gles2 a make.conf y compilar de nuevo world.
emerge --update --newuse --deep --with-bdeps=y -qv @world
No hace falta arrancar con wayland. (me parece que consume muchos recursos cuando lo hago)
_________________
Si algo falla LEE el jodido manual, Si sigue fallando LEE BIEN el jodido manual.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum