Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Errore installazione Nemo
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
GianGian2387
n00b
n00b


Joined: 03 Jun 2021
Posts: 61

PostPosted: Sat Sep 11, 2021 9:17 am    Post subject: Errore installazione Nemo Reply with quote

Buongiorno a tutti,
riscontro questo problema se provo ad installare nemo:

Quote:
Gentoo /home/jean # emerge --ask gnome-extra/nemo

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The ebuild selected to satisfy "x11-base/xorg-server[xvfb]" has unmet requirements.
- x11-base/xorg-server-1.20.13-r1::gentoo USE="elogind ipv6 test udev xephyr xorg xvfb -debug -dmx -doc -kdrive -minimal (-selinux) -suid -systemd -unwind -xcsecurity -xnest" ABI_X86="(64)"

The following REQUIRED_USE flag constraints are unsatisfied:
xephyr? ( kdrive )

The above constraints are a subset of the following complete expression:
!minimal? ( any-of ( dmx kdrive xephyr xnest xorg xvfb ) ) elogind? ( udev ) at-most-one-of ( elogind systemd ) xephyr? ( kdrive )

(dependency required by "gnome-extra/nemo-4.8.4-r1::gentoo[test]" [ebuild])
(dependency required by "gnome-extra/nemo" [argument])


se voglio aggiornare le dipendenze riscontro questo:

Quote:
Gentoo /home/jean # emerge --ask --verbose --changed-use --update --deep world

These are the packages that would be merged, in order:

Calculating dependencies /

!!! Problem resolving dependencies for x11-base/xorg-server from @selected
... done!

!!! The ebuild selected to satisfy "x11-base/xorg-server" has unmet requirements.
- x11-base/xorg-server-1.20.13-r1::gentoo USE="elogind ipv6 test udev xephyr xorg xvfb -debug -dmx -doc -kdrive -minimal (-selinux) -suid -systemd -unwind -xcsecurity -xnest" ABI_X86="(64)"

The following REQUIRED_USE flag constraints are unsatisfied:
xephyr? ( kdrive )

The above constraints are a subset of the following complete expression:
!minimal? ( any-of ( dmx kdrive xephyr xnest xorg xvfb ) ) elogind? ( udev ) at-most-one-of ( elogind systemd ) xephyr? ( kdrive )

(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

Avete idea di come possa risolvere?
Back to top
View user's profile Send private message
fedeliallalinea
Administrator
Administrator


Joined: 08 Mar 2003
Posts: 27080
Location: here

PostPosted: Sat Sep 11, 2021 7:40 pm    Post subject: Reply with quote

Code:
!!! The ebuild selected to satisfy "x11-base/xorg-server[xvfb]" has unmet requirements.
- x11-base/xorg-server-1.20.13-r1::gentoo USE="elogind ipv6 test udev xephyr xorg xvfb -debug -dmx -doc -kdrive -minimal (-selinux) -suid -systemd -unwind -xcsecurity -xnest" ABI_X86="(64)"

The following REQUIRED_USE flag constraints are unsatisfied:
xephyr? ( kdrive )

Il messaggio ti dice che se vuoi installare x11-base/xorg-server con la use flag xephyr sei obbligato ad abilitare anche kdrive, lo puoi fare con il file /etc/portage/package.use
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
GianGian2387
n00b
n00b


Joined: 03 Jun 2021
Posts: 61

PostPosted: Sat Sep 11, 2021 8:55 pm    Post subject: Reply with quote

Nell mie flag non ho inserito ne xerphy nekdrive...
attualmente nelle use ho inserito: "-systemd dbus X pipewire-alsa elogind cups zeroconf test"
Back to top
View user's profile Send private message
fedeliallalinea
Administrator
Administrator


Joined: 08 Mar 2003
Posts: 27080
Location: here

PostPosted: Sun Sep 12, 2021 5:38 am    Post subject: Reply with quote

Prova a controllare con il comando grep -r xerphy /etc/portage/package.use
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
GianGian2387
n00b
n00b


Joined: 03 Jun 2021
Posts: 61

PostPosted: Sun Sep 12, 2021 2:38 pm    Post subject: Reply with quote

Quote:
jean@Gentoo ~ $ grep -r xerphy /etc/portage/package.use
jean@Gentoo ~ $
Code:


Stessa cosa se do il comando da root
Back to top
View user's profile Send private message
fedeliallalinea
Administrator
Administrator


Joined: 08 Mar 2003
Posts: 27080
Location: here

PostPosted: Sun Sep 12, 2021 4:36 pm    Post subject: Reply with quote

Non capisco chi ha abilitato la use flag xerphy. Che output ritorna il comando emerge -pv x11-base/xorg-server?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
GianGian2387
n00b
n00b


Joined: 03 Jun 2021
Posts: 61

PostPosted: Sun Sep 12, 2021 7:07 pm    Post subject: Reply with quote

Quote:
Gentoo /home/jean # emerge -pv x11-base/xorg-server

These are the packages that would be merged, in order:

Calculating dependencies |

!!! Problem resolving dependencies for x11-base/xorg-server
... done!

!!! The ebuild selected to satisfy "x11-base/xorg-server" has unmet requirements.
- x11-base/xorg-server-1.20.13-r1::gentoo USE="elogind ipv6 test udev xephyr xorg xvfb -debug -dmx -doc -kdrive -minimal (-selinux) -suid -systemd -unwind -xcsecurity -xnest" ABI_X86="(64)"

The following REQUIRED_USE flag constraints are unsatisfied:
xephyr? ( kdrive )

The above constraints are a subset of the following complete expression:
!minimal? ( any-of ( dmx kdrive xephyr xnest xorg xvfb ) ) elogind? ( udev ) at-most-one-of ( elogind systemd ) xephyr? ( kdrive )
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum