Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Errore installazione Nemo
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
GianGian2387
Tux's lil' helper
Tux's lil' helper


Joined: 03 Jun 2021
Posts: 80

PostPosted: Sat Sep 11, 2021 9:17 am    Post subject: Errore installazione Nemo Reply with quote

Buongiorno a tutti,
riscontro questo problema se provo ad installare nemo:

Quote:
Gentoo /home/jean # emerge --ask gnome-extra/nemo

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The ebuild selected to satisfy "x11-base/xorg-server[xvfb]" has unmet requirements.
- x11-base/xorg-server-1.20.13-r1::gentoo USE="elogind ipv6 test udev xephyr xorg xvfb -debug -dmx -doc -kdrive -minimal (-selinux) -suid -systemd -unwind -xcsecurity -xnest" ABI_X86="(64)"

The following REQUIRED_USE flag constraints are unsatisfied:
xephyr? ( kdrive )

The above constraints are a subset of the following complete expression:
!minimal? ( any-of ( dmx kdrive xephyr xnest xorg xvfb ) ) elogind? ( udev ) at-most-one-of ( elogind systemd ) xephyr? ( kdrive )

(dependency required by "gnome-extra/nemo-4.8.4-r1::gentoo[test]" [ebuild])
(dependency required by "gnome-extra/nemo" [argument])


se voglio aggiornare le dipendenze riscontro questo:

Quote:
Gentoo /home/jean # emerge --ask --verbose --changed-use --update --deep world

These are the packages that would be merged, in order:

Calculating dependencies /

!!! Problem resolving dependencies for x11-base/xorg-server from @selected
... done!

!!! The ebuild selected to satisfy "x11-base/xorg-server" has unmet requirements.
- x11-base/xorg-server-1.20.13-r1::gentoo USE="elogind ipv6 test udev xephyr xorg xvfb -debug -dmx -doc -kdrive -minimal (-selinux) -suid -systemd -unwind -xcsecurity -xnest" ABI_X86="(64)"

The following REQUIRED_USE flag constraints are unsatisfied:
xephyr? ( kdrive )

The above constraints are a subset of the following complete expression:
!minimal? ( any-of ( dmx kdrive xephyr xnest xorg xvfb ) ) elogind? ( udev ) at-most-one-of ( elogind systemd ) xephyr? ( kdrive )

(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

Avete idea di come possa risolvere?
Back to top
View user's profile Send private message
fedeliallalinea
Administrator
Administrator


Joined: 08 Mar 2003
Posts: 27276
Location: here

PostPosted: Sat Sep 11, 2021 7:40 pm    Post subject: Reply with quote

Code:
!!! The ebuild selected to satisfy "x11-base/xorg-server[xvfb]" has unmet requirements.
- x11-base/xorg-server-1.20.13-r1::gentoo USE="elogind ipv6 test udev xephyr xorg xvfb -debug -dmx -doc -kdrive -minimal (-selinux) -suid -systemd -unwind -xcsecurity -xnest" ABI_X86="(64)"

The following REQUIRED_USE flag constraints are unsatisfied:
xephyr? ( kdrive )

Il messaggio ti dice che se vuoi installare x11-base/xorg-server con la use flag xephyr sei obbligato ad abilitare anche kdrive, lo puoi fare con il file /etc/portage/package.use
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
GianGian2387
Tux's lil' helper
Tux's lil' helper


Joined: 03 Jun 2021
Posts: 80

PostPosted: Sat Sep 11, 2021 8:55 pm    Post subject: Reply with quote

Nell mie flag non ho inserito ne xerphy nekdrive...
attualmente nelle use ho inserito: "-systemd dbus X pipewire-alsa elogind cups zeroconf test"
Back to top
View user's profile Send private message
fedeliallalinea
Administrator
Administrator


Joined: 08 Mar 2003
Posts: 27276
Location: here

PostPosted: Sun Sep 12, 2021 5:38 am    Post subject: Reply with quote

Prova a controllare con il comando grep -r xerphy /etc/portage/package.use
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
GianGian2387
Tux's lil' helper
Tux's lil' helper


Joined: 03 Jun 2021
Posts: 80

PostPosted: Sun Sep 12, 2021 2:38 pm    Post subject: Reply with quote

Quote:
jean@Gentoo ~ $ grep -r xerphy /etc/portage/package.use
jean@Gentoo ~ $
Code:


Stessa cosa se do il comando da root
Back to top
View user's profile Send private message
fedeliallalinea
Administrator
Administrator


Joined: 08 Mar 2003
Posts: 27276
Location: here

PostPosted: Sun Sep 12, 2021 4:36 pm    Post subject: Reply with quote

Non capisco chi ha abilitato la use flag xerphy. Che output ritorna il comando emerge -pv x11-base/xorg-server?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
GianGian2387
Tux's lil' helper
Tux's lil' helper


Joined: 03 Jun 2021
Posts: 80

PostPosted: Sun Sep 12, 2021 7:07 pm    Post subject: Reply with quote

Quote:
Gentoo /home/jean # emerge -pv x11-base/xorg-server

These are the packages that would be merged, in order:

Calculating dependencies |

!!! Problem resolving dependencies for x11-base/xorg-server
... done!

!!! The ebuild selected to satisfy "x11-base/xorg-server" has unmet requirements.
- x11-base/xorg-server-1.20.13-r1::gentoo USE="elogind ipv6 test udev xephyr xorg xvfb -debug -dmx -doc -kdrive -minimal (-selinux) -suid -systemd -unwind -xcsecurity -xnest" ABI_X86="(64)"

The following REQUIRED_USE flag constraints are unsatisfied:
xephyr? ( kdrive )

The above constraints are a subset of the following complete expression:
!minimal? ( any-of ( dmx kdrive xephyr xnest xorg xvfb ) ) elogind? ( udev ) at-most-one-of ( elogind systemd ) xephyr? ( kdrive )
Back to top
View user's profile Send private message
GianGian2387
Tux's lil' helper
Tux's lil' helper


Joined: 03 Jun 2021
Posts: 80

PostPosted: Wed Sep 29, 2021 1:30 pm    Post subject: Reply with quote

Era un problema di dipendenze alsa-plugins, ho disinstallato quelle dipendenze e sono riuscito a risolvere quasi tutto, ora il problema è che se do il comando: emerge --ask --changed-use --deep @world
ricevo questo:

Quote:

emerge --update --newuse --deep --with-bdeps=y worldCalculating dependencies... done!\[ebuild N \] media-plugins/alsa-plugins-1.2.2 USE="mix pulseaudio usb\_stream -arcam\_av -debug -ffmpeg -jack -libsamplerate -oss -speex" ABI\_X86="(64) -32 (-x32)" \[blocks B \] media-plugins/alsa-plugins ("media-plugins/alsa-plugins" is blocking media-video/pipewire-0.3.30-r2) \* Error: The above package list contains packages which cannot be \* installed at the same time on the same system. (media-plugins/alsa-plugins-1.2.2:0/0::gentoo, ebuild scheduled for merge) pulled in by >=media-plugins/alsa-plugins-1.0.27-r1\[pulseaudio,abi\_x86\_32(-)?,abi\_x86\_64(-)?,abi\_x86\_x32(-)?,abi\_mips\_n32(-)?,abi\_mips\_n64(-)?,abi\_mips\_o32(-)?,abi\_s390\_32(-)?,abi\_s390\_64(-)?\] (>=media-plugins/alsa-plugins-1.0.27-r1\[pulseaudio,abi\_x86\_64(-)\]) required by (media-sound/pulseaudio-13.0-r1:0/0::gentoo, installed) USE="X alsa alsa-plugin asyncns bluetooth caps dbus elogind gdbm glib gtk ipv6 orc qt5 ssl tcpd udev webrtc-aec -doc -equalizer -gconf -jack -libsamplerate -lirc -native-headset -ofono-headset (-oss) -realtime (-selinux) -sox (-system-wide) -systemd -test -zeroconf" ABI\_X86="(64) -32 (-x32)" (media-video/pipewire-0.3.30-r2:0/0.3::gentoo, installed) pulled in by media-video/pipewire required by u/selected For more information about Blocked Packages, please refer to the followingsection of the Gentoo Linux x86 Handbook (architecture is irrelevant):[https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked\_packages](https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages)


Sapreste dirmi come risolvere?
Avrei un altra curiosità, in fase di installazione ho dato il permesso al mio utente di utilizzare sudo (andando a compilare il file visudo), quando da terminale do un qualsiasi comando che imlica "sudo" mi viene richiesta sempre la password (ciò rende impossibile utilizzare alcuni comandi se non da teminale ad es. halt -p da una barra) per ovviare a ciò dovrei installare polkit o dovrei fare altro?


Last edited by GianGian2387 on Wed Sep 29, 2021 2:00 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Administrator
Administrator


Joined: 08 Mar 2003
Posts: 27276
Location: here

PostPosted: Wed Sep 29, 2021 1:51 pm    Post subject: Reply with quote

Puoi postare l'output del comando in modo più comprensibile?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
GianGian2387
Tux's lil' helper
Tux's lil' helper


Joined: 03 Jun 2021
Posts: 80

PostPosted: Wed Sep 29, 2021 10:21 pm    Post subject: Reply with quote

Code:
 gentoo /home/jean # emerge --update --newuse --deep --with-bdeps=y @world
Calculating dependencies... done!
[ebuild  N     ] media-plugins/alsa-plugins-1.2.2  USE="mix pulseaudio usb_stream -arcam_av -debug -ffmpeg -jack -libsamplerate -oss -speex" ABI_X86="(64) -32 (-x32)"
[blocks B      ] media-plugins/alsa-plugins ("media-plugins/alsa-plugins" is blocking media-video/pipewire-0.3.30-r2)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (media-plugins/alsa-plugins-1.2.2:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=media-plugins/alsa-plugins-1.0.27-r1[pulseaudio,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=media-plugins/alsa-plugins-1.0.27-r1[pulseaudio,abi_x86_64(-)]) required by (media-sound/pulseaudio-13.0-r1:0/0::gentoo, installed) USE="X alsa alsa-plugin asyncns bluetooth caps dbus elogind gdbm glib gtk ipv6 orc qt5 ssl tcpd udev webrtc-aec -doc -equalizer -gconf -jack -libsamplerate -lirc -native-headset -ofono-headset (-oss) -realtime (-selinux) -sox (-system-wide) -systemd -test -zeroconf" ABI_X86="(64) -32 (-x32)"

  (media-video/pipewire-0.3.30-r2:0/0.3::gentoo, installed) pulled in by
    media-video/pipewire required by @selected


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


Cambiato quote con code che almeno mantiene le tabulazioni/spazi come da output -- fedeliallalinea
Back to top
View user's profile Send private message
fedeliallalinea
Administrator
Administrator


Joined: 08 Mar 2003
Posts: 27276
Location: here

PostPosted: Thu Sep 30, 2021 5:21 am    Post subject: Reply with quote

Non conosco pipewire ma se do un'occhiata all'ebuild dice
Code:
        pipewire-alsa? (
                >=media-libs/alsa-lib-1.1.7[${MULTILIB_USEDEP}]
                || (
                        media-plugins/alsa-plugins[-pulseaudio]
                        !media-plugins/alsa-plugins
                )
        )
        !pipewire-alsa? ( media-plugins/alsa-plugins[${MULTILIB_USEDEP},pulseaudio] )

Quindi o installi pipewire disabilitando la use flag pipewire-alsa o lo installi con questa abilitata ma disabilitando la use flag pulseaudio da media-plugins/alsa-plugins.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
GianGian2387
Tux's lil' helper
Tux's lil' helper


Joined: 03 Jun 2021
Posts: 80

PostPosted: Thu Sep 30, 2021 6:25 am    Post subject: Reply with quote

La use flag pipewire-Alsa l’ho abilitata, per media-plugins/alsa-plugins, era questo “pacchetto”? A causarmi conflitti con nemo, l’ho disinstallato per poter installare pipewire, se lo vado a reinstallare credo che il sistema tornerebbe muto.

Last edited by GianGian2387 on Thu Sep 30, 2021 6:27 am; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Administrator
Administrator


Joined: 08 Mar 2003
Posts: 27276
Location: here

PostPosted: Thu Sep 30, 2021 6:27 am    Post subject: Reply with quote

GianGian2387 wrote:
La use flag pipewire-Alsa l’ho abilitata, per l’altra cosa che hai detto non saprei come fare

Se vuoi disabilitare una use flag a un pacchetto dovresti usare /etc/portage/package.use
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
GianGian2387
Tux's lil' helper
Tux's lil' helper


Joined: 03 Jun 2021
Posts: 80

PostPosted: Thu Sep 30, 2021 6:31 am    Post subject: Reply with quote

Quindi dovrei scrivere nel file: media-plugins/alsa-plugins per disabilitare alsa-plugins?
Back to top
View user's profile Send private message
fedeliallalinea
Administrator
Administrator


Joined: 08 Mar 2003
Posts: 27276
Location: here

PostPosted: Thu Sep 30, 2021 6:32 am    Post subject: Reply with quote

No devi disabilitare pulseaudio a alsa-plugin quindi scrivi
Code:
media-plugins/alsa-plugins -pulseaudio

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
GianGian2387
Tux's lil' helper
Tux's lil' helper


Joined: 03 Jun 2021
Posts: 80

PostPosted: Thu Sep 30, 2021 7:30 am    Post subject: Reply with quote

Stavo rileggendo la guida per l'installazione di pipewire e ho visto questo paragrafo (mi è sfuggito la prima volta):

Quote:
To have PipeWire to act as a PulseAudio user daemon/server, un-comment the "/usr/bin/pipewire" = { args = "-c pipewire-pulse.conf" } line in the main configuration file:

FILE /etc/pipewire/pipewire.conf
context.exec = {
#<program-name> = { [ args = "<arguments>" ] }
#
# Execute the given program with arguments.
#
# Start the session manager. Run the session manager with -h for
# options.
#
"/usr/bin/pipewire-media-session" = { args = "" }
#
# You can optionally start the pulseaudio-server here as well
# but it better to start it as a systemd service.
# It can be interesting to start another daemon here that listens
# on another address with the -a option (eg. -a tcp:4713).
"/usr/bin/pipewire" = { args = "-c pipewire-pulse.conf" }
}
To enable PulseAudio handling within the media session daemon without copying all of /usr/share/pipewire into /etc/pipewire, create /etc/pipewire/media-session.d/with-pulseaudio:

root #touch /etc/pipewire/media-session.d/with-pulseaudio
For details and other features that can be enabled, review /etc/pipewire/media-session.d/media-session.conf.


La domanda è: se configuro così risolverei il problema?
Back to top
View user's profile Send private message
fedeliallalinea
Administrator
Administrator


Joined: 08 Mar 2003
Posts: 27276
Location: here

PostPosted: Thu Sep 30, 2021 8:15 am    Post subject: Reply with quote

GianGian2387 wrote:
La domanda è: se configuro così risolverei il problema?

No, nel senso che il problema di use flag rimarrà. Ora come devi impostare le use flag lo ignoro visto che non conosco pipewire.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
GianGian2387
Tux's lil' helper
Tux's lil' helper


Joined: 03 Jun 2021
Posts: 80

PostPosted: Thu Sep 30, 2021 3:07 pm    Post subject: Reply with quote

se da terminale do nano /etc/portage/package.use mi dice che è una directory, se mi dirigo verso quella directory e scrivo media-plugins.... mi dice file o directory non esistente... se do echo media-plugins.. mi risponde ripostandomi lo stesso nome, se do il comando per aggiornare le use flag ricevo l'errore solito... come devo fare?
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 870

PostPosted: Thu Sep 30, 2021 4:12 pm    Post subject: Reply with quote

se "package.use" è una directory allora al suo interno puoi utilizzare dei files

crea un file "alsa-plugins" (il nome è arbitrario , ma può servire per riconoscere i vari pacchetti con le loro useflag)

ed inserisci il contenuto sopra indicato
Code:
media-plugins/alsa-plugins -pulseaudio


oppure , all'interno della directory esegui :
Code:
echo "media-plugins/alsa-plugins -pulseaudio" > alsa-plugins


(che significa tramite il comando echo di redirigere il contenuto tra virgolette ad un file di nome "alsa-plugins"
_________________
BOINC ed il calcolo distribuito

My LRecoverySystem Repo
Back to top
View user's profile Send private message
GianGian2387
Tux's lil' helper
Tux's lil' helper


Joined: 03 Jun 2021
Posts: 80

PostPosted: Thu Sep 30, 2021 5:58 pm    Post subject: Reply with quote

dato echo "media-plugins/alsa-plugins -pulseaudio" > alsa-plugins, ho poi dato il comando per l'aggiornamento delle USEflag
ricevo:
Quote:
entoo ~ # emerge --update --newuse --deep --with-bdeps=y @world
Calculating dependencies... done!
[ebuild N ] media-plugins/alsa-plugins-1.2.2 USE="mix pulseaudio usb_stream -arcam_av -debug -ffmpeg -jack -libsamplerate -oss -speex" ABI_X86="(64) -32 (-x32)"
[blocks B ] media-plugins/alsa-plugins ("media-plugins/alsa-plugins" is blocking media-video/pipewire-0.3.30-r2)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(media-plugins/alsa-plugins-1.2.2:0/0::gentoo, ebuild scheduled for merge) pulled in by
>=media-plugins/alsa-plugins-1.0.27-r1[pulseaudio,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=media-plugins/alsa-plugins-1.0.27-r1[pulseaudio,abi_x86_64(-)]) required by (media-sound/pulseaudio-13.0-r1:0/0::gentoo, installed) USE="X alsa alsa-plugin asyncns bluetooth caps dbus elogind gdbm glib gtk ipv6 orc qt5 ssl tcpd udev webrtc-aec -doc -equalizer -gconf -jack -libsamplerate -lirc -native-headset -ofono-headset (-oss) -realtime (-selinux) -sox (-system-wide) -systemd -test -zeroconf" ABI_X86="(64) -32 (-x32)"

(media-video/pipewire-0.3.30-r2:0/0.3::gentoo, installed) pulled in by
media-video/pipewire required by @selected


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages
Back to top
View user's profile Send private message
fedeliallalinea
Administrator
Administrator


Joined: 08 Mar 2003
Posts: 27276
Location: here

PostPosted: Fri Oct 01, 2021 5:50 am    Post subject: Reply with quote

Strano, cosa torna il comando grep -r pulseaudio /etc/portage/package.use?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
GianGian2387
Tux's lil' helper
Tux's lil' helper


Joined: 03 Jun 2021
Posts: 80

PostPosted: Fri Oct 01, 2021 8:09 pm    Post subject: Reply with quote

ho modificato le use flag, togliendo pipewire-alsa, sono riuscito a fare l'aggiornamento senza riscontrare errori! ora però l'audio risulta ovattato (ho provato le casse su di un altro dipsositivo e funzionano bene), appena possibile proverò a disinstallare pipewire e alsa-plugins e reinstallare il tutto, vediamo se risolvo così.
Back to top
View user's profile Send private message
GianGian2387
Tux's lil' helper
Tux's lil' helper


Joined: 03 Jun 2021
Posts: 80

PostPosted: Mon Oct 04, 2021 12:14 pm    Post subject: Reply with quote

Quote:
grep -r pulseaudio /etc/portage/package.use
/etc/portage/package.use/alsa-plugins:media-plugins/alsa-plugins -pulseaudio
/etc/portage/package.use/zz-autounmask:# required by media-sound/pulseaudio-13.0-r1::gentoo[alsa-plugin,alsa]
/etc/portage/package.use/zz-autounmask:>=media-plugins/alsa-plugins-1.2.2 pulseaudio
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 870

PostPosted: Mon Oct 04, 2021 8:45 pm    Post subject: Reply with quote

Il povero portage non si capisce perchè per alsa-plugins da una parte abiliti pulseauio e dall'altra lo disabiliti
Code:
/etc/portage/package.use/zz-autounmask:>=media-plugins/alsa-plugins-1.2.2 pulseaudio


/etc/portage/package.use/zz-autounmask:>=media-plugins/alsa-plugins-1.2.2 pulseaudio
/etc/portage/package.use/alsa-plugins:media-plugins/alsa-plugins -pulseaudio

decidi cosa vuoi fare.
_________________
BOINC ed il calcolo distribuito

My LRecoverySystem Repo
Back to top
View user's profile Send private message
GianGian2387
Tux's lil' helper
Tux's lil' helper


Joined: 03 Jun 2021
Posts: 80

PostPosted: Mon Oct 04, 2021 9:45 pm    Post subject: Reply with quote

Scusa, non ho capito cosa vorresti dire... Vorrei risolvere l'errore che ricevo quando aggiorno le use flag, fino ad ora ho seguito le indicazioni che mi avete dato in questo tred (togliendo la prova che ho fatto di togliere pipewire-alsa dalle use flag), ora non riesco proprio a capire dove sia l'errore
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum