Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Update-Probleme auf python3.9
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
BastiL
n00b
n00b


Joined: 15 Aug 2004
Posts: 35

PostPosted: Thu Jul 08, 2021 8:54 am    Post subject: Update-Probleme auf python3.9 Reply with quote

Hallo zusammen,

mein System scheint Python-Technisch durcheinander. Ich bekomme kein Python-Paket mehr aktualisiert. Es gibt eine Vielzahl von Abhängigkeits-Konflikten in der folgenden Form:
Code:

emerge -avuND world

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/python-exec:2

  (dev-lang/python-exec-2.4.8:2/2::gentoo, ebuild scheduled for merge) USE="(native-symlinks) -test" ABI_X86="(64)" PYTHON_TARGETS="(pypy3) (python3_10) (python3_8) (python3_9)" pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-lang/python-exec-2.4.6-r3:2/2::gentoo, installed) USE="(native-symlinks)" ABI_X86="(64)" PYTHON_TARGETS="(pypy3) python2_7 python3_6 python3_7 (python3_8) (python3_9)" pulled in by
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_6(-),python_targets_python3_7(-),python_targets_python3_8(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (virtual/python-backports_abc-0:0/0::gentoo, installed) USE="" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 python3_7 python3_8"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                 
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_6(-),python_targets_python3_7(-),python_targets_python3_8(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (virtual/python-singledispatch-0:0/0::gentoo, installed) USE="" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 python3_7 python3_8 -pypy3"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                           
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_6(-),python_targets_python3_7(-),python_targets_python3_8(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (virtual/python-pathlib-1.0:0/0::gentoo, installed) USE="" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 python3_7 python3_8 -pypy3"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                     
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7] required by (sys-devel/clang-7.1.0:7/7.1::gentoo, installed) USE="static-analyzer xml -abi_riscv_lp64 -abi_riscv_lp64d -debug -default-compiler-rt -default-libcxx -doc -test -z3" ABI_X86="32 (64) (-x32)" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARM -Hexagon -Lanai -MSP430 -Mips -PowerPC -Sparc -SystemZ -XCore" PYTHON_SINGLE_TARGET="python2_7"
                                  ^^^^^^^^^^^^^^^^^^^^^^^^                                                                                                                                                                                                                                       


Ich habe das folgende gefunden, und deshalb alle "Python-Einträge" aus /etc/portage/make.conf gelöscht:
https://www.gentoo.org/support/news-items/2021-05-05-python3-9.html

Wie kann ich das Problem angehen?
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2938
Location: Frankfurt, Germany

PostPosted: Thu Jul 08, 2021 10:15 am    Post subject: Reply with quote

Quote:
und deshalb alle "Python-Einträge" aus /etc/portage/make.conf gelöscht:

Das ist schon mal gut. Vor ein paar Jahren wurde geöegentlich empfohlen, Einträge zu PYTHON_TARGETS und PYTHON_SINGLE_TARGET in die make.conf oder package.use zu schreiben - aber das ist keine gute Idee ist. Am besten ist es, diese Einträge zu entfernen und emerge/portage einfach machen zu lassen...

Bitte poste die Ausgabe von
Code:
emerge --info

Was hat es mit "clang-7.1.0:7" auf sich? Ist das auf Deinem System installiert? Warum? Es ist veraltet! Aktuell ist Version 12... Kannst Du clang-7 löschen? Oder wird es von einem anderen Paket reingezogen?
Back to top
View user's profile Send private message
BastiL
n00b
n00b


Joined: 15 Aug 2004
Posts: 35

PostPosted: Thu Jul 08, 2021 11:12 am    Post subject: Reply with quote

mike155 wrote:

Bitte poste die Ausgabe von
Code:
emerge --info

Was hat es mit "clang-7.1.0:7" auf sich? Ist das auf Deinem System installiert? Warum? Es ist veraltet! Aktuell ist Version 12... Kannst Du clang-7 löschen? Oder wird es von einem anderen Paket reingezogen?


Sah nicht so aus als ob clang-7 noch nötig wäre, habe es gelöscht. Wird wohl standardmäßig auch in mehreren Versionen vorgehalten.

Code:

emerge --info
Portage 3.0.19 (python 3.7.10-final-0, default/linux/amd64/17.1/desktop, gcc-9.2.0, glibc-2.33-r1, 5.11.11-gentoo x86_64)
=================================================================
System uname: Linux-5.11.11-gentoo-x86_64-AMD_Ryzen_5_3500U_with_Radeon_Vega_Mobile_Gfx-with-gentoo-2.7
KiB Mem:    14326976 total,    688068 free
KiB Swap:    8388604 total,   8387324 free
Head commit of repository gentoo: 91dbfa4e7b5fb672ac0db32f99ea5905542d2e17

sh bash 5.1_p8
ld GNU ld (Gentoo 2.34 p6) 2.34.0
app-shells/bash:          5.1_p8::gentoo
dev-java/java-config:     2.3.1::gentoo
dev-lang/perl:            5.34.0::gentoo
dev-lang/python:          2.7.18_p10::gentoo, 3.6.13_p5::gentoo, 3.7.10_p6::gentoo, 3.8.10_p2::gentoo, 3.9.5_p2::gentoo, 3.10.0_beta3::gentoo
dev-lang/rust:            1.53.0::gentoo
dev-util/cmake:           3.20.4::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.7-r3::gentoo
sys-apps/sandbox:         2.24::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r5::gentoo, 2.71::gentoo
sys-devel/automake:       1.11.6-r3::gentoo, 1.13.4-r2::gentoo, 1.16.3-r1::gentoo
sys-devel/binutils:       2.34-r2::gentoo, 2.35.2::gentoo, 2.36.1-r1::gentoo
sys-devel/gcc:            9.2.0-r4::gentoo, 9.3.0-r2::gentoo, 10.3.0-r1::gentoo, 11.1.0-r1::gentoo
sys-devel/gcc-config:     2.4::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.3::gentoo
sys-kernel/linux-headers: 5.12::gentoo (virtual/os-headers)
sys-libs/glibc:           2.33-r1::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: git
    sync-uri: https://github.com/gentoo/gentoo.git
    priority: -1000

bombo82
    location: /var/lib/layman/bombo82
    masters: gentoo
    priority: 50

vifino-overlay
    location: /var/lib/layman/vifino-overlay
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.4/ext-active/ /etc/php/apache2-php8.0/ext-active/ /etc/php/cgi-php7.4/ext-active/ /etc/php/cgi-php8.0/ext-active/ /etc/php/cli-php7.4/ext-active/ /etc/php/cli-php8.0/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
ENV_UNSET="CARGO_HOME DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs binpkg-multi-instance config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/ http://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/ ftp://mirror.netcologne.de/gentoo/"
LANG="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de"
MAKEOPTS="-j7"
PKGDIR="/var/cache/binpkgs"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 bluetooth bluetoothi branding bzip2 cairo cdda cdr cli crypt cups dbus dri dts dvd dvdr emboss encode examples exif fbcondecoder ffmpeg flac fortran gdbm gif gpm gui iconv icu ipv6 jpeg lcms libglvnd libnotify libtirpc mad mng mp3 mp4 mpeg mpi mtp multilib ncurses networkmanager nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds pulseaudio python qt5 readline sddm sdl seccomp spell split-usr ssl startup-notification svg systemd tcpd tiff truetype udev udisks unicode upower usb v4l vorbis wayland wxwidgets x264 xattr xcb xml xv xvid zlib" ABI_X86="32 64" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" L10N="de" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LUA_SINGLE_TARGET="lua5-1" LUA_TARGETS="lua5-1" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-3 php7-4" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_9" PYTHON_TARGETS="python3_9" RUBY_TARGETS="ruby25 ruby26 ruby27 ruby30" USERLAND="GNU" VIDEO_CARDS="amdgpu radeonsi" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq proto steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, RUSTFLAGS


Aktuell hat alles von mir eingesetzte Python-3.7. Die Python 2.7 kann ich aus meiner Sicht weitgehend entbehren, aber es gibt ja wohl noch ein paar Abhängigkeiten, z.B. firefox.
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2938
Location: Frankfurt, Germany

PostPosted: Thu Jul 08, 2021 1:53 pm    Post subject: Reply with quote

Okay, die Python Targets sehen jetzt gut aus:
Code:
PYTHON_SINGLE_TARGET="python3_9" PYTHON_TARGETS="python3_9"

Bei Dir sind aber viel zu viele Python-Versionen installiert:
Code:
2.7.18_p10::gentoo, 3.6.13_p5::gentoo, 3.7.10_p6::gentoo, 3.8.10_p2::gentoo, 3.9.5_p2::gentoo, 3.10.0_beta3::gentoo

Entweder hast Du zu selten "emerge --depclen" aufgerufen - oder Du hast unerwünschte Einträge in /var/lib/portage/world.

Bitte schaue in "/var/lib/portage/world" nach, ob da Python-Einträge stehen - und lösche diese, falls es nicht einen expliziten Grund gibt, warum Du sie installiert haben möchtest. Das gleiche kannst Du bei der Gelegenheit auch für gcc machen.

Grundsätzlich sollten in "/var/lib/portage/world" keine Pakete stehen,
  • die Teil von @system sind
  • die nur installiert sind, weil sie von anderen Paketen reingezogen werden und die man nicht explizit installiert haben will
Hintergrund: manchmal vergisst man die Option "--oneshot" bei emerge. Dann werden Pakete nach "/var/lib/portage/world" geschrieben, die dort nicht rein sollten. Deshalb: aufräumen!

Firefox braucht übrigens kein Python 2.7 mehr.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 4045
Location: Germany

PostPosted: Thu Jul 08, 2021 2:57 pm    Post subject: Reply with quote

Jo, so wird es vom Paketmanager nach einem @world Update auch empfohlen :)
Code:
 * After world updates, it is important to remove obsolete packages with
 * emerge --depclean. Refer to `man emerge` for more information.
Back to top
View user's profile Send private message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3294
Location: Berlin

PostPosted: Thu Jul 08, 2021 6:35 pm    Post subject: Reply with quote

Bei mir hat geholfen, nachdem ich alle entsprechenden Einträge entfernt hatte:
Code:
emerge -uDNtv world --autounmask-write --autounmask-backtrack=y --autounmask=y --backtrack=100 && emerge depclean
Ist möglicherweise nicht der richtige Weg, aber das Ergebnis war bei mir zufriedenstellend.
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2322
Location: Germany

PostPosted: Thu Jul 08, 2021 8:19 pm    Post subject: Reply with quote

Die besseren Ansätze von Josef.95 und flammenflitzer, solltest du zuerst verwenden denn die machen es ordentlich.

Wenn du aber wenig Zeit hast alles neu zu bauen kannst du das auch in Teile zerlegen, und diese Teilpakete aktuallisieren.

Ich hatte mit dev-lang/python-exec auch einige Probleme.

Wenn du dich vergewisserst das du unter folgendem Verzeichnis:

Code:
$ ls /usr/lib/python-exec/
python-exec2  python2.7  python3.6  python3.7  python3.8  python3.9


Mehrere Versionen hast die auch noch ein Backup von emerge haben, also gesetz dem Fall du hast auch ein python3.8 oder ein python3.9 installiert.

Kannst du das Paket einfach entfernen musst das dann aber mit dem emerge von dort erneut installieren weil dein emerge unter /usr/bin/ in dem Moment fehlt:

Code:
# ls -lah /usr/lib/python-exec/python3.9/emerge
-rwxr-xr-x 1 root root 2,7K 28. Jun xx:xx /usr/lib/python-exec/python3.9/emerge
# emerge -C dev-lang/python-exec
    ..
    ..
    ..
# /usr/lib/python-exec/python3.9/emerge -1 python-exec


Das hatte ich auch bei diversen Paketen die ein Python-Problem hatten, obwohl python-exec installiert war und die Abhängigkeiten von der Library ebenfalls.
Libdrm wollte zum beispiel nicht, erst nachdem ich python-exec mit einem Update versehen hab und die Grafikkarten-Treiber noch mal neu gebaut. Dann wollte auch libdrm.

Generell ist ein World Update besser. Aber aus Zeitgründen, teile ich es lieber in Schritte (mit z.B. --exclude llvm) auf und schließe aufwendige Pakte aus, wie llvm, clang oder Webkit und Co, da hilft es aber zu wissen wie Grob die Abhängigkeiten zusammen hängen.

Dein CLANG fragt nach python2_7, aber clang-7.1.0 ist schon ziemlich alt und nicht mehr im Tree. Ein Update davon hilft, braucht aber auch lange zum compilieren. ;)

Der Weg ist aber Dirty. Bestehende installierte Pakete die mit python2_7 gebaut waren fragen halt so lange danach, bis du die runter wirfst oder aktuallisierst. Zuvor solltest du sicher gehen das du halt schon eine höhere Python-Version instaliert hast und wichtige Pakete wie Portage, schon aktuellere Python Versionen unterstützen:

Quote:
[I] sys-apps/portage
Verfügbare Versionen: 3.0.18^t ~3.0.19^t 3.0.20-r6^t **9999*l^t {apidoc build doc gentoo-dev +ipc +native-extensions +rsync-verify selinux test xattr KERNEL="linux" PYTHON_TARGETS="pypy3 python3_10 python3_8 python3_9"}
Installierte Versionen: 3.0.20-r6^t(xx:xx:xx xx.xx.2021)(ipc native-extensions rsync-verify xattr -apidoc -build -doc -gentoo-dev -selinux -test KERNEL="linux" PYTHON_TARGETS="python3_8 python3_9 -pypy3 -python3_10")


Das World Update sollte man nicht auf die lange Bank schieben.

Wenn du dir sicher bist das du nicht noch eine Anwengung hast die ein python 2.7 benötigt, ich hab es leider bei manchen Fremd-Skripten die nicht in Portage sind, dann kannst du python2.7 aus der Make.conf austragen und es entfernen mit:

Code:
# emereg -C =dev-lang/python-2.7.18_p10


Klar jammern dann einige Pakete und wollen es wieder rien ziehen, doch wenn du die aktuallisierst, fragen sie nicht mehr danach, bis auf wenige die ausschließlich python2.7 benötigen, auf die kannst du aber wahrscheinlich verzichten.

Aber ich bin auch ein Chaot und mache gerne Dinge kaputt, damit ich verstehe wie sie funktioniren. ;D
Ich kann aber berichten das Gentoo/Linux wirklich sehr robust ist, selbst wenn man von X11 auf einen Mix aus Wayland und X11 wechselt.

Für die Python Sache, ein ganz ganz großes Lob an Michał Górny (mgorny), an dieser Stelle!
Back to top
View user's profile Send private message
BastiL
n00b
n00b


Joined: 15 Aug 2004
Posts: 35

PostPosted: Fri Jul 09, 2021 1:03 pm    Post subject: Reply with quote

Ich habe den Vorschlag von mike155 beherzigt und mein world-File aufgeräumt. Dort steht jetzt nur noch python3.9.

Anschließend habe ich nach dem Vorschlag von flammenflitzer versucht das System zu aktualisieren:
Code:

emerge -uDNtv world --autounmask-write --autounmask-backtrack=y --autounmask=y --backtrack=100

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/python-exec:2

  (dev-lang/python-exec-2.4.8:2/2::gentoo, ebuild scheduled for merge) USE="(native-symlinks) -test" ABI_X86="(64)" PYTHON_TARGETS="(pypy3) (python3_10) (python3_8) (python3_9)" pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-lang/python-exec-2.4.6-r3:2/2::gentoo, installed) USE="(native-symlinks)" ABI_X86="(64)" PYTHON_TARGETS="(pypy3) python2_7 python3_6 python3_7 (python3_8) (python3_9)" pulled in by
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_6(-),python_targets_python3_7(-),python_targets_python3_8(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (virtual/python-backports_abc-0:0/0::gentoo, installed) USE="" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 python3_7 python3_8"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                 
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_6(-),python_targets_python3_7(-),python_targets_python3_8(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (virtual/python-pathlib-1.0:0/0::gentoo, installed) USE="" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 python3_7 python3_8 -pypy3"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                     
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_6(-),python_targets_python3_7(-),python_targets_python3_8(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (virtual/python-singledispatch-0:0/0::gentoo, installed) USE="" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 python3_7 python3_8 -pypy3"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                           
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_6(-),python_targets_python3_7(-),python_targets_python3_8(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (virtual/python-ipaddress-1.0-r1:0/0::gentoo, installed) USE="" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 python3_7 python3_8 -pypy3"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                           
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_6(-),python_targets_python3_7(-),python_targets_python3_8(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (virtual/python-enum34-2:0/0::gentoo, installed) USE="" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 python3_7 python3_8 -pypy3"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                   
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_6(-),python_targets_python3_7(-),python_targets_python3_8(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (virtual/python-typing-0-r1:0/0::gentoo, installed) USE="" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 python3_7 python3_8 -pypy3"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                     
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_6(-),python_targets_python3_7(-),python_targets_python3_8(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (virtual/python-futures-1:0/0::gentoo, installed) USE="" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 python3_7 python3_8 -pypy3"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                   

media-gfx/imagemagick:0

  (media-gfx/imagemagick-7.1.0.2:0/7.1.0-0::gentoo, ebuild scheduled for merge) USE="X bzip2 cxx jpeg lcms openmp pango perl png svg tiff truetype xml zlib -corefonts -djvu -fftw -fontconfig -fpx -graphviz -hdri -heif -jbig -jpeg2k -lqr -lzma -opencl -openexr -postscript -q32 -q8 -raw -static-libs -test -webp -wmf -zip" ABI_X86="(64)" pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (media-gfx/imagemagick-7.0.11.13:0/7.0.11-0::gentoo, installed) USE="X bzip2 cxx jpeg lcms openmp pango perl png svg tiff truetype xml zlib -corefonts -djvu -fftw -fontconfig -fpx -graphviz -hdri -heif -jbig -jpeg2k -lqr -lzma -opencl -openexr -postscript -q32 -q8 -raw -static-libs -test -webp -wmf" ABI_X86="(64)" pulled in by
    media-gfx/imagemagick:0/7.0.11-0= required by (media-video/dvdauthor-0.7.2-r2:0/0::gentoo, installed) USE="imagemagick -graphicsmagick" ABI_X86="(64)"
                         ^^^^^^^^^^^^                                                                                                                                                                                                                 

dev-libs/icu:0

  (dev-libs/icu-69.1:0/69.1::gentoo, ebuild scheduled for merge) USE="examples -debug -doc -static-libs" ABI_X86="32 (64) (-x32)" pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/icu-68.2:0/68.2::gentoo, installed) USE="examples -debug -doc -static-libs" ABI_X86="32 (64) (-x32)" pulled in by
    >=dev-libs/icu-60.2:0/68.2= required by (net-libs/webkit-gtk-2.32.1:4/37::gentoo, installed) USE="X egl examples geolocation gstreamer introspection jpeg2k jumbo-build libnotify opengl (seccomp) spell systemd wayland (-aqua) -gamepad -gles2-only -gnome-keyring -gtk-doc -test" ABI_X86="(64)"
                       ^^^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                           
    (and 4 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


emerge: there are no ebuilds to satisfy "dev-libs/boost:0/1.74.0=".
(dependency required by "dev-util/mdds-1.7.0::gentoo" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


Ich habe auch versucht, python-exec isoliert neu zu bauen aber das funktioniert auch nicht.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 4045
Location: Germany

PostPosted: Fri Jul 09, 2021 3:43 pm    Post subject: Reply with quote

Versuche mal bitte diese alten Leichen zu entfernen:
Code:
emerge -avc virtual/python-backports_abc virtual/python-pathlib virtual/python-singledispatch virtual/python-ipaddress virtual/python-enum34 virtual/python-typing

Das sind alles Pakete die es schon seit langer Zeit nicht mehr im tree gibt, und dessen deps auch nicht mehr aufgelöst werden können.
(ja, sowas passiert wenn man kein depclean nutzt)

Und dann ein:
Code:
emerge -avuDN @world --backtrack=100
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2938
Location: Frankfurt, Germany

PostPosted: Fri Jul 09, 2021 4:11 pm    Post subject: Reply with quote

BastiL wrote:
Ich habe den Vorschlag von mike155 beherzigt und mein world-File aufgeräumt. Dort steht jetzt nur noch python3.9.

Auch Python 3.9 gehört nicht ins World-File! Es stört zwar zurzeit nicht, aber es wird Ärger beim nächsten Update geben!

Versuche, Dein World-File so klein wie möglich zu halten!

In der Datei sollten wirklich nur die Pakete stehen, die Du explizit installiert haben möchtest. Alles, was über Abhängigkeiten installiert wird, gehört sehr wahrscheinlich nicht dort rein. Wenn dort Pakete mit Versionsnummer stehen, gehören die sehr wahrscheinlich auch nicht dorthin.

Stell Dir vor, dass Dein System wieder läuft, also "emerge --update --deep --changed-use @world" und "emerge --depclean" sauber durchlaufen. Alle Einträge, die Du jetzt aus dem World-File löschen kannst, ohne dass ein darauf folgendes "emerge --depclean" etwas löscht, solltest Du entfernen!

Man kann das auch einfach ausprobieren: Kopie vom World-File anlegen, verdächtige Einträge löschen, "emerge --depclean --pretend" aufrufen. Wenn emerge etwas löschen will, was man noch haben will, hat man zu viel oder die falschen Einträge gelöscht. Also: Kopie wieder zurückkopieren und weiter probieren...

Vermutlich solltest Du auch häufiger die Emerge-Option "--oneshot" bzw. "-1" verwenden, insbesondere beim Beheben von Problemen. Die bewirkt nämlich, dass die angegebenen Pakete nicht ins World-File geschrieben werden. Der Klassiker ist, dass ein Paket (z.B. glibc) nicht sauber installiert wird. Also installiert man glibc von Hand: "emerge glibc". Und weil man "--oneshot" vergessen hat, wird "glibc" ins World-File geschrieben. Was aber völlig verkehrt ist, weil es dort nicht reingehört. Ausnahme: man ist glibc Entwickler und will eine bestimmte Version wirklich und dauerhaft auf seinem System installiert haben.
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4657

PostPosted: Sat Jul 10, 2021 1:37 pm    Post subject: Reply with quote

Habt ihr den entsprechenden news eintrag vergessen?

2021-05-05-python3-9 "Python 3.9 to become the default on 2021-06-01"

Da wird ein vorgehen beschrieben wie man dieses Problem lösen kann.

Ich bin in ein ähnliches Problem gerannt als ich mein system aktualisierte (letzte woche), welches seit einigen Monaten nicht aktualisiert wurde.
In meiner make.conf waren die Einträge für PYTHON_SINGLE_TARGET und PYTHON_TARGETS nicht vorhanden.

ALs ich den enstprechenden new eintrag durchlas bin ich auf folgenden Abschnitt gestoßen:
Quote:

Safer upgrade procedure
=======================
A safer approach is to add Python 3.9 support to your system first,
and only then remove Python 3.8. However, note that involves two
rebuilds of all the affected packages, so it will take noticeably
longer.

First, enable both Python 3.8 and Python 3.9, and then run the upgrade
commands:

*/* PYTHON_TARGETS: -* python3_8 python3_9
*/* PYTHON_SINGLE_TARGET: -* python3_8

Then switch PYTHON_SINGLE_TARGET and run a second batch of upgrades:

*/* PYTHON_TARGETS: -* python3_8 python3_9
*/* PYTHON_SINGLE_TARGET: -* python3_9

Finally, switch to the final version and upgrade:

*/* PYTHON_TARGETS: -* python3_9
*/* PYTHON_SINGLE_TARGET: -* python3_9

You may wish to remove the target overrides after the defaults switch.
Alternatively, you can keep them to block the next automatic upgrade
to Python 3.10, and upgrade manually then.


Im meinem Falle hat es gereicht temporär PYTHON_TARGETS in der make.conf zu setzen:

Quote:
PYTHON_TARGETS="python3_8 python3_9"


Damit lief dann das world update sauber durch. Danach hab ich den eintrag wieder entfernt und noch ein world update (emerge -1vUD @world) gestartet um alle pakete neu zu bauen ohne python 3.8 support.

Und am schluss ein depclean run um python 3.8 komplett los zu werden.

@Bastil: Unabhängig davon solltest du dein world file, wie mike155 schon beschrieben hat, säubern
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
BastiL
n00b
n00b


Joined: 15 Aug 2004
Posts: 35

PostPosted: Tue Jul 13, 2021 7:58 am    Post subject: Reply with quote

Bin den Vorschlägen gefolgt, was bleibt an Problemen:

Code:

emerge -avuDN @world --backtrack=100

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/python-exec:2

  (dev-lang/python-exec-2.4.8:2/2::gentoo, ebuild scheduled for merge) USE="(native-symlinks) -test" ABI_X86="(64)" PYTHON_TARGETS="(pypy3) (python3_10) (python3_8) (python3_9)" pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-lang/python-exec-2.4.6-r3:2/2::gentoo, installed) USE="(native-symlinks)" ABI_X86="(64)" PYTHON_TARGETS="(pypy3) python2_7 python3_6 python3_7 (python3_8) (python3_9)" pulled in by
    >=dev-lang/python-exec-2:2/2=[python_targets_python2_7(-),python_targets_python3_6(-),python_targets_python3_7(-),python_targets_python3_8(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-)] required by (virtual/python-futures-1:0/0::gentoo, installed) USE="" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 python3_7 python3_8 -pypy3"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                   

dev-libs/icu:0

  (dev-libs/icu-69.1:0/69.1::gentoo, ebuild scheduled for merge) USE="examples -debug -doc -static-libs" ABI_X86="32 (64) (-x32)" pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/icu-68.2:0/68.2::gentoo, installed) USE="examples -debug -doc -static-libs" ABI_X86="32 (64) (-x32)" pulled in by
    >=dev-libs/icu-51.2-r1:0/68.2=[abi_x86_32(-),abi_x86_64(-)] required by (media-libs/harfbuzz-2.8.1:0/0.9.18::gentoo, installed) USE="cairo glib graphite icu introspection truetype -debug -doc -static-libs -test" ABI_X86="32 (64) (-x32)"
                          ^^^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                         
    (and 3 more with the same problem)

Back to top
View user's profile Send private message
fedeliallalinea
Administrator
Administrator


Joined: 08 Mar 2003
Posts: 26761
Location: here

PostPosted: Tue Jul 13, 2021 8:29 am    Post subject: Reply with quote

Das Paket virtual/python-futures existiert nicht mehr im Repository Gentoo
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2938
Location: Frankfurt, Germany

PostPosted: Tue Jul 13, 2021 1:16 pm    Post subject: Reply with quote

@BastiL: steht auch virtual/python-futures in Deiner World-Datei? Das wäre dann ein weiterer Eintrag, der zu viel wäre...

Am besten wäre es, wenn Du das Paket einfach löscht:
Code:
emerge --unmerge virtual/python-futures


Was passiert dann, wenn Du
Code:
emerge -avuDN @world --backtrack=100

aufrufst?
Back to top
View user's profile Send private message
ChrisJumper
Advocate
Advocate


Joined: 12 Mar 2005
Posts: 2322
Location: Germany

PostPosted: Tue Jul 13, 2021 10:22 pm    Post subject: Reply with quote

Also ich schau mir immer diese Abhängigkeiten an, weil wir Menschen die manchmal besser einschätzen können als Portage.

Wenn da eine neuere Version im Tree ist, ist klar das sehr viele alte Pakete noch die alte haben wollen, wenn es für diese aber auch Updates gibt ist es sehr wahrscheinilch das ein Update sauber durch läuft.

Wenn mir die Pakete wichtig sind, in 99% sind es halt nur Abhängigkeiten von Teilpaketen, die ich verwende. Wenn da jetzt nicht eins bei ist, das ich in einer höheren Version nicht bekomme oder es nicht mehr im Support ist. Dann überlege ich mir natürich das Risiko veraltete Software zu haben. Calibre ist als Trödel-Paket so ein Beispiel. Welches ich aber auch schon mal lösche und dann zwei drei Wochen ohne auskommen muss. Aber ich brauche es auch nicht immer.

In deinem Fall löse ich die Blocks immer mit Unemerge und dann ein neu ziehen in der aktuellen Version. Es gibt so bekannte Abhängigkeiten wie icu zu webkit-gtk.. oder glibc zu gdbus-codegen, welche mich auch nur stören weil diese länger laufen oder mehr Strom verbrauchen.

Mit equery d sys-libs/glibc findest du zum Beispiel Pakete welche die glibc eingebaut haben und eventuell neu kompiliert werden müssen. Aber achtung, die Ausgabe bezieht sich auf unterschiedliche Versionen und Slots, und nicht jeder "mindestens Version 1", bedeutet das diese nicht die höhere Version auch nehmen können. Bei manchen Versionen ist da aber der Sprung ersichtlich, diese sind danna uch meistens in Slots, also verschiedenen Versionen installiert. Wie bei Python mit 2.x vs 3.9 oder 3.10 usw.

Damit bekommst du auch eine Einschätzung, welche Pakete du unbedingt neu bauen musst, wenn du glibc aktuallisert hast und ein Programm startet nicht mehr.. (weil es dieser Version beim Build brauchte), und noch gegen die alte Version gelinkt ist.

Neben der Befragung von equery d Paketname, geht auch ldd...

Code:
 # which which
/usr/bin/which
barkley /home/alice # ldd /usr/bin/which
        linux-vdso.so.1 (0x00007ffccf1c4000)
        libc.so.6 => /lib64/libc.so.6 (0x00007f262bd45000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f262bf12000)


Da siehst du auch welche Pakete beim Build aktive verlinkt wurden.

Code:
# equery b /lib64/libc.so.6
 * Searching for /lib64/libc.so.6 ...
sys-libs/glibc-2.33-r1 (/lib64/libc.so.6 -> libc-2.33.so)
sys-libs/glibc-2.33-r1 (/lib64/libc-2.33.so)

Hier auch am Beispiel von libc.so.6, wo du mit dem equery b Befehl sehen kannst zu welchem Paket die Datei gehört. equery ist in app-portage/gentoolkit enthalten.
Back to top
View user's profile Send private message
BastiL
n00b
n00b


Joined: 15 Aug 2004
Posts: 35

PostPosted: Wed Jul 14, 2021 3:04 pm    Post subject: Reply with quote

Ich habe python-futures deinstalliert. Anschließend bekomme ich einen Versionskonflikt mit icu, den ich durch maskieren von icu-69 gelöst habe.

Weiter geht es wie folgt:
Code:

dev-python/setuptools:0

  (dev-python/setuptools-57.1.0:0/0::gentoo, ebuild scheduled for merge) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python3_8 python3_9 -pypy3 -python3_10" pulled in by
    dev-python/setuptools[python_targets_python3_9(-)] required by (net-analyzer/net-snmp-5.9.1:0/40::gentoo, ebuild scheduled for merge) USE="X bzip2 ipv6 python ssl tcpd zlib -doc -elf -kmem -lm-sensors -mfd-rewrites -minimal -mysql -netlink -pcap -pci -perl -rpm (-selinux) -smux -ucd-compat" ABI_X86="(64)" PYTHON_SINGLE_TARGET="python3_9 -python3_8"
                                                                                                                                                                                                                                                                                                                                                                   
    dev-python/setuptools[python_targets_python3_9(-)] required by (dev-util/systemtap-4.5:0/0::gentoo, ebuild scheduled for merge) USE="ssl -libvirt (-selinux) -sqlite -test -zeroconf" ABI_X86="(64)" PYTHON_SINGLE_TARGET="python3_9 -python3_8"
                                                                                                                                                                                                                                                     
    dev-python/setuptools[python_targets_python3_9(-)] required by (dev-libs/libgusb-0.3.7:0/0::gentoo, installed) USE="introspection vala -gtk-doc -static-libs -test" ABI_X86="32 (64) (-x32)"
                                                                                                                                                                                                 
    dev-python/setuptools[python_targets_python3_9(-)] required by (sys-fs/btrfs-progs-5.12.1:0/0::gentoo, ebuild scheduled for merge) USE="convert python zstd -doc -reiserfs -static -static-libs" ABI_X86="(64)" PYTHON_SINGLE_TARGET="python3_9 -python3_8"
                                                                                                                                                                                                                                                               
    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?] required by (dev-python/jinja-3.0.1:0/0::gentoo, ebuild scheduled for merge) USE="examples -doc -test" ABI_X86="(64)" PYTHON_TARGETS="python3_9 -pypy3 -python3_10 -python3_8"
                                                                                                                                                                                                                                                                                                                                   
    >=dev-python/setuptools-42.0.2[python_targets_python3_8(-)?,python_targets_python3_9(-)?] required by (dev-util/scons-4.1.0-r1:0/0::gentoo, ebuild scheduled for merge) USE="-doc -test" ABI_X86="(64)" PYTHON_TARGETS="python3_9 -python3_8"
                                                                                                                                                                                                                                                 
    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?] required by (dev-python/bleach-3.3.0:0/0::gentoo, ebuild scheduled for merge) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python3_9 -pypy3 -python3_10 -python3_8"
                                                                                                                                                                                                                                                                                                                       
    >=dev-python/setuptools-42.0.2[python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?] required by (dev-python/m2crypto-0.38.0:0/0::gentoo, ebuild scheduled for merge) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python3_9 -python3_10 -python3_8"
                                                                                                                                                                                                                                                                                         
    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?] required by (dev-python/beautifulsoup-4.9.3:4/4::gentoo, ebuild scheduled for merge) USE="-doc -test" ABI_X86="(64)" PYTHON_TARGETS="python3_9 -pypy3 -python3_10 -python3_8"
                                                                                                                                                                                                                                                                                                                                   
    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?] required by (dev-python/imagesize-1.2.0:0/0::gentoo, ebuild scheduled for merge) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python3_9 -pypy3 -python3_10 -python3_8"
                                                                                                                                                                                                                                                                                                                         
    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?] required by (dev-python/olefile-0.46-r1:0/0::gentoo, ebuild scheduled for merge) USE="-doc -test" ABI_X86="(64)" PYTHON_TARGETS="python3_9 -pypy3 -python3_10 -python3_8"
.....


Gibt also ein Problem mit setuptools und auch setuptools-scm.
Back to top
View user's profile Send private message
fedeliallalinea
Administrator
Administrator


Joined: 08 Mar 2003
Posts: 26761
Location: here

PostPosted: Thu Jul 15, 2021 8:40 am    Post subject: Reply with quote

Sie sollten die gesamte Ausgabe von emerge posten.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
BastiL
n00b
n00b


Joined: 15 Aug 2004
Posts: 35

PostPosted: Thu Jul 15, 2021 3:02 pm    Post subject: Reply with quote

Die gesamte Ausgabe ist für das Forum offenbar deutlich zu lange. Kann ich eine Datei anhängen?
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 4045
Location: Germany

PostPosted: Thu Jul 15, 2021 3:27 pm    Post subject: Reply with quote

BastiL wrote:
Die gesamte Ausgabe ist für das Forum offenbar deutlich zu lange. Kann ich eine Datei anhängen?

Nee, nutze für so extrem langen Ausgaben am besten einen Paste-Service wie zb https://dpaste.com
oder und schau dazu auch im https://wiki.gentoo.org/wiki/Wgetpaste
und poste hier dann die URL
Back to top
View user's profile Send private message
BastiL
n00b
n00b


Joined: 15 Aug 2004
Posts: 35

PostPosted: Tue Jul 20, 2021 6:53 am    Post subject: Reply with quote

Gehe jetzt schrittweise vor und bin ein bisschen weiter gekommen. Jetzt hängt es an setuptools:

Code:

emerge -av1 setuptools --backtrack=100

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-python/certifi-10001-r1::gentoo [10001::gentoo] USE="-test" PYTHON_TARGETS="python3_8 python3_9* -pypy3 -python3_10% (-python2_7%*) (-python3_6%*) (-python3_7%*)" 0 KiB
[ebuild     U  ] dev-python/setuptools-57.1.0::gentoo [46.4.0-r3::gentoo] USE="-test" PYTHON_TARGETS="python3_8 python3_9* -pypy3 -python3_10% (-python2_7%*) (-python3_6%*) (-python3_7%*)" 2.094 KiB
[ebuild   R    ] dev-python/toml-0.10.2::gentoo  USE="-test" PYTHON_TARGETS="python3_8 python3_9* -pypy3 -python3_10 (-python3_7%*)" 0 KiB
[ebuild     U  ] dev-python/setuptools_scm-6.0.1-r1::gentoo [5.0.1::gentoo] USE="-test" PYTHON_TARGETS="python3_8 python3_9* -pypy3 -python3_10% (-python3_6%*) (-python3_7%*)" 51 KiB

Total: 4 packages (3 upgrades, 1 reinstall), Size of downloads: 2.144 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-python/setuptools:0

  (dev-python/setuptools-57.1.0:0/0::gentoo, ebuild scheduled for merge) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python3_8 python3_9 -pypy3 -python3_10" pulled in by
    dev-python/setuptools[python_targets_python3_9(-)] required by (dev-libs/libgusb-0.3.7:0/0::gentoo, installed) USE="introspection vala -gtk-doc -static-libs -test" ABI_X86="32 (64) (-x32)"
                                                                                                                                                                                                                                                                                                                                                                         
    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?] required by (dev-python/toml-0.10.2:0/0::gentoo, ebuild scheduled for merge) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python3_8 python3_9 -pypy3 -python3_10"
                                                                                                                                                                                                                                                                                                                                                                                                                                                       
    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?] required by (dev-python/setuptools_scm-6.0.1-r1:0/0::gentoo, ebuild scheduled for merge) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python3_8 python3_9 -pypy3 -python3_10"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                   
    dev-python/setuptools (Argument)

  (dev-python/setuptools-46.4.0-r3:0/0::gentoo, installed) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 python3_7 python3_8 -pypy3 -python3_9" pulled in by
    >=dev-python/setuptools-42.0.2[python_targets_python3_6(-),python_targets_python3_7(-),python_targets_python3_8(-),-python_single_target_pypy3(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-python/setuptools_scm-5.0.1:0/0::gentoo, installed) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python3_6 python3_7 python3_8 -pypy3 -python3_9"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                         
    >=dev-python/setuptools-39.2.0[python_targets_python3_7(-),python_targets_python3_8(-),-python_single_target_pypy3(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-python/pip-21.1.2:0/0::gentoo, installed) USE="-test -vanilla" ABI_X86="(64)" PYTHON_TARGETS="python3_7 python3_8 -pypy3 -python3_9"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                               
    dev-python/setuptools[python_targets_python3_7(-)] required by (net-analyzer/net-snmp-5.9.1:0/40::gentoo, installed) USE="X bzip2 ipv6 python ssl tcpd zlib -doc -elf -kmem -lm-sensors -mfd-rewrites -minimal -mysql -netlink -pcap -pci -perl -rpm (-selinux) -smux -ucd-compat" ABI_X86="(64)" PYTHON_SINGLE_TARGET="python3_7 -python3_8 -python3_9"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                           
    >=dev-python/setuptools-42.0.2[python_targets_python3_7(-),python_targets_python3_8(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-python/twisted-21.2.0:0/0::gentoo, installed) USE="crypt -conch -http2 -serial -test" ABI_X86="(64)" PYTHON_TARGETS="python3_7 python3_8 -python3_9"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                     
    >=dev-python/setuptools-42.0.2[python_targets_python3_7(-),python_targets_python3_8(-),-python_single_target_pypy3(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-python/sphinx-4.0.2:0/0::gentoo, installed) USE="-doc -latex -test" ABI_X86="(64)" PYTHON_TARGETS="python3_7 python3_8 -pypy3 -python3_9"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                       

dev-python/setuptools_scm:0

  (dev-python/setuptools_scm-6.0.1-r1:0/0::gentoo, ebuild scheduled for merge) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python3_8 python3_9 -pypy3 -python3_10" pulled in by
    dev-python/setuptools_scm[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?] required by (dev-python/setuptools-57.1.0:0/0::gentoo, ebuild scheduled for merge) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python3_8 python3_9 -pypy3 -python3_10"
                                                                                                                                                                                                                                                                                                                                                                                                                                                       

  (dev-python/setuptools_scm-5.0.1:0/0::gentoo, installed) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python3_6 python3_7 python3_8 -pypy3 -python3_9" pulled in by
    dev-python/setuptools_scm[-python_single_target_pypy3(-),python_targets_python3_6(-),-python_single_target_python3_6(-),python_targets_python3_7(-),-python_single_target_python3_7(-),python_targets_python3_8(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-python/setuptools-46.4.0-r3:0/0::gentoo, installed) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 python3_7 python3_8 -pypy3 -python3_9"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                 

dev-python/certifi:0

  (dev-python/certifi-10001-r1:0/0::gentoo, ebuild scheduled for merge) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python3_8 python3_9 -pypy3 -python3_10" pulled in by
    >=dev-python/certifi-2016.9.26[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?] required by (dev-python/setuptools-57.1.0:0/0::gentoo, ebuild scheduled for merge) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python3_8 python3_9 -pypy3 -python3_10"
                                                                                                                                                                                                                                                                                                                                                                                                                                                             

  (dev-python/certifi-10001:0/0::gentoo, installed) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 python3_7 python3_8 -pypy3 -python3_9" pulled in by
    >=dev-python/certifi-2016.9.26[python_targets_python2_7(-),python_targets_python3_6(-),python_targets_python3_7(-),python_targets_python3_8(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-python/setuptools-46.4.0-r3:0/0::gentoo, installed) USE="-test" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 python3_7 python3_8 -pypy3 -python3_9"
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                     


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2938
Location: Frankfurt, Germany

PostPosted: Tue Jul 20, 2021 11:20 am    Post subject: Reply with quote

Sieht so aus, als ob dev-python/setuptools-46.4.0-r3 Probleme macht. Ich sehe zwar nicht, warum das installiert ist - aber ich würde es einfach mal löschen:
Code:
emerge --unmerge =dev-python/setuptools-46.4.0-r3
Back to top
View user's profile Send private message
BastiL
n00b
n00b


Joined: 15 Aug 2004
Posts: 35

PostPosted: Thu Jul 22, 2021 1:31 pm    Post subject: Reply with quote

Die Deinstallation der alten setuptools hat geholfen. Ich bin Schritt für Schritt vorangekommen. Aktuell klemmt es bei pygobject:

Code:

emerge -av1 pygobject

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-python/pygobject-3.40.1-r1:3::gentoo  USE="cairo examples -test" PYTHON_TARGETS="python3_9 -python3_10 -python3_8" 0 KiB

Total: 1 package (1 new), Size of downloads: 0 KiB

Would you like to merge these packages? [Yes/No] yes

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) dev-python/pygobject-3.40.1-r1::gentoo
 * pygobject-3.40.1.tar.xz BLAKE2B SHA512 size ;-) ...                                                                                       [ ok ]
>>> Unpacking source...
>>> Unpacking pygobject-3.40.1.tar.xz to /var/tmp/portage/dev-python/pygobject-3.40.1-r1/work
>>> Source unpacked in /var/tmp/portage/dev-python/pygobject-3.40.1-r1/work
>>> Preparing source in /var/tmp/portage/dev-python/pygobject-3.40.1-r1/work/pygobject-3.40.1 ...
 * Applying pygobject-3.40.1-dynamicimporter-py310.patch ...                                                                                 [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-python/pygobject-3.40.1-r1/work/pygobject-3.40.1 ...
 * python3_9: running configuring
meson setup --buildtype plain --libdir lib64 --localstatedir /var/lib --prefix /usr --sysconfdir /etc --wrap-mode nodownload --build.pkg-config-path /var/tmp/portage/dev-python/pygobject-3.40.1-r1/temp/python3.9/pkgconfig:/usr/share/pkgconfig --pkg-config-path /var/tmp/portage/dev-python/pygobject-3.40.1-r1/temp/python3.9/pkgconfig:/usr/share/pkgconfig --native-file /var/tmp/portage/dev-python/pygobject-3.40.1-r1/temp/meson.x86_64-pc-linux-gnu.amd64.ini -Dpycairo=enabled -Dtests=false -Dpython=python3.9 /var/tmp/portage/dev-python/pygobject-3.40.1-r1/work/pygobject-3.40.1 /var/tmp/portage/dev-python/pygobject-3.40.1-r1/work/pygobject-3.40.1-python3_9
Traceback (most recent call last):
  File "/usr/lib/python-exec/python3.7/meson", line 6, in <module>
    from pkg_resources import load_entry_point
ModuleNotFoundError: No module named 'pkg_resources'
 * ERROR: dev-python/pygobject-3.40.1-r1::gentoo failed (configure phase):
 *   (no error message)
 *
 * Call stack:
 *     ebuild.sh, line  127:  Called src_configure
 *   environment, line 2576:  Called python_foreach_impl 'configuring'
 *   environment, line 2256:  Called multibuild_foreach_variant '_python_multibuild_wrapper' 'configuring'
 *   environment, line 1775:  Called _multibuild_run '_python_multibuild_wrapper' 'configuring'
 *   environment, line 1773:  Called _python_multibuild_wrapper 'configuring'
 *   environment, line  808:  Called configuring
 *   environment, line 2574:  Called meson_src_configure '-Dpycairo=enabled' '-Dtests=false' '-Dpython=python3.9'
 *   environment, line 1705:  Called die
 * The specific snippet of code:
 *       "${mesonargs[@]}" ) || die
 *
 * If you need support, post the output of `emerge --info '=dev-python/pygobject-3.40.1-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-python/pygobject-3.40.1-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-python/pygobject-3.40.1-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-python/pygobject-3.40.1-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-python/pygobject-3.40.1-r1/work/pygobject-3.40.1'
 * S: '/var/tmp/portage/dev-python/pygobject-3.40.1-r1/work/pygobject-3.40.1'

>>> Failed to emerge dev-python/pygobject-3.40.1-r1, Log file:

>>>  '/var/tmp/portage/dev-python/pygobject-3.40.1-r1/temp/build.log'


Emerge info dazu:

Code:

emerge --info '=dev-python/pygobject-3.40.1-r1::gentoo'
Portage 3.0.19 (python 3.7.10-final-0, default/linux/amd64/17.1/desktop, gcc-11.1.0, glibc-2.33-r1, 5.11.11-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-5.11.11-gentoo-x86_64-AMD_Ryzen_5_3500U_with_Radeon_Vega_Mobile_Gfx-with-gentoo-2.7
KiB Mem:    14326976 total,   1694284 free
KiB Swap:    8388604 total,   8374268 free
Head commit of repository gentoo: ce233e61c3246cf357475135f3db70b6f8149565

sh bash 5.1_p8
ld GNU ld (Gentoo 2.34 p6) 2.34.0
app-shells/bash:          5.1_p8::gentoo
dev-java/java-config:     2.3.1::gentoo
dev-lang/perl:            5.34.0::gentoo
dev-lang/python:          2.7.18_p10::gentoo, 3.6.13_p5::gentoo, 3.7.10_p6::gentoo, 3.8.10_p2::gentoo, 3.9.5_p2::gentoo, 3.10.0_beta3::gentoo
dev-lang/rust:            1.53.0::gentoo
dev-util/cmake:           3.20.4::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.7-r3::gentoo
sys-apps/sandbox:         2.24::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r5::gentoo
sys-devel/automake:       1.11.6-r3::gentoo, 1.13.4-r2::gentoo, 1.16.3-r1::gentoo
sys-devel/binutils:       2.34-r2::gentoo, 2.35.2::gentoo, 2.36.1-r1::gentoo
sys-devel/gcc:            9.2.0-r4::gentoo, 9.3.0-r2::gentoo, 10.3.0-r1::gentoo, 11.1.0-r1::gentoo
sys-devel/gcc-config:     2.4::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.3::gentoo
sys-kernel/linux-headers: 5.12::gentoo (virtual/os-headers)
sys-libs/glibc:           2.33-r1::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: git
    sync-uri: https://github.com/gentoo/gentoo.git
    priority: -1000

bombo82
    location: /var/lib/layman/bombo82
    masters: gentoo
    priority: 50

vifino-overlay
    location: /var/lib/layman/vifino-overlay
    masters: gentoo
    priority: 50

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.4/ext-active/ /etc/php/apache2-php8.0/ext-active/ /etc/php/cgi-php7.4/ext-active/ /etc/php/cgi-php8.0/ext-active/ /etc/php/cli-php7.4/ext-active/ /etc/php/cli-php8.0/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe"

Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2938
Location: Frankfurt, Germany

PostPosted: Thu Jul 22, 2021 3:38 pm    Post subject: Reply with quote

Hilft evtl. ein einmaliges
Code:
emerge --oneshot dev-python/setuptools
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum