Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Thinkpad X220T Ultrabase line-in: Microphone not recognized
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
chaoscommander
Tux's lil' helper
Tux's lil' helper


Joined: 15 Oct 2012
Posts: 104

PostPosted: Wed Jun 09, 2021 3:37 pm    Post subject: Thinkpad X220T Ultrabase line-in: Microphone not recognized Reply with quote

I'm using a Thinkpad X220 Tablet with its Ultrabase 3 docking station. Everything works fine! Except one thing: I can't use the external microphone / line-in on the Ultrabase. According to pulseaudio, there is no microphone connected to it (obviously, there is). Thus, no sound is recorded from the external mic. I only noticed that recently, because people obviously can still hear me in voice chat when the computer just uses its internal microphones as a fallback.

Anyone got any idea where to start looking for the cause?
Back to top
View user's profile Send private message
garrison
n00b
n00b


Joined: 18 Mar 2003
Posts: 57

PostPosted: Wed Jun 09, 2021 5:01 pm    Post subject: Reply with quote

chaoscommander wrote:
According to pulseaudio, there is no microphone connected to it (obviously, there is).


Please test if you can actually use the mic even though pulseaudio reports it as unplugged, use pavucontrol tool to select microphone port in 'Input devices' tab. If you see anything in volume meter as you speak, this could be alsa driver jack detection issue. If volume meter is not moving at all then this is likely not a pulseaudio issue but something is wrong with kernel driver or it's options.

To confirm jack detection issue please compare 'pa-info' output before and after plugging the mic. Look for difference in 'jacks_do' section. If there is no change there for your mic port then this is alsa jack detection issue. You can report it to alsa-devel mailing list provided you tested with recent kernel. If you see a change for your mic port there, then you probably want to report this as pulseaudio issue.
Back to top
View user's profile Send private message
chaoscommander
Tux's lil' helper
Tux's lil' helper


Joined: 15 Oct 2012
Posts: 104

PostPosted: Wed Jun 09, 2021 9:47 pm    Post subject: Reply with quote

Code:
> jacks_do
card=0
/usr/bin/pa-info: line 33: amixer: command not found


I might be onto something here. :oops:

brb, compiling
Back to top
View user's profile Send private message
chaoscommander
Tux's lil' helper
Tux's lil' helper


Joined: 15 Oct 2012
Posts: 104

PostPosted: Thu Jun 10, 2021 3:03 pm    Post subject: Reply with quote

Now that I have alsa, I can confirm that the mic jack status does not change when I plug the microphone in.
Back to top
View user's profile Send private message
garrison
n00b
n00b


Joined: 18 Mar 2003
Posts: 57

PostPosted: Thu Jun 10, 2021 3:09 pm    Post subject: Reply with quote

chaoscommander wrote:
Now that I have alsa, I can confirm that the mic jack status does not change when I plug the microphone in.

You should still be able to switch to mic port manually in pavucontrol 'Input Devices' tab, see if that works for you.
Back to top
View user's profile Send private message
chaoscommander
Tux's lil' helper
Tux's lil' helper


Joined: 15 Oct 2012
Posts: 104

PostPosted: Thu Jun 10, 2021 3:31 pm    Post subject: Reply with quote

garrison wrote:
chaoscommander wrote:
Now that I have alsa, I can confirm that the mic jack status does not change when I plug the microphone in.

You should still be able to switch to mic port manually in pavucontrol 'Input Devices' tab, see if that works for you.


It does not. The drop-down menu says "Microphone (not plugged in)" and the volume meter is not displaying anything when I speak. Internal mic works.

I tried to find out which kernel options might be related, but got nothing. Any pointers?
Back to top
View user's profile Send private message
garrison
n00b
n00b


Joined: 18 Mar 2003
Posts: 57

PostPosted: Thu Jun 10, 2021 3:41 pm    Post subject: Reply with quote

I do not see a solution readily available, so maybe post this issue to alsa-devel mailing list, just make sure your kernel is somewhat recent.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum