Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
aggiornamneto dopo switch profilo
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
sacchi
Tux's lil' helper
Tux's lil' helper


Joined: 28 May 2004
Posts: 82

PostPosted: Sat Jun 05, 2021 5:54 pm    Post subject: aggiornamneto dopo switch profilo Reply with quote

Ciao a tutti!

finalmente sono riuscito a switchare sul 17.1. Ora sto provando ad aggiornare questo sistema che, a causa dei problemi con unsymlink-lib, non aggiornavo da sei mesi.
È un macello, non ne sto uscendo.

Ho commentato le linee PYTHON_TARGETS e PYTHON_SINGLE_TARGET in make.conf.
Ho una valanga di problemi sia su perl sia su python.
perl-cleaner non risolve nulla, immagino per i problemi su python.

Da dove iniziereste?
Grazie davvero...

Lorenzo

Code:
# emerge --deep --update --changed-use --newuse --verbose-conflicts --keep-going --with-bdeps=y --changed-deps --backtrack=2000 @world
Calculating dependencies                                                                                                                                                                                                                                                         ... done!
[ebuild   R    ] app-arch/bzip2-1.0.8-r1  USE="(-abi_riscv_lp64%) (-abi_riscv_lp64d%)"
[ebuild   R    ] dev-libs/libffi-3.3-r2  USE="(-abi_riscv_lp64%) (-abi_riscv_lp64d%)"
[ebuild   R    ] dev-lang/python-exec-conf-2.4.6  PYTHON_TARGETS="-python3_8*"
[ebuild   R    ] app-text/sgml-common-0.6.3-r7
[... taglio altrimenti la piattaforma mi da "error in posting"]
[ebuild     U  ] x11-libs/gtk+-3.24.29 [3.24.24-r1]
[ebuild   R    ] net-fs/samba-4.14.4  PYTHON_SINGLE_TARGET="python3_9* -python3_8*"
[ebuild     U  ] x11-libs/wxGTK-3.0.5.1 [3.0.4-r302]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.34.0:0/5.34::gentoo, ebuild scheduled for merge) USE="berkdb gdbm -debug -doc -ithreads -minimal" pulled in by
    =dev-lang/perl-5.34* required by (virtual/perl-IO-Compress-2.102.0:0/0::gentoo, ebuild scheduled for merge) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-Time-Local-1.300.0:0/0::gentoo, ebuild scheduled for merge) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-CPAN-Meta-2.150.10-r5:0/0::gentoo, installed) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-version-0.992.800:0/0::gentoo, ebuild scheduled for merge) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-ExtUtils-ParseXS-3.430.0:0/0::gentoo, ebuild scheduled for merge) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-Scalar-List-Utils-1.550.0-r1:0/0::gentoo, installed) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-Time-HiRes-1.976.700:0/0::gentoo, ebuild scheduled for merge) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-Text-Balanced-2.40.0:0/0::gentoo, ebuild scheduled for merge) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-Compress-Raw-Bzip2-2.101.0:0/0::gentoo, ebuild scheduled for merge) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-CPAN-Meta-Requirements-2.140.0-r7:0/0::gentoo, installed) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-libnet-3.130.0:0/0::gentoo, ebuild scheduled for merge) USE="ssl"
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-ExtUtils-Install-2.200.0:0/0::gentoo, ebuild scheduled for merge) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-Test-Harness-3.430.0:0/0::gentoo, ebuild scheduled for merge) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-Test-Simple-1.302.183:0/0::gentoo, ebuild scheduled for merge) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-Module-Load-0.360.0-r1:0/0::gentoo, ebuild scheduled for merge) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-MIME-Base64-3.160.0:0/0::gentoo, ebuild scheduled for merge) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-Digest-SHA-6.20.0-r2:0/0::gentoo, installed) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-CPAN-Meta-YAML-0.18.0-r7:0/0::gentoo, installed) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-Storable-3.230.0:0/0::gentoo, ebuild scheduled for merge) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-parent-0.238.0-r1:0/0::gentoo, installed) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-Module-Metadata-1.0.37-r1:0/0::gentoo, installed) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-File-Spec-3.800.0:0/0::gentoo, ebuild scheduled for merge) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-Getopt-Long-2.520.0:0/0::gentoo, ebuild scheduled for merge) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-Digest-1.190.0:0/0::gentoo, ebuild scheduled for merge) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-ExtUtils-CBuilder-0.280.236:0/0::gentoo, ebuild scheduled for merge) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-JSON-PP-4.60.0:0/0::gentoo, ebuild scheduled for merge) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-Perl-OSType-1.10.0-r5:0/0::gentoo, installed) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-Exporter-5.760.0:0/0::gentoo, ebuild scheduled for merge) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-Sys-Syslog-0.360.0-r1:0/0::gentoo, installed) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-Locale-Maketext-1.290.0-r4:0/0::gentoo, installed) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-Text-ParseWords-3.300.0-r8:0/0::gentoo, installed) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-XSLoader-0.300.0-r4:0/0::gentoo, installed) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-File-Path-2.180.0:0/0::gentoo, ebuild scheduled for merge) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-Data-Dumper-2.179.0:0/0::gentoo, ebuild scheduled for merge) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-Parse-CPAN-Meta-2.150.10-r5:0/0::gentoo, installed) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-ExtUtils-Manifest-1.730.0:0/0::gentoo, ebuild scheduled for merge) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-Socket-2.31.0:0/0::gentoo, ebuild scheduled for merge) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-ExtUtils-MakeMaker-7.620.0:0/0::gentoo, ebuild scheduled for merge) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-Carp-1.520.0-r1:0/0::gentoo, ebuild scheduled for merge) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-IO-Socket-IP-0.410.0:0/0::gentoo, ebuild scheduled for merge) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-podlators-4.140.0-r2:0/0::gentoo, installed) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-IO-1.460.0:0/0::gentoo, ebuild scheduled for merge) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-Digest-MD5-2.580.0:0/0::gentoo, ebuild scheduled for merge) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-Encode-3.80.0:0/0::gentoo, ebuild scheduled for merge) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-Archive-Tar-2.380.0:0/0::gentoo, ebuild scheduled for merge) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-Compress-Raw-Zlib-2.101.0:0/0::gentoo, ebuild scheduled for merge) USE=""
    ^              ^^^^^
    =dev-lang/perl-5.34* required by (virtual/perl-if-0.60.900:0/0::gentoo, ebuild scheduled for merge) USE=""
    ^              ^^^^^

  (dev-lang/perl-5.32.1:0/5.32::gentoo, installed) USE="berkdb gdbm -debug -doc -ithreads -minimal" pulled in by
    dev-lang/perl:0/5.32= required by (dev-perl/Params-Util-1.70.0:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Net-DNS-SEC-1.160.0:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Module-Build-0.422.400:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/MailTools-2.190.0:0/0::gentoo, installed) USE="-examples -test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Net-Daemon-0.480.0-r2:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Canary-Stability-2013.0.0:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32=[-build(-)] required by (dev-perl/Module-Build-Tiny-0.39.0:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (sys-apps/ucspi-ssl-0.99e:0/0::gentoo, installed) USE="perl -bindist"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Crypt-OpenSSL-DSA-0.200.0:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Socket6-0.280.0:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Authen-PAM-0.160.0-r3:0/0::gentoo, installed) USE="-examples"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/XML-SAX-Writer-0.570.0:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/TimeDate-2.330.0:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/common-sense-3.750.0:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/XML-XPath-1.420.0:0/0::gentoo, installed) USE="-examples -test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/File-Which-1.230.0:0/0::gentoo, installed) USE="-pwhich -test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32=[-build(-)] required by (dev-perl/Text-WrapI18N-0.60.0-r1:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (virtual/perl-parent-0.238.0-r1:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Net-DNS-1.230.0:0/0::gentoo, installed) USE="-examples -minimal -test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/FFI-CheckLib-0.280.0:0/0::gentoo, installed) USE="-examples -test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/MIME-Charset-1.12.2:0/0::gentoo, installed) USE="" L10N="-ja -zh"
                 ^^^^^^^^
    dev-lang/perl:0/5.32=[-build(-)] required by (dev-perl/IPC-System-Simple-1.250.0:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Net-SSLeay-1.880.0-r1:0/0::gentoo, installed) USE="-examples -minimal -test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (virtual/perl-Sys-Syslog-0.360.0-r1:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Authen-SASL-2.160.0-r2:0/0::gentoo, installed) USE="-kerberos -test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32=[-build(-)] required by (dev-perl/HTTP-Date-6.20.0-r1:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Parse-Yapp-1.210.0:0/0::gentoo, installed) USE="-examples"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/LWP-Protocol-https-6.70.0:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/IPC-Run-0.960.0:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/perl-ldap-0.650.0:0/0::gentoo, installed) USE="ssl xml -sasl"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (net-misc/wakeonlan-0.41-r4:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Capture-Tiny-0.480.0:0/0::gentoo, installed) USE="-examples -test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/ExtUtils-Config-0.8.0:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Unicode-LineBreak-2019.1.0:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (net-dns/dnssec-tools-2.2.3-r2:0/0::gentoo, installed) USE="-static-libs"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/B-Hooks-EndOfScope-0.240.0:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (virtual/perl-podlators-4.140.0-r2:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32=[-build(-)] required by (dev-perl/XML-SAX-Expat-0.510.0:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/HTTP-Cookies-6.40.0:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/XML-LibXML-2.20.100:0/0::gentoo, installed) USE="-examples -minimal -test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (virtual/perl-Pod-Parser-1.630.0-r8:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Data-OptList-0.110.0:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32=[-build(-)] required by (net-nds/openldap-2.4.58:0/0::gentoo, installed) USE="berkdb crypt ipv6 perl samba ssl syslog -cxx -debug -experimental -gnutls -iodbc -kerberos -kinit -minimal -odbc -overlays -pbkdf2 -sasl (-selinux) -sha2 -smbkrb5passwd -static-libs -tcpd -test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (net-print/cups-filters-1.28.7:0/0::gentoo, installed) USE="dbus foomatic jpeg ldap perl png postscript tiff zeroconf -pclm -pdf -test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/PlRPC-0.202.0-r3:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/NetAddr-IP-4.79.0:0/0::gentoo, installed) USE="ipv6 -test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/WWW-RobotRules-6.20.0-r1:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Devel-CheckLib-1.140.0:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/File-chdir-0.101.100:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Locale-gettext-1.70.0:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32=[-build(-)] required by (dev-perl/HTML-Tagset-3.200.0-r1:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/XML-Twig-3.520.0:0/0::gentoo, installed) USE="nls -test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Digest-BubbleBabble-0.20.0-r2:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Getopt-GUI-Long-0.930.0-r2:0/0::gentoo, installed) USE="-examples"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (app-text/po4a-0.63:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (virtual/perl-Module-Metadata-1.0.37-r1:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (virtual/perl-CPAN-Meta-YAML-0.18.0-r7:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32=[-build(-)] required by (dev-perl/IO-HTML-1.1.0:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (virtual/perl-Digest-SHA-6.20.0-r2:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/File-BaseDir-0.80.0:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Digest-SHA1-2.130.0-r2:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/File-DesktopEntry-0.220.0:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/HTTP-Message-6.290.0:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/YAML-Tiny-1.730.0:0/0::gentoo, installed) USE="-minimal -test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (virtual/perl-File-Temp-0.231.100:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (perl-core/File-Temp-0.231.100:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Sys-Hostname-Long-1.500.0-r1:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (virtual/perl-Text-ParseWords-3.300.0-r8:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Path-Tiny-0.104.0:0/0::gentoo, installed) USE="-minimal -test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/ExtUtils-Helpers-0.26.0:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/XML-NamespaceSupport-1.120.0:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Sub-Name-0.210.0:0/0::gentoo, installed) USE="-suggested -test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Pod-Parser-1.630.0-r1:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Unicode-UTF8-0.620.0:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/HTTP-Negotiate-6.10.0-r1:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Crypt-OpenSSL-Guess-0.130.0:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32=[-build(-)] required by (dev-perl/LWP-MediaTypes-6.20.0-r1:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/ExtUtils-InstallPaths-0.12.0:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32=[-build(-)] required by (dev-perl/Tie-IxHash-1.230.0:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32=[-build(-)] required by (dev-perl/XML-Generator-1.40.0-r1:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Authen-Libwrap-0.230.0-r2:0/0::gentoo, installed) USE="-examples -test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32=[-build(-)] required by (dev-perl/IO-Tty-1.120.0:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/XML-SAX-1.0.0:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Module-Implementation-0.90.0:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (virtual/perl-CPAN-Meta-2.150.10-r5:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Net-LibIDN2-1.0.0-r2:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (virtual/perl-Scalar-List-Utils-1.550.0-r1:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32=[-build(-)] required by (dev-perl/Sub-Install-0.928.0:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/CGI-4.510.0:0/0::gentoo, installed) USE="-examples -test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/URI-1.730.0:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/XML-Simple-2.250.0:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/JSON-4.30.0:0/0::gentoo, installed) USE="xs -examples -test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-vcs/subversion-1.14.1:0/0::gentoo, installed) USE="apache2 berkdb extras nls perl -debug -doc -gnome-keyring -java -kwallet -ruby -sasl -test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Encode-Locale-1.50.0:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-vcs/gitolite-3.6.11:0/0::gentoo, installed) USE="(-selinux) -tools"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Alien-Libxml2-0.170.0:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Mozilla-CA-20999999:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/TermReadKey-2.370.0:0/0::gentoo, installed) USE="-examples"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/XML-SAX-Base-1.90.0:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/IO-Socket-INET6-2.720.0-r1:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/IO-Socket-SSL-2.66.0:0/0::gentoo, installed) USE="-examples -idn"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/DBI-1.643.0:0/0::gentoo, installed) USE="-examples -test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Try-Tiny-0.300.0:0/0::gentoo, installed) USE="-minimal -test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Convert-ASN1-0.270.0-r1:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Parse-RecDescent-1.967.15:0/0::gentoo, installed) USE="-examples -test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Text-Iconv-1.700.0-r2:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32=[-build(-)] required by (dev-perl/XML-Filter-BufferText-1.10.0-r1:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32=[-build(-)] required by (dev-perl/Locale-Maketext-Lexicon-1.0.0:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (virtual/perl-CPAN-Meta-Requirements-2.140.0-r7:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32=[-build(-)] required by (dev-perl/Sub-Exporter-0.987.0:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/SGMLSpm-1.1-r1:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Alien-Build-2.380.0:0/0::gentoo, installed) USE="-examples -minimal -test -zip"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Sub-Exporter-Progressive-0.1.13:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/GraphViz-2.240.0:0/0::gentoo, installed) USE="-examples -test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/JSON-XS-3.40.0:0/0::gentoo, installed) USE="-examples -test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Net-HTTP-6.210.0:0/0::gentoo, installed) USE="-minimal -test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Crypt-OpenSSL-Random-0.150.0:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Error-0.170.290:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Data-Validate-IP-0.300.0:0/0::gentoo, installed) USE="-examples -test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Variable-Magic-0.620.0:0/0::gentoo, installed) USE="-examples -test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Digest-HMAC-1.40.0:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (virtual/perl-Perl-OSType-1.10.0-r5:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32=[-build(-)] required by (dev-perl/MD5-2.30.0-r1:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (virtual/perl-Locale-Maketext-1.290.0-r4:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (virtual/perl-XSLoader-0.300.0-r4:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (virtual/perl-Parse-CPAN-Meta-2.150.10-r5:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/File-Listing-6.140.0:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Types-Serialiser-1.0.0-r1:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32=[-build(-)] required by (dev-perl/Text-CharWidth-0.40.0-r1:0/0::gentoo, installed) USE=""
                 ^^^^^^^^
    dev-lang/perl:0/5.32= required by (dev-perl/Module-Runtime-0.16.0:0/0::gentoo, installed) USE="-test"
                 ^^^^^^^^

dev-python/setuptools:0

  (dev-python/setuptools-57.0.0:0/0::gentoo, ebuild scheduled for merge) USE="-test" PYTHON_TARGETS="python3_9 -pypy3 -python3_10 -python3_8" pulled in by
    >=dev-python/setuptools-42.0.2[python_targets_python3_9(-)] required by (net-analyzer/fail2ban-0.11.2:0/0::gentoo, ebuild scheduled for merge) USE="(-selinux) -systemd" PYTHON_SINGLE_TARGET="python3_9 -python3_8"

    dev-python/setuptools[python_targets_python3_9(-)] required by (net-analyzer/rrdtool-1.7.2-r100:0/8.0.0::gentoo, ebuild scheduled for merge) USE="perl python -dbi -doc -graph -lua -rados -rrdcgi -ruby -static-libs -tcl -tcpd -test" LUA_TARGETS="lua5-1 -lua5-2 -lua5-3 -lua5-4 -luajit" PYTHON_SINGLE_TARGET="python3_9 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-),-python_single_target_python3_10(-)] required by (dev-python/jinja-3.0.1:0/0::gentoo, ebuild scheduled for merge) USE="-doc -examples -test" PYTHON_TARGETS="python3_9 -pypy3 -python3_10 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-),-python_single_target_python3_10(-)] required by (dev-python/pyxattr-0.7.2:0/0::gentoo, ebuild scheduled for merge) USE="-doc -test" PYTHON_TARGETS="python3_9 -pypy3 -python3_10 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-python/m2crypto-0.37.1-r1:0/0::gentoo, ebuild scheduled for merge) USE="-test" PYTHON_TARGETS="python3_9 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-util/meson-0.57.2:0/0::gentoo, ebuild scheduled for merge) USE="(-test)" PYTHON_TARGETS="python3_9 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-python/unittest2-1.1.0-r1:0/0::gentoo, ebuild scheduled for merge) USE="-test" PYTHON_TARGETS="python3_9 -pypy3 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-python/traceback2-1.4.0-r1:0/0::gentoo, ebuild scheduled for merge) USE="-test" PYTHON_TARGETS="python3_9 -pypy3 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-util/scons-4.1.0-r1:0/0::gentoo, ebuild scheduled for merge) USE="-doc -test" PYTHON_TARGETS="python3_9 -python3_8"

    dev-python/setuptools[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-),-python_single_target_python3_10(-)] required by (dev-python/pycparser-2.20-r1:0/0::gentoo, ebuild scheduled for merge) USE="" PYTHON_TARGETS="python3_9 -pypy3 -python3_10 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-python/pbr-5.6.0:0/0::gentoo, ebuild scheduled for merge) USE="-test" PYTHON_TARGETS="python3_9 -pypy3 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-),-python_single_target_python3_10(-)] required by (dev-python/pyasn1-0.4.8-r1:0/0::gentoo, ebuild scheduled for merge) USE="-doc" PYTHON_TARGETS="python3_9 -pypy3 -python3_10 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-),-python_single_target_python3_10(-)] required by (dev-python/python-mimeparse-1.6.0-r3:0/0::gentoo, ebuild scheduled for merge) USE="" PYTHON_TARGETS="python3_9 -pypy3 -python3_10 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-),-python_single_target_python3_10(-)] required by (dev-python/setuptools_scm-6.0.1-r1:0/0::gentoo, ebuild scheduled for merge) USE="-test" PYTHON_TARGETS="python3_9 -pypy3 -python3_10 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-),-python_single_target_python3_10(-)] required by (dev-python/pyrsistent-0.17.3:0/0::gentoo, ebuild scheduled for merge) USE="-test" PYTHON_TARGETS="python3_9 -pypy3 -python3_10 -python3_8"

    dev-python/setuptools[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-),-python_single_target_python3_10(-)] required by (dev-python/namespace-sphinxcontrib-1.0:0/0::gentoo, ebuild scheduled for merge) USE="" PYTHON_TARGETS="python3_9 -pypy3 -python3_10 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-python/extras-1.0.0-r1:0/0::gentoo, ebuild scheduled for merge) USE="-test" PYTHON_TARGETS="python3_9 -pypy3 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-python/linecache2-1.0.0-r1:0/0::gentoo, ebuild scheduled for merge) USE="-test" PYTHON_TARGETS="python3_9 -pypy3 -python3_8"

    dev-python/setuptools[python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (sys-apps/file-5.40-r2:0/0::gentoo, ebuild scheduled for merge) USE="bzip2 python seccomp zlib -lzma -static-libs" PYTHON_TARGETS="python3_9 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-),-python_single_target_python3_10(-)] required by (dev-python/six-1.16.0:0/0::gentoo, ebuild scheduled for merge) USE="-doc -test" PYTHON_TARGETS="python3_9 -pypy3 -python3_10 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-),-python_single_target_python3_10(-)] required by (dev-python/ply-3.11-r1:0/3.11::gentoo, ebuild scheduled for merge) USE="-examples" PYTHON_TARGETS="python3_9 -pypy3 -python3_10 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-),-python_single_target_python3_10(-)] required by (dev-python/pytz-2021.1:0/0::gentoo, ebuild scheduled for merge) USE="" PYTHON_TARGETS="python3_9 -pypy3 -python3_10 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-),-python_single_target_python3_10(-)] required by (dev-python/pycparser-2.20-r1:0/0::gentoo, ebuild scheduled for merge) USE="" PYTHON_TARGETS="python3_9 -pypy3 -python3_10 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-),-python_single_target_python3_10(-)] required by (dev-python/pygments-2.9.0:0/0::gentoo, ebuild scheduled for merge) USE="-doc -test" PYTHON_TARGETS="python3_9 -pypy3 -python3_10 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-),-python_single_target_python3_10(-)] required by (dev-python/PySocks-1.7.1-r1:0/0::gentoo, ebuild scheduled for merge) USE="" PYTHON_TARGETS="python3_9 -pypy3 -python3_10 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-),-python_single_target_python3_10(-)] required by (dev-python/urllib3-1.26.5:0/0::gentoo, ebuild scheduled for merge) USE="-brotli -test" PYTHON_TARGETS="python3_9 -pypy3 -python3_10 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?,-python_single_target_python3_8(-),-python_single_target_python3_9(-),-python_single_target_python3_10(-)] required by (dev-python/cffi-1.14.5:0/1.14.5::gentoo, ebuild scheduled for merge) USE="-doc -test" PYTHON_TARGETS="python3_9 -python3_10 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-),-python_single_target_python3_10(-)] required by (dev-python/toml-0.10.2:0/0::gentoo, ebuild scheduled for merge) USE="-test" PYTHON_TARGETS="python3_9 -pypy3 -python3_10 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-),-python_single_target_python3_10(-)] required by (dev-python/requests-2.25.1-r2:0/0::gentoo, ebuild scheduled for merge) USE="-socks5 -test" PYTHON_TARGETS="python3_9 -pypy3 -python3_10 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-python/testtools-2.4.0-r1:0/0::gentoo, ebuild scheduled for merge) USE="-doc -test" PYTHON_TARGETS="python3_9 -pypy3 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-),-python_single_target_python3_10(-)] required by (dev-python/chardet-4.0.0:0/0::gentoo, ebuild scheduled for merge) USE="-test" PYTHON_TARGETS="python3_9 -pypy3 -python3_10 -python3_8"

    dev-python/setuptools[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-python/subunit-1.4.0:0/0::gentoo, ebuild scheduled for merge) USE="-static-libs -test" PYTHON_TARGETS="python3_9 -pypy3 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-),-python_single_target_python3_10(-)] required by (dev-python/markupsafe-2.0.1:0/0::gentoo, ebuild scheduled for merge) USE="-test" PYTHON_TARGETS="python3_9 -pypy3 -python3_10 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-python/ndg-httpsclient-0.5.1:0/0::gentoo, ebuild scheduled for merge) USE="-test" PYTHON_TARGETS="python3_9 -pypy3 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-),-python_single_target_python3_10(-)] required by (dev-python/cython-0.29.23:0/0::gentoo, ebuild scheduled for merge) USE="-doc -emacs -test" PYTHON_TARGETS="python3_9 -pypy3 -python3_10 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-python/pyelftools-0.27:0/0::gentoo, ebuild scheduled for merge) USE="-examples" PYTHON_TARGETS="python3_9 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-),-python_single_target_python3_10(-)] required by (dev-python/mako-1.1.4:0/0::gentoo, ebuild scheduled for merge) USE="-doc -test" PYTHON_TARGETS="python3_9 -pypy3 -python3_10 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-),-python_single_target_python3_10(-)] required by (dev-python/idna-3.2:0/0::gentoo, ebuild scheduled for merge) USE="" PYTHON_TARGETS="python3_9 -pypy3 -python3_10 -python3_8"

    dev-python/setuptools[python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (net-analyzer/speedtest-cli-2.1.3:0/0::gentoo, ebuild scheduled for merge) USE="" PYTHON_TARGETS="python3_9 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (app-portage/gemato-16.2:0/0::gentoo, ebuild scheduled for merge) USE="gpg -test -tools" PYTHON_TARGETS="python3_9 -pypy3 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-python/fixtures-3.0.0-r1:0/0::gentoo, ebuild scheduled for merge) USE="-test" PYTHON_TARGETS="python3_9 -pypy3 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-),-python_single_target_python3_10(-)] required by (dev-python/docutils-0.17.1:0/0::gentoo, ebuild scheduled for merge) USE="" PYTHON_TARGETS="python3_9 -pypy3 -python3_10 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (net-analyzer/speedtest-cli-2.1.3:0/0::gentoo, ebuild scheduled for merge) USE="" PYTHON_TARGETS="python3_9 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-),-python_single_target_python3_10(-)] required by (dev-python/pycairo-1.20.0:0/0::gentoo, ebuild scheduled for merge) USE="-doc -examples -test" PYTHON_TARGETS="python3_9 -pypy3 -python3_10 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-python/subunit-1.4.0:0/0::gentoo, ebuild scheduled for merge) USE="-static-libs -test" PYTHON_TARGETS="python3_9 -pypy3 -python3_8"

    dev-python/setuptools[python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?,-python_single_target_python3_8(-),-python_single_target_python3_9(-),-python_single_target_python3_10(-)] required by (sys-libs/cracklib-2.9.7:0/0::gentoo, ebuild scheduled for merge) USE="nls python (split-usr) zlib -static-libs" PYTHON_TARGETS="python3_9 -python3_10 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-),-python_single_target_python3_10(-)] required by (dev-python/cryptography-3.4.7-r1:0/0::gentoo, ebuild scheduled for merge) USE="-test" PYTHON_TARGETS="python3_9 -pypy3 -python3_10 -python3_8"

    >=dev-python/setuptools-42.0.2[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-),-python_single_target_python3_10(-)] required by (dev-python/pyopenssl-20.0.1:0/0::gentoo, ebuild scheduled for merge) USE="-doc -test" PYTHON_TARGETS="python3_9 -pypy3 -python3_10 -python3_8"


  (dev-python/setuptools-53.0.0:0/0::gentoo, installed) USE="-test" PYTHON_TARGETS="python3_7 python3_8 -pypy3 -python3_9" pulled in by
    >=dev-python/setuptools-42.0.2[python_targets_python3_7(-),python_targets_python3_8(-),-python_single_target_pypy3(-),-python_single_target_python3_6(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-python/setuptools_scm-5.0.1:0/0::gentoo, installed) USE="-test" PYTHON_TARGETS="python3_7 python3_8 -pypy3 -python3_6 -python3_9"

    >=dev-python/setuptools-42.0.2[python_targets_python3_7(-),-python_single_target_python3_7(-)] required by (dev-python/ctypesgen-1.0.2:0/0::gentoo, installed) USE="" PYTHON_TARGETS="python3_7"


dev-python/certifi:0

  (dev-python/certifi-10001-r1:0/0::gentoo, ebuild scheduled for merge) USE="-test" PYTHON_TARGETS="python3_9 -pypy3 -python3_10 -python3_8" pulled in by
    >=dev-python/certifi-2017.4.17[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-),-python_single_target_python3_10(-)] required by (dev-python/requests-2.25.1-r2:0/0::gentoo, ebuild scheduled for merge) USE="-socks5 -test" PYTHON_TARGETS="python3_9 -pypy3 -python3_10 -python3_8"

    >=dev-python/certifi-2016.9.26[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-),-python_single_target_python3_10(-)] required by (dev-python/setuptools-57.0.0:0/0::gentoo, ebuild scheduled for merge) USE="-test" PYTHON_TARGETS="python3_9 -pypy3 -python3_10 -python3_8"


  (dev-python/certifi-10001-r1:0/0::gentoo, installed) USE="-test" PYTHON_TARGETS="python3_7 python3_8 -pypy3 -python3_6 -python3_9" pulled in by
    >=dev-python/certifi-2016.9.26[python_targets_python3_7(-),python_targets_python3_8(-),-python_single_target_pypy3(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-python/setuptools-53.0.0:0/0::gentoo, installed) USE="-test" PYTHON_TARGETS="python3_7 python3_8 -pypy3 -python3_9"


dev-python/setuptools_scm:0

  (dev-python/setuptools_scm-6.0.1-r1:0/0::gentoo, ebuild scheduled for merge) USE="-test" PYTHON_TARGETS="python3_9 -pypy3 -python3_10 -python3_8" pulled in by
    dev-python/setuptools_scm[python_targets_pypy3(-)?,python_targets_python3_8(-)?,python_targets_python3_9(-)?,python_targets_python3_10(-)?,-python_single_target_pypy3(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-),-python_single_target_python3_10(-)] required by (dev-python/setuptools-57.0.0:0/0::gentoo, ebuild scheduled for merge) USE="-test" PYTHON_TARGETS="python3_9 -pypy3 -python3_10 -python3_8"


  (dev-python/setuptools_scm-5.0.1:0/0::gentoo, installed) USE="-test" PYTHON_TARGETS="python3_7 python3_8 -pypy3 -python3_6 -python3_9" pulled in by
    dev-python/setuptools_scm[python_targets_python3_7(-),python_targets_python3_8(-),-python_single_target_pypy3(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-python/setuptools-53.0.0:0/0::gentoo, installed) USE="-test" PYTHON_TARGETS="python3_7 python3_8 -pypy3 -python3_9"



It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
fedeliallalinea
Administrator
Administrator


Joined: 08 Mar 2003
Posts: 27068
Location: here

PostPosted: Sat Jun 05, 2021 6:26 pm    Post subject: Reply with quote

Un problema è sicuramente il pacchetto dev-python/ctypesgen che non esiste più nell'albero e non ha supporto a python3_9.
Dovresti vedere se riesci a rimuoverlo, se vuoi vedere chi dipende da questo pacchetto puoi usare il comando emerge -cp dev-python/ctypesgen.
Per ultimo, non c'entra con il tuo problema, usa --changed-use al posto di --newuse la prima ricompila solo i pacchetti che hanno un cambiamento nelle use flag mentre l'atro compila anche i pacchetti che aggiungono una nuova use flag anche se non l'abiliti.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
sacchi
Tux's lil' helper
Tux's lil' helper


Joined: 28 May 2004
Posts: 82

PostPosted: Mon Jun 07, 2021 4:01 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Un problema è sicuramente il pacchetto dev-python/ctypesgen che non esiste più nell'albero e non ha supporto a python3_9.
Dovresti vedere se riesci a rimuoverlo, se vuoi vedere chi dipende da questo pacchetto puoi usare il comando emerge -cp dev-python/ctypesgen.
Per ultimo, non c'entra con il tuo problema, usa --changed-use al posto di --newuse la prima ricompila solo i pacchetti che hanno un cambiamento nelle use flag mentre l'atro compila anche i pacchetti che aggiungono una nuova use flag anche se non l'abiliti.


Sono davvero colpito.... da quel marasma totale ho tolto il pacchetto che mi hai segnalato e ora è partito ad aggiornare... complimenti davvero.
Mi metto comodo.... 555 pacchetti da aggiornare!
Grazie ancora!

Lorenzo
Back to top
View user's profile Send private message
fedeliallalinea
Administrator
Administrator


Joined: 08 Mar 2003
Posts: 27068
Location: here

PostPosted: Mon Jun 07, 2021 4:25 pm    Post subject: Reply with quote

sacchi wrote:
Sono davvero colpito.... da quel marasma totale ho tolto il pacchetto che mi hai segnalato e ora è partito ad aggiornare... complimenti davvero.

Di solito in quel marasma c'è quasi sempre il colpevole, ammetto che l'output non è molto facile da interpretare.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum