Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Risolto] Problema Installa softwrae
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
antonellocaroli
Guru
Guru


Joined: 11 Aug 2016
Posts: 416

PostPosted: Fri Feb 12, 2021 6:06 pm    Post subject: [Risolto] Problema Installa softwrae Reply with quote

Sto avendo un proble nell'installazione di un software, non so se é un problema della mia ebuild o qualcosa sul sistema:

Code:
Calculating dependencies... done!
[ebuild  N     ] net-libs/libmicrohttpd-0.9.70-r1:0/12::gentoo  USE="epoll ssl -static-libs -test" ABI_X86="(64) -32 (-x32)" 0 KiB
[ebuild     U  ] dev-qt/qtcore-5.15.2-r2:5/5.15.2::gentoo [5.15.1-r1:5/5.15.1::gentoo] USE="icu -debug -old-kernel -systemd -test" 49.005 KiB
[ebuild     U  ] dev-qt/qttest-5.15.2:5/5.15::gentoo [5.15.1:5/5.15::gentoo] USE="-debug -test" 0 KiB
[ebuild  N     ] dev-qt/qtscript-5.15.2:5/5.15::gentoo  USE="jit -debug -scripttools -test" 2.601 KiB
[ebuild     U  ] dev-qt/qtnetwork-5.15.2-r1:5/5.15::gentoo [5.15.1-r1:5/5.15::gentoo] USE="ssl -bindist -connman -debug -gssapi -libproxy (-libressl) -networkmanager -sctp -test" 0 KiB
[ebuild     U  ] dev-qt/qtdbus-5.15.2:5/5.15::gentoo [5.15.1:5/5.15::gentoo] USE="-debug -test" 0 KiB
[ebuild     U  ] dev-qt/qtgui-5.15.2-r1:5/5.15.2::gentoo [5.15.1-r1:5/5.15.1::gentoo] USE="X accessibility dbus gif jpeg libinput png udev -debug -egl -eglfs -evdev -gles2-only -ibus -test -tslib -tuio -vnc -vulkan -wayland" 0 KiB
[ebuild     U  ] dev-qt/qtwidgets-5.15.2:5/5.15::gentoo [5.15.1:5/5.15::gentoo] USE="X png -debug -gles2-only -gtk -test" 0 KiB
[ebuild     U  ] dev-qt/qtdeclarative-5.15.2:5/5.15::gentoo [5.15.1:5/5.15::gentoo] USE="jit widgets -debug -gles2-only -localstorage -test -vulkan" 21.055 KiB
[ebuild  N     ] dev-qt/qtcharts-5.15.2:5/5.15::gentoo  USE="-debug -qml -test" 4.153 KiB
[ebuild  N     ] dev-qt/qtgraphicaleffects-5.15.2:5/5.15::gentoo  USE="-debug -test" 13.712 KiB
[ebuild  N     ] dev-qt/qtquickcontrols2-5.15.2:5/5.15::gentoo  USE="-debug -test -widgets" 8.091 KiB
[ebuild  N    ~] media-sound/hqplayer4desktop-bin-4.10.0::antonellocaroli  USE="-client -manual" 0 KiB

Total: 13 packages (7 upgrades, 6 new), Size of downloads: 98.615 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-qt/qtcore:5

  (dev-qt/qtcore-5.15.1-r1:5/5.15.1::gentoo, installed) USE="icu -debug -old-kernel -systemd -test" ABI_X86="(64)" pulled in by
    ~dev-qt/qtcore-5.15.1:5/5.15.1= required by (dev-qt/qtsql-5.15.1:5/5.15.1::gentoo, installed) USE="sqlite -debug -freetds -mysql -oci8 -odbc -postgres -test" ABI_X86="(64)"
    ^                    ^^^^^^^^^^                                                                                                                                                                                                                                                                                                                                                                               
    (and 16 more with the same problem)

  (dev-qt/qtcore-5.15.2-r2:5/5.15.2::gentoo, ebuild scheduled for merge) USE="icu -debug -old-kernel -systemd -test" ABI_X86="(64)" pulled in by
    ~dev-qt/qtcore-5.15.2 required by (dev-qt/qtdeclarative-5.15.2:5/5.15::gentoo, ebuild scheduled for merge) USE="jit widgets -debug -gles2-only -localstorage -test -vulkan" ABI_X86="(64)"
    ^              ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                   
    (and 9 more with the same problem)

dev-qt/qtdeclarative:5

  (dev-qt/qtdeclarative-5.15.1:5/5.15::gentoo, installed) USE="jit widgets -debug -gles2-only -localstorage -test -vulkan" ABI_X86="(64)" pulled in by
    ~dev-qt/qtdeclarative-5.15.1 required by (dev-qt/qtquickcontrols-5.15.1:5/5.15::gentoo, installed) USE="widgets -debug -test" ABI_X86="(64)"
    ^                     ^^^^^^                                                                                                                                                                                                                                                   

  (dev-qt/qtdeclarative-5.15.2:5/5.15::gentoo, ebuild scheduled for merge) USE="jit widgets -debug -gles2-only -localstorage -test -vulkan" ABI_X86="(64)" pulled in by
    ~dev-qt/qtdeclarative-5.15.2 required by (dev-qt/qtquickcontrols2-5.15.2:5/5.15::gentoo, ebuild scheduled for merge) USE="-debug -test -widgets" ABI_X86="(64)"
    ^                     ^^^^^^                                                                                                                                                                                                                                                                     
    (and 1 more with the same problem)

dev-qt/qtgui:5

  (dev-qt/qtgui-5.15.1-r1:5/5.15.1::gentoo, installed) USE="X accessibility dbus gif jpeg libinput png udev -debug -egl -eglfs -evdev -gles2-only -ibus -test -tslib -tuio -vnc -vulkan -wayland" ABI_X86="(64)" pulled in by
    ~dev-qt/qtgui-5.15.1:5/5.15.1= required by (dev-qt/designer-5.15.1:5/5.15::gentoo, installed) USE="-debug -declarative -test -webkit" ABI_X86="(64)"
    ^                   ^^^^^^^^^^                                                                                                                                                                                                                                                                           
    (and 8 more with the same problem)

  (dev-qt/qtgui-5.15.2-r1:5/5.15.2::gentoo, ebuild scheduled for merge) USE="X accessibility dbus gif jpeg libinput png udev -debug -egl -eglfs -evdev -gles2-only -ibus -test -tslib -tuio -vnc -vulkan -wayland" ABI_X86="(64)" pulled in by
    ~dev-qt/qtgui-5.15.2 required by (dev-qt/qtquickcontrols2-5.15.2:5/5.15::gentoo, ebuild scheduled for merge) USE="-debug -test -widgets" ABI_X86="(64)"
    ^             ^^^^^^                                                                                                                                                                                                                                                                     
    (and 4 more with the same problem)

dev-qt/qtnetwork:5

  (dev-qt/qtnetwork-5.15.1-r1:5/5.15::gentoo, installed) USE="ssl -bindist -connman -debug -gssapi -libproxy (-libressl) -networkmanager -sctp -test" ABI_X86="(64)" pulled in by
    ~dev-qt/qtnetwork-5.15.1 required by (dev-qt/qtmultimedia-5.15.1:5/5.15::gentoo, installed) USE="alsa pulseaudio widgets -debug -gles2-only -gstreamer -openal -qml -test" ABI_X86="(64)"
    ^                 ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                     
    (and 2 more with the same problem)

  (dev-qt/qtnetwork-5.15.2-r1:5/5.15::gentoo, ebuild scheduled for merge) USE="ssl -bindist -connman -debug -gssapi -libproxy (-libressl) -networkmanager -sctp -test" ABI_X86="(64)" pulled in by
    ~dev-qt/qtnetwork-5.15.2 required by (dev-qt/qtdeclarative-5.15.2:5/5.15::gentoo, ebuild scheduled for merge) USE="jit widgets -debug -gles2-only -localstorage -test -vulkan" ABI_X86="(64)"
    ^                 ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                   

dev-qt/qtwidgets:5

  (dev-qt/qtwidgets-5.15.1:5/5.15::gentoo, installed) USE="X png -debug -gles2-only -gtk -test" ABI_X86="(64)" pulled in by
    ~dev-qt/qtwidgets-5.15.1[-gles2-only] required by (dev-qt/qtopengl-5.15.1:5/5.15::gentoo, installed) USE="-debug -gles2-only -test" ABI_X86="(64)"
    ^                 ^^^^^^                                                                                                                                                                                                                                                             
    (and 6 more with the same problem)

  (dev-qt/qtwidgets-5.15.2:5/5.15::gentoo, ebuild scheduled for merge) USE="X png -debug -gles2-only -gtk -test" ABI_X86="(64)" pulled in by
    ~dev-qt/qtwidgets-5.15.2[gles2-only=] required by (dev-qt/qtdeclarative-5.15.2:5/5.15::gentoo, ebuild scheduled for merge) USE="jit widgets -debug -gles2-only -localstorage -test -vulkan" ABI_X86="(64)"
    ^                 ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                 
    (and 1 more with the same problem)

dev-qt/qtdbus:5

  (dev-qt/qtdbus-5.15.2:5/5.15::gentoo, ebuild scheduled for merge) USE="-debug -test" ABI_X86="(64)" pulled in by
    ~dev-qt/qtdbus-5.15.2 required by (dev-qt/qtgui-5.15.2-r1:5/5.15.2::gentoo, ebuild scheduled for merge) USE="X accessibility dbus gif jpeg libinput png udev -debug -egl -eglfs -evdev -gles2-only -ibus -test -tslib -tuio -vnc -vulkan -wayland" ABI_X86="(64)"
    ^              ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                 

  (dev-qt/qtdbus-5.15.1:5/5.15::gentoo, installed) USE="-debug -test" ABI_X86="(64)" pulled in by
    ~dev-qt/qtdbus-5.15.1 required by (dev-qt/qtgui-5.15.1-r1:5/5.15.1::gentoo, installed) USE="X accessibility dbus gif jpeg libinput png udev -debug -egl -eglfs -evdev -gles2-only -ibus -test -tslib -tuio -vnc -vulkan -wayland" ABI_X86="(64)"
    ^              ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                 

dev-qt/qttest:5

  (dev-qt/qttest-5.15.2:5/5.15::gentoo, ebuild scheduled for merge) USE="-debug -test" ABI_X86="(64)" pulled in by
    ~dev-qt/qttest-5.15.2 required by (dev-qt/qtdeclarative-5.15.2:5/5.15::gentoo, ebuild scheduled for merge) USE="jit widgets -debug -gles2-only -localstorage -test -vulkan" ABI_X86="(64)"
    ^              ^^^^^^                                                                                                                                                                                                                                                                                                                                                                                   

  (dev-qt/qttest-5.15.1:5/5.15::gentoo, installed) USE="-debug -test" ABI_X86="(64)" pulled in by
    ~dev-qt/qttest-5.15.1 required by (dev-qt/qtdeclarative-5.15.1:5/5.15::gentoo, installed) USE="jit widgets -debug -gles2-only -localstorage -test -vulkan" ABI_X86="(64)"
    ^              ^^^^^^                                                                                                                                                                                                                                                                                                                                                                   

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.



Code:
RDEPEND=">=sys-devel/gcc-5.1.0[openmp]
   >=media-libs/alsa-lib-1.0.16
   >=media-libs/flac-1.3.0
   >=dev-qt/qtcore-5.5.0
   >=dev-qt/qtgui-5.5.0
   >=dev-qt/qtwidgets-5.5.0
   >=dev-qt/qtnetwork-5.5.0
   >=dev-qt/qtdeclarative-5.5.0
   >=dev-qt/qtscript-5.15.1
   >=dev-qt/qtsql-5.15.1
   >=dev-qt/qtsvg-5.15.1
   >=dev-qt/qtcharts-5.15.1
   >=net-libs/libmicrohttpd-0.9.62
   >=dev-qt/qtquickcontrols2-5.11.3
   manual? ( app-text/evince )
   client? ( media-sound/hqplayer4client-bin )"

DEPEND="${RDEPEND}"


Last edited by antonellocaroli on Sat Feb 13, 2021 2:19 am; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Moderator
Moderator


Joined: 08 Mar 2003
Posts: 26019
Location: here

PostPosted: Fri Feb 12, 2021 6:13 pm    Post subject: Reply with quote

Stai cercando di installare un software che ha bisogno le qt ma nel frattempo le qt si sono aggiornate.
Visto che non puoi mischiare versioni dei pacchetti qt prima di installare il software aggiorna il sistema con emerge -uUD @world
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
antonellocaroli
Guru
Guru


Joined: 11 Aug 2016
Posts: 416

PostPosted: Sat Feb 13, 2021 2:19 am    Post subject: Reply with quote

fedeliallalinea wrote:
Stai cercando di installare un software che ha bisogno le qt ma nel frattempo le qt si sono aggiornate.
Visto che non puoi mischiare versioni dei pacchetti qt prima di installare il software aggiorna il sistema con emerge -uUD @world


Grazie!!!
Back to top
View user's profile Send private message
antonellocaroli
Guru
Guru


Joined: 11 Aug 2016
Posts: 416

PostPosted: Mon May 03, 2021 5:03 pm    Post subject: Reply with quote

Non voglio aprire un altro post, mi sembra che posso farlo qui.

ogni volta che faccio un aggiornamento ho questo messaggio

Code:
WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-python/idna:0

  (dev-python/idna-3.1:0/0::gentoo, ebuild scheduled for merge) USE="" PYTHON_TARGETS="python3_8 -pypy3 -python3_7 -python3_9" conflicts with
    <dev-python/idna-3[python_targets_python3_8(-),-python_single_target_pypy3(-),-python_single_target_python3_7(-),-python_single_target_python3_8(-),-python_single_target_python3_9(-)] required by (dev-python/requests-2.25.1-r1:0/0::gentoo, installed) USE="-socks5 -test" PYTHON_TARGETS="python3_8 -pypy3 -python3_7 -python3_9"
    ^                                           
 


non penso sia un problema, ma io la leggo come qualcosa che si risolverá da solo....o sbaglio?
Back to top
View user's profile Send private message
fedeliallalinea
Moderator
Moderator


Joined: 08 Mar 2003
Posts: 26019
Location: here

PostPosted: Mon May 03, 2021 6:29 pm    Post subject: Reply with quote

antonellocaroli wrote:
non penso sia un problema, ma io la leggo come qualcosa che si risolverá da solo....o sbaglio?

Esattamente, si risolvera' da solo quando ci sara' una versione di dev-python/requests che supportera' la versine di dev-python/idna-3
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum