Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Reihenfolge bei der Installation von gentoo
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) Diskussionsforum
View previous topic :: View next topic  
Author Message
ManfredB
l33t
l33t


Joined: 27 Dec 2007
Posts: 669

PostPosted: Sat Feb 20, 2021 3:34 pm    Post subject: Reihenfolge bei der Installation von gentoo Reply with quote

Hallo zusammen,

ich nutze seit vielen Jahren WIKIs von Gentoo.

Heute kann ich schon die meisten Inhalte ohne Vorlage durchführen.

Doch etwas ist mir in letzter Zeit aufgefallen:

Im WIKI systemd wird gleich am Anfang gentoo-sources installiert.

Im AMD64 WIKI kommt gentoo-sources erst sehr spät an die Reihe.

Eben bin ich dabei, gentoo-unstable neu zu installieren.

Gerade wird das Basis-Update durchgeführt.

Doch gleich am Anfang sehe ich an einer Meldung, daß möglicherweise doch auch hier zuerst gentoo-sources
installiert werden sollten:

Code:

* Determining the location of the kernel source code
 * Unable to find kernel sources at /usr/src/linux
 * Please make sure that /usr/src/linux points at your running kernel,
 * (or the kernel you wish to build against).
 * Alternatively, set the KERNEL_DIR environment variable to the kernel sources location
 * Unable to calculate Linux Kernel version for build, attempting to use running version
 * Checking for suitable kernel configuration options...


Ich nutze bei dieser Installation allerdings gentoo-kernel-bin.

Um das korrekt durchzuführen, gebe ich folgendes ein:

emerge --ask sys-kernel/linux-firmware sys-kernel/gentoo-kernel-bin.

Das tue ich deshalb, weil erst firmware und dann kernel installiert werden sollten.

Aber nun zurück zu der Meldung, die sich da direkt vor Beginn des Updates zeigt.

Sehe ich das richtig, daß - wie bei systemd - auch hier zuerst gentoo-sources installiert werden sollten,
um die Meldung gar nicht erst auftauchen zu sehen?

Dann sollte das doch vielleicht im WIKI AMD64 geändert werden.

Nur ein Vorschlag - keine Kritik.

Gruß
Manfred
Back to top
View user's profile Send private message
forrestfunk81
Guru
Guru


Joined: 07 Feb 2006
Posts: 528
Location: münchen.de

PostPosted: Mon Feb 22, 2021 1:13 pm    Post subject: Reply with quote

Diese Meldung ist wahrscheinlich eine Warnung und kein Error, oder?

Portage prüft bei der Installation einiger Pakete, ob die benötigten Kernel Konfigurationen gesetzt sind. Wenn dem nicht der Fall ist, gibt es eine Warnung ala "Kernel Config CONFIG_XXX is not set when it should be". Oft sind das nur optionale Konfigurationen, welche man bei speziellen Setups benötigt. Manchmal sind es aber auch essentielle Konfigurationen. Das kommt auf den Einzelfall an.

Aber in allen Fällen benötigt das gerade installierte Programm diese Kernel Konfigurationen zur Laufzeit und noch nicht zur Installation / zum Kompilieren.

Das heißt, wenn du die Warnungen, welche Kernel Optionen eventuell fehlen, bei der Installation via emerge angezeigt haben willst, müssen die Kernel Sources installiert und fertig konfiguriert sein. Aber man kann ohne Probleme die Pakete zuerst installieren und dann die Kernel Souces später installieren und konfigurieren. Man kann auch ein komplettes System ganz ohne Kernel Sources installieren und z.B. den fertigen Kernel einer anderen Distribution verwenden (Vorsicht bei Verwendung von Modulen).
_________________
# cd /pub/
# more beer
Back to top
View user's profile Send private message
ManfredB
l33t
l33t


Joined: 27 Dec 2007
Posts: 669

PostPosted: Mon Feb 22, 2021 2:20 pm    Post subject: Reply with quote

Danke für diese Aufklärung.

Gruß
Manfred
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) Diskussionsforum All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum