Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Can not run makeicecat due to Perl rename program
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
pepegaclapwr
n00b
n00b


Joined: 18 Feb 2021
Posts: 3

PostPosted: Sun Feb 21, 2021 10:53 pm    Post subject: Can not run makeicecat due to Perl rename program Reply with quote

Hello everyone, it's me againe w/ another problem.

Alter succesfully using Icecat I've tried to update it to the latest version.
Now I ran into the problem that I cant run the updating script named makeicecat from the git site of the developers.

I'm receiving the following message: ERROR: This script requires the Perl rename program (version >= 1.10)
e.g.: 'rename' from the Guix 'rename' package
'perl-rename' from the Parabola 'perl-file-rename' package
'prename' from the Trisquel 'rename package

But I've already emerged the dev-perl/rename-1.900.0 package from the gentoo repo.

What am I missing? Am I emerging the wrong package?

Thanks for your help in advance.
Back to top
View user's profile Send private message
halcon
Guru
Guru


Joined: 15 Dec 2019
Posts: 547

PostPosted: Sun Feb 21, 2021 11:26 pm    Post subject: Reply with quote

As I see, here is some mess...

1. The homepage "https://metacpan.org/release/rename" indicated for "rename" on Gentoo packages, is wrong. The right one is https://metacpan.org/release/PEDERST/rename-1.9

2. The versions of perl packages in Gentoo are not equal to those in CPAN; rename-1.9 in CPAN = 1.900.0 in Gentoo. Similarly, 1.10 in CPAN (required) should be 1.1000.00 or something. Greater than 900. (I don't know all the rules of perl version renaming in Gentoo). So, there is no the required rename version in Gentoo.

3. Also, there is no required rename version in CPAN on the page of the author PEDERST. Version 1.9 is the latest there. It seems that the development of this package has been continued by another author, RMBARKER, under a slightly different name, File-Rename. The newest version is 1.13, it should satisfy the requirement >= 1.10.

4. Information from the AUR -
https://aur.archlinux.org/packages/perl-file-rename/
https://aur.archlinux.org/packages/icecat/
- proves my guess about changing package name.

5. There is no File-Rename package in the main ::Gentoo tree but there is in an overlay, you could try to install it from there and check if icecat work.

6. If you want to install the latest version 1.13, not 1.10 (as in the overlay), you could try to copy the ebuild to your local repo and to change one line:
DIST_VERSION=1.10
->
DIST_VERSION=1.13

EDIT
That said... I see in another your thread that you are trying not only to update a complicated package (a browser) bypassing the package manager, but you installed it in an unsupported way too, via tar. Usually it is a bad idea. Gentoo has a very good package manager - Portage. If some package is absent in Portage, a new ebuild should be written for it, and then this package can be installed using Portage and the new ebuild.

EDIT2
https://bugs.gentoo.org/427186
http://gpo.zugaina.org/www-client/icecat

EDIT3
I created a new bug: https://bugs.gentoo.org/771996
_________________
A wife asks her husband, a programmer:
- Could you please go shopping for me and buy one carton of milk, and if they have eggs, get 6?
He comes back with 6 cartons of milk.
- Why did you buy 6 cartons of milk?
- They had eggs.
Back to top
View user's profile Send private message
halcon
Guru
Guru


Joined: 15 Dec 2019
Posts: 547

PostPosted: Wed Mar 03, 2021 8:22 pm    Post subject: Reply with quote

halcon wrote:
The versions of perl packages in Gentoo are not equal to those in CPAN; rename-1.9 in CPAN = 1.900.0 in Gentoo. Similarly, 1.10 in CPAN (required) should be 1.1000.00 or something. Greater than 900. (I don't know all the rules of perl version renaming in Gentoo).

Found it:
https://packages.gentoo.org/packages/dev-perl/Gentoo-PerlMod-Version

EDIT
According to the logic of this tool, the old rename-1.9 should be not 1.9 but 1.09 (in CPAN).
Code:
gentoo-perlmod-version.pl 1.9
1.9 => 1.900.0
gentoo-perlmod-version.pl 1.10
1.10 => 1.100.0
gentoo-perlmod-version.pl 1.09
1.09 => 1.90.0

_________________
A wife asks her husband, a programmer:
- Could you please go shopping for me and buy one carton of milk, and if they have eggs, get 6?
He comes back with 6 cartons of milk.
- Why did you buy 6 cartons of milk?
- They had eggs.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum