Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Low input signal for ALC269VC mic
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
linux slacker

Joined: 03 May 2002
Posts: 29
Location: Buffalo, NY

PostPosted: Tue Jan 19, 2021 10:07 pm    Post subject: Low input signal for ALC269VC mic Reply with quote

Hey all: been having a struggle getting the mic to work properly on my laptop. Output is fine, but the input internal mic consistently has been recording low levels regardless of what I try.

Relevant lines from dmesg:


[    4.839993] snd_hda_intel 0000:00:0e.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    5.169694] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC269VC: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[    5.169703] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    5.169709] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x15/0x0/0x0/0x0/0x0)
[    5.169712] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
[    5.169716] snd_hda_codec_realtek hdaudioC0D0:    inputs:
[    5.169722] snd_hda_codec_realtek hdaudioC0D0:      Mic=0x18
[    5.169726] snd_hda_codec_realtek hdaudioC0D0:      Internal Mic=0x12
[    5.215433] input: HDA Intel PCH Mic as /devices/pci0000:00/0000:00:0e.0/sound/card0/input7
[    5.216963] input: HDA Intel PCH Headphone as /devices/pci0000:00/0000:00:0e.0/sound/card0/input8
[    5.217123] input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:0e.0/sound/card0/input12
[    5.217266] input: HDA Intel PCH HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:0e.0/sound/card0/input13
[    5.219165] input: HDA Intel PCH HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:0e.0/sound/card0/input14
[    5.219312] input: HDA Intel PCH HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:0e.0/sound/card0/input15
[    5.219451] input: HDA Intel PCH HDMI/DP,pcm=10 as /device

Relevant data from lspci -vk


00:0e.0 Audio device: Intel Corporation Celeron/Pentium Silver Processor High Definition Audio (rev 03)
   DeviceName: Onboard - Sound
   Subsystem: Device 1c6c:122a
   Flags: bus master, fast devsel, latency 0, IRQ 131
   Memory at a1210000 (64-bit, non-prefetchable) [size=16K]
   Memory at a1000000 (64-bit, non-prefetchable) [size=1M]
   Capabilities: [50] Power Management version 3
   Capabilities: [80] Vendor Specific Information: Len=14 <?>
   Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
   Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
   Kernel driver in use: snd_hda_intel
   Kernel modules: snd_hda_intel

Sound modules loaded: lsmod | grep snd


snd_hda_codec_hdmi     57344  1
snd_hda_codec_realtek   110592  1
snd_hda_codec_generic    77824  1 snd_hda_codec_realtek
ledtrig_audio          16384  1 snd_hda_codec_generic
snd_hrtimer            16384  0
led_class              16384  2 snd_hda_codec_generic,input_leds
snd_hda_intel          32768  2
snd_intel_dspcfg       16384  1 snd_hda_intel
snd_hda_codec         110592  4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek
snd_hwdep              16384  1 snd_hda_codec
snd_hda_core           65536  5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek
snd_pcm                98304  4 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_core
snd_timer              32768  2 snd_hrtimer,snd_pcm
snd                    81920  11 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_timer,snd_pcm
soundcore              16384  1 snd

I've gone into alsamixer and made sure all the input channels are unmuted. The problem is then when I use pavucontrol or audacity to check the mic input levels, they are consistently low. As in, speaking loudly inches from the mic produces no discernible effect on the sound level. The really weird bit is that if I drum/tap the laptop with my fingers, this does produce an input (i.e. I can record this activity and play it back with audacity). But nothing else (?) including what would be 'normal' speaking levels for conferencing. If I really amp up the Mic Boost levels in alsamixer all this does is increase the noise floor in the playback, but I still can't hear my voice.

Things I've also tried in /etc/modprobe.d/alsa.conf:


options snd-hda-intel model=laptop-dmic

Also models inv-dmic, auto, alc269-dmic, alc269vb-dmic without improvement.

Anyone with any ideas? Feels like I'm missing something somehow, but don't know what it might be.
Error of opinion may be tolerated where reason is left free to combat it. -- Thomas Jefferson, First Inaugural Address, 1801
Back to top
View user's profile Send private message

Joined: 22 Jun 2007
Posts: 512
Location: New Zealand

PostPosted: Thu Jan 21, 2021 8:47 am    Post subject: Reply with quote

Well, it's beginning to sound like a hardware issue, but one thing I'd be trying in that scenario (if you haven't already tried it) is disabling pulseaudio to rule it out as the culprit. If you've already tried that, or if you get rid of pa and it makes no difference, maybe try another OS (using a livecd or whatever) to check if it's a hardware issue?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum