Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[not solvable] WLAN Region einstellen
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1650
Location: Schweiz

PostPosted: Tue Jan 12, 2021 8:38 pm    Post subject: [not solvable] WLAN Region einstellen Reply with quote

Hallo,
ich habe ein kleines Problemchen mit dem WLAN auf meinem Laptop und auch eine Google-Suche liefert nichts was geholfen hätte.

Das Problem:
Wenn der NetworkManager die WLAN Verbindung aufbaut passiert das mit der falschen Region (richtig wäre in meinem Fall die Region "CH").
Code:

...Jan 12 21:19:39 slap systemd[1]: Starting Network Manager...
Jan 12 21:19:39 slap systemd[1]: Started Network Manager.
Jan 12 21:19:39 slap systemd[1]: Starting WPA supplicant...
Jan 12 21:19:39 slap wpa_supplicant[628]: Successfully initialized wpa_supplicant
Jan 12 21:19:39 slap systemd[1]: Started WPA supplicant.
Jan 12 21:19:43 slap wpa_supplicant[628]: wlp2s0: CTRL-EVENT-REGDOM-CHANGE init=DRIVER type=COUNTRY alpha2=DE
Jan 12 21:19:50 slap wpa_supplicant[628]: wlp2s0: SME: Trying to authenticate with 78:8a:20:f2:73:f4 (SSID='schmidicom' freq=5180 MHz)
Jan 12 21:19:50 slap wpa_supplicant[628]: wlp2s0: Trying to associate with 78:8a:20:f2:73:f4 (SSID='schmidicom' freq=5180 MHz)
Jan 12 21:19:50 slap wpa_supplicant[628]: wlp2s0: Associated with 78:8a:20:f2:73:f4
Jan 12 21:19:50 slap wpa_supplicant[628]: wlp2s0: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
Jan 12 21:19:50 slap wpa_supplicant[628]: wlp2s0: WPA: Key negotiation completed with 78:8a:20:f2:73:f4 [PTK=CCMP GTK=CCMP]
Jan 12 21:19:50 slap wpa_supplicant[628]: wlp2s0: CTRL-EVENT-CONNECTED - Connection to 78:8a:20:f2:73:f4 completed [id=0 id_str=]
Jan 12 21:19:50 slap wpa_supplicant[628]: wlp2s0: CTRL-EVENT-SIGNAL-CHANGE above=0 signal=-43 noise=9999 txrate=6000
Jan 12 21:19:50 slap wpa_supplicant[628]: wlp2s0: CTRL-EVENT-SIGNAL-CHANGE above=1 signal=-43 noise=9999 txrate=400000
...


Egal was ich mache es wird immer die Region DE genommen.
- Die "/etc/wpa_supplicant/wpa_supplicant.conf" ändert nichts...
- Den Modul-Parameter "ieee80211_regdom" von "cfg80211" festlegen bringt nichts...
- Der NetworkManager und seine Konfigurationsdatei scheint auch noch nie etwas von WLAN Regionscodes gehört zu haben...
- Und der Befehl "env COUNTRY=CH crda" liefert nur ein "Failed to set regulatory domain: -7"...
- Einstellungen in "/etc/default/crda" werden ebenfalls komplett ignoriert...

Weiß irgendjemand wie ich mein Linux dazu bekomme die korrekten WLAN Regularien zu benutzen? Wenn möglich dauerhaft?
_________________
GPG: 0x3FC78AEE51E5FB95


Last edited by schmidicom on Thu Jan 14, 2021 10:10 am; edited 2 times in total
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4605

PostPosted: Tue Jan 12, 2021 9:53 pm    Post subject: Reply with quote

was ich im internet gefunden habe.

Quote:

REGDOMAIN=BR

to /etc/default/crda


https://forums.gentoo.org/viewtopic-t-921478-start-0.html wrote:

I was concentrating debugging at dmesg too much and missed some obvious log lines in /var/log/messages and journalctl, which showed that the regulatory domain was being reset based on my timezone. My timezone was set to Americas/New_York. I changed it to Americas/Sao_Paulo and there you go, BR became the default regulatory domain. I don't even need the /etc/default/crda config any longer.

_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2564
Location: Frankfurt, Germany

PostPosted: Wed Jan 13, 2021 12:28 am    Post subject: Reply with quote

Hast Du schon https://wiki.archlinux.org/index.php/Network_configuration/Wireless#Respecting_the_regulatory_domain gelesen?

Was sagt:
Code:
iw reg get

Kannst Du die Domain ändern mit:
Code:
iw reg set CH
iw reg set DE
iw reg set US

Bei mir klappt das gut. "iw reg get" zeigt dann auch die jeweiligen Landes-Werte an. Ich benutze allerdings kein NetworkManager.
Back to top
View user's profile Send private message
ManfredB
l33t
l33t


Joined: 27 Dec 2007
Posts: 629

PostPosted: Wed Jan 13, 2021 8:39 am    Post subject: Reply with quote

Hallo mike155,

für mich ist interessant, daß du keinen networkmanager nutzt.

Daher die Frage: wie richtest du auf dem Notebook WLAN ein?

Das würde mich auch sehr interessieren, denn wenn ich ein Update durchführe,
sieht das seit networkmanager 18.1 so aus:
emerge -avuDN world --exclude net-misc/networkmanager.

Die neueren Versionen verhindern eine dauerhafte Verbindung nach dem Motto:
ein - aus -ein -aus usw. usw.

Aus dem WIKI habe ich zwar einiges versucht, hatte aber keinen Erfolg damit.

Sorry, wenn ich hier in diesem Thread das anspreche.

Gruß
Manfred
Back to top
View user's profile Send private message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1650
Location: Schweiz

PostPosted: Wed Jan 13, 2021 9:41 am    Post subject: Reply with quote

@firefly
Ich habe zwei Stunden mit Google gesucht und nix gefunden...
Aber ich werde das gerne mal ausprobieren, hoffentlich bekomme ich es damit hin. Übrigens, meine Zeitzone ist auf "Europe/Zurich" eingestellt, also eigentlich müsste crda von selbst merken das DE nicht die richtige Region ist.

@mike155
Das Programm hab ich nicht installiert und selbst wenn damit bleibt die Einstellung ja nicht gespeichert, sprich ich müsste es nach jedem Reboot nochmal machen. Und gerade auf dem Laptop ist ein Netzwerksetup ohne Integration in den KDE-Desktop (was ohne den NetworkManager der Fall wäre) keine brauchbare Option.


EDIT:
@firefly
Funktioniert leider auch nicht...
wpa_supplicant verwendet weiter DE als Region und scheißt auf andere Regionen...
_________________
GPG: 0x3FC78AEE51E5FB95
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4605

PostPosted: Wed Jan 13, 2021 11:13 am    Post subject: Reply with quote

wenn du direkt wpa_supplicant verwendest dann gibt es da auch ne option für die config

Quote:
country=us

_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1650
Location: Schweiz

PostPosted: Wed Jan 13, 2021 11:26 am    Post subject: Reply with quote

firefly wrote:
wenn du direkt wpa_supplicant verwendest dann gibt es da auch ne option für die config
Code:
country=us

Wie bereits geschrieben funktioniert das ja leider auch nicht, egal was ich in die "/etc/wpa_supplicant/wpa_supplicant.conf" reinschreibe es wird immer wieder DE als Region genommen.
Und auf den Networkmanager zu verzichten ist keine Option, zumindest nicht auf dem Laptop.
_________________
GPG: 0x3FC78AEE51E5FB95
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4605

PostPosted: Wed Jan 13, 2021 11:52 am    Post subject: Reply with quote

Jetzt bin ich verwirrt.
Was genau verwendest du jetzt?.
networkmanager erstellt eine eigene configuration für wpa_supplicant
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1650
Location: Schweiz

PostPosted: Wed Jan 13, 2021 11:59 am    Post subject: Reply with quote

NetworkManager über den KDE Plasma und dieser benutzt so weit ich weiß wpa_supplicant wenn das USE-Flag "iwd" nicht gesetzt ist...
_________________
GPG: 0x3FC78AEE51E5FB95
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4605

PostPosted: Wed Jan 13, 2021 12:14 pm    Post subject: Reply with quote

schmidicom wrote:
NetworkManager über den KDE Plasma und dieser benutzt so weit ich weiß wpa_supplicant wenn das USE-Flag "iwd" nicht gesetzt ist...

Ok

Dann hilft aktuell nur folgender Hack: https://www.linuxquestions.org/questions/slackware-14/network-manager-wifi-regional-settings-4175559295/#post5452473
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2564
Location: Frankfurt, Germany

PostPosted: Wed Jan 13, 2021 2:08 pm    Post subject: Reply with quote

schmidicom wrote:
@mike155
Das Programm hab ich nicht installiert und selbst wenn damit bleibt die Einstellung ja nicht gespeichert, sprich ich müsste es nach jedem Reboot nochmal machen. Und gerade auf dem Laptop ist ein Netzwerksetup ohne Integration in den KDE-Desktop (was ohne den NetworkManager der Fall wäre) keine brauchbare Option.

Es geht darum zu sehen, ob man die Regulatory Domain bei Deinem Notebook überhaupt ändern kann. Das geht bei manchen Notebooks nicht.
Back to top
View user's profile Send private message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1650
Location: Schweiz

PostPosted: Wed Jan 13, 2021 5:33 pm    Post subject: Reply with quote

mike155 wrote:
Kannst Du die Domain ändern

Der Befhel "iw reg set CH" bringt zumindest mal keine Fehlermeldung.
Und das hier ist die Ausgabe danach:
Code:
root@slap ~# iw reg get
global
country CH: DFS-ETSI
        (2402 - 2482 @ 40), (N/A, 20), (N/A)
        (5150 - 5330 @ 80), (N/A, 20), (0 ms), NO-OUTDOOR, DFS, AUTO-BW
        (5170 - 5250 @ 80), (N/A, 23), (N/A), NO-OUTDOOR, AUTO-BW
        (5490 - 5710 @ 160), (N/A, 27), (0 ms), DFS
        (57000 - 66000 @ 2160), (N/A, 40), (N/A)

phy#0 (self-managed)
country DE: DFS-UNSET
        (2402 - 2437 @ 40), (6, 22), (N/A), AUTO-BW, NO-HT40MINUS, NO-80MHZ, NO-160MHZ
        (2422 - 2462 @ 40), (6, 22), (N/A), AUTO-BW, NO-80MHZ, NO-160MHZ
        (2447 - 2482 @ 40), (6, 22), (N/A), AUTO-BW, NO-HT40PLUS, NO-80MHZ, NO-160MHZ
        (5170 - 5190 @ 80), (6, 22), (N/A), NO-OUTDOOR, AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
        (5190 - 5210 @ 80), (6, 22), (N/A), NO-OUTDOOR, AUTO-BW, IR-CONCURRENT, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
        (5210 - 5230 @ 80), (6, 22), (N/A), NO-OUTDOOR, AUTO-BW, IR-CONCURRENT, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
        (5230 - 5250 @ 80), (6, 22), (N/A), NO-OUTDOOR, AUTO-BW, IR-CONCURRENT, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
        (5250 - 5270 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
        (5270 - 5290 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
        (5290 - 5310 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
        (5310 - 5330 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
        (5490 - 5510 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
        (5510 - 5530 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
        (5530 - 5550 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
        (5550 - 5570 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
        (5570 - 5590 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
        (5590 - 5610 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
        (5610 - 5630 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
        (5630 - 5650 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
        (5650 - 5670 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
        (5670 - 5690 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
        (5690 - 5710 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40MINUS, NO-160MHZ, PASSIVE-SCAN
        (5710 - 5730 @ 80), (6, 22), (0 ms), DFS, AUTO-BW, NO-HT40PLUS, NO-160MHZ, PASSIVE-SCAN
        (5735 - 5755 @ 80), (6, 22), (N/A), AUTO-BW, NO-HT40MINUS, NO-160MHZ
        (5755 - 5775 @ 80), (6, 22), (N/A), AUTO-BW, NO-HT40PLUS, NO-160MHZ
        (5775 - 5795 @ 80), (6, 22), (N/A), AUTO-BW, NO-HT40MINUS, NO-160MHZ
        (5795 - 5815 @ 80), (6, 22), (N/A), AUTO-BW, NO-HT40PLUS, NO-160MHZ
        (5815 - 5835 @ 20), (6, 22), (N/A), AUTO-BW, NO-HT40MINUS, NO-HT40PLUS, NO-80MHZ, NO-160MHZ

_________________
GPG: 0x3FC78AEE51E5FB95
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2564
Location: Frankfurt, Germany

PostPosted: Wed Jan 13, 2021 6:26 pm    Post subject: Reply with quote

Der obere Teil kommt bei mir auch (bei dem Notebook, bei dem ich die Regulatory Domain setzen kann).

Der untere Teil (ab phy#0) kommt bei mir nicht - und ich habe das auch sonst noch nie gesehen. Das kann harmlos sein und an Deiner Hardware liegen. Es kann aber auch Teil des Problems sein - und NetworkManager, wpa_supplicant, usw. bei Dir durcheinander bringen.

Hast Du eine Ahnung, was sich hinter phy#0 verbirgt?
Back to top
View user's profile Send private message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1650
Location: Schweiz

PostPosted: Wed Jan 13, 2021 7:14 pm    Post subject: Reply with quote

mike155 wrote:
Hast Du eine Ahnung, was sich hinter phy#0 verbirgt?

Das wird vermutlich die WLAN Karte selbst sein.
Code:
02:00.0 Network controller [0280]: Intel Corporation Wireless 8265 / 8275 [8086:24fd] (rev 78)
        Subsystem: Intel Corporation Dual Band Wireless-AC 8265 [8086:1010]
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 139
        Region 0: Memory at df100000 (64-bit, non-prefetchable) [size=8K]
        Capabilities: <access denied>
        Kernel driver in use: iwlwifi
        Kernel modules: iwlwifi

In anderen Foren habe ich was davon gelesen das es beim Modul "iwlwifi" vor Kernel 5.5 noch den Parameter "lar_disable" gab den man für ein funktionierendes CRDA auf "1" stellen musste, ob da aber was dran ist weiß ich nicht.

EDIT:
Ich denke mal der folgende Kommentar aus dem Kernel-Bugzilla dürfte erklären warum es sich nicht mehr einstellen lässt und warum in der Ausgabe von "iw reg get" self-managed drin steht.
https://bugzilla.kernel.org/show_bug.cgi?id=205695#c6
Ich verstehe den Kommentar so das die WLAN-Karte (oder vermutlich eher die Firmware darin) die aktuelle Region selber erkennen soll (wie auch immer das ohne Zugang zu einem Handynetz oder ähnliches auch nur halbwegs akzeptabel funktionieren kann) und es dem Betriebssystem mit Absicht nicht erlaubt dies zu ändern.

PS:
Es würde mich nicht wundern wenn das eine weitere Konsequenz von diesem EU-Regulierungswahn im Funkbereich ist. https://heise.de/-2803189

EDIT2:
LAR bedeutet wohl "Location Aware Regulatory"
_________________
GPG: 0x3FC78AEE51E5FB95


Last edited by schmidicom on Thu Jan 14, 2021 7:27 pm; edited 2 times in total
Back to top
View user's profile Send private message
Max Steel
Advocate
Advocate


Joined: 12 Feb 2007
Posts: 2126
Location: My own world! I and Gentoo!

PostPosted: Thu Jan 14, 2021 3:27 pm    Post subject: Reply with quote

schmidicom wrote:

Ich verstehe den Kommentar so das diese WLAN-Karte (oder vermutlich eher die Firmware darin) die aktuelle Region selber erkennen soll (wie auch immer das ohne Zugang zu einem Handynetz oder ähnliches auch nur halbwegs akzeptabel funktionieren kann) und es dem Betriebssystem mit Absicht nicht erlaubt dies zu ändern.


Es horcht sich in die nahen WLAN-Netze und versucht herauszufinden "was die machen". Wenn das alle machen, wissen alle dass sie in dem Land des ersten APs sein müssten. Was wahrscheinlich USA ist. Weil machmal ;)
_________________
mfg
Steel
___________________

Heim-PC: Intel i7-5820K, 32GB RAM, GTX 1080
Laptop: Intel Core i5-4300U, 16GB RAM, Intel Graphic
Arbeit-PC: Intel i5-3470S, 16GB RAM, Intel Graphic
Arbeit-Laptop: Ryzen 5 3500U, 20GB RAM, Vega Graphic
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2564
Location: Frankfurt, Germany

PostPosted: Thu Jan 14, 2021 4:44 pm    Post subject: Reply with quote

Teste doch mal, ob es mit Kernel 5.3 noch geht und ab Kernel 5.4 nicht mehr. Dann weißt Du, dass tatsächlich Bug 205695 die Ursache ist. Es könnte ja auch andere Gründe geben. Bei manchen Notebooks ist die Domain wohl fest im EPROM hinterlegt.
Back to top
View user's profile Send private message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1650
Location: Schweiz

PostPosted: Thu Jan 14, 2021 8:11 pm    Post subject: Reply with quote

mike155 wrote:
Teste doch mal, ob es mit Kernel 5.3 noch geht und ab Kernel 5.4 nicht mehr. Dann weißt Du, dass tatsächlich Bug 205695 die Ursache ist. Es könnte ja auch andere Gründe geben. Bei manchen Notebooks ist die Domain wohl fest im EPROM hinterlegt.

Kernel 5.3 ist leider nicht mehr im Gentoo Repository drin aber dafür 5.4.89 bei dem der Modulparameter lar_disable noch vorhanden war. Und diesen Kernel habe ich jetzt mal installiert und gebootet, mit dem eben genannten Modulparameter.
Hier das Ergebnis:
Code:
~> cat /sys/module/iwlwifi/parameters/lar_disable
Y

Code:
~> iw reg get
global
country CH: DFS-ETSI
        (2402 - 2482 @ 40), (N/A, 20), (N/A)
        (5150 - 5330 @ 80), (N/A, 20), (0 ms), NO-OUTDOOR, DFS, AUTO-BW
        (5170 - 5250 @ 80), (N/A, 23), (N/A), NO-OUTDOOR, AUTO-BW
        (5490 - 5710 @ 160), (N/A, 27), (0 ms), DFS
        (57000 - 66000 @ 2160), (N/A, 40), (N/A)

Code:
~> journalctl -b -u wpa_supplicant
-- Journal begins at Thu 2021-01-14 13:12:45 CET, ends at Thu 2021-01-14 21:02:55 CET. --
Jan 14 21:01:16 slap systemd[1]: Starting WPA supplicant...
Jan 14 21:01:16 slap wpa_supplicant[408]: Successfully initialized wpa_supplicant
Jan 14 21:01:16 slap systemd[1]: Started WPA supplicant.
Jan 14 21:02:09 slap wpa_supplicant[408]: wlp2s0: SME: Trying to authenticate with 78:8a:20:f2:73:f4 (SSID='schmidicom' freq=5180 MHz)
Jan 14 21:02:09 slap wpa_supplicant[408]: wlp2s0: Trying to associate with 78:8a:20:f2:73:f4 (SSID='schmidicom' freq=5180 MHz)
Jan 14 21:02:09 slap wpa_supplicant[408]: wlp2s0: Associated with 78:8a:20:f2:73:f4
Jan 14 21:02:09 slap wpa_supplicant[408]: wlp2s0: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
Jan 14 21:02:09 slap wpa_supplicant[408]: wlp2s0: CTRL-EVENT-REGDOM-CHANGE init=COUNTRY_IE type=COUNTRY alpha2=CH
Jan 14 21:02:09 slap wpa_supplicant[408]: wlp2s0: WPA: Key negotiation completed with 78:8a:20:f2:73:f4 [PTK=CCMP GTK=CCMP]
Jan 14 21:02:09 slap wpa_supplicant[408]: wlp2s0: CTRL-EVENT-CONNECTED - Connection to 78:8a:20:f2:73:f4 completed [id=0 id_str=]
Jan 14 21:02:09 slap wpa_supplicant[408]: wlp2s0: CTRL-EVENT-SIGNAL-CHANGE above=0 signal=-44 noise=9999 txrate=6000

In diesem Beispiel musste ich weder dem NetworkManager noch wpa_supplicant extra mitteilen was für eine Region genommen werden soll/muss, und alle von Hand veränderten Konfigurationsdateien die ich weiter oben bereits erwähnt habe sind leer.

EDIT:
Hier sagt der NetworkManager im KDE Plasma nun auch wieder das die WLAN-Geschwindigkeit 400Mbit/s beträgt (was richtig ist), mit der deutschen Region wars gerade mal 65Mbit/s. Mit anderen Worten diese Schnapsidee mit der von der WLAN-Karte erzwungenen Region funktioniert nicht nur nicht richtig sie versaut auch gleich noch die WLAN-Geschwindigkeit.
_________________
GPG: 0x3FC78AEE51E5FB95
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2564
Location: Frankfurt, Germany

PostPosted: Thu Jan 14, 2021 8:28 pm    Post subject: Reply with quote

Gut! Dann kannst Du ja den Patch, mit dem das Feature in neueren Kernels deaktiviert wurde, raussuchen - und ihn in Zukunft als reverse Patch auf alle neueren Kernel anwenden - damit das Feature wieder in Deinen Kernels verfügbar ist. :)
Back to top
View user's profile Send private message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1650
Location: Schweiz

PostPosted: Fri Jan 15, 2021 7:57 am    Post subject: Reply with quote

mike155 wrote:
Gut! Dann kannst Du ja den Patch, mit dem das Feature in neueren Kernels deaktiviert wurde, raussuchen - und ihn in Zukunft als reverse Patch auf alle neueren Kernel anwenden - damit das Feature wieder in Deinen Kernels verfügbar ist. :)

Funktioniert nicht, die Änderungen seit dem entfernen sind offenbar zu groß...
_________________
GPG: 0x3FC78AEE51E5FB95
Back to top
View user's profile Send private message
forrestfunk81
Guru
Guru


Joined: 07 Feb 2006
Posts: 522
Location: münchen.de

PostPosted: Fri Jan 15, 2021 12:33 pm    Post subject: Reply with quote

OMG! Dieses Thema ist echt zum k***** und weckt böse Erinnerungen. Diese Regdomain Geschichte hat mich auf meinem Home Router ein halbes Jahr gekostet um von Kernel 5.3 auf einen aktuelleren (damals 5.7) zu aktualisieren.

Ja, es ist tatsächlich so, dass im EEPROM der Wlan Hardware die zulässige Regulatory Domain "eingebrannt" ist und der Kernel sich daran hält. Wenn man Hardware besitzt, welche für eine andere Region gebaut/geflashed wurde, ist diese nicht mehr wirklich nutzbar. Das erinnert mich stark an die DVD Region Code Geschichte, als man eine US DVD nicht auf einem EU Player abspielen konnte.

In meinem Fall ist die Wifi Hardware ein Compex WLE600VX mit ath10k Treiber, im EEPROM festgelegte Regdomain: US. Bei den zahlreichen Versuchen habe ich es auch irgendwie hinbekommen mit 'iw reg set' doch die DE Domain zu setzen. Aber die wurde trotzdem ignoriert und es waren nur die US Frequenzen nutzbar. In der Schnittmenge der US und DE Frequenzen tummeln sich hier aber so viele Wlan APs, dass der Durchsatz gering war. Außerdem gab es regelmäßig Verbindungsabbrüche mit Clients, bei welchen die DE Domain verwendet wird. Ab Kernel 5.4 ist hostapd gar nicht mehr gestartet, wenn dort country=DE konfiguriert war. Fehlermeldung war ähnlich wie bei dir "Failed to set regulatory domain:", an den genauen Error Code erinnere ich mich aber nicht mehr.

Für den ath10k Treiber kann man den Kernel so konfigurieren, dass die EEPROM Einstellung ignoriert wird:
Code:
General Setup
    Configure standard kernel features (expert users)
Networking support
  -> Wireless
    cfg80211 certification onus
    Ministrel 802.11ac support
Device Drivers
  -> Network device support
    -> Wireless LAN
      -> Atheros Wireless Cards
        Atheros DFS support for certified platforms
        Atheros dynamic user regulatory hints
        Atheros dynamic user regulatory testing


Disclaimer: Bitte verantwortungsvoll damit umgehen! Es macht schon Sinn, nur auf Frequenzen zu senden, die dafür in der Region auch freigegeben sind.

cfg80211 und ath10k müssen als Modul gebaut werden, so dass die Regdomain beim Booten überschrieben werden kann. Konfigurationen dazu:
Code:
/etc/default/crda
  REGDOMAIN=DE

/etc/modprobe.d/cfg80211.conf
  options cfg80211 ieee80211_regdom=DE


Für ath10k sieht man gut im Kernel Source, wann das setzen der Regdomain vom Kernel akzeptiert wird (siehe /usr/src/linux/drivers/net/wireless/ath/regd.c).

Ob es für Intel Karten mit iwlwifi ähnliche Tricks gibt weiß ich nicht.
Eventuell kannst du dir da auch die cfg80211 Kernel Options ankucken. Laut Kernel Wiki ist es möglich eigene "regulatory information" anzulegen und als REGDB zu verwenden:
Code:
CONFIG_CFG80211_REQUIRE_SIGNED_REGDB=y
CONFIG_CFG80211_USE_KERNEL_REGDB_KEYS=y
CONFIG_CFG80211_EXTRA_REGDB_KEYDIR=""


Aber das ganze ist mal wieder Regulierung at its best. Wenn man sich an die Regeln halten will, muss man hacken und Vorsichtsmaßnahmen umgehen :-/

Weiterführende Links:
https://wireless.wiki.kernel.org/en/developers/Regulatory
https://phabricator.vyos.net/T452
_________________
# cd /pub/
# more beer
Back to top
View user's profile Send private message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1650
Location: Schweiz

PostPosted: Fri Jan 15, 2021 2:56 pm    Post subject: Reply with quote

@forrestfunk81
Nein nichts davon wird mir weiterhelfen, weil der Treiber (in meinem Fall "iwlwifi") seit Kernel 5.5 die Auswahl der Region der WLAN-Karte überlässt (nennt sich "Location Aware Regulatory") und keine Möglichkeit mehr anbietet diesen bescheuerten Automatismus wieder abzuschalten. Und den Patch der die Moduloption "lar_disable" entfernte lässt sich inzwischen mit "patch -R -p1 < linux-f06021a18fcf8d8a1e79c5e0a8ec4eb2b038e153.patch" nicht einmal mehr rückgängig machen.
_________________
GPG: 0x3FC78AEE51E5FB95
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2564
Location: Frankfurt, Germany

PostPosted: Fri Jan 15, 2021 4:58 pm    Post subject: Reply with quote

Ich habe mir den Patch angeschaut. Die Logik mit dem lar-Modul-Parameter brauchst Du nicht. Eigentlich sollte es ausreichend sein, ein "return false" in die Funktion iwl_mvm_is_lar_supported() in drivers/net/wireless/intel/iwlwifi/mvm/mvm.h zu schreiben. Ich habe es nicht getestet, aber das sollte funktionieren.

Ich werde diesen Post in ein paar Stunden entfernen.
Back to top
View user's profile Send private message
forrestfunk81
Guru
Guru


Joined: 07 Feb 2006
Posts: 522
Location: münchen.de

PostPosted: Fri Jan 15, 2021 5:52 pm    Post subject: Reply with quote

schmidicom wrote:
@forrestfunk81
Nein nichts davon wird mir weiterhelfen, weil der Treiber (in meinem Fall "iwlwifi") seit Kernel 5.5 die Auswahl der Region der WLAN-Karte überlässt (nennt sich "Location Aware Regulatory") und keine Möglichkeit mehr anbietet diesen bescheuerten Automatismus wieder abzuschalten.


Deshalb auch der Hinweis auf die Custom regulatory information im Kernel Wiki. Vielleicht kannst du bei iwlwifi die Regdomain nicht (mehr) ändern. Aber so wie es aussieht, kann man die von CRDA gelieferten erlaubten Frequenzen auf diese Art manipulieren. In deinem Fall also trotz festgelegter Regdomain DE die CH Channels verwenden.

Sorry, aber ich muss mich bei dem Thema echt nochmal aufregen. Hat eigentlich irgendjemand von den Beteiligten daran gedacht, dass Laptops mobil sind und somit auch wenn die Geräte in einer Region beheimatet sind, trotzdem auch in andere Regionen reisen und dortige Wlans verwenden?
_________________
# cd /pub/
# more beer
Back to top
View user's profile Send private message
mike155
Advocate
Advocate


Joined: 17 Sep 2010
Posts: 2564
Location: Frankfurt, Germany

PostPosted: Fri Jan 15, 2021 6:32 pm    Post subject: Reply with quote

forrestfunk81 wrote:
Sorry, aber ich muss mich bei dem Thema echt nochmal aufregen. Hat eigentlich irgendjemand von den Beteiligten daran gedacht, dass Laptops mobil sind und somit auch wenn die Geräte in einer Region beheimatet sind, trotzdem auch in andere Regionen reisen und dortige Wlans verwenden?

Jetzt muss ich Intel und andere Hersteller mal in Schutz nehmen!

Das Problem sind doch nicht die Hersteller! Sondern die Regulierungsbehörden und Regierungen, die sich nicht auf einen weltweiten Standard einigen konnten - und gleichzeitig die Hersteller zwingen, die Regeln in den jeweiligen Ländern einzuhalten. Schau Dir die Regeln an: im 2.4 GHz Band darf in den USA mit 1W Sendeleistung gefunkt werden. In Europa ist nur ein Zehntel davon erlaubt. Das ist ein gewaltiger Unterschied!

Die Notebook-Hersteller wollen natürlich nicht für jede Region einzelne Hardware entwickeln. Deshalb entwickeln sie Universal-Chips, die dann über Parametrierung an die jeweiligen Regionen angepasst werden.

Zuerst hat man die Auswahl der Region den Anwendern überlassen. Aber es ist doch klar, was passiert ist! Die meisten Anwender haben ihre Geräte nicht konfiguriert. Wie auch? Lieschen Müller hat doch keine Ahnung davon, dass es in unterschiedlichen Ländern unterschiedliche Anforderungen gibt - und dass man deshalb überhaupt etwas konfigurieren müsse. Und dann gibt es Spaßvögel, die die Region bewusst falsch konfigurieren: "Oh! Mein WLAN funzt gleich viel besser, wenn ich USA als Region wähle! Bessere Sendeleistung, hehe! Mir doch egal, wenn mein Nachbar dann Störungen und Verbindungsabbrüche auf seiner WLAN-Verbindung bekommt".

Also, die Hersteller müssen da nachbessern. Und ich finde die Idee, die Domain aus den WLAN Access Points auszulesen, gar nicht so dumm. Die wird in den meisten Fällen einigermaßen stimmen, weil der Router-/Access Point-Markt viel stärker regionalisiert ist - und die Geräte meistens richtig konfiguriert sind.

Von daher kann ich es nachvollziehen, dass Intel u.a. die Möglichkeit abschalten, die Regulatory Domain zu konfigurieren. Es ist mehr eine juristische Lösung, als eine technische. Die Hersteller zeigen damit den Regulierungsbehörden, dass sie die lokale Gesetzgebung achten und dass sie alles in ihrer Macht stehende unternehmen um sicherzustellen, dass lokale Anforderungen eingehalten werden.


Last edited by mike155 on Fri Jan 15, 2021 6:38 pm; edited 1 time in total
Back to top
View user's profile Send private message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1650
Location: Schweiz

PostPosted: Fri Jan 15, 2021 6:38 pm    Post subject: Reply with quote

forrestfunk81 wrote:
Deshalb auch der Hinweis auf die Custom regulatory information im Kernel Wiki. Vielleicht kannst du bei iwlwifi die Regdomain nicht (mehr) ändern. Aber so wie es aussieht, kann man die von CRDA gelieferten erlaubten Frequenzen auf diese Art manipulieren. In deinem Fall also trotz festgelegter Regdomain DE die CH Channels verwenden.

Ja das könnte eventuell funktionieren, aber es wäre ein wirklich hässlicher Hack.

forrestfunk81 wrote:
Sorry, aber ich muss mich bei dem Thema echt nochmal aufregen. Hat eigentlich irgendjemand von den Beteiligten daran gedacht, dass Laptops mobil sind und somit auch wenn die Geräte in einer Region beheimatet sind, trotzdem auch in andere Regionen reisen und dortige Wlans verwenden?

Dafür brauchst du dich nicht zu entschuldigen denn diese geistige Totgeburt sollte einen auch aufregen. Einmal mehr ein Gesetzt, oder von mir aus auch Richtlinie (andere Bezeichnung aber genau so schlimm), das so abartig re­a­li­täts­fremd ist wie es nur geht und mehr als deutlich Zeigt das hier wieder einmal Leute am Werk waren die nicht wissen was sie tun/anrichten! Das Gesetz verlangt das die Hersteller von Funkhardware (das betrifft im übrigen nicht nur WLAN) es dem Benutzer unmöglich machen lokal unerlaubte Frequenzen zu verwenden, das dies aber dazu führt das die Hardware derart vernagelt werden muss das im Fehlerfall (was nicht vermeidbar ist und öfter vorkommt als viele glauben wollen) niemand mehr eingreifen kann interessiert offenbar nicht...

mike155 wrote:
Also, die Hersteller müssen da nachbessern. Und ich finde die Idee, die Domain aus den WLAN Access Points auszulesen, gar nicht so dumm. Die wird in den meisten Fällen einigermaßen stimmen, weil der Router-/Access Point-Markt viel stärker regionalisiert ist - und die Geräte meistens richtig konfiguriert sind.

Mein UniFi-AP sendet ein "Country Beacon" mit dem korrekten Code (habe das extra überprüft, genau überprüft) und trotzdem stellt sich die WLAN-Karte selbst auf die falsche Region ein. Die Programmierer mögen das Gesetz nicht gemacht haben, aber sie setzten es genau so lieblos um wie das Gesetz selbst aufgestellt wurde.
_________________
GPG: 0x3FC78AEE51E5FB95


Last edited by schmidicom on Fri Jan 15, 2021 7:57 pm; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum