Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Emacs opens in terminal window (i3wm)
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
kiigass
n00b
n00b


Joined: 21 Nov 2018
Posts: 58

PostPosted: Mon Sep 02, 2019 1:50 pm    Post subject: Emacs opens in terminal window (i3wm) Reply with quote

Hi,

I am new to gentoo and to i3wm, but not to emacs. I have installed everything so far and now, whenever I command "emacs" from my cli, it opens emacs in that terminal. But I would prefer emacs to open in a new emacs-window. How do I do that? Is this a problem of my i3wm or rather with my gentoo? Do I need to set a USE-flag?

Any help is appreciated,
thanks
Kiigass
Back to top
View user's profile Send private message
fedeliallalinea
Moderator
Moderator


Joined: 08 Mar 2003
Posts: 25865
Location: here

PostPosted: Mon Sep 02, 2019 2:05 pm    Post subject: Reply with quote

Probably you should activate gtk (this for gtk3) or gtk2 use flag for enable gui emacs
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
kiigass
n00b
n00b


Joined: 21 Nov 2018
Posts: 58

PostPosted: Mon Sep 02, 2019 2:11 pm    Post subject: Reply with quote

How can I check which use flags are active for my emacs?
Back to top
View user's profile Send private message
fedeliallalinea
Moderator
Moderator


Joined: 08 Mar 2003
Posts: 25865
Location: here

PostPosted: Mon Sep 02, 2019 2:25 pm    Post subject: Reply with quote

kiigass wrote:
How can I check which use flags are active for my emacs?

equery uses emacs or emerge -pv emacs
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Michael Allan
n00b
n00b


Joined: 24 Mar 2017
Posts: 4

PostPosted: Tue Jan 05, 2021 7:59 pm    Post subject: Reply with quote

Use flag `X` used to add the graphical front end, now it’s `gui`.

app-editors/emacs: Migrate from `X` to `gui` USE flag.
https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=d7fbd72efd2cc6096a71ac654e1659f12963dfe3
Back to top
View user's profile Send private message
Moriah
Advocate
Advocate


Joined: 27 Mar 2004
Posts: 2222
Location: Kentucky

PostPosted: Sat Jan 09, 2021 8:34 pm    Post subject: Reply with quote

I've run into this problem before, but since I generally don't emerge emacs very often -- like every few years -- I never remember the magic word. ;-)

I'm now trying to build a development environment in an oracle virtualbox vm running a gentoo guest on a windows-10 host. I have fiddled with use flags until I'm blue in the face, but I can't get emacs to run in X mode, only termnal mode.

I had no trouble emerging xemacs and getting it to run in X mode.

Because I do not have the vm honoring the windows clipboard, and I do not yet have a web browser running in the vm, it is difficult to post a cut-and-paste copy of the output from emerge -pv emacs. If I manually invoke 'USE="X gui" emacs' then it works. Why doesn't it honor the same flags in package.use ???
_________________
The MyWord KJV Bible tool is at http://www.elilabs.com/~myword

Foghorn Leghorn is a Warner Bros. cartoon character.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 16902

PostPosted: Sat Jan 09, 2021 10:28 pm    Post subject: Reply with quote

You may have conflicting flags in package.use that direct it to do otherwise. If emerge --pretend --verbose app-editors/emacs tries to set the flags to disabled, and setting $USE sets them to enabled, then I would inspect grep -r emacs /etc/portage/package.use for relevant per-package overrides. If you don't find any, then your global USE must not be enabling the gui and you should add a line to package.use to enable it.

Alternatively, you could switch to Vim, which has separate packages for console vim (app-editors/vim) and X vim (app-editors/gvim, with a variety of GUI toolkits to pick from).
Back to top
View user's profile Send private message
Moriah
Advocate
Advocate


Joined: 27 Mar 2004
Posts: 2222
Location: Kentucky

PostPosted: Sat Jan 09, 2021 11:01 pm    Post subject: Reply with quote

This is like a Ford vs Chevy argument, but I'm not interested in using vim. I've been an emacs user since 1986, and to quote an old cigarette ad, "I'd rather fight than switch." ;-)

My package.use file has exactly one line in it, for emacs.

I just built the system yesterday and got it to boot. Now I'm adding the useful tools I need to do software development on it. Emacs comes first, because I hate nano.
_________________
The MyWord KJV Bible tool is at http://www.elilabs.com/~myword

Foghorn Leghorn is a Warner Bros. cartoon character.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum