Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RESOLU] Besoin d'aide pour installaion UEFI
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
sluggeek
n00b
n00b


Joined: 21 May 2020
Posts: 17
Location: France

PostPosted: Thu Nov 05, 2020 8:42 pm    Post subject: [RESOLU] Besoin d'aide pour installaion UEFI Reply with quote

Bonjour,

Après m'être fait la main sur virtualbox, j'ai décidé d'installer Gentoo sur un vrai PC. En UEFI / GPT

Je fais l'installation et tout ce passe bien. La machine reboot tranquillement et je crie victoire :). Peu après me rendant compte d'une énorme bêtise dans la configuration du noyau, je décide de reprendre l'installation à 0.

Et la c'est le drame, deux tentatives, 2 plantages dus -je pense - à un mauvais partitionnement ... Ce qui m'énerve c'est que le premier coup j'y étais arrivé (la chance).

Après avoir refais le tour de la documentation, du moins celle que je comprends, voici ce que je projette de faire.

Pourriez vous dire si mon partitionnement et mes commandes sont les bonnes SVP

Partition Montage Taille Systeme de fichier Code HEX
/dev/nvme0n1p1 /boot/efi 256Mo Fat 32 EF00
/dev/nvme0n1p2 swap 1Go swap 8200
/dev/nvme0n1p3 / le reste Ext 4 8300

Formatage :

mkfs.fat -F32 /dev/nvme0n1p1
mkswap /dev/nvme0n1p2 && swapon /dev/nvme0n1p2
mkfs.ext4 /dev/nvme0n1p3


Montage :

mkdir -p /mnt/gentoo/boot/efi
mount /dev/nvme0n1p1 /mnt/gentoo/boot/efi
mkdir -p /mnt/gentoo
mount /dev/nvme0n1p3 /mnt/gentoo


FSTAB

/dev/nvme0n1p1 /boot/efi vfat defaults,noatime 1 2
/dev/nvme0n1p2 none swap sw 0 0
/dev/nvme0n1p3 / ext4 noatime 0 1


Grub

grub-install --target=x86_64-efi --efi-directory=/boot/efi
grub-mkconfig -o /boot/grub/grub.cfg


Je compile le noyau avec genkernel. Quand je serais plus aguerri je le recompilerais manuellement. Un problème à la fois :)


Pourriez vous me dire si tout cela vous semble correct ?

Bien cordialement,


Last edited by sluggeek on Sun Nov 22, 2020 6:48 am; edited 1 time in total
Back to top
View user's profile Send private message
sluggeek
n00b
n00b


Joined: 21 May 2020
Posts: 17
Location: France

PostPosted: Sat Nov 07, 2020 10:27 am    Post subject: Reply with quote

Vous êtes sympas aucune réponse pour me forcer à trouver la solution tout seul, à la dure :)

Après avoir regardé comment Manjaro et Debian ont partitionné le disque lors d'installation similaires, j'ai pu valider la solution de mon premier poste et installer gentoo tranquillement. Au passage cdisk marche très bien maintenant avec les tables de partitionnement GPT.


Encore merci,

Biz
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 794
Location: S.O. France

PostPosted: Sat Nov 07, 2020 8:23 pm    Post subject: Reply with quote

Y'avait pas de problèmes dans ton message. On a été décontenancés.

Vivement que tu casse ta gentoo, qu'on puisse t'aider :roll:
Back to top
View user's profile Send private message
sluggeek
n00b
n00b


Joined: 21 May 2020
Posts: 17
Location: France

PostPosted: Sun Nov 08, 2020 9:58 am    Post subject: Reply with quote

Quote:

Y'avait pas de problèmes dans ton message. On a été décontenancés.


:D :D :D

Sans soucis, ça m'a pris du temps mais j'ai compris plein de chose.

Quant à casser gentoo, je pense que c'est juste une question de temps ! De toute façon quand on tente des trucs, tôt ou tard, ça merdouille.

Biz tout le monde
Back to top
View user's profile Send private message
sluggeek
n00b
n00b


Joined: 21 May 2020
Posts: 17
Location: France

PostPosted: Mon Nov 16, 2020 10:31 am    Post subject: Reply with quote

Bonjour, je me permets de compléter mes messages précédants:

Pour une raison que j'ignore, et je ne sais pas si cela est uniquement valable pour mon thinkpad T14, mais le schéma de partitionnement que j'ai indiqué ne m'a jamais permis d'avoir une gentoo bootable sur une vraie machine. En revanche il fonctionne parfaitement sur une machine virtuelle.

Pour que gentoo soit bootable j'ai été obligé de laisser un espace vide de 1Mo avant la partition EFI et un espace vide de 8Mo tout à la fin du disque (je pense que 1Mo devrait suffire). Le premier espace vide n'est pas une partition Bios Boot (inutile avec UEFI/GPT) c'est juste un espace vide. J'imagine que cela vient de mon utilitaire de partionnement : cfdisk. Je pense que d'autres utilitaires laissent ces espaces vides par défaut.

Si vous avez des informations là dessus, je suis preneur.

J'ai trouvé la solution en installant une Manjaro et en regardant comment celle ci, qui fonctionnait parfaitement, avait partitionné mon disque. C'est sans doute pas très glorieux comme technique, mais ça a le mérite d'être efficace.

Bon courage tout le monde !

Edit : orthographe
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 794
Location: S.O. France

PostPosted: Mon Nov 16, 2020 6:12 pm    Post subject: Reply with quote

Peux-tu poster parted -l
Back to top
View user's profile Send private message
sluggeek
n00b
n00b


Joined: 21 May 2020
Posts: 17
Location: France

PostPosted: Mon Nov 16, 2020 7:03 pm    Post subject: Reply with quote

J'ai pas gardé le parted des installations qui marchaient pas. Tu veux celui d'une installation qui marche ?

Bien à toi.
Back to top
View user's profile Send private message
YetiBarBar
Guru
Guru


Joined: 23 Dec 2005
Posts: 512

PostPosted: Mon Nov 16, 2020 7:18 pm    Post subject: Reply with quote

Bonjour,

Je n'ai jamais séparé /boot/efi de /boot (mais ça a l'air d'être désormais la méthode recommandée désormais).

Il y a, selon moi, une erreur logique dans ton l'ordre de montage de tes partitions indiqués dans ton 1er post: il faut:
1°/ Monter la partition /mnt/gentoo (ton future /)
2°/ Créer le dossier /mnt/gentoo/boot/ (ton futur /boot/) et y monter ta partition boot (future /boot) (cette étape seulement si /boot séparé)
3°/ Créer le dossier /mnt/gentoo/boot/efi (ton futur /boot/efi) et y monter ta partition EFI.

Si tu montes la partition EFI en premier, elle se retrouve masquée par le montage de ton futur / sur /mnt/gentoo/, les fichiers n'y sont pas écrits (ils sont écrits sur ta future /)
Back to top
View user's profile Send private message
sluggeek
n00b
n00b


Joined: 21 May 2020
Posts: 17
Location: France

PostPosted: Mon Nov 16, 2020 8:57 pm    Post subject: Reply with quote

@Yeti
Merci de m'avoir répondu,

Effectivement j'ai mal copié mes commandes, lors de l'installation j'ai bien fait comme tu le dis sinon cela n'a pas de sens, bien vu.

Je pense qu'on sépare /boot et /boot/efi pour n'avoir que cette dernière en fat et laisser /boot en ext

En fait j'ai réussi mon installation j'indique juste qu'il faut laisser un petit espace vide avant la première partitions et après la dernière pour que gentoo boot (en tout cas sur mon thinkpad). J'ai jamais eu ce problème avec des machines virtuelles.

Bien à toi,
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 794
Location: S.O. France

PostPosted: Tue Nov 17, 2020 3:20 pm    Post subject: Reply with quote

sluggeek wrote:
J'ai pas gardé le parted des installations qui marchaient pas. Tu veux celui d'une installation qui marche ?

Oui
Back to top
View user's profile Send private message
Anard
n00b
n00b


Joined: 01 Oct 2020
Posts: 42

PostPosted: Wed Nov 18, 2020 6:46 am    Post subject: Reply with quote

sluggeek wrote:
Je pense qu'on sépare /boot et /boot/efi pour n'avoir que cette dernière en fat et laisser /boot en ext

+1
_________________
"iMack" : GA-H97M-D3H, Intel i5 4460, 16Go DDR3, Intel HD4600, SSD 256+128Go, HDD 500Go+2To / Clover - macOS Mojave / Gentoo-Xfce
"Portable" : HP Pavilion DV3500, Intel T6400, 4Go, NVidia 9300M, HDD 256Go / Grub2 - Gentoo-Xfce
Back to top
View user's profile Send private message
sluggeek
n00b
n00b


Joined: 21 May 2020
Posts: 17
Location: France

PostPosted: Wed Nov 18, 2020 4:43 pm    Post subject: Reply with quote

Bonjour,
Désolé d'avoir tardé mais j'ai eu pas mal de problèmes à résoudre. J'ai dû refaire une installation dual boot arch / gentoo afin de trouver et résoudre un problème avec Xorg.

Voici le schéma de partitionnement, il y a un espace libre de 2Mo avant la première partition et un autre d'environ 1Mo après la dernière partition.
Après avoir consulté la doc, gdisk propose comme choix par défaut, de commencer au secteur 2048, ce qui laisse un petit espace devant la première partition. Peut-être que cfdisk ne le fait pas et commence ses partitions au tout début du disque. Il faudrait que je fasse des tests sur une VM.

Après je ne suis pas un spécialiste, peut-être cet espace est nécessaire au bon alignement des partitions ? Je n'en sais rien, je travaille de manière empirique. Mais bon ça ma permis de me dépanner !


Number Start End Size File system Name Flags
1 3146kB 318MB 315MB fat32 efi boot, esp
2 318MB 1391MB 1074MB linux-swap(v1) swap
3 1391MB 44.3GB 42.9GB ext4 gentoofs
4 44.3GB 256GB 212GB ext4 archfs



Bien cordialement,
Back to top
View user's profile Send private message
YetiBarBar
Guru
Guru


Joined: 23 Dec 2005
Posts: 512

PostPosted: Thu Nov 19, 2020 7:09 pm    Post subject: Reply with quote

Bonsoir,

Il y a une notion assez vague à travers tous tes posts qui fait qu'il est compliqué de t'aider... Qu'appeles-tu gentoo non-bootable?
- Grub qui s'affiche ou pas?
- Kernel qui foire avec l'invite de login?
- Autre?

Si grub ne s'affiche pas, tu peux tenter de t'aider d'une clef USB bootable avec "refind" (une alternative à grub), et voir si ça détecte ta gentoo et si elle boote... (ça pourrait mettre en évidence un problème de'installation ou d'EFI).

Autre blague du genre, ton uefi veut-il un OS signé?
Back to top
View user's profile Send private message
sluggeek
n00b
n00b


Joined: 21 May 2020
Posts: 17
Location: France

PostPosted: Sun Nov 22, 2020 6:48 am    Post subject: Reply with quote

@Yetibarbar,

Merci de ta réponse, effectivement je dois pas être clair dans mes messages :

Je n'ai aucun problème, j'ai tout solutionné comme un grand suite à mon premier post. J'indiquais juste comment j'y étais parvenu :). Je vais éditer le sujet du message.

Encore merci de m'avoir répondu, et j'essaierai d'être plus clair, moins brouillon dans mes prochains messages.

Bien à toi,
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum