Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Pulseaudionot audio input not working in Firefox (WebRTC?)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
mohr
n00b
n00b


Joined: 22 Jan 2020
Posts: 4

PostPosted: Sat Oct 17, 2020 2:26 pm    Post subject: Pulseaudionot audio input not working in Firefox (WebRTC?) Reply with quote

I'm running firefox 78.3.1, pulseaudio 13.0 and 5.4.66 kernel with UVC and PVC modules. I have Creative Live! Cam Socialize webcam, but the same problem persists on my built-in camera on my T480s (different device).

My camera audio works fine in apps like Discord, however when I try to use it through a website in firefox (like Google Meet) I'm getting major issues. First of all, the device is not being listed when Firefox propts me to allow audio input. There's only a "default" option. However, that was the case with some other apps too (Skype I think), but selecting "default device" in other apps resulted in getting audio input from my camera.
Choosing the default device in Firefox results in either no input sound being detected or the tab crashing. In previous versions of Firefox enabling audio input would cause a terryfying noise to be played through my speakers.

(edit I've realized I should've probable posted the output of arecord instead of aplay)
I've run arecord -L with the following result, tho I'm rather unfamiliar with Linux audio architecture, so I'm not sure if there's anything wrong here:
Code:

null
    Discard all samples (playback) or generate zero samples (capture)
jack
    JACK Audio Connection Kit
pulse
    PulseAudio Sound Server
upmix
    Plugin for channel upmix (4,6,8)
vdownmix
    Plugin for channel downmix (stereo) with a simple spacialization
sysdefault:CARD=USB
    Scarlett Solo USB, USB Audio
    Default Audio Device
front:CARD=USB,DEV=0
    Scarlett Solo USB, USB Audio
    Front speakers
surround21:CARD=USB,DEV=0
    Scarlett Solo USB, USB Audio
    2.1 Surround output to Front and Subwoofer speakers
surround40:CARD=USB,DEV=0
    Scarlett Solo USB, USB Audio
    4.0 Surround output to Front and Rear speakers
surround41:CARD=USB,DEV=0
    Scarlett Solo USB, USB Audio
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=USB,DEV=0
    Scarlett Solo USB, USB Audio
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=USB,DEV=0
    Scarlett Solo USB, USB Audio
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=USB,DEV=0
    Scarlett Solo USB, USB Audio
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=USB,DEV=0
    Scarlett Solo USB, USB Audio
    IEC958 (S/PDIF) Digital Audio Output
usbstream:CARD=USB
    Scarlett Solo USB
    USB Stream Output
sysdefault:CARD=Socialize
    VF0640 Live! Cam Socialize, USB Audio
    Default Audio Device
front:CARD=Socialize,DEV=0
    VF0640 Live! Cam Socialize, USB Audio
    Front speakers
surround21:CARD=Socialize,DEV=0
    VF0640 Live! Cam Socialize, USB Audio
    2.1 Surround output to Front and Subwoofer speakers
surround40:CARD=Socialize,DEV=0
    VF0640 Live! Cam Socialize, USB Audio
    4.0 Surround output to Front and Rear speakers
surround41:CARD=Socialize,DEV=0
    VF0640 Live! Cam Socialize, USB Audio
    4.1 Surround output to Front, Rear and Subwoofer speakers
surround50:CARD=Socialize,DEV=0
    VF0640 Live! Cam Socialize, USB Audio
    5.0 Surround output to Front, Center and Rear speakers
surround51:CARD=Socialize,DEV=0
    VF0640 Live! Cam Socialize, USB Audio
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
surround71:CARD=Socialize,DEV=0
    VF0640 Live! Cam Socialize, USB Audio
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
iec958:CARD=Socialize,DEV=0
    VF0640 Live! Cam Socialize, USB Audio
    IEC958 (S/PDIF) Digital Audio Output
usbstream:CARD=Socialize
    VF0640 Live! Cam Socialize
    USB Stream Output



It's also worth noting that this isn't my only input device. I'm using a Focusrite audio interface (which is always my audio output device) and getting the same issue if I use it as input instead.

I'm not really sure wether it's a problem with some drivers, pulseaudio configuration or Firefox.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum