Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Dantrell's GNOME Without Systemd Project (Part 3)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 21, 22, 23  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
saboya
Guru
Guru


Joined: 28 Nov 2006
Posts: 543
Location: Brazil

PostPosted: Thu Oct 15, 2020 8:41 pm    Post subject: Reply with quote

For 3.38, gnome-extra/gnome-tweaks-3.34.0 needs this patch applied:

https://gitlab.gnome.org/GNOME/gnome-tweaks/-/merge_requests/60

Because 3.38 pulls in gui-libs/libhandy-1.0.0:1.0.0.

Tested locally and can confirm it works.
Back to top
View user's profile Send private message
dantrell
l33t
l33t


Joined: 01 Jun 2007
Posts: 743
Location: Earth

PostPosted: Sat Oct 17, 2020 10:42 am    Post subject: Reply with quote

saboya wrote:
I have some time to test it again.

What a coincidence, I also just got back from other pursuits to put some work in. ;)

saboya wrote:
Aaaaand... No more black screens :)

I tested GDM 3.34 but could not get it to fail.

Nevertheless, I went ahead and let GDM 3.36 through for stable.

saboya wrote:
media-video/totem-3.38.0 needs >=dev-libs/totem-pl-parser-3.26.5, but currently 3.26.4 is being pulled.

Fixed.

saboya wrote:
But it specifically needs app-misc/tracker-2. So I believe it must depend on >=app-misc/tracker-2.3.0:0.

saboya wrote:
Also, app-misc/tracker-2.3.6 miners USE flag is satisfied with app-misc/tracker-miners-3.0.1, which I also believe is incorrect and should depend on >=app-misc/tracker-miners-2.3:0 as well.

Fixed and fixed.

saboya wrote:
And maybe add a tracker3 USE flag to use tracker3 instead now that totem-3.38 is in the tree.

Not sure about this one.

GNOME 3.38 curently uses both tracker2 and tracker3 but upstream is planning to drop tracker2 at some point.

I think I'm going to wait a bit and see.

saboya wrote:
For 3.38, gnome-extra/gnome-tweaks-3.34.0 needs this patch applied: [...]

Applied.

dantrell wrote:
Elleni wrote:
[...] I will happily test when the time has come.

I'll be switching things over after I account for @saboya's feedback.

Stay tuned for a day or two (or maybe sooner). :wink:

Switched.

Good luck? Good luck. :twisted:
_________________
Dantrell B.
Back to top
View user's profile Send private message
Elleni
Veteran
Veteran


Joined: 23 May 2006
Posts: 1122

PostPosted: Sat Oct 17, 2020 12:58 pm    Post subject: Reply with quote

Hi dantrell and thanks for the switch. I am doing the upgrade, while some package were skipped
Code:
!!! The following update has been skipped due to unsatisfied dependencies:

mail-client/geary:0

  selected: (mail-client/geary-3.34.2-r3:0/0::dantrell-gnome, installed)
  skipped: (mail-client/geary-3.36.3.1:0/0::dantrell-gnome, ebuild scheduled for merge) (see unsatisfied dependency below)

!!! All ebuilds that could satisfy ">=dev-libs/libpeas-1.24.0" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-libs/libpeas-1.28.0::dantrell-gnome (masked by: missing keyword)
- dev-libs/libpeas-1.26.0::dantrell-gnome (masked by: missing keyword)
- dev-libs/libpeas-1.26.0::gentoo (masked by: package.mask)
- dev-libs/libpeas-1.24.1::dantrell-gnome (masked by: missing keyword)

(dependency required by "mail-client/geary-3.36.3.1::dantrell-gnome" [ebuild])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.



!!! The following update has been skipped due to unsatisfied dependencies:

www-client/epiphany:0

  selected: (www-client/epiphany-3.36.4:0/0::dantrell-gnome-3-36, installed)
  skipped: (www-client/epiphany-3.38.0:0/0::dantrell-gnome-3-38, ebuild scheduled for merge) (see unsatisfied dependency below)

!!! All ebuilds that could satisfy ">=net-libs/webkit-gtk-2.29.3:4=" have been masked.
!!! One of the following masked packages is required to complete your request:
- net-libs/webkit-gtk-2.30.1::dantrell-gnome (masked by: missing keyword)

(dependency required by "www-client/epiphany-3.38.0::dantrell-gnome-3-38" [ebuild])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.



!!! The following update(s) have been skipped due to unsatisfied dependencies
!!! triggered by backtracking:

gnome-base/gnome-extra-apps:3.0
gnome-base/gnome:2.0

The following packages are causing rebuilds:

  (dev-libs/glib-2.66.1:2/66::dantrell-gnome, ebuild scheduled for merge) causes rebuilds for:
    (gnome-base/gnome-shell-common-0.0.1-r1:0/0::dantrell-gnome, ebuild scheduled for merge)
    (dev-libs/totem-pl-parser-3.26.5:0/18::dantrell-gnome, ebuild scheduled for merge)
    (x11-libs/libxklavier-5.4:0/16::dantrell-gnome, ebuild scheduled for merge)
    (net-misc/networkmanager-1.24.2:0/0::dantrell-gnome, ebuild scheduled for merge)
    (media-video/ffmpegthumbnailer-2.2.0-r1:0/0::gentoo, ebuild scheduled for merge)
    (net-libs/libslirp-4.3.1:0/0::gentoo, ebuild scheduled for merge)


For gnome-contacts-3.38 I got
Code:
folks found: NO found 0.13.2 but need: '>=0.14'
Adding dev-libs/folks to package_accept.keywords worked though.

Then I had a ninja build error. Here is the corresponding build log. I checked if there is a newer version for ~amd64 but there isn't. Also tried emerging -1 of meson and also with MAKEOPTS="-j=1" but it did not help so I am out of ideas :)
Back to top
View user's profile Send private message
dantrell
l33t
l33t


Joined: 01 Jun 2007
Posts: 743
Location: Earth

PostPosted: Sat Oct 17, 2020 8:50 pm    Post subject: Reply with quote

Elleni wrote:
I am doing the upgrade, while some package were skipped [...]

The majority of your issues were keyword related so you still could have gotten GNOME 3.38 built by carefully parsing the emerge output and temporarily ignoring GNOME Boxes.

Elleni wrote:
For gnome-contacts-3.38 I got [...]

Fixed.

Elleni wrote:
Then I had a ninja build error.

That Meson warning is annoying but it's just a warning (otherwise the build would have never left the configuration process).

The real error was further down:

Code:
FAILED: subprojects/gtk-frdp/src/gtk-frdp-0.1.vapi
/usr/bin/vapigen-0.44 --quiet --library=gtk-frdp-0.1 --directory=/var/tmp/portage/gnome-extra/gnome-boxes-3.38.0/work/gnome-boxes-3.38.0-build/subprojects/gtk-frdp/src --metadatadir=/var/tmp/portage/gnome-extra/gnome-boxes-3.38.0/work/gnome-boxes-3.38.0/subprojects/gtk-frdp/src --pkg=gio-2.0 --pkg=gtk+-3.0 --metadatadir=/var/tmp/portage/gnome-extra/gnome-boxes-3.38.0/work/gnome-boxes-3.38.0/subprojects/gtk-frdp/src /var/tmp/portage/gnome-extra/gnome-boxes-3.38.0/work/gnome-boxes-3.38.0-build/subprojects/gtk-frdp/src/GtkFrdp-0.1.gir
GModule-2.0.gir:377.5-377.19: error: unknown child element `docsection' in `namespace'

So you could have gotten GNOME Boxes to build by disabling the rdp USE flag.

The actual issue though was that enabling the rdp USE flag requires at least Vala 0.48 to build.

I went ahead and adjusted things accordingly.

Good luck with the rest. :twisted:
_________________
Dantrell B.
Back to top
View user's profile Send private message
Elleni
Veteran
Veteran


Joined: 23 May 2006
Posts: 1122

PostPosted: Sun Oct 18, 2020 10:06 am    Post subject: Reply with quote

dantrell wrote:
The majority of your issues were keyword related so you still could have gotten GNOME 3.38 built by carefully parsing the emerge output and temporarily ignoring GNOME Boxes.
I did continue with --keep-going and was sure you would fix remaining keyword issues lightning fast, as you did. Thank you!
dantrell wrote:

That Meson warning is annoying but it's just a warning (otherwise the build would have never left the configuration process).

The real error was further down:

Code:
FAILED: subprojects/gtk-frdp/src/gtk-frdp-0.1.vapi
/usr/bin/vapigen-0.44 --quiet --library=gtk-frdp-0.1 --directory=/var/tmp/portage/gnome-extra/gnome-boxes-3.38.0/work/gnome-boxes-3.38.0-build/subprojects/gtk-frdp/src --metadatadir=/var/tmp/portage/gnome-extra/gnome-boxes-3.38.0/work/gnome-boxes-3.38.0/subprojects/gtk-frdp/src --pkg=gio-2.0 --pkg=gtk+-3.0 --metadatadir=/var/tmp/portage/gnome-extra/gnome-boxes-3.38.0/work/gnome-boxes-3.38.0/subprojects/gtk-frdp/src /var/tmp/portage/gnome-extra/gnome-boxes-3.38.0/work/gnome-boxes-3.38.0-build/subprojects/gtk-frdp/src/GtkFrdp-0.1.gir
GModule-2.0.gir:377.5-377.19: error: unknown child element `docsection' in `namespace'

So you could have gotten GNOME Boxes to build by disabling the rdp USE flag.

The actual issue though was that enabling the rdp USE flag requires at least Vala 0.48 to build.

I went ahead and adjusted things accordingly.

Good luck with the rest. :twisted:


Thanks for this teaching explanation :)

All went well, and compiled fine.
Back to top
View user's profile Send private message
dantrell
l33t
l33t


Joined: 01 Jun 2007
Posts: 743
Location: Earth

PostPosted: Wed Nov 11, 2020 7:07 pm    Post subject: Reply with quote

Since updates have been rolling out rather slowly (i.e. every 1-2 weeks), I thought I should let you all know that it's because things really have been that slow.

In fact, I just synced up again and barely anything has changed. :o

I'll probably be rolling out the changes I have stacked soon and after that, you can expect another lull in updates until around the time of the next GNOME stable/bugfix releases.
_________________
Dantrell B.
Back to top
View user's profile Send private message
simonvanderveldt
Tux's lil' helper
Tux's lil' helper


Joined: 26 Jan 2016
Posts: 124

PostPosted: Wed Nov 11, 2020 7:08 pm    Post subject: Reply with quote

Not related to 3.38 at all, but I was wondering if you could stabilize a newer babl version?
GIMP 2.10.20 depends on 0.1.78 which currently isn't stabilized it seems.

Quote:

!!! The following update has been skipped due to unsatisfied dependencies:

media-gfx/gimp:0

selected: (media-gfx/gimp-2.10.18-r2:0/0::gentoo, installed)
skipped: (media-gfx/gimp-2.10.20-r3:0/2::gentoo, ebuild scheduled for merge) (see unsatisfied dependency below)

!!! All ebuilds that could satisfy ">=media-libs/babl-0.1.78" have been masked.
!!! One of the following masked packages is required to complete your request:
- media-libs/babl-9999::gentoo (masked by: package.mask, missing keyword)
- media-libs/babl-0.1.78::dantrell-gnome (masked by: missing keyword)
- media-libs/babl-0.1.78::gentoo (masked by: package.mask)

(dependency required by "media-gfx/gimp-2.10.20-r3::gentoo" [ebuild])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


And thanks for the continued work on this project!
Back to top
View user's profile Send private message
dantrell
l33t
l33t


Joined: 01 Jun 2007
Posts: 743
Location: Earth

PostPosted: Wed Nov 11, 2020 10:45 pm    Post subject: Reply with quote

simonvanderveldt wrote:
Not related to 3.38 at all, but I was wondering if you could stabilize a newer babl version?

Done.

Took a bit because I wanted to conduct a few QA checks.

simonvanderveldt wrote:
And thanks for the continued work on this project!

Thanks for your continued support. ;)
_________________
Dantrell B.
Back to top
View user's profile Send private message
simonvanderveldt
Tux's lil' helper
Tux's lil' helper


Joined: 26 Jan 2016
Posts: 124

PostPosted: Thu Nov 12, 2020 9:53 am    Post subject: Reply with quote

dantrell wrote:
simonvanderveldt wrote:
Not related to 3.38 at all, but I was wondering if you could stabilize a newer babl version?

Done.

Took a bit because I wanted to conduct a few QA checks.

Thanks! It works, and then there's was the next package that's required for this :P

Code:
!!! The following update has been skipped due to unsatisfied dependencies:

media-gfx/gimp:0

  selected: (media-gfx/gimp-2.10.18-r2:0/0::gentoo, installed)
  skipped: (media-gfx/gimp-2.10.20-r3:0/2::gentoo, ebuild scheduled for merge) (see unsatisfied dependency below)

!!! All ebuilds that could satisfy ">=media-libs/gegl-0.4.24:0.4[cairo]" have been masked.
!!! One of the following masked packages is required to complete your request:
- media-libs/gegl-9999::gentoo (masked by: package.mask, missing keyword)
- media-libs/gegl-0.4.26-r1::dantrell-gnome (masked by: missing keyword)
- media-libs/gegl-0.4.26-r1::gentoo (masked by: package.mask, ~amd64 keyword)
- media-libs/gegl-0.4.26::dantrell-gnome (masked by: missing keyword)
- media-libs/gegl-0.4.26::gentoo (masked by: package.mask, ~amd64 keyword)
- media-libs/gegl-0.4.24::dantrell-gnome (masked by: missing keyword)
- media-libs/gegl-0.4.24::gentoo (masked by: package.mask)


I can of course also keyword this myself, not sure if that would be more correct?
(equery still doesn't work correctly showing the keywords so it's a bit difficult to assess the keywording of all the ebuilds for me)

[edit] Another package that I think could use a bump/stabilization would be inkscape. I currently have 0.92.4-r3 installed from dantrell-gnome and gentoo has 1.0-r1 stabilized.
The 0.92.4-r3 version also still requires python2.7 for numpy which prevents a couple of python2.7 packages to be pruned.
Back to top
View user's profile Send private message
dantrell
l33t
l33t


Joined: 01 Jun 2007
Posts: 743
Location: Earth

PostPosted: Thu Nov 12, 2020 5:41 pm    Post subject: Reply with quote

simonvanderveldt wrote:
I can of course also keyword this myself, not sure if that would be more correct?

Done but I swear I checked if this needed to be stabilized too. :o

simonvanderveldt wrote:
Another package that I think could use a bump/stabilization would be inkscape.

Done.
_________________
Dantrell B.
Back to top
View user's profile Send private message
saboya
Guru
Guru


Joined: 28 Nov 2006
Posts: 543
Location: Brazil

PostPosted: Thu Dec 03, 2020 4:16 am    Post subject: Reply with quote

I've run into this before (https://forums.gentoo.org/viewtopic-t-1095396-postdays-0-postorder-asc-start-450.html), and it just bit me again:

dev-libs/glib does not have PYTHON_COMPAT set, nor does it inherit from python-single-r1. But it breaks if you remove the python version it was installed with. This time I upgraded from 3.7 to 3.8 and it happened again.
Back to top
View user's profile Send private message
dantrell
l33t
l33t


Joined: 01 Jun 2007
Posts: 743
Location: Earth

PostPosted: Thu Dec 03, 2020 6:26 pm    Post subject: Reply with quote

saboya wrote:
dev-libs/glib does not have PYTHON_COMPAT set, nor does it inherit from python-single-r1.

Unless you are talking about something else, PYTHON_COMPAT is set.

However, you are correct that GLib does not inherit from python-single-r1. It instead mirrors the main tree which inherits from python-any-r1 (because GLib is compatible with multiple versions of Python).

I double checked how python-any-r1 works and it apparently does not result in PYTHON_TARGETS showing up (unlike with python-r1 and python-single-r1).

saboya wrote:
But it breaks if you remove the python version it was installed with. This time I upgraded from 3.7 to 3.8 and it happened again.

After investigating and comparing both implementations I figured out why this issue is happening and I will indeed have to switch to python-single-r1 unless I want to mirror the full scope of the main tree's implementation.
_________________
Dantrell B.
Back to top
View user's profile Send private message
saboya
Guru
Guru


Joined: 28 Nov 2006
Posts: 543
Location: Brazil

PostPosted: Fri Dec 04, 2020 1:06 pm    Post subject: Reply with quote

dantrell wrote:
saboya wrote:
dev-libs/glib does not have PYTHON_COMPAT set, nor does it inherit from python-single-r1.

Unless you are talking about something else, PYTHON_COMPAT is set.


My bad, I didn't actually check the ebuild, only that it does not result in PYTHON_TARGETS showing up (I guess I made the same assumption that you did haha).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 21, 22, 23
Page 23 of 23

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum