Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem with gentoo kernel r9
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Wedge_
Advocate
Advocate


Joined: 08 Aug 2002
Posts: 3614
Location: Scotland

PostPosted: Mon Sep 09, 2002 12:00 pm    Post subject: Problem with gentoo kernel r9 Reply with quote

When I try to boot with an r9 kernel, it always seems to have trouble with my hard drive. I'm using the same options as I did with the r7 kernel, and it worked fine. It scans all the IDE channels, and finds all the drives, but then it comes up with this:
Code:
hde: dma_intr : status=0xff {Busy}
hde: DMA disabled
ide2: reset timed out, status=0xff
hde: status timeout : status=0xff {Busy}
hde: Drive not ready for command
ide2: reset timed out, status=0xff
end_request: I/O error, dev 21:0c (hde), sector xxxx


The last line appears half a dozen times, then it goes into a kernel panic. I've tried turning DMA on and off by default, and it doesn't help. What am I doing wrong?
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 16090
Location: Colorado

PostPosted: Mon Sep 09, 2002 1:04 pm    Post subject: Reply with quote

Have you checked for any bug reports? You many not be doing anything 'wrong'.
_________________
lolgov. 'cause where we're going, you don't have civil liberties.

In Loving Memory
1787 - 2008
Back to top
View user's profile Send private message
Archi
n00b
n00b


Joined: 21 May 2002
Posts: 1
Location: Paris - France

PostPosted: Fri Sep 13, 2002 2:28 pm    Post subject: It's a problem pur IDE Reply with quote

The probleme is known, recompil your kernel with the special flag (see help) in IDE
Soory for the flag ...
_________________
71024D/57E4B4C3
Back to top
View user's profile Send private message
Wedge_
Advocate
Advocate


Joined: 08 Aug 2002
Posts: 3614
Location: Scotland

PostPosted: Fri Sep 13, 2002 2:40 pm    Post subject: Reply with quote

Thanks, I'll try that.
Edit: Maybe I'm not looking for the right thing, but I can't find anything that works. The ide help file mentions some parameters you can pass to the kernel for specific chipsets, but the one I have (HPT 372) isn't listed there. I also tried recompiling it with the "Attempt to hack around chipsets that timeout" option enabled, but that didn't help either.
Back to top
View user's profile Send private message
gnarlie
n00b
n00b


Joined: 08 Sep 2002
Posts: 15

PostPosted: Mon Sep 16, 2002 7:59 am    Post subject: mm Reply with quote

I have same kinda problems with mjc-sources and a kt133a-mobo. system can run fine for days but then a hda timeout and dma -> off.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum