Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 202008-06 ] iproute2
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2454

PostPosted: Sat Aug 08, 2020 8:26 am    Post subject: [ GLSA 202008-06 ] iproute2 Reply with quote

Gentoo Linux Security Advisory

Title: iproute2: Denial of service (GLSA 202008-06)
Severity: normal
Exploitable: remote
Date: 2020-08-08
Bug(s): #722144
ID: 202008-06

Synopsis

A use-after-free was found in iproute2, possibly allowing a Denial
of Service condition.


Background

iproute2 is a set of tools for managing Linux network routing and
advanced features.


Affected Packages

Package: sys-apps/iproute2
Vulnerable: < 5.1.0
Unaffected: >= 5.1.0
Architectures: All supported architectures


Description

iproute2 was found to contain a use-after-free in get_netnsid_from_name
in ip/ipnetns.c.


Impact

A remote attacker, able to feed iproute2 crafted data, may be able to
cause a Denial of Service condition.


Workaround

There is no known workaround at this time.

Resolution

All iproute2 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=sys-apps/iproute2-5.1.0"
   


References

CVE-2019-20795
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum