Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Acronis Cyber Backup 12.5.23094 and snapapi-0.7.130
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
NelvinBHV
n00b
n00b


Joined: 11 Jul 2020
Posts: 2

PostPosted: Sat Jul 11, 2020 5:25 am    Post subject: Acronis Cyber Backup 12.5.23094 and snapapi-0.7.130 Reply with quote

Hello to all Gentoo-users,

i want to switch to a new kernel on my server. I switch from 4.19.97-gentoo to the lastest 5.7.8-gentoo, because i need some new driver for my dvb-card.
This works without a problem. On my server i use Acronis Cyber Backup to backup complete machine to the cloud from HostEurope.

I downloaded the lastest version from Acronis Cyber Backup and installed it.
Code:
wget -O /tmp/Backup_Agent_for_Linux_x86_64.bin "https://eu2-cloud.acronis.com/bc/api/ams/links/agents/redirect?language=multi&system=linux&architecture=64&productType=enterprise"

Unfortunately, the required SNAPAPI module no longer compiles

Code:
DKMS make.log for snapapi26-0.7.130 for kernel 5.7.8-gentoo (x86_64)
Sa 11. Jul 07:14:10 CEST 2020
make: Verzeichnis „/usr/src/linux-5.7.8-gentoo“ wird betreten
grep: ./arch/x86/include/asm/system.h: Datei oder Verzeichnis nicht gefunden
grep: ./include/asm/system.h: Datei oder Verzeichnis nicht gefunden
grep: ./include/asm-generic/system.h: Datei oder Verzeichnis nicht gefunden
  AR      /var/lib/dkms/snapapi26/0.7.130/build/built-in.a
  CC [M]  /var/lib/dkms/snapapi26/0.7.130/build/snapapi26.o
  CC [M]  /var/lib/dkms/snapapi26/0.7.130/build/snumbd26.o
In Datei, eingebunden von ./include/linux/umh.h:4,
                 von ./include/linux/kmod.h:9,
                 von ./include/linux/module.h:16,
                 von /var/lib/dkms/snapapi26/0.7.130/build/snumbd26.c:18:
/var/lib/dkms/snapapi26/0.7.130/build/snumbd26.c: In Funktion »register_device«:
./include/linux/gfp.h:292:20: Warnung: Übergabe des Arguments 1 von »blk_alloc_queue« wandelt eine Zahl in einen Zeiger um, ohne explizite Typkonvertierung [-Wint-conversion]
  292 | #define GFP_KERNEL (__GFP_RECLAIM | __GFP_IO | __GFP_FS)
      |                    ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
      |                    |
      |                    unsigned int
/var/lib/dkms/snapapi26/0.7.130/build/snumbd26.c:553:26: Anmerkung: bei Substitution des Makros »GFP_KERNEL«
  553 |  queue = blk_alloc_queue(GFP_KERNEL);
      |                          ^~~~~~~~~~
In Datei, eingebunden von /var/lib/dkms/snapapi26/0.7.130/build/snumbd26.c:40:
./include/linux/blkdev.h:1146:23: Anmerkung: »blk_qc_t (*)(struct request_queue *, struct bio *)« {alias »unsigned int (*)(struct request_queue *, struct bio *)«} erwartet, aber Argument hat Typ »unsigned int«
 1146 | struct request_queue *blk_alloc_queue(make_request_fn make_request, int node_id);
      |                       ^~~~~~~~~~~~~~~
/var/lib/dkms/snapapi26/0.7.130/build/snumbd26.c:553:10: Fehler: Zu wenige Argumente für Funktion »blk_alloc_queue«
  553 |  queue = blk_alloc_queue(GFP_KERNEL);
      |          ^~~~~~~~~~~~~~~
In Datei, eingebunden von /var/lib/dkms/snapapi26/0.7.130/build/snumbd26.c:40:
./include/linux/blkdev.h:1146:23: Anmerkung: hier deklariert
 1146 | struct request_queue *blk_alloc_queue(make_request_fn make_request, int node_id);
      |                       ^~~~~~~~~~~~~~~
/var/lib/dkms/snapapi26/0.7.130/build/snumbd26.c:575:2: Fehler: Implizite Deklaration der Funktion »blk_queue_make_request«; meinten Sie »blk_queue_max_segments«? [-Werror=implicit-function-declaration]
  575 |  blk_queue_make_request(queue, snumbd_make_request);
      |  ^~~~~~~~~~~~~~~~~~~~~~
      |  blk_queue_max_segments
cc1: Einige Warnungen werden als Fehler behandelt
/var/lib/dkms/snapapi26/0.7.130/build/snapapi26.c: In Funktion »session_devinfo«:
/var/lib/dkms/snapapi26/0.7.130/build/snapapi26.c:3133:15: Fehler: Implizite Deklaration der Funktion »part_stat_read« [-Werror=implicit-function-declaration]
 3133 |   out.reads = part_stat_read(bdev->bd_part, _READS);
      |               ^~~~~~~~~~~~~~
make[1]: *** [scripts/Makefile.build:267: /var/lib/dkms/snapapi26/0.7.130/build/snumbd26.o] Fehler 1
make[1]: *** Es wird auf noch nicht beendete Prozesse gewartet....
/var/lib/dkms/snapapi26/0.7.130/build/snapapi26.c:3099:16: Fehler: »ios« nicht deklariert (erste Verwendung in dieser Funktion)
 3099 | #define _READS ios[0]
      |                ^~~
/var/lib/dkms/snapapi26/0.7.130/build/snapapi26.c:3133:45: Anmerkung: bei Substitution des Makros »_READS«
 3133 |   out.reads = part_stat_read(bdev->bd_part, _READS);
      |                                             ^~~~~~
/var/lib/dkms/snapapi26/0.7.130/build/snapapi26.c:3099:16: Anmerkung: jeder nicht deklarierte Bezeichner wird nur einmal für jede Funktion, in der er vorkommt, gemeldet
 3099 | #define _READS ios[0]
      |                ^~~
/var/lib/dkms/snapapi26/0.7.130/build/snapapi26.c:3133:45: Anmerkung: bei Substitution des Makros »_READS«
 3133 |   out.reads = part_stat_read(bdev->bd_part, _READS);
      |                                             ^~~~~~
/var/lib/dkms/snapapi26/0.7.130/build/snapapi26.c:3101:23: Fehler: »sectors« nicht deklariert (erstmalige Verwendung in dieser Funktion); meinten Sie »sector_t«?
 3101 | #define _READ_SECTORS sectors[0]
      |                       ^~~~~~~
/var/lib/dkms/snapapi26/0.7.130/build/snapapi26.c:3134:52: Anmerkung: bei Substitution des Makros »_READ_SECTORS«
 3134 |   out.read_sectors = part_stat_read(bdev->bd_part, _READ_SECTORS);
      |                                                    ^~~~~~~~~~~~~
cc1: Einige Warnungen werden als Fehler behandelt
make[1]: *** [scripts/Makefile.build:267: /var/lib/dkms/snapapi26/0.7.130/build/snapapi26.o] Fehler 1
make: *** [Makefile:1732: /var/lib/dkms/snapapi26/0.7.130/build] Fehler 2
make: Verzeichnis „/usr/src/linux-5.7.8-gentoo“ wird verlassen


Has anyone found a solution or has the same problem?

Thanks
NelvinBHV
Back to top
View user's profile Send private message
Banana
Guru
Guru


Joined: 21 May 2004
Posts: 564
Location: Germany

PostPosted: Sat Jul 11, 2020 6:19 am    Post subject: Reply with quote

Hello NelvinBHV.

I do not know this backup software so my first question is: Is there a need to use this software? Since a basic backup of a system could be done with basic tools you propably already have installed.
_________________
My personal space
Back to top
View user's profile Send private message
NelvinBHV
n00b
n00b


Joined: 11 Jul 2020
Posts: 2

PostPosted: Sat Jul 11, 2020 3:10 pm    Post subject: Reply with quote

Hello Banana,

yes this software have to be used. I pick HostEurope Cloud Backup because they have to limit for just 10€ per month.
The only way is to use Acronis Cloud Backup. The backup agent installed without an error, but the need snapapi module fails every time.
Back to top
View user's profile Send private message
wjb
Guru
Guru


Joined: 10 Jul 2005
Posts: 432
Location: Fife, Scotland

PostPosted: Sat Jul 11, 2020 6:28 pm    Post subject: Reply with quote

Did you do a system update, or literally just update the kernel? Did sys-kernel/linux-headers get updated as well?

i.e. Can you describe how you did this bit:
Quote:
I switch from 4.19.97-gentoo to the latest 5.7.8-gentoo,


If you did do a proper update, I'd say the Acronis Forums are a better place to ask your question - you're a customer of theirs after all.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24341
Location: here

PostPosted: Sat Jul 11, 2020 6:40 pm    Post subject: Reply with quote

Probably software is tested only with long term support kernel, try with 5.4.x version (if have support for your device)
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum