Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] PulseAudio stopped working
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Siarhei
n00b
n00b


Joined: 10 Jan 2016
Posts: 38
Location: Minsk

PostPosted: Tue Apr 28, 2020 11:35 am    Post subject: [SOLVED] PulseAudio stopped working Reply with quote

Hi all! I have an audio card Sound BlasterX AE-5, Linux supported by driver CA0132. Recently, PulseAudio has stopped working with the parameter "default-sample-format = s24le". Only works with parameter "default-sample-format = s16le". My audio card supports 16, 24, 32 bit. The sound has become somehow lifeless :( . How can I return music playback to 24 bits? Sorry for my English :)
aplay -l - http://dpaste.com/0FW8AQ5
cat /proc/asound/card2/codec#1 - http://dpaste.com/2EQDDWP
emerge --info - http://dpaste.com/073HKWA
P.s. file "/etc/pulse/daemon.conf" remained by default, I just changed the setting "default-sample-format = s24le" to "default-sample-format = s16le" in order to have a sound.


Last edited by Siarhei on Tue May 19, 2020 7:07 am; edited 1 time in total
Back to top
View user's profile Send private message
Siarhei
n00b
n00b


Joined: 10 Jan 2016
Posts: 38
Location: Minsk

PostPosted: Wed Apr 29, 2020 10:07 am    Post subject: Reply with quote

with "default-sample-format = s24le" https://photos.app.goo.gl/bn61fYVAwbAJubEj7
with "default-sample-format = s16le" https://photos.app.goo.gl/zrWHiFZ3A9C7SdYj6
my /etc/pulse/daemon.conf http://dpaste.com/01XQVDP
Back to top
View user's profile Send private message
Siarhei
n00b
n00b


Joined: 10 Jan 2016
Posts: 38
Location: Minsk

PostPosted: Tue May 19, 2020 7:06 am    Post subject: [solved] Reply with quote

Upgrading the kernel to gentoo-sources-5.6.13 made the sound great. Support for 24 bit sound has returned. Maybe something in the driver fixed.
Here is my configuration for high fidelity audio playback:
/etc/pulse/daemon.conf
Code:
# This file is part of PulseAudio.
#
# PulseAudio is free software; you can redistribute it and/or modify
# it under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, see <http://www.gnu.org/licenses/>.

## Configuration file for the PulseAudio daemon. See pulse-daemon.conf(5) for
## more information. Default values are commented out.  Use either ; or # for
## commenting.

daemonize = no
; fail = yes
; allow-module-loading = yes
; allow-exit = yes
; use-pid-file = yes
; system-instance = no
; local-server-type = user
; enable-shm = yes
; enable-memfd = yes
; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB
; lock-memory = no
; cpu-limit = no

high-priority = yes
nice-level = -11

realtime-scheduling = yes
realtime-priority = 9

; exit-idle-time = 20
; scache-idle-time = 20

; dl-search-path = (depends on architecture)

; load-default-script-file = yes
; default-script-file = /etc/pulse/default.pa

; log-target = auto
; log-level = notice
; log-meta = no
; log-time = no
; log-backtrace = 0

resample-method = soxr-vhq
; avoid-resampling = false
; enable-remixing = yes
; remixing-use-all-sink-channels = yes
enable-lfe-remixing = no
; lfe-crossover-freq = 0

; flat-volumes = no

; rlimit-fsize = -1
; rlimit-data = -1
; rlimit-stack = -1
; rlimit-core = -1
; rlimit-as = -1
; rlimit-rss = -1
; rlimit-nproc = -1
; rlimit-nofile = 256
; rlimit-memlock = -1
; rlimit-locks = -1
; rlimit-sigpending = -1
; rlimit-msgqueue = -1
; rlimit-nice = 31
rlimit-rtprio = 9
; rlimit-rttime = 200000

default-sample-format = s24le
default-sample-rate = 96000
alternate-sample-rate = 96000
default-sample-channels = 2
default-channel-map = front-left,front-right

default-fragments = 2
default-fragment-size-msec = 125

; enable-deferred-volume = yes
; deferred-volume-safety-margin-usec = 8000
; deferred-volume-extra-delay-usec = 0


default.pa (if you have glitches, skips or crackling)
Changed the line "load-module module-udev-detect" to "load-module module-udev-detect tsched=0"
Back to top
View user's profile Send private message
Siarhei
n00b
n00b


Joined: 10 Jan 2016
Posts: 38
Location: Minsk

PostPosted: Sat May 23, 2020 6:25 pm    Post subject: Reply with quote

The problem was not in the driver. "load-module module-udev-detect tsched=0" - way to success
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum