Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Módulo do kernel para placa som Sunrise Point-LP
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
nazgulba
n00b
n00b


Joined: 22 Oct 2019
Posts: 26
Location: Latitude: -20.3222, Longitude: -40.3381 20° 19′ 20″ Sul, 40° 20′ 17″ Oeste

PostPosted: Thu Mar 26, 2020 10:41 pm    Post subject: [SOLVED] Módulo do kernel para placa som Sunrise Point-LP Reply with quote

Depois de um problema com o meu notebook DELL Inspiron 7460, tive que instalar o Gentoo LInux do zero. Após a verificação dos itens e configurações constatei que a placa de som não está funcionando embora seja detectada. Segui as recomendações do wiki https://wiki.gentoo.org/wiki/ALSA porém não tive êxito. Executei alguns comandos a seguir para verificar se pelo menos a placa está sendo detectada.

Code:
lspci -vv | grep -i audio

00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
        Subsystem: Dell Sunrise Point-LP HD Audio


Code:
ls /dev/snd
seq  timer



Code:
alsamixer
cannot open mixer: Arquivo ou diretório inexistente


Code:
lspci -nnk
00:1f.3 Audio device [0403]: Intel Corporation Sunrise Point-LP HD Audio [8086:9d71] (rev 21)
        Subsystem: Dell Sunrise Point-LP HD Audio [1028:0781]
        Kernel driver in use: snd_hda_intel


Meu kernel config
http://dpaste.com/1M3ZCHD

Tomei até uma medida extrema e não recomendada ativei todos os módulos no kernel para PCI devices, pois não encontrei que módulo é da Sunrise Point-LP

Dmesg
http://dpaste.com/0T6K7SG


Last edited by nazgulba on Wed Apr 15, 2020 2:10 pm; edited 1 time in total
Back to top
View user's profile Send private message
overlock
n00b
n00b


Joined: 28 Mar 2020
Posts: 2

PostPosted: Sun Mar 29, 2020 11:06 pm    Post subject: Reply with quote

Estava com um problema semelhante,eu estava compilando os drivers de som como M e por algum motivo o não estava sendo ativado no boot,então compilei tudo como ativo,mas uma dica que dou no live cd de um # lspci -k e anote os modulos ativos e use a pesquisa no make menuconfig e habilite só os módulos que precisa.[/b]
Back to top
View user's profile Send private message
nazgulba
n00b
n00b


Joined: 22 Oct 2019
Posts: 26
Location: Latitude: -20.3222, Longitude: -40.3381 20° 19′ 20″ Sul, 40° 20′ 17″ Oeste

PostPosted: Tue Mar 31, 2020 12:02 am    Post subject: Reply with quote

Peguei resposta no forum em inglês de multimedia. Me orientaram a configurar driver direto no kernel ao inves de usar como módulo.

Funcionou após desativar o PIN CNTRL no kernel, recomplidar kernel, boot e não subiu o kernel. Boot com cd instalação do gentoo e ativado PIN CTRL no kernel, mantendo o SunRise driver no kernel. Compilei e rebotei.

Placa de som detectada.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum