Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Bluetooth Kopfhörer
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3143
Location: Berlin

PostPosted: Wed Mar 18, 2020 3:50 pm    Post subject: Bluetooth Kopfhörer Reply with quote

Hallo, ich nutze mit meinem Hama Bluetooth USB Adapter (Bluetooth 4.0 C1 + EDR) zwei Kopfhörer. (Beide Funktionieren unter Windows10 tadellos im Umkreis von ca. 20 mtr.. Mit Gentoo macht der eine aber Probleme. Ich habe, sobald ich mich in einer Entfernung von ca. 5mtr. bewege, ständig Aussetzer. Ich habe jetzt die Installation geändert: Alt
Code:
media-sound/pulseaudio-13.0::gentoo  USE="X alsa alsa-plugin asyncns caps dbus equalizer gdbm glib gtk ipv6 libsamplerate orc qt5 realtime ssl systemd tcpd udev webrtc-aec bluetooth -doc (-elogind) -gconf -jack -libressl -lirc native-headset ofono-headset (-oss) (-selinux) -sox (-system-wide) -test -zeroconf" ABI_X86="32 (64) (-x32)" 0 KiB

Neu
Code:
media-sound/pulseaudio-13.0::gentoo  USE="X alsa alsa-plugin asyncns caps dbus equalizer gdbm glib gtk ipv6 libsamplerate orc qt5 realtime ssl systemd tcpd udev webrtc-aec -bluetooth -doc (-elogind) -gconf -jack -libressl -lirc -native-headset -ofono-headset (-oss) (-selinux) -sox (-system-wide) -test -zeroconf" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild   R   ~] media-sound/pulseaudio-modules-bt-1.3::gentoo  0 KiB
. Ich habe das Gefühl, das die Übertragung geringfügig besser geworden ist. Aber es ist immer noch unbefriedigend. Vielleicht hat jemand eine Idee.
Die Daten vom gut funktionierenden Kopfhörer
Code:
Proxelle SOLO Bluetooth 4.2 InEar Kopfhörer
Code:
$ pactl list | grep -Pzo '.*bluez_card(.*\n)*'
        Name: bluez_card.00_00_00_00_47_93
        Treiber: module-bluez5-device.c
        Owner-Modul: 30
        Eigenschaften:
                device.description = "Proxelle SOLO"
                device.string = "00:00:00:00:47:93"
                device.api = "bluez"
                device.class = "sound"
                device.bus = "bluetooth"
                device.form_factor = "headset"
                bluez.path = "/org/bluez/hci0/dev_00_00_00_00_47_93"
                bluez.class = "0x240404"
                bluez.alias = "Proxelle SOLO"
                device.icon_name = "audio-headset-bluetooth"
                device.intended_roles = "phone"
        Profile:
                headset_head_unit: Headset Head Unit (HSP/HFP) (Ziele: 1, Quellen: 1, Priorität: 30, verfügbar: ja)
                a2dp_sink_sbc: High Fidelity Playback (A2DP Sink: SBC) (Ziele: 1, Quellen: 0, Priorität: 40, verfügbar: ja)
                a2dp_sink_aac: High Fidelity Playback (A2DP Sink: AAC) (Ziele: 1, Quellen: 0, Priorität: 40, verfügbar: nein)
                a2dp_sink_aptx: High Fidelity Playback (A2DP Sink: aptX) (Ziele: 1, Quellen: 0, Priorität: 40, verfügbar: nein)
                a2dp_sink_aptx_hd: High Fidelity Playback (A2DP Sink: aptX HD) (Ziele: 1, Quellen: 0, Priorität: 40, verfügbar: nein)
                a2dp_sink_ldac: High Fidelity Playback (A2DP Sink: LDAC) (Ziele: 1, Quellen: 0, Priorität: 40, verfügbar: nein)
                off: Off (Ziele: 0, Quellen: 0, Priorität: 0, verfügbar: ja)
        Aktives Profil: a2dp_sink_sbc
        Ports:
                headset-output: Headset (priority: 0, latency offset: 0 usec, available)
                        Teil der/des Profil(s): headset_head_unit, a2dp_sink_sbc, a2dp_sink_aac, a2dp_sink_aptx, a2dp_sink_aptx_hd, a2dp_sink_ldac
                headset-input: Headset (priority: 0, latency offset: 0 usec)
                        Teil der/des Profil(s): headset_head_unit

Die Daten vom schlecht funktionierenden Kopfhörer
Code:
Mpow 059 Bluetooth Kopfhörer Over Ear Hi-Fi Stereo Dual 40mm Treiber Over Ear mit CVC 6.0 Noise CancelingBluetooth Version: 4.0 Reichweite: 10 m
Code:
$ pactl list | grep -Pzo '.*bluez_card(.*\n)*'
        Name: bluez_card.EB_06_EF_A2_D7_E4
        Treiber: module-bluez5-device.c
        Owner-Modul: 29
        Eigenschaften:
                device.description = "MPOW-059"
                device.string = "EB:06:EF:A2:D7:E4"
                device.api = "bluez"
                device.class = "sound"
                device.bus = "bluetooth"
                device.form_factor = "headset"
                bluez.path = "/org/bluez/hci0/dev_EB_06_EF_A2_D7_E4"
                bluez.class = "0x240404"
                bluez.alias = "MPOW-059"
                device.icon_name = "audio-headset-bluetooth"
                device.intended_roles = "phone"
        Profile:
                headset_head_unit: Headset Head Unit (HSP/HFP) (Ziele: 1, Quellen: 1, Priorität: 30, verfügbar: ja)
                a2dp_sink_sbc: High Fidelity Playback (A2DP Sink: SBC) (Ziele: 1, Quellen: 0, Priorität: 40, verfügbar: ja)
                a2dp_sink_aac: High Fidelity Playback (A2DP Sink: AAC) (Ziele: 1, Quellen: 0, Priorität: 40, verfügbar: nein)
                a2dp_sink_aptx: High Fidelity Playback (A2DP Sink: aptX) (Ziele: 1, Quellen: 0, Priorität: 40, verfügbar: nein)
                a2dp_sink_aptx_hd: High Fidelity Playback (A2DP Sink: aptX HD) (Ziele: 1, Quellen: 0, Priorität: 40, verfügbar: nein)
                a2dp_sink_ldac: High Fidelity Playback (A2DP Sink: LDAC) (Ziele: 1, Quellen: 0, Priorität: 40, verfügbar: nein)
                off: Off (Ziele: 0, Quellen: 0, Priorität: 0, verfügbar: ja)
        Aktives Profil: a2dp_sink_sbc
        Ports:
                headset-output: Headset (priority: 0, latency offset: 0 usec, available)
                        Teil der/des Profil(s): headset_head_unit, a2dp_sink_sbc, a2dp_sink_aac, a2dp_sink_aptx, a2dp_sink_aptx_hd, a2dp_sink_ldac
                headset-input: Headset (priority: 0, latency offset: 0 usec)
                        Teil der/des Profil(s): headset_head_unit
Back to top
View user's profile Send private message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3143
Location: Berlin

PostPosted: Sun Mar 22, 2020 5:26 pm    Post subject: Reply with quote

Das liegt an meinem System. Wenn ich Kubuntu benutze, funktioniert der betreffende Kopfhörer fehlerfrei. Allerdings finde ich den Fehler nicht. :(
Back to top
View user's profile Send private message
firefly
Advocate
Advocate


Joined: 31 Oct 2002
Posts: 4515

PostPosted: Sun Mar 22, 2020 5:40 pm    Post subject: Reply with quote

werden die gleichen libraries/programme verwendet (auch in gleicher version?)
Wenn ja dann prüfe mal ob es in der konfiguration unterschiede gibt
_________________
Ein Ring, sie zu knechten, sie alle zu finden,
Ins Dunkel zu treiben und ewig zu binden
Im Lande Mordor, wo die Schatten drohn.
Back to top
View user's profile Send private message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3143
Location: Berlin

PostPosted: Tue Mar 24, 2020 3:06 pm    Post subject: Reply with quote

Das kann man schlecht nachvollziehen. Ich habe die
Code:
/etc/pulse/default.pa, daemon.conf, client.conf, system.pa
und die
Code:
/etc/bluetooth/main.conf
von Kubuntu übernommen und die bei Kubuntu nicht vorhandene
Code:
/etc/bluetooth/audio.conf
gelöscht.
ich habe festgestellt, das bei KDE systemsettings5 bei Kubuntu das phonon-gstreamer Backend installiert und aktiv ist. Außerdem ist dort gst-plugins-pulse pulseaudio-modules-bt installiert.
Bei meiner Gentoo KDE Installation habe ich installiert:
Code:
media-plugins/gst-plugins-pulse-1.14.5:1.0 ABI_X86="32 (64) (-x32)"
media-sound/pulseaudio-modules-bt-1.3
media-libs/phonon-4.11.1-r1::gentoo  USE="gstreamer pulseaudio vlc -debug -designer"
media-libs/phonon-vlc-0.11.1::gentoo  USE="-debug"
media-libs/phonon-gstreamer-4.10.0::gentoo  USE="alsa network -debug"
media-sound/pulseaudio-13.0::gentoo  USE="X alsa alsa-plugin asyncns caps dbus equalizer gdbm glib gtk ipv6 libsamplerate orc qt5 realtime sox ssl systemd tcpd udev webrtc-aec -bluetooth -doc (-elogind) -gconf -jack -libressl -lirc -native-headset -ofono-headset (-oss) (-selinux) (-system-wide) -test -zeroconf" ABI_X86="32 (64) (-x32)"
Im KDE Kontrollzentrum kann ich allerdings kein Backend auswählen. Ich probiere jetzt über /usr/bin/phononsettings die Backends durch.
Back to top
View user's profile Send private message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3143
Location: Berlin

PostPosted: Thu Mar 26, 2020 5:22 pm    Post subject: Reply with quote

Ich habe icewm und kde installiert.Wenn ich mich bei icewm einlogge, besteht das Problem nicht. Nur wenn ich kde starte. :? Ich habe mit phonon schon alle Varianten durch.
Code:
USE="-pulseaudio -vlc -gstreamer" emerge phonon
USE="pulseaudio -vlc -gstreamer" emerge phonon
USE="-pulseaudio vlc -gstreamer" emerge phonon
USE="-pulseaudio -vlc gstreamer" emerge phonon
USE="-pulseaudio vlc gstreamer" emerge phonon
USE="pulseaudio vlc gstreamer" emerge phonon
Ich wollte phonon auch ganz entfernen, das funktioniert aber nicht.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4482

PostPosted: Fri Mar 27, 2020 5:27 am    Post subject: Reply with quote

flammenflitzer wrote:
Ich habe icewm und kde installiert.Wenn ich mich bei icewm einlogge, besteht das Problem nicht. Nur wenn ich kde starte. :? Ich habe mit phonon schon alle Varianten durch.
Code:
USE="-pulseaudio -vlc -gstreamer" emerge phonon
USE="pulseaudio -vlc -gstreamer" emerge phonon
USE="-pulseaudio vlc -gstreamer" emerge phonon
USE="-pulseaudio -vlc gstreamer" emerge phonon
USE="-pulseaudio vlc gstreamer" emerge phonon
USE="pulseaudio vlc gstreamer" emerge phonon
Ich wollte phonon auch ganz entfernen, das funktioniert aber nicht.

vlc und gstreamer flags in phonon managen nur Abhängigkeiten und aktivieren KEINEN Support in phonon. Du musst phonon-vlc und phonon-gstreamer entsprechend selber deinstallieren.
Aber wahrscheinlich hilft es nicht, wenn du eh schon selber in systemsettings die backends durchprobiert hast.

Ich würde testweise plasma-pa deinstallieren. Logout und Login und schauen obs geht.
Wenn ja brauchst du kde-plasma/plasma-meta -pulseaudio in der package.use.
Als alternatives Mixer-Plugin bietet sich dann kmix an.
Back to top
View user's profile Send private message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3143
Location: Berlin

PostPosted: Fri Mar 27, 2020 6:39 pm    Post subject: Reply with quote

Ich denke, das ich das Problem gelöst habe. Ich habe verschiedene Prozesse gekillt und entsprechend dem Ergebnis kdeconnect deinstalliert. Wenn die Kopfhörer wieder aufgeladen sind, teste ich weiter. Ich denke aber, das ich das Problem gelöst habe. Ich werde dann ggf. auf [gelöst] setzen. Schönen Abend :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum