Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Can't build mate-applets
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Linx_
n00b
n00b


Joined: 01 Jul 2018
Posts: 27

PostPosted: Tue Feb 18, 2020 2:23 am    Post subject: [SOLVED] Can't build mate-applets Reply with quote

Hello, all. I'm reinstalling my Gentoo box after a year or so, and mate-applets is choking on the cpufreq bug no matter what I try. I'm on gentoo-sources 4.19.104 and ~amd64. I've applied the patch here, with no luck. https://www.gentoofan.org/gentoo/misc/gst/gstreamer-1.16.2-make43.patch

As a side note, it seems like the Mate packages in portage are really, really stale. Building it has been a mess with workarounds, masks, and patches at every turn because the base system is so far ahead of the desktop packages. make-4.3 breaks a whole bunch of gstreamer stuff, and apparently mate-applets has problems with quite a few kernels from what I can tell. Anybody know when the upstream might get merged into portage?
_________________
I occasionally post sober.


Last edited by Linx_ on Thu Feb 20, 2020 5:20 am; edited 1 time in total
Back to top
View user's profile Send private message
Juippisi
Developer
Developer


Joined: 30 Sep 2005
Posts: 425
Location: /home

PostPosted: Tue Feb 18, 2020 4:54 am    Post subject: Re: Can't build mate-applets Reply with quote

Linx_ wrote:

As a side note, it seems like the Mate packages in portage are really, really stale. Building it has been a mess with workarounds, masks, and patches at every turn because the base system is so far ahead of the desktop packages. make-4.3 breaks a whole bunch of gstreamer stuff, and apparently mate-applets has problems with quite a few kernels from what I can tell. Anybody know when the upstream might get merged into portage?


It's because every dev in the mate project are currently inactive, and probably looking for retirement of Gentoo work. And no one else outside the project seem to be interested in maintaining Mate-related packages.

I've asked one active proxy-maintainer who keeps mate bumped in their overlay to take it and proxy-maintain it in ::gentoo, but they don't seem interested in doing that. And I get it, it's a lot of duplicated work, if it's already in your overlay and you have the latest packages installed.
Back to top
View user's profile Send private message
Muso
Veteran
Veteran


Joined: 22 Oct 2002
Posts: 1057
Location: The Holy city of Honolulu

PostPosted: Tue Feb 18, 2020 8:03 am    Post subject: Reply with quote

As Juippisi has stated. Maybe look for a new WM/DE that is more actively maintained?
_________________
"You can lead a horticulture but you can't make her think" ~ Dorothy Parker
2020 is the year of the Linux Desktop!
Back to top
View user's profile Send private message
Linx_
n00b
n00b


Joined: 01 Jul 2018
Posts: 27

PostPosted: Tue Feb 18, 2020 4:24 pm    Post subject: Re: Can't build mate-applets Reply with quote

Juippisi wrote:
Linx_ wrote:

As a side note, it seems like the Mate packages in portage are really, really stale. Building it has been a mess with workarounds, masks, and patches at every turn because the base system is so far ahead of the desktop packages. make-4.3 breaks a whole bunch of gstreamer stuff, and apparently mate-applets has problems with quite a few kernels from what I can tell. Anybody know when the upstream might get merged into portage?


It's because every dev in the mate project are currently inactive, and probably looking for retirement of Gentoo work. And no one else outside the project seem to be interested in maintaining Mate-related packages.

I've asked one active proxy-maintainer who keeps mate bumped in their overlay to take it and proxy-maintain it in ::gentoo, but they don't seem interested in doing that. And I get it, it's a lot of duplicated work, if it's already in your overlay and you have the latest packages installed.

What overlay is that? I tried mate-de-gentoo, but I just got a package block on gdbus-codegen and glib that I couldn't resolve.
_________________
I occasionally post sober.


Last edited by Linx_ on Tue Feb 18, 2020 4:54 pm; edited 2 times in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 23479
Location: here

PostPosted: Tue Feb 18, 2020 4:33 pm    Post subject: Re: Can't build mate-applets Reply with quote

Linx_ wrote:
What overlay is that? I tried mate-de-gentoo, but I just got a package block on gdbus-codeblocks and glib that I couldn't resolve.

I tried now mate-de-gentoo and emerge --ask --changed-use mate-base/mate return no blocker, you can post exact emerge output?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Linx_
n00b
n00b


Joined: 01 Jul 2018
Posts: 27

PostPosted: Tue Feb 18, 2020 4:49 pm    Post subject: Re: Can't build mate-applets Reply with quote

fedeliallalinea wrote:
Linx_ wrote:
What overlay is that? I tried mate-de-gentoo, but I just got a package block on gdbus-codeblocks and glib that I couldn't resolve.

I tried now mate-de-gentoo and emerge --ask --changed-use mate-base/mate return no blocker, you can post exact emerge output?

You are correct, but the block comes in when I try to update my @world. Try running emerge -auDvN @world and see what you get.

Code:
[blocks B      ] <dev-util/gdbus-codegen-2.62.4 ("<dev-util/gdbus-codegen-2.62.4" is blocking dev-libs/glib-2.62.4)

Total: 19 packages (3 upgrades, 16 new), Size of downloads: 4,959 KiB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-util/gdbus-codegen-2.60.7:0/0::gentoo, installed) pulled in by
    dev-util/gdbus-codegen required by (mail-client/evolution-3.32.5-r2:2.0/2.0::gentoo, installed) USE="bogofilter ldap spell ssl weather -archive -geolocation -gtk-doc -highlight -spamassassin -ytnef" ABI_X86="(64)"
    dev-util/gdbus-codegen required by (gnome-base/dconf-0.32.0-r2:0/0::gentoo, installed) USE="-gtk-doc -test" ABI_X86="(64)"
    dev-util/gdbus-codegen required by (x11-misc/mate-notification-daemon-1.24.0:0/0::mate-de-gentoo, ebuild scheduled for merge) USE="" ABI_X86="(64)"
    dev-util/gdbus-codegen required by (app-misc/geoclue-2.5.3-r2:2.0/2.0::gentoo, installed) USE="introspection -gtk-doc -modemmanager -vala -zeroconf" ABI_X86="(64)"
    dev-util/gdbus-codegen required by (net-print/cups-filters-1.27.1:0/0::gentoo, installed) USE="dbus foomatic jpeg ldap pdf png postscript tiff -ipp_autosetup -pclm -perl -static-libs -test -zeroconf" ABI_X86="(64)"
    >=dev-util/gdbus-codegen-2.48 required by (x11-libs/gtk+-3.24.13:3/3::gentoo, installed) USE="X colord cups introspection xinerama (-aqua) -broadway -cloudprint -examples -gtk-doc -test -vim-syntax -wayland" ABI_X86="(64) -32 (-x32)"
    dev-util/gdbus-codegen required by (net-libs/webkit-gtk-2.26.4-r1:4/37::gentoo, installed) USE="X egl geolocation gnome-keyring gstreamer introspection jpeg2k jumbo-build libnotify opengl (seccomp) spell (-aqua) -coverage -gles2-only -gtk-doc -test -wayland" ABI_X86="(64)"
    dev-util/gdbus-codegen required by (app-crypt/libsecret-0.18.8:0/0::gentoo, installed) USE="crypt introspection vala -test" ABI_X86="(64) -32 (-x32)"
    dev-util/gdbus-codegen required by (net-misc/networkmanager-1.18.4-r3:0/0::gentoo, installed) USE="dhclient introspection modemmanager ncurses nss policykit ppp systemd wext wifi -audit -bluetooth -connection-sharing (-consolekit) -dhcpcd (-elogind) -gnutls -iwd -json -ofono -ovs -resolvconf (-selinux) -teamd -test -vala" ABI_X86="(64) -32 (-x32)"
    dev-util/gdbus-codegen required by (net-misc/modemmanager-1.10.0:0/1::gentoo, installed) USE="introspection policykit qmi systemd udev (-elogind) -mbim -vala" ABI_X86="(64)"
    >=dev-util/gdbus-codegen-2.30.0 required by (net-libs/gnome-online-accounts-3.32.1:0/1::gentoo, installed) USE="introspection vala -debug -gnome -kerberos" ABI_X86="(64)"
    dev-util/gdbus-codegen required by (gnome-extra/evolution-data-server-3.32.5:0/62-24::gentoo, installed) USE="berkdb gnome-online-accounts gtk introspection ipv6 ldap vala weather -gtk-doc -kerberos -oauth -test" ABI_X86="(64)"
    dev-util/gdbus-codegen required by (app-crypt/gcr-3.34.0-r1:0/1::gentoo, installed) USE="gtk introspection vala -debug -test" ABI_X86="(64)"
    dev-util/gdbus-codegen required by (gnome-base/gnome-desktop-3.32.2:3/17::gentoo, installed) USE="introspection (seccomp) udev -debug -gtk-doc -test" ABI_X86="(64)"
    dev-util/gdbus-codegen required by (xfce-base/xfconf-4.14.1:0/3::gentoo, installed) USE="introspection -debug -perl -vala" ABI_X86="(64)"

  (dev-libs/glib-2.62.4:2/2::mate-de-gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-2.36 required by (net-libs/libqmi-1.22.2:0/5.4::gentoo, installed) USE="mbim -doc -static-libs" ABI_X86="(64)"
    >=dev-libs/glib-2.42 required by (xfce-base/exo-0.12.11:0/0::gentoo, installed) USE="-gtk2" ABI_X86="(64)"
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.34.3:2[abi_x86_64(-)]) required by (gnome-base/librsvg-2.40.20:2/2::gentoo, installed) USE="introspection vala -tools" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.42:2 required by (xfce-base/libxfce4ui-4.15.1:0/0::gentoo, installed) USE="introspection startup-notification -debug -glade -libgtop -vala" ABI_X86="(64)"
    >=dev-libs/glib-2.52:2 required by (net-libs/gnome-online-accounts-3.32.1:0/1::gentoo, installed) USE="introspection vala -debug -gnome -kerberos" ABI_X86="(64)"
    >=dev-libs/glib-2.53.4:2 required by (dev-util/gtk-update-icon-cache-3.24.13:0/0::gentoo, installed) USE="" ABI_X86="(64)"
    >=dev-libs/glib-2.44:2 required by (gnome-base/gnome-keyring-3.31.91-r1:0/0::gentoo, installed) USE="caps filecaps pam ssh-agent (-selinux) -test" ABI_X86="(64)"
    dev-libs/glib:2 required by (app-office/libreoffice-6.3.4.2-r1:0/0::gentoo, installed) USE="branding cups dbus eds gstreamer gtk ldap mariadb -accessibility -bluetooth -coinmp -debug -firebird -googledrive -gtk2 -java -kde -odk -pdfimport -postgres -test" ABI_X86="(64)" LIBREOFFICE_EXTENSIONS="-nlpsolver -scripting-beanshell -scripting-javascript -wiki-publisher" PYTHON_SINGLE_TARGET="python3_6 -python3_7 -python3_8"
    >=dev-libs/glib-2.55.1:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.55.1:2[abi_x86_64(-)]) required by (net-libs/glib-networking-2.60.4:0/0::gentoo, installed) USE="libproxy ssl -gnome -test" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.44.0:2 required by (dev-libs/libgweather-3.34.0:2/3-16-2::gentoo, installed) USE="introspection vala -glade -gtk-doc" ABI_X86="(64)"
    >=dev-libs/glib-2.50:2 required by (x11-misc/mate-notification-daemon-1.24.0:0/0::mate-de-gentoo, ebuild scheduled for merge) USE="" ABI_X86="(64)"
    >=dev-libs/glib-2.30.0:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.30.0:2[abi_x86_64(-)]) required by (media-libs/graphene-1.8.6:0/0::gentoo, installed) USE="introspection -doc -test" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="sse2"
    >=dev-libs/glib-2.38.0:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?,static-libs?] (>=dev-libs/glib-2.38.0:2[abi_x86_64(-)]) required by (dev-libs/libgudev-233-r1:0/0::gentoo, installed) USE="introspection (-static-libs)" ABI_X86="(64) -32 (-x32)"
    dev-libs/glib:2 required by (app-text/poppler-0.85.0:0/95::gentoo, installed) USE="cairo cxx introspection jpeg jpeg2k lcms png qt5 tiff utils -cjk -curl -debug -doc -nss" ABI_X86="(64)"
    >=dev-libs/glib-2.57.2:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.57.2:2[abi_x86_64(-)]) required by (x11-libs/gtk+-3.24.13:3/3::gentoo, installed) USE="X colord cups introspection xinerama (-aqua) -broadway -cloudprint -examples -gtk-doc -test -vim-syntax -wayland" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.48.0:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.48.0:2[abi_x86_64(-)]) required by (x11-libs/gdk-pixbuf-2.40.0:2/2::gentoo, installed) USE="X introspection jpeg tiff -gtk-doc" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.32:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.32:2[abi_x86_64(-)]) required by (app-accessibility/at-spi2-atk-2.34.0:2/2::gentoo, installed) USE="-test" ABI_X86="(64) -32 (-x32)"
    dev-libs/glib required by (media-gfx/fontforge-20190801:0/0::gentoo, installed) USE="X cairo gif gtk jpeg png python readline svg tiff unicode -test -truetype-debugger" ABI_X86="(64)" PYTHON_SINGLE_TARGET="python3_6 -python3_7"
    >=dev-libs/glib-2.32:2 required by (x11-libs/libwnck-3.30.0:3/3::gentoo, installed) USE="introspection startup-notification -tools" ABI_X86="(64)"
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.34.3:2[abi_x86_64(-)]) required by (x11-libs/cairo-1.16.0-r3:0/0::gentoo, installed) USE="X glib opengl svg (-aqua) -debug (-gles2-only) -static-libs -utils -valgrind" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.44.0:2 required by (net-libs/webkit-gtk-2.26.4-r1:4/37::gentoo, installed) USE="X egl geolocation gnome-keyring gstreamer introspection jpeg2k jumbo-build libnotify opengl (seccomp) spell (-aqua) -coverage -gles2-only -gtk-doc -test -wayland" ABI_X86="(64)"
    >=dev-libs/glib-2.46:2[dbus] required by (mail-client/evolution-3.32.5-r2:2.0/2.0::gentoo, installed) USE="bogofilter ldap spell ssl weather -archive -geolocation -gtk-doc -highlight -spamassassin -ytnef" ABI_X86="(64)"
    >=dev-libs/glib-2.44.0:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.44.0:2[abi_x86_64(-)]) required by (dev-libs/json-glib-1.4.4:0/0::gentoo, installed) USE="introspection -gtk-doc" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.44.0:2 required by (x11-misc/lightdm-1.30.0:0/0::gentoo, installed) USE="gtk introspection qt5 -audit -gnome -non_root -vala" ABI_X86="(64)"
    >=dev-libs/glib-2.38.0:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.38.0:2[abi_x86_64(-)]) required by (dev-libs/atk-2.34.1:0/0::gentoo, installed) USE="introspection -gtk-doc" ABI_X86="(64) -32 (-x32)"
    dev-libs/glib:2 required by (net-print/cups-filters-1.27.1:0/0::gentoo, installed) USE="dbus foomatic jpeg ldap pdf png postscript tiff -ipp_autosetup -pclm -perl -static-libs -test -zeroconf" ABI_X86="(64)"
    >=dev-libs/glib-2.38.2-r1:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.38.2-r1:2[abi_x86_64(-)]) required by (media-plugins/gst-plugins-gtk-1.14.5:1.0/1.0::gentoo, installed) USE="X egl opengl -gles2 -wayland" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.38.2-r1:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.38.2-r1:2[abi_x86_64(-)]) required by (media-libs/gst-plugins-base-1.14.5-r1:1.0/1.0::gentoo, installed) USE="X alsa egl introspection nls ogg opengl orc pango theora vorbis -gbm -gles2 -ivorbis -wayland" ABI_X86="(64) -32 (-x32)"
    dev-libs/glib:2 required by (dev-qt/qtgui-5.14.1-r2:5/5.14.1::gentoo, installed) USE="X dbus egl gif jpeg libinput png udev -accessibility -debug -eglfs -evdev (-gles2) -ibus -test -tslib -tuio -vnc -wayland" ABI_X86="(64)"
    >=dev-libs/glib-2.24:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.24:2[abi_x86_64(-)]) required by (net-libs/rest-0.8.1:0.7/0.7::gentoo, installed) USE="introspection -test" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.58.0:2 required by (dev-libs/gobject-introspection-1.60.2-r1:0/0::gentoo, installed) USE="cairo -doctool -test" ABI_X86="(64)" PYTHON_SINGLE_TARGET="python3_6 -python3_7 -python3_8"
    >=dev-libs/glib-2.38:2 required by (app-crypt/gcr-3.34.0-r1:0/1::gentoo, installed) USE="gtk introspection vala -debug -test" ABI_X86="(64)"
    dev-libs/glib:2 required by (dev-libs/libical-3.0.7:0/3::gentoo, installed) USE="berkdb introspection -doc -examples -static-libs -test -vala" ABI_X86="(64)"
    >=dev-libs/glib-2.16:2/2= required by (x11-libs/libxklavier-5.4:0/16::gentoo, installed) USE="introspection -vala" ABI_X86="(64)"
    >=dev-libs/glib-2.44.0:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.44.0:2[abi_x86_64(-)]) required by (dev-libs/libgusb-0.3.3:0/0::gentoo, installed) USE="introspection -gtk-doc -static-libs -test -vala" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.40:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.40:2[abi_x86_64(-)]) required by (dev-libs/dbus-glib-0.110:0/0::gentoo, installed) USE="-debug -static-libs -test" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.48:2 required by (dev-python/pygobject-3.34.0:3/3::gentoo, installed) USE="cairo -examples -test" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 -python3_7 -python3_8"
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.34.3:2[abi_x86_64(-)]) required by (dev-libs/libcroco-0.6.13:0.6/0.6::gentoo, installed) USE="-test" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.38.2-r1:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.38.2-r1:2[abi_x86_64(-)]) required by (media-plugins/gst-plugins-opus-1.14.5:1.0/1.0::gentoo, installed) USE="" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.26.0:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.26.0:2[abi_x86_64(-)]) required by (media-sound/pulseaudio-13.0:0/0::gentoo, installed) USE="X alsa alsa-plugin asyncns caps dbus gdbm glib gtk ipv6 orc qt5 ssl systemd tcpd udev webrtc-aec -bluetooth -doc (-elogind) -equalizer -gconf -jack -libressl -libsamplerate -lirc -native-headset -ofono-headset (-oss) -realtime (-selinux) -sox (-system-wide) -test -zeroconf" ABI_X86="(64) -32 (-x32)"
    dev-libs/glib:2 required by (app-text/gtkspell-3.0.10:3/0::gentoo, installed) USE="introspection -vala" ABI_X86="(64)"
    >=dev-libs/glib-2.36:2 required by (net-libs/libmbim-1.18.0:0/0::gentoo, installed) USE="udev -static-libs" ABI_X86="(64)"
    >=dev-libs/glib-2.40:2 required by (sys-apps/xdg-dbus-proxy-0.1.2:0/0::gentoo, installed) USE="" ABI_X86="(64)"
    >=dev-libs/glib-2.32:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.32:2[abi_x86_64(-)]) required by (media-libs/libcanberra-0.30-r5:0/0::gentoo, installed) USE="alsa gstreamer gtk gtk3 pulseaudio sound udev -gnome -oss -tdb" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.50.2:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.50.2:2[abi_x86_64(-)]) required by (x11-libs/pango-1.42.4-r2:0/0::gentoo, installed) USE="X introspection -test" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.36:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.36:2[abi_x86_64(-)]) required by (app-accessibility/at-spi2-core-2.34.0:2/2::gentoo, installed) USE="X introspection -gtk-doc -test" ABI_X86="(64) -32 (-x32)"
    dev-libs/glib:2 required by (sys-auth/polkit-0.116-r1:0/0::gentoo, installed) USE="gtk introspection nls pam systemd (-consolekit) (-elogind) -examples -jit -kde (-selinux) -test" ABI_X86="(64)"
    >=dev-libs/glib-2.44.0:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.44.0:2[abi_x86_64(-)]) required by (x11-misc/colord-1.3.5:0/2::gentoo, installed) USE="gusb introspection policykit scanner systemd udev -argyllcms -examples -extra-print-profiles -vala" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.26:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.26:2[abi_x86_64(-)]) required by (x11-libs/libnotify-0.7.8:0/0::gentoo, installed) USE="introspection -gtk-doc -test" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.30 required by (gnome-extra/polkit-gnome-0.105-r2:0/0::gentoo, installed) USE="" ABI_X86="(64)"
    >=dev-libs/glib-2.38:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.38:2[abi_x86_64(-)]) required by (net-libs/libsoup-2.66.4:2.4/2.4::gentoo, installed) USE="introspection ssl vala -gssapi -gtk-doc -samba -test" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.38.2-r1:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.38.2-r1:2[abi_x86_64(-)]) required by (media-libs/gst-plugins-bad-1.14.5:1.0/1.0::gentoo, installed) USE="X bzip2 egl gtk introspection nls opengl orc -gles2 -test -vcd -vnc -wayland" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.40.0:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.40.0:2[abi_x86_64(-)]) required by (media-libs/gst-plugins-bad-1.14.5:1.0/1.0::gentoo, installed) USE="X bzip2 egl gtk introspection nls opengl orc -gles2 -test -vcd -vnc -wayland" ABI_X86="(64) -32 (-x32)"
    dev-libs/glib:2 required by (dev-qt/qtcore-5.14.1-r1:5/5.14::gentoo, installed) USE="icu systemd -debug -test" ABI_X86="(64)"
    dev-libs/glib:2 required by (x11-drivers/nvidia-drivers-440.59:0/440::gentoo, ebuild scheduled for merge) USE="X acpi driver gtk3 kms multilib tools -compat -libglvnd -static-libs -uvm -wayland" ABI_X86="32 (64) (-x32)"
    >=dev-libs/glib-2.38:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.38:2[abi_x86_64(-)]) required by (media-libs/harfbuzz-2.6.4:0/0.9.18::gentoo, installed) USE="cairo glib graphite icu introspection truetype -debug -static-libs -test" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.42 required by (xfce-base/xfconf-4.14.1:0/3::gentoo, installed) USE="introspection -debug -perl -vala" ABI_X86="(64)"
    >=dev-libs/glib-2.44.0:2 required by (gnome-base/dconf-0.32.0-r2:0/0::gentoo, installed) USE="-gtk-doc -test" ABI_X86="(64)"
    >=dev-libs/glib-2.44:2 required by (sci-geosciences/geocode-glib-3.26.1:0/0::gentoo, installed) USE="introspection -gtk-doc -test" ABI_X86="(64)"
    >=dev-libs/glib-2.44:2 required by (app-misc/geoclue-2.5.3-r2:2.0/2.0::gentoo, installed) USE="introspection -gtk-doc -modemmanager -vala -zeroconf" ABI_X86="(64)"
    >=dev-libs/glib-2.38.2-r1:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.38.2-r1:2[abi_x86_64(-)]) required by (media-libs/gst-plugins-good-1.14.5:1.0/1.0::gentoo, installed) USE="nls orc" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.34.3:2[abi_x86_64(-)]) required by (x11-libs/gtk+-2.24.32-r1:2/2::gentoo, installed) USE="cups introspection xinerama (-aqua) -examples -test -vim-syntax" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.42 required by (xfce-base/libxfce4util-4.15.0:0/7::gentoo, installed) USE="introspection -vala" ABI_X86="(64)"
    >=dev-libs/glib-2.40.0:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.40.0:2[abi_x86_64(-)]) required by (media-libs/gst-plugins-base-1.14.5-r1:1.0/1.0::gentoo, installed) USE="X alsa egl introspection nls ogg opengl orc pango theora vorbis -gbm -gles2 -ivorbis -wayland" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2 required by (x11-misc/shared-mime-info-1.10-r1:0/0::gentoo, installed) USE="-test" ABI_X86="(64)"
    dev-libs/glib:2 required by (x11-themes/sound-theme-freedesktop-0.8:0/0::gentoo, installed) USE="" ABI_X86="(64)"
    >=dev-libs/glib-2.46:2 required by (gnome-extra/evolution-data-server-3.32.5:0/62-24::gentoo, installed) USE="berkdb gnome-online-accounts gtk introspection ipv6 ldap vala weather -gtk-doc -kerberos -oauth -test" ABI_X86="(64)"
    >=dev-libs/glib-2.40.0:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.40.0:2[abi_x86_64(-)]) required by (media-libs/gstreamer-1.14.5:1.0/1.0::gentoo, installed) USE="caps introspection nls orc -test -unwind" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.44:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.44:2[abi_x86_64(-)]) required by (app-crypt/libsecret-0.18.8:0/0::gentoo, installed) USE="crypt introspection vala -test" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.40:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.40:2[abi_x86_64(-)]) required by (net-misc/networkmanager-1.18.4-r3:0/0::gentoo, installed) USE="dhclient introspection modemmanager ncurses nss policykit ppp systemd wext wifi -audit -bluetooth -connection-sharing (-consolekit) -dhcpcd (-elogind) -gnutls -iwd -json -ofono -ovs -resolvconf (-selinux) -teamd -test -vala" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.48.0:2 required by (dev-lang/vala-0.46.6:0.46/0.46::gentoo, installed) USE="-test -valadoc" ABI_X86="(64)"
    >=dev-libs/glib-2.16:2= required by (x11-libs/libxklavier-5.4:0/16::gentoo, installed) USE="introspection -vala" ABI_X86="(64)"
    >=dev-libs/glib-2.40.0:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.40.0:2[abi_x86_64(-)]) required by (media-libs/gst-plugins-good-1.14.5:1.0/1.0::gentoo, installed) USE="nls orc" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.53.0:2 required by (gnome-base/gnome-desktop-3.32.2:3/17::gentoo, installed) USE="introspection (seccomp) udev -debug -gtk-doc -test" ABI_X86="(64)"
    >=dev-libs/glib-2.12:2 required by (dev-util/desktop-file-utils-0.24:0/0::gentoo, installed) USE="-emacs" ABI_X86="(64)"
    >=dev-libs/glib-2.44.0:2 required by (dev-libs/libgdata-0.17.11:0/22::gentoo, installed) USE="crypt gnome-online-accounts introspection -gtk-doc -test -vala" ABI_X86="(64)"
    >=dev-libs/glib-2.6:2 required by (app-text/enchant-2.2.7:2/2::gentoo, installed) USE="hunspell -aspell" ABI_X86="(64)"
    >=dev-libs/glib-2.36.0:2 required by (net-misc/modemmanager-1.10.0:0/1::gentoo, installed) USE="introspection policykit qmi systemd udev (-elogind) -mbim -vala" ABI_X86="(64)"


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


[Moderator edit: broke long whitespace-free lines in code tags to fix thread layout. -Hu]
_________________
I occasionally post sober.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 23479
Location: here

PostPosted: Tue Feb 18, 2020 5:22 pm    Post subject: Reply with quote

The problem is dev-util/gdbus-codegen-2.62.4 package, what overlay want to install this version (not the official gentoo tree nor mate-de-gentoo)
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Linx_
n00b
n00b


Joined: 01 Jul 2018
Posts: 27

PostPosted: Tue Feb 18, 2020 5:52 pm    Post subject: Reply with quote

fedeliallalinea wrote:
The problem is dev-util/gdbus-codegen-2.62.4 package, what overlay want to install this version (not the official gentoo tree nor mate-de-gentoo)

It's mate-de-gentoo. I don't use any other overlays.
_________________
I occasionally post sober.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 23479
Location: here

PostPosted: Tue Feb 18, 2020 6:04 pm    Post subject: Reply with quote

Linx_ wrote:
It's mate-de-gentoo. I don't use any other overlays.

I just synched now mate-de-gentoo and I don't see dev-util/gdbus-codegen-2.62.4 ebuild in overlay, there is not even the category dev-util.
Code:
$ find /var/db/repos/mate-de-gentoo/ -name 'gdbus-codegen*'
$

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Linx_
n00b
n00b


Joined: 01 Jul 2018
Posts: 27

PostPosted: Tue Feb 18, 2020 6:09 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Linx_ wrote:
It's mate-de-gentoo. I don't use any other overlays.

I just synched now mate-de-gentoo and I don't see dev-util/gdbus-codegen-2.62.4 ebuild in overlay, there is not even the category dev-util.
Code:
$ find /var/db/repos/mate-de-gentoo/ -name 'gdbus-codegen*'
$

I saw that, but I think what's happening is that it is pulling in dev-libs/glib-2.62.4 from the overlay and gdbus-codegen has to be the same version. You are correct that it's not in ::gentoo or in the overlay, but I'm pretty sure that's why it's getting pulled in from somewhere.
_________________
I occasionally post sober.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 23479
Location: here

PostPosted: Tue Feb 18, 2020 6:38 pm    Post subject: Reply with quote

You can post full emerge -uUDt @world output?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Linx_
n00b
n00b


Joined: 01 Jul 2018
Posts: 27

PostPosted: Tue Feb 18, 2020 6:49 pm    Post subject: Reply with quote

Code:
 # emerge -uUDt @world

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[nomerge       ] mail-client/evolution-3.32.5-r2
[nomerge       ]  x11-libs/libnotify-0.7.8
[nomerge       ]   virtual/notification-daemon-0
[ebuild     U  ]    x11-misc/mate-notification-daemon-1.24.0 [1.22.0-r1]
[ebuild     U  ]     mate-base/mate-common-9999 [1.22.0]
[ebuild     U  ]     dev-libs/glib-2.62.4 [2.60.7-r1]
[nomerge       ] mail-client/evolution-3.32.5-r2
[nomerge       ]  net-libs/webkit-gtk-2.26.4-r1
[nomerge       ]   dev-lang/ruby-2.7.0
[ebuild  N     ]    dev-ruby/bundler-2.1.4  USE="doc -test" RUBY_TARGETS="ruby24 ruby25 ruby27 -ruby26"
[ebuild  N     ]     dev-ruby/rdoc-6.2.0  USE="-doc -test" RUBY_TARGETS="ruby24 ruby25 ruby27 -ruby26"
[ebuild  N     ]      dev-ruby/racc-1.4.16-r1  USE="-doc -test" RUBY_TARGETS="ruby24 ruby25 ruby27 -ruby26"
[ebuild  N     ]      dev-ruby/kpeg-1.1.0-r1  USE="-doc -test" RUBY_TARGETS="ruby24 ruby25 ruby27 -ruby26"
[nomerge       ] dev-ruby/racc-1.4.16-r1  USE="-doc -test" RUBY_TARGETS="ruby24 ruby25 ruby27 -ruby26"
[nomerge       ]  dev-lang/ruby-2.4.9
[ebuild  N     ]   dev-ruby/did_you_mean-1.1.2  USE="-test" RUBY_TARGETS="ruby24"
[nomerge       ] dev-ruby/racc-1.4.16-r1  USE="-doc -test" RUBY_TARGETS="ruby24 ruby25 ruby27 -ruby26"
[nomerge       ]  dev-lang/ruby-2.7.0
[ebuild  N     ]   dev-ruby/did_you_mean-1.4.0  USE="-test" RUBY_TARGETS="ruby25 ruby27 -ruby26"
[ebuild  N     ]   dev-ruby/xmlrpc-0.3.0  USE="-doc -test" RUBY_TARGETS="ruby24 ruby25 ruby27 -ruby26"
[ebuild  N     ]   dev-ruby/net-telnet-0.2.0  USE="-doc -test" RUBY_TARGETS="ruby24 ruby25 ruby27 -ruby26"
[ebuild  N     ]   dev-ruby/minitest-5.14.0  USE="-doc -test" RUBY_TARGETS="ruby24 ruby25 ruby27 -ruby26"
[nomerge       ] dev-ruby/racc-1.4.16-r1  USE="-doc -test" RUBY_TARGETS="ruby24 ruby25 ruby27 -ruby26"
[nomerge       ]  dev-lang/ruby-2.5.7
[ebuild  N     ]   dev-ruby/did_you_mean-1.2.1  USE="-test" RUBY_TARGETS="ruby25"
[ebuild  N     ]   dev-ruby/json-2.3.0  USE="-doc -test" RUBY_TARGETS="ruby24 ruby25 ruby27 -ruby26"
[ebuild  N     ]    dev-ruby/rake-13.0.1  USE="-doc -test" RUBY_TARGETS="ruby24 ruby25 ruby27 -ruby26"
[nomerge       ] x11-base/xorg-x11-7.4-r3
[nomerge       ]  x11-base/xorg-server-1.20.7
[nomerge       ]   x11-base/xorg-drivers-1.20-r1
[ebuild  N     ]    x11-drivers/xf86-input-libinput-0.29.0
[ebuild  N     ]    x11-drivers/xf86-input-keyboard-1.9.0
[ebuild  N     ]    x11-drivers/xf86-input-mouse-1.9.3
[ebuild  N     ]    x11-drivers/nvidia-drivers-440.59  USE="X acpi driver gtk3 kms multilib tools -compat -libglvnd -static-libs -uvm -wayland" ABI_X86="32 (64) (-x32)"
[blocks B      ] <dev-util/gdbus-codegen-2.62.4 ("<dev-util/gdbus-codegen-2.62.4" is blocking dev-libs/glib-2.62.4)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-util/gdbus-codegen-2.60.7:0/0::gentoo, installed) pulled in by
    dev-util/gdbus-codegen required by (gnome-base/dconf-0.32.0-r2:0/0::gentoo, installed) USE="-gtk-doc -test" ABI_X86="(64)"
    dev-util/gdbus-codegen required by (gnome-extra/evolution-data-server-3.32.5:0/62-24::gentoo, installed) USE="berkdb gnome-online-accounts gtk introspection ipv6 ldap vala weather -gtk-doc -kerberos -oauth -test" ABI_X86="(64)"
    >=dev-util/gdbus-codegen-2.48 required by (x11-libs/gtk+-3.24.13:3/3::gentoo, installed) USE="X colord cups introspection xinerama (-aqua) -broadway -cloudprint -examples -gtk-doc -test -vim-syntax -wayland" ABI_X86="(64) -32 (-x32)"
    dev-util/gdbus-codegen required by (app-misc/geoclue-2.5.3-r2:2.0/2.0::gentoo, installed) USE="introspection -gtk-doc -modemmanager -vala -zeroconf" ABI_X86="(64)"
    dev-util/gdbus-codegen required by (app-crypt/libsecret-0.18.8:0/0::gentoo, installed) USE="crypt introspection vala -test" ABI_X86="(64) -32 (-x32)"
    dev-util/gdbus-codegen required by (net-libs/webkit-gtk-2.26.4-r1:4/37::gentoo, installed) USE="X egl geolocation gnome-keyring gstreamer introspection jpeg2k jumbo-build libnotify opengl (seccomp) spell (-aqua) -coverage -gles2-only -gtk-doc -test -wayland" ABI_X86="(64)"
    dev-util/gdbus-codegen required by (app-crypt/gcr-3.34.0-r1:0/1::gentoo, installed) USE="gtk introspection vala -debug -test" ABI_X86="(64)"
    dev-util/gdbus-codegen required by (x11-misc/mate-notification-daemon-1.24.0:0/0::mate-de-gentoo, ebuild scheduled for merge) USE="" ABI_X86="(64)"
    dev-util/gdbus-codegen required by (net-misc/modemmanager-1.10.0:0/1::gentoo, installed) USE="introspection policykit qmi systemd udev (-elogind) -mbim -vala" ABI_X86="(64)"
    dev-util/gdbus-codegen required by (mail-client/evolution-3.32.5-r2:2.0/2.0::gentoo, installed) USE="bogofilter ldap spell ssl weather -archive -geolocation -gtk-doc -highlight -spamassassin -ytnef" ABI_X86="(64)"
    >=dev-util/gdbus-codegen-2.30.0 required by (net-libs/gnome-online-accounts-3.32.1:0/1::gentoo, installed) USE="introspection vala -debug -gnome -kerberos" ABI_X86="(64)"
    dev-util/gdbus-codegen required by (net-print/cups-filters-1.27.1:0/0::gentoo, installed) USE="dbus foomatic jpeg ldap pdf png postscript tiff -ipp_autosetup -pclm -perl -static-libs -test -zeroconf" ABI_X86="(64)"
    dev-util/gdbus-codegen required by (net-misc/networkmanager-1.18.4-r3:0/0::gentoo, installed) USE="dhclient introspection modemmanager ncurses nss policykit ppp systemd wext wifi -audit -bluetooth -connection-sharing (-consolekit) -dhcpcd (-elogind) -gnutls -iwd -json -ofono -ovs -resolvconf (-selinux) -teamd -test -vala" ABI_X86="(64) -32 (-x32)"
    dev-util/gdbus-codegen required by (gnome-base/gnome-desktop-3.32.2:3/17::gentoo, installed) USE="introspection (seccomp) udev -debug -gtk-doc -test" ABI_X86="(64)"
    dev-util/gdbus-codegen required by (xfce-base/xfconf-4.14.1:0/3::gentoo, installed) USE="introspection -debug -perl -vala" ABI_X86="(64)"

  (dev-libs/glib-2.62.4:2/2::mate-de-gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-2.38:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.38:2[abi_x86_64(-)]) required by (media-libs/harfbuzz-2.6.4:0/0.9.18::gentoo, installed) USE="cairo glib graphite icu introspection truetype -debug -static-libs -test" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.57.2:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.57.2:2[abi_x86_64(-)]) required by (x11-libs/gtk+-3.24.13:3/3::gentoo, installed) USE="X colord cups introspection xinerama (-aqua) -broadway -cloudprint -examples -gtk-doc -test -vim-syntax -wayland" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.16:2= required by (x11-libs/libxklavier-5.4:0/16::gentoo, installed) USE="introspection -vala" ABI_X86="(64)"
    >=dev-libs/glib-2.44.0:2 required by (x11-misc/lightdm-1.30.0:0/0::gentoo, installed) USE="gtk introspection qt5 -audit -gnome -non_root -vala" ABI_X86="(64)"
    >=dev-libs/glib-2.53.0:2 required by (gnome-base/gnome-desktop-3.32.2:3/17::gentoo, installed) USE="introspection (seccomp) udev -debug -gtk-doc -test" ABI_X86="(64)"
    >=dev-libs/glib-2.50:2 required by (x11-misc/mate-notification-daemon-1.24.0:0/0::mate-de-gentoo, ebuild scheduled for merge) USE="" ABI_X86="(64)"
    >=dev-libs/glib-2.44:2 required by (gnome-base/gnome-keyring-3.31.91-r1:0/0::gentoo, installed) USE="caps filecaps pam ssh-agent (-selinux) -test" ABI_X86="(64)"
    dev-libs/glib:2 required by (x11-drivers/nvidia-drivers-440.59:0/440::gentoo, ebuild scheduled for merge) USE="X acpi driver gtk3 kms multilib tools -compat -libglvnd -static-libs -uvm -wayland" ABI_X86="32 (64) (-x32)"
    >=dev-libs/glib-2.40.0:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.40.0:2[abi_x86_64(-)]) required by (media-libs/gst-plugins-base-1.14.5-r1:1.0/1.0::gentoo, installed) USE="X alsa egl introspection nls ogg opengl orc pango theora vorbis -gbm -gles2 -ivorbis -wayland" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.32:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.32:2[abi_x86_64(-)]) required by (media-libs/libcanberra-0.30-r5:0/0::gentoo, installed) USE="alsa gstreamer gtk gtk3 pulseaudio sound udev -gnome -oss -tdb" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.6:2 required by (app-text/enchant-2.2.7:2/2::gentoo, installed) USE="hunspell -aspell" ABI_X86="(64)"
    >=dev-libs/glib-2.26.0:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.26.0:2[abi_x86_64(-)]) required by (media-sound/pulseaudio-13.0:0/0::gentoo, installed) USE="X alsa alsa-plugin asyncns caps dbus gdbm glib gtk ipv6 orc qt5 ssl systemd tcpd udev webrtc-aec -bluetooth -doc (-elogind) -equalizer -gconf -jack -libressl -libsamplerate -lirc -native-headset -ofono-headset (-oss) -realtime (-selinux) -sox (-system-wide) -test -zeroconf" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.46:2 required by (gnome-extra/evolution-data-server-3.32.5:0/62-24::gentoo, installed) USE="berkdb gnome-online-accounts gtk introspection ipv6 ldap vala weather -gtk-doc -kerberos -oauth -test" ABI_X86="(64)"
    >=dev-libs/glib-2.44.0:2 required by (dev-libs/libgweather-3.34.0:2/3-16-2::gentoo, installed) USE="introspection vala -glade -gtk-doc" ABI_X86="(64)"
    >=dev-libs/glib-2.30 required by (gnome-extra/polkit-gnome-0.105-r2:0/0::gentoo, installed) USE="" ABI_X86="(64)"
    dev-libs/glib:2 required by (dev-libs/libical-3.0.7:0/3::gentoo, installed) USE="berkdb introspection -doc -examples -static-libs -test -vala" ABI_X86="(64)"
    >=dev-libs/glib-2.36:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.36:2[abi_x86_64(-)]) required by (app-accessibility/at-spi2-core-2.34.0:2/2::gentoo, installed) USE="X introspection -gtk-doc -test" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.44.0:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.44.0:2[abi_x86_64(-)]) required by (x11-misc/colord-1.3.5:0/2::gentoo, installed) USE="gusb introspection policykit scanner systemd udev -argyllcms -examples -extra-print-profiles -vala" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.38.0:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?,static-libs?] (>=dev-libs/glib-2.38.0:2[abi_x86_64(-)]) required by (dev-libs/libgudev-233-r1:0/0::gentoo, installed) USE="introspection (-static-libs)" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.38.2-r1:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.38.2-r1:2[abi_x86_64(-)]) required by (media-libs/gst-plugins-good-1.14.5:1.0/1.0::gentoo, installed) USE="nls orc" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.44.0:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.44.0:2[abi_x86_64(-)]) required by (dev-libs/json-glib-1.4.4:0/0::gentoo, installed) USE="introspection -gtk-doc" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.38.2-r1:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.38.2-r1:2[abi_x86_64(-)]) required by (media-plugins/gst-plugins-opus-1.14.5:1.0/1.0::gentoo, installed) USE="" ABI_X86="(64) -32 (-x32)"
    dev-libs/glib:2 required by (dev-qt/qtgui-5.14.1-r2:5/5.14.1::gentoo, installed) USE="X dbus egl gif jpeg libinput png udev -accessibility -debug -eglfs -evdev (-gles2) -ibus -test -tslib -tuio -vnc -wayland" ABI_X86="(64)"
    dev-libs/glib:2 required by (dev-qt/qtcore-5.14.1-r1:5/5.14::gentoo, installed) USE="icu systemd -debug -test" ABI_X86="(64)"
    dev-libs/glib:2 required by (app-text/gtkspell-3.0.10:3/0::gentoo, installed) USE="introspection -vala" ABI_X86="(64)"
    >=dev-libs/glib-2.40.0:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.40.0:2[abi_x86_64(-)]) required by (media-libs/gst-plugins-bad-1.14.5:1.0/1.0::gentoo, installed) USE="X bzip2 egl gtk introspection nls opengl orc -gles2 -test -vcd -vnc -wayland" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.48.0:2 required by (dev-lang/vala-0.46.6:0.46/0.46::gentoo, installed) USE="-test -valadoc" ABI_X86="(64)"
    >=dev-libs/glib-2.36:2 required by (net-libs/libmbim-1.18.0:0/0::gentoo, installed) USE="udev -static-libs" ABI_X86="(64)"
    >=dev-libs/glib-2.12:2 required by (dev-util/desktop-file-utils-0.24:0/0::gentoo, installed) USE="-emacs" ABI_X86="(64)"
    >=dev-libs/glib-2.50.2:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.50.2:2[abi_x86_64(-)]) required by (x11-libs/pango-1.42.4-r2:0/0::gentoo, installed) USE="X introspection -test" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.44:2 required by (sci-geosciences/geocode-glib-3.26.1:0/0::gentoo, installed) USE="introspection -gtk-doc -test" ABI_X86="(64)"
    >=dev-libs/glib-2.44.0:2 required by (net-libs/webkit-gtk-2.26.4-r1:4/37::gentoo, installed) USE="X egl geolocation gnome-keyring gstreamer introspection jpeg2k jumbo-build libnotify opengl (seccomp) spell (-aqua) -coverage -gles2-only -gtk-doc -test -wayland" ABI_X86="(64)"
    >=dev-libs/glib-2.40:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.40:2[abi_x86_64(-)]) required by (dev-libs/dbus-glib-0.110:0/0::gentoo, installed) USE="-debug -static-libs -test" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.38:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.38:2[abi_x86_64(-)]) required by (net-libs/libsoup-2.66.4:2.4/2.4::gentoo, installed) USE="introspection ssl vala -gssapi -gtk-doc -samba -test" ABI_X86="(64) -32 (-x32)"
    dev-libs/glib:2 required by (app-office/libreoffice-6.3.4.2-r1:0/0::gentoo, installed) USE="branding cups dbus eds gstreamer gtk ldap mariadb -accessibility -bluetooth -coinmp -debug -firebird -googledrive -gtk2 -java -kde -odk -pdfimport -postgres -test" ABI_X86="(64)" LIBREOFFICE_EXTENSIONS="-nlpsolver -scripting-beanshell -scripting-javascript -wiki-publisher" PYTHON_SINGLE_TARGET="python3_6 -python3_7 -python3_8"
    >=dev-libs/glib-2 required by (x11-misc/shared-mime-info-1.10-r1:0/0::gentoo, installed) USE="-test" ABI_X86="(64)"
    dev-libs/glib:2 required by (net-print/cups-filters-1.27.1:0/0::gentoo, installed) USE="dbus foomatic jpeg ldap pdf png postscript tiff -ipp_autosetup -pclm -perl -static-libs -test -zeroconf" ABI_X86="(64)"
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.34.3:2[abi_x86_64(-)]) required by (gnome-base/librsvg-2.40.20:2/2::gentoo, installed) USE="introspection vala -tools" ABI_X86="(64) -32 (-x32)"
    dev-libs/glib:2 required by (sys-auth/polkit-0.116-r1:0/0::gentoo, installed) USE="gtk introspection nls pam systemd (-consolekit) (-elogind) -examples -jit -kde (-selinux) -test" ABI_X86="(64)"
    >=dev-libs/glib-2.26:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.26:2[abi_x86_64(-)]) required by (x11-libs/libnotify-0.7.8:0/0::gentoo, installed) USE="introspection -gtk-doc -test" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.40:2 required by (sys-apps/xdg-dbus-proxy-0.1.2:0/0::gentoo, installed) USE="" ABI_X86="(64)"
    >=dev-libs/glib-2.32:2 required by (x11-libs/libwnck-3.30.0:3/3::gentoo, installed) USE="introspection startup-notification -tools" ABI_X86="(64)"
    >=dev-libs/glib-2.40:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.40:2[abi_x86_64(-)]) required by (net-misc/networkmanager-1.18.4-r3:0/0::gentoo, installed) USE="dhclient introspection modemmanager ncurses nss policykit ppp systemd wext wifi -audit -bluetooth -connection-sharing (-consolekit) -dhcpcd (-elogind) -gnutls -iwd -json -ofono -ovs -resolvconf (-selinux) -teamd -test -vala" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.42:2 required by (xfce-base/libxfce4ui-4.15.1:0/0::gentoo, installed) USE="introspection startup-notification -debug -glade -libgtop -vala" ABI_X86="(64)"
    >=dev-libs/glib-2.38.0:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.38.0:2[abi_x86_64(-)]) required by (dev-libs/atk-2.34.1:0/0::gentoo, installed) USE="introspection -gtk-doc" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.46:2[dbus] required by (mail-client/evolution-3.32.5-r2:2.0/2.0::gentoo, installed) USE="bogofilter ldap spell ssl weather -archive -geolocation -gtk-doc -highlight -spamassassin -ytnef" ABI_X86="(64)"
    >=dev-libs/glib-2.38.2-r1:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.38.2-r1:2[abi_x86_64(-)]) required by (media-libs/gst-plugins-base-1.14.5-r1:1.0/1.0::gentoo, installed) USE="X alsa egl introspection nls ogg opengl orc pango theora vorbis -gbm -gles2 -ivorbis -wayland" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.40.0:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.40.0:2[abi_x86_64(-)]) required by (media-libs/gstreamer-1.14.5:1.0/1.0::gentoo, installed) USE="caps introspection nls orc -test -unwind" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.38.2-r1:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.38.2-r1:2[abi_x86_64(-)]) required by (media-plugins/gst-plugins-gtk-1.14.5:1.0/1.0::gentoo, installed) USE="X egl opengl -gles2 -wayland" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.32:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.32:2[abi_x86_64(-)]) required by (app-accessibility/at-spi2-atk-2.34.0:2/2::gentoo, installed) USE="-test" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.42 required by (xfce-base/xfconf-4.14.1:0/3::gentoo, installed) USE="introspection -debug -perl -vala" ABI_X86="(64)"
    >=dev-libs/glib-2.40.0:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.40.0:2[abi_x86_64(-)]) required by (media-libs/gst-plugins-good-1.14.5:1.0/1.0::gentoo, installed) USE="nls orc" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.30.0:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.30.0:2[abi_x86_64(-)]) required by (media-libs/graphene-1.8.6:0/0::gentoo, installed) USE="introspection -doc -test" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="sse2"
    >=dev-libs/glib-2.44.0:2 required by (gnome-base/dconf-0.32.0-r2:0/0::gentoo, installed) USE="-gtk-doc -test" ABI_X86="(64)"
    >=dev-libs/glib-2.44.0:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.44.0:2[abi_x86_64(-)]) required by (dev-libs/libgusb-0.3.3:0/0::gentoo, installed) USE="introspection -gtk-doc -static-libs -test -vala" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.34.3:2[abi_x86_64(-)]) required by (x11-libs/cairo-1.16.0-r3:0/0::gentoo, installed) USE="X glib opengl svg (-aqua) -debug (-gles2-only) -static-libs -utils -valgrind" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.16:2/2= required by (x11-libs/libxklavier-5.4:0/16::gentoo, installed) USE="introspection -vala" ABI_X86="(64)"
    >=dev-libs/glib-2.48:2 required by (dev-python/pygobject-3.34.0:3/3::gentoo, installed) USE="cairo -examples -test" ABI_X86="(64)" PYTHON_TARGETS="python2_7 python3_6 -python3_7 -python3_8"
    >=dev-libs/glib-2.44:2 required by (app-misc/geoclue-2.5.3-r2:2.0/2.0::gentoo, installed) USE="introspection -gtk-doc -modemmanager -vala -zeroconf" ABI_X86="(64)"
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.34.3:2[abi_x86_64(-)]) required by (dev-libs/libcroco-0.6.13:0.6/0.6::gentoo, installed) USE="-test" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.53.4:2 required by (dev-util/gtk-update-icon-cache-3.24.13:0/0::gentoo, installed) USE="" ABI_X86="(64)"
    >=dev-libs/glib-2.44:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.44:2[abi_x86_64(-)]) required by (app-crypt/libsecret-0.18.8:0/0::gentoo, installed) USE="crypt introspection vala -test" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.38.2-r1:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.38.2-r1:2[abi_x86_64(-)]) required by (media-libs/gst-plugins-bad-1.14.5:1.0/1.0::gentoo, installed) USE="X bzip2 egl gtk introspection nls opengl orc -gles2 -test -vcd -vnc -wayland" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.36.0:2 required by (net-misc/modemmanager-1.10.0:0/1::gentoo, installed) USE="introspection policykit qmi systemd udev (-elogind) -mbim -vala" ABI_X86="(64)"
    >=dev-libs/glib-2.36 required by (net-libs/libqmi-1.22.2:0/5.4::gentoo, installed) USE="mbim -doc -static-libs" ABI_X86="(64)"
    dev-libs/glib:2 required by (x11-themes/sound-theme-freedesktop-0.8:0/0::gentoo, installed) USE="" ABI_X86="(64)"
    >=dev-libs/glib-2.42 required by (xfce-base/libxfce4util-4.15.0:0/7::gentoo, installed) USE="introspection -vala" ABI_X86="(64)"
    >=dev-libs/glib-2.48.0:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.48.0:2[abi_x86_64(-)]) required by (x11-libs/gdk-pixbuf-2.40.0:2/2::gentoo, installed) USE="X introspection jpeg tiff -gtk-doc" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.38:2 required by (app-crypt/gcr-3.34.0-r1:0/1::gentoo, installed) USE="gtk introspection vala -debug -test" ABI_X86="(64)"
    >=dev-libs/glib-2.42 required by (xfce-base/exo-0.12.11:0/0::gentoo, installed) USE="-gtk2" ABI_X86="(64)"
    dev-libs/glib required by (media-gfx/fontforge-20190801:0/0::gentoo, installed) USE="X cairo gif gtk jpeg png python readline svg tiff unicode -test -truetype-debugger" ABI_X86="(64)" PYTHON_SINGLE_TARGET="python3_6 -python3_7"
    >=dev-libs/glib-2.34.3:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.34.3:2[abi_x86_64(-)]) required by (x11-libs/gtk+-2.24.32-r1:2/2::gentoo, installed) USE="cups introspection xinerama (-aqua) -examples -test -vim-syntax" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.55.1:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.55.1:2[abi_x86_64(-)]) required by (net-libs/glib-networking-2.60.4:0/0::gentoo, installed) USE="libproxy ssl -gnome -test" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.52:2 required by (net-libs/gnome-online-accounts-3.32.1:0/1::gentoo, installed) USE="introspection vala -debug -gnome -kerberos" ABI_X86="(64)"
    >=dev-libs/glib-2.44.0:2 required by (dev-libs/libgdata-0.17.11:0/22::gentoo, installed) USE="crypt gnome-online-accounts introspection -gtk-doc -test -vala" ABI_X86="(64)"
    dev-libs/glib:2 required by (app-text/poppler-0.85.0:0/95::gentoo, installed) USE="cairo cxx introspection jpeg jpeg2k lcms png qt5 tiff utils -cjk -curl -debug -doc -nss" ABI_X86="(64)"
    >=dev-libs/glib-2.24:2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,
abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,
abi_s390_64(-)?] (>=dev-libs/glib-2.24:2[abi_x86_64(-)]) required by (net-libs/rest-0.8.1:0.7/0.7::gentoo, installed) USE="introspection -test" ABI_X86="(64) -32 (-x32)"
    >=dev-libs/glib-2.58.0:2 required by (dev-libs/gobject-introspection-1.60.2-r1:0/0::gentoo, installed) USE="cairo -doctool -test" ABI_X86="(64)" PYTHON_SINGLE_TARGET="python3_6 -python3_7 -python3_8"


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


[Moderator edit: broke long whitespace-free lines in code tags to fix thread layout. -Hu]
_________________
I occasionally post sober.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 23479
Location: here

PostPosted: Tue Feb 18, 2020 7:30 pm    Post subject: Reply with quote

Sorry, I misread the error I think if you mask dev-libs/glib::mate-de-gentoo the problem is solved
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Linx_
n00b
n00b


Joined: 01 Jul 2018
Posts: 27

PostPosted: Tue Feb 18, 2020 8:06 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Sorry, I misread the error I think if you mask dev-libs/glib::mate-de-gentoo the problem is solved

That does fix the block, but it causes package failures that depend on the newer glib. app-text/atril fails for sure.
_________________
I occasionally post sober.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 23479
Location: here

PostPosted: Tue Feb 18, 2020 8:16 pm    Post subject: Reply with quote

Linx_ wrote:
That does fix the block, but it causes package failures that depend on the newer glib. app-text/atril fails for sure.

I don't know if really app-text/atril-1.24.0 need gdbus-codegen-2.62.4, according to atril-1.24.0 ebuild no
Code:
DEPEND="${RDEPEND}
   app-text/docbook-xml-dtd:4.1.2
   app-text/rarian
   app-text/yelp-tools
   >=app-text/scrollkeeper-dtd-1:1.0
   dev-util/gdbus-codegen
   dev-util/glib-utils
   dev-util/gtk-doc
   dev-util/gtk-doc-am
   >=dev-util/intltool-0.50.1
   sys-devel/gettext
   virtual/pkgconfig"

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Linx_
n00b
n00b


Joined: 01 Jul 2018
Posts: 27

PostPosted: Tue Feb 18, 2020 8:22 pm    Post subject: Reply with quote

It depends on gio, which I believe is part of glib.
Code:
checking for library containing hypot... -lm
checking for LIBDOCUMENT... no
configure: error: Package requirements (gtk+-3.0 >= 3.22.0 gio-2.0 >= 2.62.0) were not met:

Package dependency requirement 'gio-2.0 >= 2.62.0' could not be satisfied.
Package 'gio-2.0' has version '2.60.7', required version is '>= 2.62.0'

_________________
I occasionally post sober.
Back to top
View user's profile Send private message
Linx_
n00b
n00b


Joined: 01 Jul 2018
Posts: 27

PostPosted: Tue Feb 18, 2020 10:26 pm    Post subject: Reply with quote

Sooooo..... it seems I was misreading the error all along. It's the fact that there is NOT a gdbus-codegen ebuild to match the glib version that's causing the block. I missed the "<" at the beginning of the error.

It appears the overlay needs another ebuild for gdbus. I masked the glib version from the overlay and created a local repo with dev-libs/glib and dev-util/gdbus-codegen v2.62.3 ebuilds from another overlay, and this seems to be the correct answer. No blocks. EXCEPT.... gdbus will not build.

The gdbus-codegen ebuild wants to apply a patch and do some python setup that is throwing "no such file" errors. This seems to be the problematic section of the ebuild.
Code:
python_prepare_all() {
   PATCHES=(
      "${FILESDIR}/${PN}-2.56.1-sitedir.patch"
   )
   distutils-r1_python_prepare_all

   sed -e 's:@PYTHON@:python:' gdbus-codegen.in > gdbus-codegen || die
   sed -e "s:@VERSION@:${PV}:" config.py.in > config.py || die
   cp "${FILESDIR}/setup.py-2.32.4" setup.py || die "cp failed"
   sed -e "s/@PV@/${PV}/" -i setup.py || die "sed setup.py failed"
}

I've tried deleting the patch section from the ebuild, but it just throws other errors in its place. Here is the output it generates.

Code:
>>> Unpacking source...
>>> Unpacking glib-2.62.3.tar.xz to /var/tmp/portage/dev-util/gdbus-codegen-2.62.3/work
>>> Source unpacked in /var/tmp/portage/dev-util/gdbus-codegen-2.62.3/work
>>> Preparing source in /var/tmp/portage/dev-util/gdbus-codegen-2.62.3/work/glib-2.62.3/gio/gdbus-2.0/codegen ...
 * Applying gdbus-codegen-2.56.1-sitedir.patch ...
/var/tmp/portage/dev-util/gdbus-codegen-2.62.3/temp/environment: line 1323: /var/tmp/portage/dev-util/gdbus-codegen-2.62.3/files/gdbus-codegen-2.56.1-sitedir.patch: No such file or directory
/var/tmp/portage/dev-util/gdbus-codegen-2.62.3/temp/environment: line 1326: /var/tmp/portage/dev-util/gdbus-codegen-2.62.3/files/gdbus-codegen-2.56.1-sitedir.patch: No such file or directory
 [ !! ]
 * ERROR: dev-util/gdbus-codegen-2.62.3::localrepo failed (prepare phase):
 *   patch -p1  failed with /var/tmp/portage/dev-util/gdbus-codegen-2.62.3/files/gdbus-codegen-2.56.1-sitedir.patch
 *
 * Call stack:
 *               ebuild.sh, line  125:  Called src_prepare
 *             environment, line 3824:  Called distutils-r1_src_prepare
 *             environment, line 1099:  Called python_prepare_all
 *             environment, line 3649:  Called distutils-r1_python_prepare_all
 *             environment, line 1004:  Called default
 *      phase-functions.sh, line  855:  Called default_src_prepare
 *      phase-functions.sh, line  920:  Called __eapi6_src_prepare
 *             environment, line  277:  Called eapply '/var/tmp/portage/dev-util/gdbus-codegen-2.62.3/files/gdbus-codegen-2.56.1-sitedir.patch'
 *             environment, line 1391:  Called _eapply_patch '/var/tmp/portage/dev-util/gdbus-codegen-2.62.3/files/gdbus-codegen-2.56.1-sitedir.patch'
 *             environment, line 1329:  Called __helpers_die 'patch -p1  failed with /var/tmp/portage/dev-util/gdbus-codegen-2.62.3/files/gdbus-codegen-2.56.1-sitedir.patch'
 *   isolated-functions.sh, line  112:  Called die
 * The specific snippet of code:
 *         die "$@"
 *
 * If you need support, post the output of `emerge --info '=dev-util/gdbus-codegen-2.62.3::localrepo'`,
 * the complete build log and the output of `emerge -pqv '=dev-util/gdbus-codegen-2.62.3::localrepo'`.
 * The complete build log is located at '/var/tmp/portage/dev-util/gdbus-codegen-2.62.3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-util/gdbus-codegen-2.62.3/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-util/gdbus-codegen-2.62.3/work/glib-2.62.3/gio/gdbus-2.0/codegen'
 * S: '/var/tmp/portage/dev-util/gdbus-codegen-2.62.3/work/glib-2.62.3/gio/gdbus-2.0/codegen'

 * Messages for package dev-util/gdbus-codegen-2.62.3:

 * ERROR: dev-util/gdbus-codegen-2.62.3::localrepo failed (prepare phase):
 *   patch -p1  failed with /var/tmp/portage/dev-util/gdbus-codegen-2.62.3/files/gdbus-codegen-2.56.1-sitedir.patch
 *
 * Call stack:
 *               ebuild.sh, line  125:  Called src_prepare
 *             environment, line 3824:  Called distutils-r1_src_prepare
 *             environment, line 1099:  Called python_prepare_all
 *             environment, line 3649:  Called distutils-r1_python_prepare_all
 *             environment, line 1004:  Called default
 *      phase-functions.sh, line  855:  Called default_src_prepare
 *      phase-functions.sh, line  920:  Called __eapi6_src_prepare
 *             environment, line  277:  Called eapply '/var/tmp/portage/dev-util/gdbus-codegen-2.62.3/files/gdbus-codegen-2.56.1-sitedir.patch'
 *             environment, line 1391:  Called _eapply_patch '/var/tmp/portage/dev-util/gdbus-codegen-2.62.3/files/gdbus-codegen-2.56.1-sitedir.patch'
 *             environment, line 1329:  Called __helpers_die 'patch -p1  failed with /var/tmp/portage/dev-util/gdbus-codegen-2.62.3/files/gdbus-codegen-2.56.1-sitedir.patch'
 *   isolated-functions.sh, line  112:  Called die
 * The specific snippet of code:
 *         die "$@"
 *
 * If you need support, post the output of `emerge --info '=dev-util/gdbus-codegen-2.62.3::localrepo'`,
 * the complete build log and the output of `emerge -pqv '=dev-util/gdbus-codegen-2.62.3::localrepo'`.
 * The complete build log is located at '/var/tmp/portage/dev-util/gdbus-codegen-2.62.3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-util/gdbus-codegen-2.62.3/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-util/gdbus-codegen-2.62.3/work/glib-2.62.3/gio/gdbus-2.0/codegen'
 * S: '/var/tmp/portage/dev-util/gdbus-codegen-2.62.3/work/glib-2.62.3/gio/gdbus-2.0/codegen'

_________________
I occasionally post sober.
Back to top
View user's profile Send private message
Linx_
n00b
n00b


Joined: 01 Jul 2018
Posts: 27

PostPosted: Tue Feb 18, 2020 11:04 pm    Post subject: Reply with quote

OK, stupid error on my part. I was missing the /files under the ebuild directory that contains the patch and setup.py.

What a train wreck. The state of portage is a disgrace. If I were qualified I would offer to help, but unfortunately, I'm not.
_________________
I occasionally post sober.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 14931

PostPosted: Wed Feb 19, 2020 2:16 am    Post subject: Reply with quote

Linx_ wrote:
OK, stupid error on my part. I was missing the /files under the ebuild directory that contains the patch and setup.py.

What a train wreck. The state of portage is a disgrace. If I were qualified I would offer to help, but unfortunately, I'm not.
Could you elaborate on this criticism? According to the output, the failure was in an overlay, not the Portage tree. You should blame the maintainer of the overlay for implementing it incorrectly, not blame Portage for following the instructions it was given.
Back to top
View user's profile Send private message
Linx_
n00b
n00b


Joined: 01 Jul 2018
Posts: 27

PostPosted: Wed Feb 19, 2020 6:13 pm    Post subject: Reply with quote

Hu wrote:
Linx_ wrote:
OK, stupid error on my part. I was missing the /files under the ebuild directory that contains the patch and setup.py.

What a train wreck. The state of portage is a disgrace. If I were qualified I would offer to help, but unfortunately, I'm not.
Could you elaborate on this criticism? According to the output, the failure was in an overlay, not the Portage tree. You should blame the maintainer of the overlay for implementing it incorrectly, not blame Portage for following the instructions it was given.

No, I'm talking about portage. I mean the fact that I have to use an unofficial overlay at all just to get a working desktop that will compile. I don't think that's an unreasonable or outlandish expectation. The packages in portage should be able to handle that all by themselves, but instead I have to go to a third-party overlay that might pull in god-knows-what to break my system because packages in portage are years out of date and several versions behind the upstream. The devs only seem interested in maintaining the base system, because new kernels and toolchain packages hit portage within hours of being released upstream, but quite a lot of desktop-related packages are years out of date. That's what I'm talking about.
_________________
I occasionally post sober.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 23479
Location: here

PostPosted: Wed Feb 19, 2020 7:12 pm    Post subject: Reply with quote

Linx_ wrote:
The devs only seem interested in maintaining the base system, because new kernels and toolchain packages hit portage within hours of being released upstream, but quite a lot of desktop-related packages are years out of date. That's what I'm talking about.

This ins't true for example plasma 5.18.1 is released yesterday and today is in tree.
Unfortunately there are no active developer that use mate desktop and packages are outdated.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
coderanger
n00b
n00b


Joined: 19 Sep 2018
Posts: 68

PostPosted: Wed Feb 19, 2020 8:05 pm    Post subject: Reply with quote

I was able to update glib to 2.62.4 and installed mate 1.24 via own local portage (only a few things copied from mate-de-gentoo)

Last edited by coderanger on Wed Feb 19, 2020 8:38 pm; edited 2 times in total
Back to top
View user's profile Send private message
Linx_
n00b
n00b


Joined: 01 Jul 2018
Posts: 27

PostPosted: Wed Feb 19, 2020 8:08 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Linx_ wrote:
The devs only seem interested in maintaining the base system, because new kernels and toolchain packages hit portage within hours of being released upstream, but quite a lot of desktop-related packages are years out of date. That's what I'm talking about.

This ins't true for example plasma 5.18.1 is released yesterday and today is in tree.
Unfortunately there are no active developer that use mate desktop and packages are outdated.

I didn't say that all desktop packages are outdated. I said there are a lot that are, and I stand by that statement. Some parts of portage are very well-maintained, but there are sizeable sections that are in terrible condition, and that shouldn't happen in a quality distro. You don't see that kind of neglect in other distros like Mint or Arch. When the devs don't want to maintain something, they drop it instead of letting it rot away. See Mint KDE edition.
_________________
I occasionally post sober.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 14931

PostPosted: Thu Feb 20, 2020 4:09 am    Post subject: Reply with quote

Linx_ wrote:
No, I'm talking about portage. I mean the fact that I have to use an unofficial overlay at all just to get a working desktop that will compile.
My preferred desktop has always worked fine. I don't use MATE. If it is that badly broken in the main tree, then someone should file a bug to have it masked or even tree-cleaned, so that users cannot stumble into it unaware.
Linx_ wrote:
The devs only seem interested in maintaining the base system, because new kernels and toolchain packages hit portage within hours of being released upstream, but quite a lot of desktop-related packages are years out of date. That's what I'm talking about.
Developers work on what they want to work on. Your experience suggests that there are active developers interested in development tooling packages, and few or no developers interested in MATE. Unfortunately, eliminating broken packages is itself something that is done only by developers who like doing that kind of work, so if the janitorially-oriented developers go inactive, garbage builds up.
Back to top
View user's profile Send private message
Linx_
n00b
n00b


Joined: 01 Jul 2018
Posts: 27

PostPosted: Thu Feb 20, 2020 4:44 am    Post subject: Reply with quote

Hu wrote:
Developers work on what they want to work on. Your experience suggests that there are active developers interested in development tooling packages, and few or no developers interested in MATE. Unfortunately, eliminating broken packages is itself something that is done only by developers who like doing that kind of work, so if the janitorially-oriented developers go inactive, garbage builds up.

Yes, that's basically what I said. But that's no way to run a project like a Linux distribution. If Gentoo is going to be a professional, polished distro that lives in the same space as Arch, Kali, Debian, and others, users can't be limited to what the devs personally use because that's not a distro. That's called a hobby. The difference between work and play is doing what needs to be done instead of what you personally want to do. Gentoo is built around the philosophy of choice and freedom, which is why I use it. To then turn around and say that a user's choice is a non-starter because none of the devs like it is the opposite of what Gentoo is about. We're not talking about some obscure wm like Afterstep here that nobody uses. Mate is one of the 4 or 5 most popular DEs out there right now and it's in active development.

As I said, if I were even remotely qualified I would do it myself, but I'm not.
_________________
I occasionally post sober.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum