Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Risolto]Errore X
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
ilnanny
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jul 2017
Posts: 115
Location: Italy/Taranto

PostPosted: Fri Jan 31, 2020 6:08 am    Post subject: [Risolto]Errore X Reply with quote

Salve Forum .
Ho insallato gentoo da chroot su una workstation recuperata
installato X e tutti i miei programmi preferiti ,
il problema è che all'avvio di X mi restituisce l'errore :
Code:
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.

Questo è il Xorg.0.log:
Code:
[    43.326]
X.Org X Server 1.20.6
X Protocol Version 11, Revision 0
[    43.327] Build Operating System: Linux 4.19.0-6-amd64 x86_64 Gentoo
[    43.327] Current Operating System: Linux gent3500 4.19.97-gentoo-x86_64 #1 SMP Tue Jan 28 13:54:33 CET 2020 x86_64
[    43.327] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.19.97-gentoo-x86_64 root=UUID=078dee95-a158-4f8f-b03c-5ccda09a8cf2 ro
[    43.327] Build Date: 30 January 2020  07:21:03AM
[    43.327] 
[    43.327] Current version of pixman: 0.38.4
[    43.328]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[    43.328] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    43.329] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Jan 31 05:42:37 2020
[    43.332] (==) Using config file: "/etc/X11/xorg.conf"
[    43.332] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    43.332] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    43.334] (==) ServerLayout "Xorg Configured"
[    43.334] (**) |-->Screen "Monitor" (0)
[    43.334] (**) |   |-->Monitor "StandardMonitor"
[    43.334] (**) |   |-->Device "nouveauVGA"
[    43.334] (==) Automatically adding devices
[    43.334] (==) Automatically enabling devices
[    43.334] (==) Automatically adding GPU devices
[    43.334] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    43.341] (**) FontPath set to:
   /usr/share/fonts/corefonts,
   /usr/share/fonts/misc,
   /usr/share/fonts/droid,
   /usr/share/fonts/misc/,
   /usr/share/fonts/TTF/,
   /usr/share/fonts/OTF/,
   /usr/share/fonts/Type1/,
   /usr/share/fonts/100dpi/,
   /usr/share/fonts/75dpi/
[    43.341] (==) ModulePath set to "/usr/lib64/xorg/modules"
[    43.341] (**) Extension "Composite" is enabled
[    43.341] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[    43.341] (II) Loader magic: 0x564f30728c60
[    43.341] (II) Module ABI versions:
[    43.341]    X.Org ANSI C Emulation: 0.4
[    43.341]    X.Org Video Driver: 24.0
[    43.341]    X.Org XInput driver : 24.1
[    43.341]    X.Org Server Extension : 10.0
[    43.346] (--) PCI:*(2@0:0:0) 10de:06dd:10de:0780 rev 163, Mem @ 0xf4000000/33554432, 0xe0000000/134217728, 0xe8000000/67108864, I/O @ 0x0000dc80/128, BIOS @ 0x????????/131072
[    43.346] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[    43.346] (II) LoadModule: "dri"
[    43.346] (II) Module "dri" already built-in
[    43.346] (II) LoadModule: "dbe"
[    43.346] (II) Module "dbe" already built-in
[    43.346] (II) LoadModule: "glx"
[    43.348] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[    43.363] (II) Module glx: vendor="X.Org Foundation"
[    43.363]    compiled for 1.20.6, module version = 1.0.0
[    43.363]    ABI class: X.Org Server Extension, version 10.0
[    43.363] (II) LoadModule: "extmod"
[    43.363] (II) Module "extmod" already built-in
[    43.363] (II) LoadModule: "nouveau"
[    43.364] (II) Loading /usr/lib64/xorg/modules/drivers/nouveau_drv.so
[    43.366] (II) Module nouveau: vendor="X.Org Foundation"
[    43.366]    compiled for 1.20.6, module version = 1.0.16
[    43.367]    Module class: X.Org Video Driver
[    43.367]    ABI class: X.Org Video Driver, version 24.0
[    43.367] (II) NOUVEAU driver
[    43.367] (II) NOUVEAU driver for NVIDIA chipset families :
[    43.367]    RIVA TNT            (NV04)
[    43.367]    RIVA TNT2           (NV05)
[    43.367]    GeForce 256         (NV10)
[    43.367]    GeForce 2           (NV11, NV15)
[    43.367]    GeForce 4MX         (NV17, NV18)
[    43.367]    GeForce 3           (NV20)
[    43.367]    GeForce 4Ti         (NV25, NV28)
[    43.367]    GeForce FX          (NV3x)
[    43.367]    GeForce 6           (NV4x)
[    43.367]    GeForce 7           (G7x)
[    43.367]    GeForce 8           (G8x)
[    43.367]    GeForce 9           (G9x)
[    43.367]    GeForce GTX 2xx/3xx (GT2xx)
[    43.367]    GeForce GTX 4xx/5xx (GFxxx)
[    43.367]    GeForce GTX 6xx/7xx (GKxxx)
[    43.367]    GeForce GTX 9xx     (GMxxx)
[    43.367]    GeForce GTX 10xx    (GPxxx)
[    43.367] (--) using VT number 7

[    43.486] (EE) [drm] Failed to open DRM device for pci:0000:02:00.0: -19
[    43.486] (EE) No devices detected.
[    43.486] (EE)
Fatal server error:
[    43.486] (EE) no screens found(EE)
[    43.486] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[    43.486] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    43.486] (EE)
[    43.494] (EE) Server terminated with error (1). Closing log file.

Grazie anticipatamente.
_________________
== Lila-HD-icon-theme ==
https://github.com/ilnanny/Lila-HD-icon-theme


Last edited by ilnanny on Tue Feb 04, 2020 6:01 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24202
Location: here

PostPosted: Fri Jan 31, 2020 7:05 am    Post subject: Reply with quote

Che scheda modello di scheda hai? Vuoi usare nouveau al posto dei driver proprietari?
Puoi postare il risultato del comando grep DRM /usr/src/linux/.config e il tuo dmesg con wgetpaste?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ilnanny
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jul 2017
Posts: 115
Location: Italy/Taranto

PostPosted: Fri Jan 31, 2020 8:11 am    Post subject: Reply with quote

@fedeliallalinea appena arrivo a casa posto il risultato.
Grazie
_________________
== Lila-HD-icon-theme ==
https://github.com/ilnanny/Lila-HD-icon-theme


Last edited by ilnanny on Fri Jan 31, 2020 10:16 am; edited 1 time in total
Back to top
View user's profile Send private message
ilnanny
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jul 2017
Posts: 115
Location: Italy/Taranto

PostPosted: Fri Jan 31, 2020 10:15 am    Post subject: Reply with quote

fedeliallalinea wrote:
Che scheda modello di scheda hai? Vuoi usare nouveau al posto dei driver proprietari?


vorrei installare i driver proprietari ,ma non essedoci riuscito per adesso ho compilato con i nouveau
fedeliallalinea wrote:
Puoi postare il risultato del comando grep DRM /usr/src/linux/.config


qui : https://pastebin.com/uL1QQAn6


fedeliallalinea wrote:
e il tuo dmesg

qui: https://pastebin.com/BQTdQ7QW
_________________
== Lila-HD-icon-theme ==
https://github.com/ilnanny/Lila-HD-icon-theme
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24202
Location: here

PostPosted: Fri Jan 31, 2020 10:54 am    Post subject: Reply with quote

Che errore ti da con i driver proprietari?
Per nouveau dovresti abilitare il supporto nel kernel
Code:
# CONFIG_DRM_NOUVEAU is not set

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ilnanny
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jul 2017
Posts: 115
Location: Italy/Taranto

PostPosted: Fri Jan 31, 2020 10:58 am    Post subject: Reply with quote

fedeliallalinea wrote:
Che errore ti da con i driver proprietari?
Per nouveau dovresti abilitare il supporto nel kernel
Code:
# CONFIG_DRM_NOUVEAU is not set


non me li fà compilare perchè dice che c'è un errore nel ebuild.
Adesso ricompilo il kernel con il parametro esatto e poi quando provo ad installare i Nvidia scrivo l'errore qui .
Grazie mille.
_________________
== Lila-HD-icon-theme ==
https://github.com/ilnanny/Lila-HD-icon-theme
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24202
Location: here

PostPosted: Fri Jan 31, 2020 11:12 am    Post subject: Reply with quote

ilnanny wrote:
Adesso ricompilo il kernel con il parametro esatto e poi quando provo ad installare i Nvidia scrivo l'errore qui .

Ricorda che devi disabilitare il driver nouveau se vuoi fare andare i driver nvidia (non per compilarli) se no i due moduli vanno in conflitto.

EDIT: Se il driver nouveau lo compili come modulo puoi metterlo nella blacklist per non farlo caricare echo "blacklist nouveau" >> /etc/modprobe.d/nouveau.conf, in realta' puoi farlo anche se e' compilato nel kernel passando una linea a grub ma non ricordo quale.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
fturco
Veteran
Veteran


Joined: 08 Dec 2010
Posts: 1105
Location: Italy

PostPosted: Fri Jan 31, 2020 11:34 am    Post subject: Reply with quote

fedeliallalinea wrote:
EDIT: Se il driver nouveau lo compili come modulo puoi metterlo nella blacklist per non farlo caricare echo "blacklist nouveau" >> /etc/modprobe.d/nouveau.conf, in realta' puoi farlo anche se e' compilato nel kernel passando una linea a grub ma non ricordo quale.

Intendi questo?
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24202
Location: here

PostPosted: Fri Jan 31, 2020 12:51 pm    Post subject: Reply with quote

fturco wrote:
fedeliallalinea wrote:
EDIT: Se il driver nouveau lo compili come modulo puoi metterlo nella blacklist per non farlo caricare echo "blacklist nouveau" >> /etc/modprobe.d/nouveau.conf, in realta' puoi farlo anche se e' compilato nel kernel passando una linea a grub ma non ricordo quale.

Intendi questo?

Esattamente, grazie
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
ilnanny
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jul 2017
Posts: 115
Location: Italy/Taranto

PostPosted: Tue Feb 04, 2020 6:07 pm    Post subject: Reply with quote

Alla fine ho lasciato i driver open perchè per le mie esigenze vanno più che bene .(utilizzo di inkscape ed ogni tanto gimp )
in realtà non vedo la differenza tra nvidia e nouveau.
Grazie ancora per l'aiuto
_________________
== Lila-HD-icon-theme ==
https://github.com/ilnanny/Lila-HD-icon-theme
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum