Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Startx fails with XKEYBOARD error {Solved}
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Tefrem34
Guru
Guru


Joined: 14 Sep 2014
Posts: 326
Location: USA, California

PostPosted: Sat Jan 04, 2020 7:47 pm    Post subject: Startx fails with XKEYBOARD error {Solved} Reply with quote

[Solved]
Hello,

I can not get my kde desktop to work after updating to kde-plasma/*-5.17.4. I have been having this issue before but I thought that is was because I was not getting all the packages for that version to all install properly.
After rebooting my system I am getting this error after running startx:

Code:
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:     Unsupported high keycodes 372 for name <I372> ignored
>                    X11 cannot support keycodes above 255.
>                    This warning only shows for the first high keycode.
Errors from xkbcomp are not fatal to the X server
Couldn't exec startkde: No such file or directory
xinit: connection to X sever lost


I have this in my .xinitrc file:
Code:
exec ck-launch-session dbus-launch --sh-syntax --exit-with-session startkde

Which had been working fine before I upgraded.

I really would appreciate the help.

Thank you


Last edited by Tefrem34 on Sat Feb 15, 2020 9:38 am; edited 4 times in total
Back to top
View user's profile Send private message
Ionen
l33t
l33t


Joined: 06 Dec 2018
Posts: 690

PostPosted: Sat Jan 04, 2020 7:50 pm    Post subject: Reply with quote

The keyboard stuff is harmless and can be ignored, it's just antiquated design at work.

I don't use kde but the real error is that it's not finding strartkde, but if that's really your current .xinitrc and it's being used I guess it's not a typo? (which one is wrong? did you type the error message by hand?) Do make sure the file exist though, if something changed someone who use KDE will probably know better :)
Edit: I see you edited back the strartkde typo, well I hope that wasn't actually the problem
Back to top
View user's profile Send private message
Ionen
l33t
l33t


Joined: 06 Dec 2018
Posts: 690

PostPosted: Sat Jan 04, 2020 8:01 pm    Post subject: Reply with quote

As I said, I don't use it but shouldn't it be startplasma-x11? See this wiki entry
Back to top
View user's profile Send private message
Tefrem34
Guru
Guru


Joined: 14 Sep 2014
Posts: 326
Location: USA, California

PostPosted: Sat Jan 04, 2020 8:05 pm    Post subject: Reply with quote

The thing is, that it wasn't giving me this error with the previous version.
Which now that I am looking, there is only one version. So I do not know that I can roll back.
I also can not find any "startkde" package in the repos.
Back to top
View user's profile Send private message
Tefrem34
Guru
Guru


Joined: 14 Sep 2014
Posts: 326
Location: USA, California

PostPosted: Sat Jan 04, 2020 8:09 pm    Post subject: Reply with quote

Awesome!!!

That is what I had wrong. I didn't know that they had changed the commands for the new plasma version.

Thank you very much for your help.
Back to top
View user's profile Send private message
Ionen
l33t
l33t


Joined: 06 Dec 2018
Posts: 690

PostPosted: Sat Jan 04, 2020 8:10 pm    Post subject: Reply with quote

Glad to hear. My best guess is that startkde was being offered for compatibility but wasn't the proper way to start it, must've gotten rid of it.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum