Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
unable to su without password[solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Adel Ahmed
Veteran
Veteran


Joined: 21 Sep 2012
Posts: 1282

PostPosted: Wed Nov 27, 2019 10:26 am    Post subject: unable to su without password[solved] Reply with quote

I have just setup my gentoo machine.
I'm trying to get the user 'adel' to su without being prompted for a password but I have had no success so far
here's my /etc/pam.d/su:
https://pastebin.com/tAJn7wxd

that file did not exist I created it.

I'm using systemd and I have the pam flag enabled
shadow package has the pam flag enabled.


I did not re emerge the shadow package


Last edited by Adel Ahmed on Wed Nov 27, 2019 10:39 am; edited 1 time in total
Back to top
View user's profile Send private message
freke
Guru
Guru


Joined: 23 Jan 2003
Posts: 588
Location: Somewhere in Denmark

PostPosted: Wed Nov 27, 2019 10:30 am    Post subject: Reply with quote

I don't su myself, bad habbit maybe - but login as root whenever I'm dealing with my servers.

But this is stickied in the Installing Gentoo sub-forum: https://forums.gentoo.org/viewtopic-t-11126.html

Appearently 'unable to su' is one of the most asked questions ;)
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 15283

PostPosted: Thu Nov 28, 2019 1:31 am    Post subject: Reply with quote

The FAQ is for users whose su doesn't work at all. As I understand it, OP's su is working exactly as designed, and he wants to reduce its security by allowing his account to elevate to root without giving a password.

OP: please pastebin the supporting pam configuration file(s). My guess is that you put the pam_succeed_if call too far down, and some module higher up is requiring a password before pam_succeed_if is reached.
Back to top
View user's profile Send private message
Adel Ahmed
Veteran
Veteran


Joined: 21 Sep 2012
Posts: 1282

PostPosted: Thu Nov 28, 2019 2:41 am    Post subject: Reply with quote

sorry to not update this, the problem had en resolved, i forgot to re emerge shadow package after changing the use flags
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum