Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
cannot get external monitor (HDMI) to work
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
dgulotta
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jan 2006
Posts: 83

PostPosted: Wed Nov 06, 2019 11:31 pm    Post subject: cannot get external monitor (HDMI) to work Reply with quote

I am trying to connect my laptop to an external monitor using an HDMI cable, but I cannot seem to get it to work. The monitor says "no signal" and xrandr does not appear to detect the monitor. Is there anything that I can do to try to fix this problem? If it matters, the laptop has only integrated Intel graphics.
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7312
Location: Saint Amant, Acadiana

PostPosted: Thu Nov 07, 2019 1:26 am    Post subject: Reply with quote

Are these cable and monitor tested and good?
If you boot with some liveCD, Ubuntu or whatnot, will the monitor work?
Any options in the BIOS setup for HDMI you could change?
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
dgulotta
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jan 2006
Posts: 83

PostPosted: Thu Nov 07, 2019 5:23 pm    Post subject: Reply with quote

I checked that the monitor and cable work with a different computer.

I tried booting from a Gentoo minimal install CD and the HDMI output still did not work. That CD does not have X but I seem to remember external monitors just working upon boot before. I was probably using VGA in the past rather than HDMI though - does that make a difference?

I did not see any relevant options in the BIOS.

My laptop suffered some water damage a while ago - is it possible that the HDMI connector is broken although the video is otherwise fine?
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43972
Location: 56N 3W

PostPosted: Thu Nov 07, 2019 5:40 pm    Post subject: Reply with quote

dgulotta,

Many laptops have a BIOS controlled toggle, where to direct the video output.
Its usually a 3 way, Internal only, External only and both.

A few rare laptops have a second GPU for external only.

What is your laptop make and model?

Please post the output of
Code:
lspci -knn

_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
dgulotta
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jan 2006
Posts: 83

PostPosted: Fri Nov 08, 2019 1:06 pm    Post subject: Reply with quote

The laptop is an HP ZBook 15 G4.

lspci -knn:
Code:
00:00.0 Host bridge [0600]: Intel Corporation Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers [8086:5910] (rev 05)
   Subsystem: Hewlett-Packard Company Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers [103c:8275]
00:02.0 VGA compatible controller [0300]: Intel Corporation HD Graphics 630 [8086:591b] (rev 04)
   Subsystem: Hewlett-Packard Company HD Graphics 630 [103c:8276]
   Kernel driver in use: i915
00:14.0 USB controller [0c03]: Intel Corporation 100 Series/C230 Series Chipset Family USB 3.0 xHCI Controller [8086:a12f] (rev 31)
   Subsystem: Hewlett-Packard Company 100 Series/C230 Series Chipset Family USB 3.0 xHCI Controller [103c:8275]
   Kernel driver in use: xhci_hcd
00:14.2 Signal processing controller [1180]: Intel Corporation 100 Series/C230 Series Chipset Family Thermal Subsystem [8086:a131] (rev 31)
   Subsystem: Hewlett-Packard Company 100 Series/C230 Series Chipset Family Thermal Subsystem [103c:8275]
00:16.0 Communication controller [0780]: Intel Corporation 100 Series/C230 Series Chipset Family MEI Controller #1 [8086:a13a] (rev 31)
   Subsystem: Hewlett-Packard Company 100 Series/C230 Series Chipset Family MEI Controller [103c:8275]
00:17.0 SATA controller [0106]: Intel Corporation Q170/Q150/B150/H170/H110/Z170/CM236 Chipset SATA Controller [AHCI Mode] [8086:a102] (rev 31)
   Subsystem: Hewlett-Packard Company Q170/Q150/B150/H170/H110/Z170/CM236 Chipset SATA Controller [AHCI Mode] [103c:8275]
   Kernel driver in use: ahci
00:1c.0 PCI bridge [0604]: Intel Corporation 100 Series/C230 Series Chipset Family PCI Express Root Port #1 [8086:a110] (rev f1)
   Kernel driver in use: pcieport
00:1c.1 PCI bridge [0604]: Intel Corporation 100 Series/C230 Series Chipset Family PCI Express Root Port #2 [8086:a111] (rev f1)
   Kernel driver in use: pcieport
00:1c.4 PCI bridge [0604]: Intel Corporation 100 Series/C230 Series Chipset Family PCI Express Root Port #5 [8086:a114] (rev f1)
   Kernel driver in use: pcieport
00:1d.0 PCI bridge [0604]: Intel Corporation 100 Series/C230 Series Chipset Family PCI Express Root Port #9 [8086:a118] (rev f1)
   Kernel driver in use: pcieport
00:1f.0 ISA bridge [0601]: Intel Corporation CM238 Chipset LPC/eSPI Controller [8086:a154] (rev 31)
   Subsystem: Hewlett-Packard Company CM238 Chipset LPC/eSPI Controller [103c:8275]
00:1f.2 Memory controller [0580]: Intel Corporation 100 Series/C230 Series Chipset Family Power Management Controller [8086:a121] (rev 31)
   Subsystem: Hewlett-Packard Company 100 Series/C230 Series Chipset Family Power Management Controller [103c:8275]
00:1f.3 Audio device [0403]: Intel Corporation CM238 HD Audio Controller [8086:a171] (rev 31)
   Subsystem: Hewlett-Packard Company CM238 HD Audio Controller [103c:8275]
   Kernel driver in use: snd_hda_intel
   Kernel modules: snd_hda_intel
00:1f.4 SMBus [0c05]: Intel Corporation 100 Series/C230 Series Chipset Family SMBus [8086:a123] (rev 31)
   Subsystem: Hewlett-Packard Company 100 Series/C230 Series Chipset Family SMBus [103c:8275]
   Kernel driver in use: i801_smbus
00:1f.6 Ethernet controller [0200]: Intel Corporation Ethernet Connection (2) I219-LM [8086:15b7] (rev 31)
   Subsystem: Hewlett-Packard Company Ethernet Connection (2) I219-LM [103c:8275]
   Kernel driver in use: e1000e
01:00.0 Network controller [0280]: Intel Corporation Wireless 8265 / 8275 [8086:24fd] (rev 78)
   Subsystem: Intel Corporation Dual Band Wireless-AC 8265 [8086:1010]
   Kernel driver in use: iwlwifi
   Kernel modules: iwlwifi
02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS525A PCI Express Card Reader [10ec:525a] (rev 01)
   Subsystem: Hewlett-Packard Company RTS525A PCI Express Card Reader [103c:8275]
6e:00.0 Non-Volatile memory controller [0108]: Samsung Electronics Co Ltd NVMe SSD Controller SM961/PM961 [144d:a804]
   Subsystem: Samsung Electronics Co Ltd NVMe SSD Controller SM961/PM961 [144d:a801]
   Kernel driver in use: nvme
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43972
Location: 56N 3W

PostPosted: Fri Nov 08, 2019 7:36 pm    Post subject: Reply with quote

dgulotta,

The specification says you have a hybrid Graphics system.

That link says that the discrete GPUs have dedicated video RAM, so that's not Optimus. It looks like its a second real graphics system.

Your lspci output only shows
Code:
00:02.0 VGA compatible controller [0300]: Intel Corporation HD Graphics 630 [8086:591b] (rev 04)
   Subsystem: Hewlett-Packard Company HD Graphics 630 [103c:8276]


The second GPU is not listed, so it is probably disabled in the BIOS.

I suspect that the internal GPU cannot drive external displays.

Poke about in the BIOS and enable the other GPU.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7312
Location: Saint Amant, Acadiana

PostPosted: Fri Nov 08, 2019 8:03 pm    Post subject: Reply with quote

Quote:
My laptop suffered some water damage a while ago

Looking at pictures in the service manual (here) you may need to re-seat the discrete video card, or perhaps replace it. 8O
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43972
Location: 56N 3W

PostPosted: Fri Nov 08, 2019 9:13 pm    Post subject: Reply with quote

dgulotta,

See page 14 in Jaglovers link. Connecting a display to the HDMI port is not sufficient.
You need to use the display switching Action key too.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
dgulotta
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jan 2006
Posts: 83

PostPosted: Sun Nov 10, 2019 4:17 pm    Post subject: Reply with quote

Jaglover: Thanks for the link to the service manual. I do not have a discrete video card though.

NeddySeagoon; Unfortunately, that button just opens the XFCE display settings (or does nothing if I'm at a terminal or the boot screen).
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43972
Location: 56N 3W

PostPosted: Sun Nov 10, 2019 4:22 pm    Post subject: Reply with quote

dgulotta,

Pastebin /var/log/Xorg.0.log
That will show what Xorg detected when it started.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7312
Location: Saint Amant, Acadiana

PostPosted: Sun Nov 10, 2019 4:49 pm    Post subject: Reply with quote

Missing graphics card may be the reason ... nothing is connected to the HDMI in this case.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum