Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xorg-server slot conflict [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
gtwrek
n00b
n00b


Joined: 10 Mar 2017
Posts: 56
Location: San Jose, CA

PostPosted: Wed Oct 30, 2019 6:57 pm    Post subject: xorg-server slot conflict [SOLVED] Reply with quote

Ok, I can usually figure these things out myself, but I'm stuck this time.
I'm a regular gentoo user, but lazy admin - typically only updating things once or twice a year.

In the past, I've had trouble because I wasn't use "-1" enough when emerging, resulting in a cluttered world file. I've cleaned this up (I think).

Anyway, I recently sync'd, and am having trouble doing a world update. Debugging it seems xorg-server is my problem child.
So, just trying that:

Code:
sudo emerge -av1u --verbose-conflicts --backtrack=100 x11-base/xorg-server
[ebuild     U  ] x11-base/xorg-server-1.20.5:0/1.20.5::gentoo [1.20.3:0/1.20.3::gentoo] USE="glamor ipv6 suid udev xorg xvfb -debug -dmx -doc -elogind% -kdrive (-libglvnd) -libressl -minimal (-selinux) -static-libs -systemd -unwind -wayland -xcsecurity -xephyr -xnest" 5,984 KiB

Total: 1 package (1 upgrade), Size of downloads: 5,984 KiB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-base/xorg-server:0

  (x11-base/xorg-server-1.20.5:0/1.20.5::gentoo, ebuild scheduled for merge) pulled in by
    x11-base/xorg-server (Argument)

  (x11-base/xorg-server-1.20.3:0/1.20.3::gentoo, installed) pulled in by
    x11-base/xorg-server:0/1.20.3= required by (x11-drivers/xf86-input-evdev-2.10.6:0/0::gentoo, installed)
                        ^^^^^^^^^^                                                                         
    x11-base/xorg-server:0/1.20.3= required by (x11-drivers/xf86-input-void-1.4.1:0/0::gentoo, installed)
                        ^^^^^^^^^^                                                                       
    x11-base/xorg-server:0/1.20.3= required by (x11-drivers/xf86-video-nouveau-1.0.15-r1:0/0::gentoo, installed)
                        ^^^^^^^^^^                                                                               


!!! The slot conflict(s) shown above involve package(s) which may need to
!!! be rebuilt in order to solve the conflict(s). However, the following
!!! package(s) cannot be rebuilt for the reason(s) shown:

  (x11-drivers/xf86-video-nouveau-1.0.15-r1:0/0::gentoo, installed): ebuild is masked or unavailable


A couple of things going on there. I don't understand the slot conflict, nor why it's occurring. However the latter problem is weird. Checking both my local repo, and gentoo, I have:
xf86-video-nouveau-1.0.16.ebuild

As the only ebuild available I can't figure out who/what is trying to pull in =x11-drivers/xf86-video-nouveau-1.0.15-r1 (which isn't available)

A few pastebins:
emerge --info : https://pastebin.com/QEwbtyk6
make.conf :https://pastebin.com/J14zA74r
world: https://pastebin.com/JurbX9sx

Any help appreciated.


Last edited by gtwrek on Wed Oct 30, 2019 9:25 pm; edited 1 time in total
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7798
Location: Saint Amant, Acadiana

PostPosted: Wed Oct 30, 2019 7:00 pm    Post subject: Reply with quote

You could grep your /etc/portage for nouveau or you could force portage to install xf86-video-nouveau-1.0.16 and see what it complains about.
_________________
My Gentoo installation notes.
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
fedeliallalinea
Moderator
Moderator


Joined: 08 Mar 2003
Posts: 25791
Location: here

PostPosted: Wed Oct 30, 2019 7:01 pm    Post subject: Reply with quote

What return emerge -uUD @world command?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
fedeliallalinea
Moderator
Moderator


Joined: 08 Mar 2003
Posts: 25791
Location: here

PostPosted: Wed Oct 30, 2019 7:05 pm    Post subject: Reply with quote

Jaglover wrote:
You could grep your /etc/portage for nouveau or you could force portage to install xf86-video-nouveau-1.0.16 and see what it complains about.

I think the problem is that gtwrek try to update only x11-base/xorg-server without dependencies.

gtwrek wrote:
In the past, I've had trouble because I wasn't use "-1" enough when emerging, resulting in a cluttered world file. I've cleaned this up (I think).

If you use --update (-u) the --oneshot (-1) isn't required. -1 is required when you try to rebuild a package that is a dependency and should not be writed in the world file.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
gtwrek
n00b
n00b


Joined: 10 Mar 2017
Posts: 56
Location: San Jose, CA

PostPosted: Wed Oct 30, 2019 7:17 pm    Post subject: Reply with quote

fedeliallalinea wrote:
What return emerge -uUD @world command?


After a long list up updates (snipped), a similar error message:

Code:
x11-base/xorg-server:0

  (x11-base/xorg-server-1.20.5:0/1.20.5::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-base/xorg-server-1.20.3:0/1.20.3::gentoo, installed) pulled in by
    x11-base/xorg-server:0/1.20.3= required by (x11-drivers/xf86-input-void-1.4.1:0/0::gentoo, installed)
                        ^^^^^^^^^^
    (and 1 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

!!! The slot conflict(s) shown above involve package(s) which may need to
!!! be rebuilt in order to solve the conflict(s). However, the following
!!! package(s) cannot be rebuilt for the reason(s) shown:

  (x11-base/xorg-server-1.20.3:0/1.20.3::gentoo, installed): ebuild is masked or unavailable
Back to top
View user's profile Send private message
fedeliallalinea
Moderator
Moderator


Joined: 08 Mar 2003
Posts: 25791
Location: here

PostPosted: Wed Oct 30, 2019 7:36 pm    Post subject: Reply with quote

And work if you try to update these packages individually (emerge -1 xorg-server xf86-input-evdev xf86-input-void xf86-video-nouveau)?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
gtwrek
n00b
n00b


Joined: 10 Mar 2017
Posts: 56
Location: San Jose, CA

PostPosted: Wed Oct 30, 2019 7:50 pm    Post subject: Reply with quote

Ok, that got me closer. I explicty pegged all but the xorg-server version:
Code:
sudo emerge -av1 xorg-server =x11-drivers/xf86-input-void-1.4.1 =x11-drivers/xf86-input-evdev-2.10.6 =x11-drivers/xf86-video-nouveau-1.0.16


Got a successful emerge with that. Weird, the (lack of) "-u" seems to make a difference here that I don't understand.

My world is still failing. Similar errors now on different ebuilds. I'll see if I can apply the same type of solution here. I may return here with more questions...

Thanks,
Mark
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum