Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] OpenRC stuck (net-wireless/wpa_supplicant)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
ranumm
n00b
n00b


Joined: 16 Aug 2019
Posts: 8

PostPosted: Mon Oct 14, 2019 7:01 am    Post subject: [SOLVED] OpenRC stuck (net-wireless/wpa_supplicant) Reply with quote

Hi everyone,
I have a small problem at startup that I can't solve.
After "Successfully initialized wpa_supplicant" the underscore "flashes" to infinity until I send several "enter" from my keyboard. The "rc.log" does not report errors and everything works correctly, this has happened since the last update.
I also did a fresh new gentoo installation and I have the same problem.

Can someone help me? Thanks.

Code:
 
...
* Starting WPA Supplicant Daemon ...
Successfully initialized wpa_supplicant
 [ ok ]
 * Starting DHCP Client Daemon ...
 [ ok ]
...


Last edited by ranumm on Sat Oct 26, 2019 8:21 am; edited 4 times in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 45383
Location: 56N 3W

PostPosted: Mon Oct 14, 2019 8:50 am    Post subject: Reply with quote

ranumm,

Edit the file /etc/rc.conf

Find
Code:
# Set rc_interactive to "YES" and you'll be able to press the I key during
# boot so you can choose to start specific services. Set to "NO" to disable
# this feature. This feature is automatically disabled if rc_parallel is
# set to YES.
#rc_interactive="YES"
and uncomment the last line.

When OpenRC starts you will get a new prompt that allows you to choose if a service starts or not.
Reboot and press the 'I' key.

Step through the service start processes. Which one hangs?
Its not as simple as its the one after the screen message as the kernel messages need not appear on the screen in the order that processes execute.

If you have parallel startup enabled, this is well known to produce hangs, so disable that.
rc_interactive="YES" will force it off anyway so that the on screen message order and the rc.log is useful.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
ranumm
n00b
n00b


Joined: 16 Aug 2019
Posts: 8

PostPosted: Mon Oct 14, 2019 11:12 am    Post subject: Reply with quote

NeddySeagoon wrote:
Step through the service start processes. Which one hangs?

This:
Code:
...
 * About to start the service wpa_supplicant
 *   1) Start the service2) Skip the service
 *   3) Continue boot process4) Exit to shell
 * Executing: /lib/rc/sh/openrc-run.sh /lib/rc/sh/openrc-run.sh /etc/init.d/wpa_supplicant start
 * Starting WPA Supplicant Daemon ...
Successfully initialized wpa_supplicant
 * Detaching to start `/usr/sbin/wpa_supplicant' ... [ ok ]

 * About to start the service dhcpcd
 *   1) Start the service2) Skip the service
 *   3) Continue boot process4) Exit to shell
 * Executing: /lib/rc/sh/openrc-run.sh /lib/rc/sh/openrc-run.sh /etc/init.d/dhcpcd start
 * Starting DHCP Client Daemon ...
 * start-stop-daemon: fopen `/var/run/dhcpcd.pid': No such file or directory
 * Detaching to start `/sbin/dhcpcd' ... [ ok ]
...


NeddySeagoon wrote:
If you have parallel startup enabled, this is well known to produce hangs, so disable that.

Nope, it is disabled.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 45383
Location: 56N 3W

PostPosted: Mon Oct 14, 2019 12:27 pm    Post subject: Reply with quote

ranumm,

You do not need to start wpa_supplicant in any runlevel.
If you use a GUI network controller, it will manage wpa_supplicant.
If you use the net.<wifi_interface> startup script, then wpa_supplicant is started via the configuration for net.<wifi_interface>.

Trying to run wpa_supplicant twice is a bad thing.

Code:
 * start-stop-daemon: fopen `/var/run/dhcpcd.pid': No such file or directory


/var/run should be a symbolic link to /run
Code:
$ ls -l /var
...
lrwxrwxrwx  1 root     root     4 May 14  2013 run -> /run
...

/run is in tmpfs, which is read/write from very early in the boot process.
The file /var/run/dhcpcd.pid should be created when dhcpcd starts.

Do you have the symlink?

What does
Code:
$ mount | grep run
tmpfs on /run type tmpfs (rw,nodev,relatime,size=1639916k,mode=755)

show for you?
size= is 50% of RAM by default.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7405

PostPosted: Mon Oct 14, 2019 12:46 pm    Post subject: Reply with quote

I think Hu could answer you -> https://forums.gentoo.org/viewtopic-p-8378572.html#8378572
Back to top
View user's profile Send private message
ranumm
n00b
n00b


Joined: 16 Aug 2019
Posts: 8

PostPosted: Sat Oct 26, 2019 8:20 am    Post subject: Reply with quote

Conflict in the wpa_supplicant and Netifrc configuration files. Solved!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum