Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Risolto] come risolvo questo conflitto?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
tano70
Tux's lil' helper
Tux's lil' helper


Joined: 26 Aug 2013
Posts: 120
Location: Torino

PostPosted: Tue Oct 08, 2019 5:32 pm    Post subject: [Risolto] come risolvo questo conflitto? Reply with quote

Buonasera a tutti gli esperti del forum, mi sto accingendo a installare questa splendida distro in un portatile HP 15 DW0120NL cje ja queste caratteristiche: https://support.hp.com/it-it/document/c06434026
il mio scopo è quello di avere un sistema dual boot lasciando windows 10 che ho ridimensionato per lasciare il rimanente spazio alle altre distro. Ho già fatto le fasi iniziali, con il settagio del profile list (ho scelto il numero 20) e cioè il Desktop 17.1 64 bit. Lanciando il primo (
Code:
chroot) GentooDesktop / # emerge --ask --update --deep --newuse @world
ho già subito i primi conflitti che non riesco in nessun modo a risolvere:
https://paste.ofcode.org/khtQuThjXmHjW9LKjp9NDr
qualcuno mi dice cosa devo fare esattamente?
Inoltre vorrei anche delle dritte du come configurare al meglio il kernel (cioè cosa abilitare per sfruttare le sue caratteristiche tecniche), uso gen kernel. Sto facendo tutto non da live ma da una chiavetta usb con clonato il mio sistema Gentoo che ho su altro portatile con caratteristiche simili (un Lenovo X1 Carbon core i7 di terza generazione- Con questa chiavetta da cui sto installando Gentoo sul portatile HP, attualmente non funziona ne il touchpad ne tantomeno viene riconosciuto il chip wifi che usa un driver Realtek, tanto che sto usando la linea da ethernet. Attendo i vostri consigli, e soprattutto il modo per risolvere quel conflitto che ho postato nel link.


Last edited by tano70 on Sat Oct 12, 2019 8:31 am; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22301
Location: here

PostPosted: Tue Oct 08, 2019 5:42 pm    Post subject: Reply with quote

Code:
It might be possible to break this cycle
by applying the following change:
- sys-libs/ncurses-6.1_p20181020 (Change USE: -gpm)

Prova, come dice portage, con
Code:
# USE="-gpm" emerge -1 =sys-libs/ncurses-6.1_p20181020
# emerge -1 sys-libs/gpm
#  emerge -1 =sys-libs/ncurses-6.1_p20181020

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
tano70
Tux's lil' helper
Tux's lil' helper


Joined: 26 Aug 2013
Posts: 120
Location: Torino

PostPosted: Tue Oct 08, 2019 5:54 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Code:
It might be possible to break this cycle
by applying the following change:
- sys-libs/ncurses-6.1_p20181020 (Change USE: -gpm)

Prova, come dice portage, con
Code:
# USE="-gpm" emerge -1 =sys-libs/ncurses-6.1_p20181020
# emerge -1 sys-libs/gpm
#  emerge -1 =sys-libs/ncurses-6.1_p20181020

Grazieee!!! con i comandi che mi hai postato ho risolto il problema. penso che adesso posso dare nuovamente l'emerge per farmi installare i 131 pacchetti. Altra premessa, prima che do il comando che mi farà emergere tutti quei pacchetti, avendo il mio portatile oltre alla scheda base (Intel Uhd 620) anche una scheda discreta (la Nvidia MX130) che da bios di windows non mi fa disattivare, nel make .conf cosa mi suggerisci di mettere? al momento ho settato VIDEO_CARDS="intel i965" mi suggerisci di mettere dentro anche nvidia? esiste a tuo avviso un modo per disabilitarla visto che su linux non penso mi servirà a molto? e un altra cosa relativa al mio processore, il settaggio che ho adesso è corretto?
CFLAGS="-march=native -O2 -pipe"
CXXFLAGS="-march=native -O2 -pipe"
MAKEOPTS="-j4 -l5"
CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3"

Ho lanciato il comando e mi trovo ancora questi errori che mi bloccano:

Code:
Total: 127 packages (3 upgrades, 112 new, 12 reinstalls), Size of downloads: 479.409 KiB

 * Error: circular dependencies:

(virtual/pkgconfig-1:0/0::gentoo, ebuild scheduled for merge) depends on
 (dev-util/pkgconfig-0.29.2:0/0::gentoo, ebuild scheduled for merge) (runtime)
  (dev-libs/glib-2.60.6:2/2::gentoo, ebuild scheduled for merge) (buildtime)
   (virtual/pkgconfig-1:0/0::gentoo, ebuild scheduled for merge) (buildtime)

It might be possible to break this cycle
by applying the following change:
- dev-util/pkgconfig-0.29.2 (Change USE: +internal-glib)

Note that this change can be reverted, once the package has been installed.

Note that the dependency graph contains a lot of cycles.
Several changes might be required to resolve all cycles.
Temporarily changing some use flag for all packages might be the better option.

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/openssl:0

  (dev-libs/openssl-1.1.1d-r1:0/1.1::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/openssl-1.1.0g:0[bindist=] required by (net-misc/openssh-8.0_p1-r2:0/0::gentoo, ebuild scheduled for merge)
    ^^                 ^^^^^^^^                                                                                                                                                                     

  (dev-libs/openssl-1.0.2t-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/openssl:0/0= required by (app-portage/portage-utils-0.80:0/0::gentoo, installed)
                    ^^^^^                                                                                                       
    (and 2 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

(chroot) GentooDesktop / #
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22301
Location: here

PostPosted: Tue Oct 08, 2019 7:27 pm    Post subject: Reply with quote

Per nvidia puoi provare una di queste due guide https://wiki.gentoo.org/wiki/NVIDIA/Optimus e https://wiki.gentoo.org/wiki/NVIDIA/Bumblebee. Personalmente "uso" bumblebee nel senso che l'ho configurato ma mai usato.
Code:
(virtual/pkgconfig-1:0/0::gentoo, ebuild scheduled for merge) depends on
 (dev-util/pkgconfig-0.29.2:0/0::gentoo, ebuild scheduled for merge) (runtime)
  (dev-libs/glib-2.60.6:2/2::gentoo, ebuild scheduled for merge) (buildtime)
   (virtual/pkgconfig-1:0/0::gentoo, ebuild scheduled for merge) (buildtime)

It might be possible to break this cycle
by applying the following change:
- dev-util/pkgconfig-0.29.2 (Change USE: +internal-glib)

Qua fai la stessa cosa che abbiamo fatto per ncurses
Code:
# USE="internal-glib" emerge -1 dev-util/pkgconfig
# emerge -1 dev-libs/glib
# emerge -1 dev-util/pkgconfig

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum