Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] problems with starting lightdm
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Prof. Frink
Apprentice
Apprentice


Joined: 07 Jan 2017
Posts: 176

PostPosted: Mon Sep 30, 2019 12:30 pm    Post subject: [SOLVED] problems with starting lightdm Reply with quote

Hey,

i did a lot of updates on my computer, but now I can not login with lightdm, I do not know what the problem is. It did not work with lightdm-1.26-0-r1, 1.28.0 and 1.30.0. One problem maybe, that I use a lot of testig packages, even my kernel is the newest one (5.3.1-gentoo). I recompiled the whole system after a gcc update (gcc-9.2.0) and then I tried to recompile the kernel, but that did not work. I have no idea how to solve the problem, or which log-files / information might be important.

Frink


Last edited by Prof. Frink on Mon Sep 30, 2019 1:25 pm; edited 1 time in total
Back to top
View user's profile Send private message
Prof. Frink
Apprentice
Apprentice


Joined: 07 Jan 2017
Posts: 176

PostPosted: Mon Sep 30, 2019 12:32 pm    Post subject: Reply with quote

This is is lightdm-log, but I am not sure, if it is really a lightdm-problem: http://dpaste.com/3F2YQ9G
Back to top
View user's profile Send private message
guitou
Guru
Guru


Joined: 02 Oct 2003
Posts: 414
Location: France

PostPosted: Mon Sep 30, 2019 12:57 pm    Post subject: Reply with quote

Hello.

Quote:

[+0.10s] DEBUG: Process 4801 exited with return value 1
[+0.10s] DEBUG: XServer 0: X server stopped


You may find out some relevant information in X server log.

++
Gi)
Back to top
View user's profile Send private message
Prof. Frink
Apprentice
Apprentice


Joined: 07 Jan 2017
Posts: 176

PostPosted: Mon Sep 30, 2019 1:24 pm    Post subject: Reply with quote

Thx man, thx a lot. I activated

Code:
        Option      "TearFree"    "true"


in


Code:
/etc/X11/xorg.conf.d/20-intel.conf


in the past and it was working for a long time, but this is for KDE, which I do not use, after removing it and executing

Code:
emerge --ask x11-drivers/xf86-video-intel


I can login with lightdm again. I know it is always dificult in gentoo when one starts using testing packages. The best is probably to stay on stable always, but sometimes you want some software, which is not stable yet :)

Thx.
Back to top
View user's profile Send private message
guitou
Guru
Guru


Joined: 02 Oct 2003
Posts: 414
Location: France

PostPosted: Mon Sep 30, 2019 1:31 pm    Post subject: Reply with quote

Glad you managed to find out :)
Back to top
View user's profile Send private message
Prof. Frink
Apprentice
Apprentice


Joined: 07 Jan 2017
Posts: 176

PostPosted: Mon Sep 30, 2019 9:00 pm    Post subject: Reply with quote

Thx, my computer problems are still not solved completely, but I will try to solve it on my own and you will here again from we, when I do not know how to go on. Thx.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum