Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] can't emerge stable openssl
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1629

PostPosted: Thu Sep 19, 2019 6:47 pm    Post subject: [SOLVED] can't emerge stable openssl Reply with quote

Hi All

I have installed now stable openssl version 1.0.2r. Now it wants to upgrade to version openssl-1.1.1d. However I have to accept keywords ~amd64. Why is that and how I can prevent it? I have a stable arch so I prefer the stable version.

here is the output that I get:
Code:

[ebuild     U ~] dev-libs/openssl-1.1.1d [1.0.2r] USE="-bindist* -sslv3* -tls-heartbeat*"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/openssl:0

  (dev-libs/openssl-1.1.1d:0/1.1::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/openssl:0[-bindist(-)] required by (dev-python/cryptography-2.6.1:0/0::gentoo, installed)
                                                                                                                       
    dev-libs/openssl (Argument)

  (dev-libs/openssl-1.0.2r:0/0::gentoo, installed) pulled in by
    dev-libs/openssl:0=[bindist=] required by (dev-qt/qtnetwork-5.12.3:5/5.12::gentoo, installed)
                        ^^^^^^^^                                                                                                     
    >=dev-libs/openssl-1.0.2k:0=[bindist=] required by (net-wireless/wpa_supplicant-2.6-r10:0/0::gentoo, installed)
                                 ^^^^^^^^                                                                                                             
    dev-libs/openssl:0/0= required by (dev-libs/xmlsec-1.2.28:0/0::gentoo, installed)
                    ^^^^^                                                                                               
    (and 19 more with the same problems)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by kde-frameworks/kdelibs4support-5.60.0::gentoo[-libressl]
# required by kde-plasma/plasma-workspace-5.15.5::gentoo
# required by virtual/notification-daemon-0::gentoo[kde]
# required by x11-libs/libnotify-0.7.7-r1::gentoo
# required by app-office/orage-4.12.1-r1::gentoo
# required by @selected
# required by @world (argument)
=dev-libs/openssl-1.1.1d ~amd64

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.

 * In order to avoid wasting time, backtracking has terminated early
 * due to the above autounmask change(s). The --autounmask-backtrack=y
 * option can be used to force further backtracking, but there is no
 * guarantee that it will produce a solution.

Code:

emerge --verbose-conflicts openssl
Calculating dependencies... done!
[ebuild     U ~] dev-libs/openssl-1.1.1d [1.0.2r] USE="-bindist* -sslv3* -tls-heartbeat*"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/openssl:0

  (dev-libs/openssl-1.1.1d:0/1.1::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/openssl:0[-bindist(-)] required by (dev-python/cryptography-2.6.1:0/0::gentoo, installed)
                                                                                                                       
    dev-libs/openssl (Argument)

  (dev-libs/openssl-1.0.2r:0/0::gentoo, installed) pulled in by
    dev-libs/openssl:0/0= required by (dev-lang/python-2.7.15:2.7/2.7::gentoo, installed)
                    ^^^^^                                                                                                   
    dev-libs/openssl:0/0= required by (dev-libs/xmlsec-1.2.28:0/0::gentoo, installed)
                    ^^^^^                                                                                               
    dev-libs/openssl:0/0= required by (net-libs/libtorrent-rasterbar-1.1.13:0/9::gentoo, installed)
                    ^^^^^                                                                                                             
    dev-libs/openssl:0=[bindist=] required by (dev-qt/qtnetwork-5.12.3:5/5.12::gentoo, installed)
                        ^^^^^^^^                                                                                                     
    dev-libs/openssl:0/0= required by (app-emulation/virtualbox-5.2.26-r1:0/0::gentoo, installed)
                    ^^^^^                                                                                                           
    dev-libs/openssl:0/0= required by (dev-perl/Net-SSLeay-1.820.0:0/0::gentoo, installed)
                    ^^^^^                                                                                                     
    dev-libs/openssl:0/0=[abi_x86_64(-)] required by (app-arch/libarchive-3.3.3:0/13::gentoo, installed)
                    ^^^^^                                                                                                                   
    dev-libs/openssl:0/0= required by (net-misc/wget-1.20.3-r1:0/0::gentoo, installed)
                    ^^^^^                                                                                                 
    dev-libs/openssl:0/0= required by (net-misc/openssh-8.0_p1-r2:0/0::gentoo, installed)
                    ^^^^^                                                                                                   
    dev-libs/openssl:0/0=[abi_x86_64(-)] required by (net-misc/curl-7.65.0:0/0::gentoo, installed)
                    ^^^^^                                                                                                             
    dev-libs/openssl:0/0=[abi_x86_64(-)] required by (net-libs/neon-0.30.2:0/27::gentoo, installed)
                    ^^^^^                                                                                                             
    >=dev-libs/openssl-1.0.1h-r2:0/0=[abi_x86_64(-)] required by (net-nds/openldap-2.4.45:0/0::gentoo, installed)
                                ^^^^^                                                                                                               
    dev-libs/openssl:0/0= required by (x11-base/xorg-server-1.20.5:0/1.20.5::gentoo, installed)
                    ^^^^^                                                                                                         
    dev-libs/openssl:0/0=[bindist] required by (dev-qt/qtnetwork-5.12.3:5/5.12::gentoo, installed)
                    ^^^^^                                                                                                             
    dev-libs/openssl:0/0= required by (net-misc/iputils-20180629:0/0::gentoo, installed)
                    ^^^^^                                                                                                   
    dev-libs/openssl:0/0=[abi_x86_64(-)] required by (app-crypt/rhash-1.3.6-r1:0/0::gentoo, installed)
                    ^^^^^                                                                                                                 
    dev-libs/openssl:0/0= required by (sys-fs/cryptsetup-2.1.0:0/12::gentoo, installed)
                    ^^^^^                                                                                                 
    dev-libs/openssl:0/0= required by (dev-lang/python-3.6.5:3.6/3.6m::gentoo, installed)
                    ^^^^^                                                                                                   
    dev-libs/openssl:0/0= required by (dev-python/cryptography-2.6.1:0/0::gentoo, installed)
                    ^^^^^                                                                                                       
    dev-libs/openssl:0/0=[abi_x86_64(-)] required by (dev-db/mariadb-connector-c-3.0.6-r1:0/3::gentoo, installed)
                    ^^^^^                                                                                                                           
    >=dev-libs/openssl-1.0.2k:0=[bindist=] required by (net-wireless/wpa_supplicant-2.6-r10:0/0::gentoo, installed)
                                 ^^^^^^^^                                                                                                             


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by dev-python/cryptography-2.6.1::gentoo[-libressl]
# required by dev-python/urllib3-1.24.2::gentoo
# required by dev-python/requests-2.21.0-r1::gentoo
# required by dev-python/ssl-fetch-0.4::gentoo
# required by app-portage/mirrorselect-2.2.4-r1::gentoo
# required by @selected
# required by @world (argument)
=dev-libs/openssl-1.1.1d ~amd64





Thanks a lot


Last edited by queen on Thu Sep 19, 2019 9:34 pm; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22713
Location: here

PostPosted: Thu Sep 19, 2019 6:58 pm    Post subject: Reply with quote

Remove bindist use flag from your make.conf and then run emerge -UD @world. After that try to install unstable openssl
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1629

PostPosted: Thu Sep 19, 2019 7:07 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Remove bindist use flag from your make.conf and then run emerge -UD @world. After that try to install unstable openssl


I want the stable openssl. And I don't have bindist in make.conf file
Back to top
View user's profile Send private message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1629

PostPosted: Thu Sep 19, 2019 9:34 pm    Post subject: Reply with quote

The problem was solved. I ran
Code:
emerge -UD @world
and it pulled a stable openssl version. bindist wasn't in make.conf file at all.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22713
Location: here

PostPosted: Fri Sep 20, 2019 5:25 am    Post subject: Reply with quote

queen wrote:
...and it pulled a stable openssl version. bindist wasn't in make.conf file at all.

Ok then all we needed to do was recompile the packages they still had yet bindist use flag enabled
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum