Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Segfault in qtwebengine-5.12.4+ [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
binro
l33t
l33t


Joined: 06 May 2005
Posts: 639
Location: Bangkok, Thailand

PostPosted: Sat Sep 14, 2019 4:10 pm    Post subject: Segfault in qtwebengine-5.12.4+ [SOLVED] Reply with quote

Using konqueror and qt-5.12.4 I started getting a segfault every time I opened a page:

Code:

Sep 14 22:53:47 localhost kernel QtWebEngineProc[20217]: segfault at 77 ip 00007f78ec0cad7c sp 00007ffe3547a100
error 4 in libQt5WebEngineCore.so.5.12.5[7f78eb14d000+5065000]
Sep 14 22:53:47 localhost kernel Code: 02 00 00 00 75 20 48 63 4b 48 48 89 ca 48 89 44 cb 08 83 c2
01 83 e2 07 89 53 48 5b 41 5c 5d c3 66 0f 1f 44 00 00 48 8b 50 ff <66> 83 7a 0b
7f 77 d5 48 8b 50 ff 0f b7 52 0b 83 e2 07 66 83 fa 05

I saw a new version of Qt was available (5.12.5) and spent 13 hours compiling it, only to get the same error. I am using gcc-9.1.0 if that makes any difference.

Thanks
Robin
_________________
"Ship me somewheres east of Suez, where the best is like the worst,
Where there ain't no Ten Commandments an' a man can raise a thirst"
from "Mandalay" by Rudyard Kipling


Last edited by binro on Sun Nov 10, 2019 4:13 pm; edited 1 time in total
Back to top
View user's profile Send private message
equaeghe
Guru
Guru


Joined: 22 Feb 2005
Posts: 482

PostPosted: Sun Sep 15, 2019 7:26 am    Post subject: Re: Segfault in qtwebengine-5.12.4+ Reply with quote

binro wrote:

Code:

Sep 14 22:53:47 localhost kernel QtWebEngineProc[20217]: segfault at 77 ip 00007f78ec0cad7c sp 00007ffe3547a100
error 4 in libQt5WebEngineCore.so.5.12.5[7f78eb14d000+5065000]
Sep 14 22:53:47 localhost kernel Code: 02 00 00 00 75 20 48 63 4b 48 48 89 ca 48 89 44 cb 08 83 c2
01 83 e2 07 89 53 48 5b 41 5c 5d c3 66 0f 1f 44 00 00 48 8b 50 ff <66> 83 7a 0b
7f 77 d5 48 8b 50 ff 0f b7 52 0b 83 e2 07 66 83 fa 05

I'm hitting the same issue with 5.12.3 (stable) since restarting my laptop this morning. Also Firefox crashes (in non safe-mode); I don't know if that is related. I suppose it is due to a problem in some library.
The things I emerged yesterday are:
Code:
acct-group/plugdev-0
media-fonts/fira-code-1.207
dev-libs/openssl-1.0.2t
sys-kernel/gentoo-sources-4.19.72
net-libs/nghttp2-1.39.2
net-libs/nodejs-8.12.0
dev-util/cbindgen-0.9.1
dev-python/certifi-2019.6.16
media-libs/dav1d-0.3.1
sys-apps/xdg-desktop-portal-1.4.2-r1
media-libs/libaom-1.0.0-r2
www-client/firefox-68.1.0

I already tried rebooting with my previous kernel without change, so I'm excluding that as a cause. I don't use qtwebengine-based programs that often, so it may also be due to an emerge a day earlier:
Code:
sys-devel/gnuconfig-20180101
kde-plasma/ksysguard-5.15.5
media-libs/mesa-19.0.8

Some of these are more likely than others, but perhaps you can cross-compare and we can look in the depgraph.
Back to top
View user's profile Send private message
equaeghe
Guru
Guru


Joined: 22 Feb 2005
Posts: 482

PostPosted: Sun Sep 15, 2019 7:40 am    Post subject: Reply with quote

Bug 694442 reported
Back to top
View user's profile Send private message
binro
l33t
l33t


Joined: 06 May 2005
Posts: 639
Location: Bangkok, Thailand

PostPosted: Sun Sep 15, 2019 1:48 pm    Post subject: Reply with quote

Firefox works OK for me, that's what I am using now. Perhaps I should report the problem directly to Qt.
_________________
"Ship me somewheres east of Suez, where the best is like the worst,
Where there ain't no Ten Commandments an' a man can raise a thirst"
from "Mandalay" by Rudyard Kipling
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7167
Location: Austria

PostPosted: Sun Sep 15, 2019 5:00 pm    Post subject: Reply with quote

Please do the following:

Code:
# equery s dev-libs/openssl
# emerge -1v openssl
# equery s dev-libs/openssl


In case of a size difference, you've hit bug 694512.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
binro
l33t
l33t


Joined: 06 May 2005
Posts: 639
Location: Bangkok, Thailand

PostPosted: Mon Sep 16, 2019 10:34 am    Post subject: Reply with quote

Code:

# equery s dev-libs/openssl * dev-libs/openssl-1.1.1c-r1 Total files : 8481 Total size  : 15.13 MiB
# equery s dev-libs/openssl * dev-libs/openssl-1.1.1c-r1 Total files : 8481 Total size : 15.13 MiB

No difference. :(
_________________
"Ship me somewheres east of Suez, where the best is like the worst,
Where there ain't no Ten Commandments an' a man can raise a thirst"
from "Mandalay" by Rudyard Kipling
Back to top
View user's profile Send private message
binro
l33t
l33t


Joined: 06 May 2005
Posts: 639
Location: Bangkok, Thailand

PostPosted: Sun Nov 10, 2019 4:12 pm    Post subject: Reply with quote

This problem is fixed with dev-qt/qtwebengine-5.13.2 and kde-apps/konqueror-19.08.2.
_________________
"Ship me somewheres east of Suez, where the best is like the worst,
Where there ain't no Ten Commandments an' a man can raise a thirst"
from "Mandalay" by Rudyard Kipling
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum