Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Dantrell's GNOME Without Systemd Project (Part 3)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6, 7  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Shibotto
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jun 2015
Posts: 122
Location: Italy

PostPosted: Sun Aug 04, 2019 2:25 pm    Post subject: Reply with quote

So, this is what I did. Since don't really grasp ebuilds yet, I took gnome-next as a reference and made a few modifications to trim off useless things. It's horrible, I know.

Targeting libhandy-0.0.9 of course gives no problem, since it's the one included in GNOME 3.32, so next I tested 0.0.10, the current stable:
  • gnome-contacts-3.32.1: Fails at build time, fix upstream.
  • gnome-control-center-3.32.2: Works.
  • epiphany-3.32.4: Works.

And that's pretty much it, I didn't exactly work myself to the bone. :lol:

---

On a completely unrelated matter, I noticed Gentoo included gnome-usage as sys-process/gnome-usage (instead of gnome-extra/gnome-usage), so maybe some masks need to be adjusted.
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 580
Location: Earth

PostPosted: Sun Aug 04, 2019 9:20 pm    Post subject: Reply with quote

dantrell wrote:
Actually, it looks like GNOME 3.34 (e.g. GNOME Control Center) will see greater use of libhandy so this is probably something that should be done.

You know, until now it slipped my mind that you mentioned GNOME Control Center for GNOME 3.32.

I must have been thinking of another package. :oops:

Shibotto wrote:
So, this is what I did. Since don't really grasp ebuilds yet, I took gnome-next as a reference and made a few modifications to trim off useless things. It's horrible, I know.

Targeting libhandy-0.0.9 of course gives no problem, since it's the one included in GNOME 3.32, so next I tested 0.0.10, the current stable:
  • gnome-contacts-3.32.1: Fails at build time, fix upstream.
  • gnome-control-center-3.32.2: Works.
  • epiphany-3.32.4: Works.

And that's pretty much it, I didn't exactly work myself to the bone. :lol:

I added my versions here but I didn't integrate it just yet (although I did apply the linked patch).

I also used EAPI 6 since I'm not that familiar with EAPI 7 for non-trivial use cases.

Shibotto wrote:
On a completely unrelated matter, I noticed Gentoo included gnome-usage as sys-process/gnome-usage (instead of gnome-extra/gnome-usage), so maybe some masks need to be adjusted.

Thanks for the heads up.

This issue has been corrected. :wink:
_________________
Dantrell B.
Back to top
View user's profile Send private message
Shibotto
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jun 2015
Posts: 122
Location: Italy

PostPosted: Wed Aug 07, 2019 10:17 am    Post subject: Reply with quote

dantrell wrote:
I added my versions here but I didn't integrate it just yet (although I did apply the linked patch).

Works fine here, thanks :-B

I also found another thing: media-gfx/gthumb with USE="gstreamer" should also depend on media-plugins/gst-plugins-gtk:1.0 in order to embed videos in the main window. This is required for >=3.6, but *not* for 3.4. I reported to Gentoo with screenshots.

And here's the Simpson clip in the screenshots :P
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 580
Location: Earth

PostPosted: Wed Aug 07, 2019 7:32 pm    Post subject: Reply with quote

Shibotto wrote:
I also found another thing: media-gfx/gthumb with USE="gstreamer" should also depend on media-plugins/gst-plugins-gtk:1.0 in order to embed videos in the main window. This is required for >=3.6, but *not* for 3.4. I reported to Gentoo with screenshots.

Fixed.

But what are you doing that you are running into so many small issues? :o
_________________
Dantrell B.
Back to top
View user's profile Send private message
Shibotto
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jun 2015
Posts: 122
Location: Italy

PostPosted: Wed Aug 07, 2019 8:57 pm    Post subject: Reply with quote

dantrell wrote:
But what are you doing that you are running into so many small issues? :o

Holiday 8)
Back to top
View user's profile Send private message
Child_of_Sun_24
Guru
Guru


Joined: 28 Jul 2004
Posts: 458

PostPosted: Thu Aug 15, 2019 7:40 am    Post subject: Reply with quote

Hi dantrell,

I have changed my active python single target and python target to python3_7, so far everything works fine but media-video/totem-3.32.1-r1 tells me about a missing IUSE flag "threads" here is the complete error:

Code:
emerge: there are no ebuilds built with USE flags to satisfy "dev-lang/python:3.7[threads]".
!!! One of the following packages is required to complete your request:
- dev-lang/python-3.7.4-r1::gentoo (Missing IUSE: threads)
- dev-lang/python-3.7.3::gentoo (Missing IUSE: threads)
- dev-lang/python-3.7.2::gentoo (Missing IUSE: threads)
(dependency required by "media-video/totem-3.32.1-r1::dantrell-gnome-3-32[python,python_single_target_python3_7]" [ebuild])
(dependency required by "totem" [argument])


Python 3.7 has no Use Flag threads and i don't know if it works when i edit the ebuild.

Using -python to build totem works.
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 580
Location: Earth

PostPosted: Thu Aug 15, 2019 8:36 pm    Post subject: Reply with quote

Child_of_Sun_24 wrote:
I have changed my active python single target and python target to python3_7, so far everything works fine but media-video/totem-3.32.1-r1 tells me about a missing IUSE flag "threads" here is the complete error: [...]

Sync up and you should be good to go. :wink:
_________________
Dantrell B.
Back to top
View user's profile Send private message
Child_of_Sun_24
Guru
Guru


Joined: 28 Jul 2004
Posts: 458

PostPosted: Tue Aug 20, 2019 4:27 pm    Post subject: Reply with quote

I made a new Installation of my System and have included dantrell-gnome from the beginning. Now there is an error with dev-scheme/guile-2.0.14-r3. It's a segfault in boehm-gc during compiling it:
Code:
[11062.683260] guile[9530]: segfault at 7f80ae9b21a8 ip 00007f84b7484883 sp 00007ffef870a660 error 4 in libgc.so.1.4.3[7f84b746c000+2c000]
[11062.683267] Code: 8d 2d 91 4c 01 00 90 4a 8d 04 e5 00 00 00 00 48 89 c1 48 89 04 24 49 8b 45 00 4c 8b 3c 08 4d 85 ff 74 27 31 ed 66 90 4d 89 fe <4d> 8b 7f 08 49 8b 7e 10 48 f7 d7 e8 fd d9 fe ff 85 c0 0f 84 45 01


Here is the build.log:
https://pastebin.com/3ux715sR

Here is the emerge --info:
https://pastebin.com/d5fXu4ke

I hope you can help me to fix this error (At the moment i have installed dev-scheme/guile-1.8.8-r3 and masked dev-scheme/guile-2.0.14-r3)

*EDIT* Looks like it doesn't like to be compiled in a VM, have compiled it native and it worked :-)
Back to top
View user's profile Send private message
Child_of_Sun_24
Guru
Guru


Joined: 28 Jul 2004
Posts: 458

PostPosted: Fri Aug 23, 2019 5:35 am    Post subject: Reply with quote

Hi,

I have a new Problem, gucharmap won't compile (Every Version), so i used a binpkg from my old installation and so i could install it.

But i can't compile it, here is the build.log:
https://pastebin.com/P5CdVRRN

Here is emerge --info:
https://pastebin.com/Q4g7ZTvc

I hope this helps to solve this, even older Versions won't compile with the same error.
Back to top
View user's profile Send private message
Shibotto
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jun 2015
Posts: 122
Location: Italy

PostPosted: Fri Aug 23, 2019 10:15 am    Post subject: Reply with quote

Child_of_Sun_24 wrote:
Hi,

I have a new Problem, gucharmap won't compile (Every Version), so i used a binpkg from my old installation and so i could install it.

But i can't compile it, here is the build.log:
https://pastebin.com/P5CdVRRN

Here is emerge --info:
https://pastebin.com/Q4g7ZTvc

I hope this helps to solve this, even older Versions won't compile with the same error.


gnome-extra/gucharmap-12.0.1 compiles with app-i18n/unicode-data-12.0.0 (instead of 12.1.0). Previous gucharmap versions don't :D
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 580
Location: Earth

PostPosted: Sat Aug 24, 2019 1:51 am    Post subject: Reply with quote

Child_of_Sun_24 wrote:
I have a new Problem, gucharmap won't compile (Every Version), so i used a binpkg from my old installation and so i could install it.

I was able to reproduce and correct this issue.

Sync up and you should be good to go.

Shibotto wrote:
gnome-extra/gucharmap-12.0.1 compiles with app-i18n/unicode-data-12.0.0 (instead of 12.1.0). Previous gucharmap versions don't :D

P.S. Thanks for the tip.

I ended up directly tying versions of gucharmap to their unicode-data counterparts.
_________________
Dantrell B.
Back to top
View user's profile Send private message
Child_of_Sun_24
Guru
Guru


Joined: 28 Jul 2004
Posts: 458

PostPosted: Sat Aug 24, 2019 6:24 am    Post subject: Reply with quote

Thank you :-) Now it compiles fine :-)
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 580
Location: Earth

PostPosted: Thu Aug 29, 2019 11:02 am    Post subject: Reply with quote

Shibotto wrote:
Here I am again! I was wondering if you have any plan to include libhandy as a standalone library.

Shibotto wrote:
This solution however will require manual intervention during upgrade, since /usr/lib64/libhandy-0.0.so is already owned by one of those packages, so beware :lol:

A bit overdue but I finally got around to integrating this.

For aforementioned reasons, these changes are slotted in ~. :wink:
_________________
Dantrell B.
Back to top
View user's profile Send private message
Shibotto
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jun 2015
Posts: 122
Location: Italy

PostPosted: Mon Sep 02, 2019 10:29 am    Post subject: Reply with quote

dantrell wrote:
A bit overdue but I finally got around to integrating this.

Thanks for the notice, I already prepared in advance (and not because I needed libhandy-0.0.10, nooooo... :roll: )

So, I got myself a new rig with a Ryzen APU to finally retire my infamously old Athlon 64 desktop (the one that took +5h for webkit-gtk) and I'm taking the opportunity to put some sense into my Gentoo configs.
Reworking my USE flags, I noticed that gnome-base/gnome-control-center has a libinput flag, so I was wondering if maybe it would be reasonable to take advantage of INPUT_DEVICES (input_devices_libinput) instead. Also I'm not sure if it can be optional under Wayland, since afaik libinput is the only supported input library.

Also (again) since I'm now finally on a UEFI system, I run into the OpenRC read-only root issue. If I don't get too lazy, I will try to investigate it :D
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 580
Location: Earth

PostPosted: Mon Sep 02, 2019 3:25 pm    Post subject: Reply with quote

Shibotto wrote:
So, I got myself a new rig with a Ryzen APU to finally retire my infamously old Athlon 64 desktop (the one that took +5h for webkit-gtk) and I'm taking the opportunity to put some sense into my Gentoo configs.

Out of curiosity, why not Threadripper?

Shibotto wrote:
Reworking my USE flags, I noticed that gnome-base/gnome-control-center has a libinput flag, so I was wondering if maybe it would be reasonable to take advantage of INPUT_DEVICES (input_devices_libinput) instead. Also I'm not sure if it can be optional under Wayland, since afaik libinput is the only supported input library.

I'll review this.

Shibotto wrote:
Also (again) since I'm now finally on a UEFI system, I run into the OpenRC read-only root issue. If I don't get too lazy, I will try to investigate it :D

Please do as I turned up nothing. :?
_________________
Dantrell B.
Back to top
View user's profile Send private message
Shibotto
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jun 2015
Posts: 122
Location: Italy

PostPosted: Sat Sep 07, 2019 3:51 pm    Post subject: Reply with quote

dantrell wrote:
Out of curiosity, why not Threadripper?

My two main reasons were that this PC is always on, so I'd rather have low power consumption, and that I don't care about a dedicated graphic card, since I don't play game or do video editing. I got a very good deal from a friend on a not so much used 2200G, which I know is a weak Ryzen, but still I do webkit-gtk in only 42 minutes (it's become my "distress" unit of measurement :lol: )

dantrell wrote:
Shibotto wrote:
Also (again) since I'm now finally on a UEFI system, I run into the OpenRC read-only root issue. If I don't get too lazy, I will try to investigate it :D

Please do as I turned up nothing. :?

Well, it turned out it had nothing to do with UEFI, services are just missing from runlevels, the root service for this issue in particular. :lol:
Having the stage3 I used when I installed Gentoo on my laptop 2 years ago (still an OCD the size of Switzerland) helped me understand how this happened:
visual help (please ignore the sloppy chroot)
tl;dr in 2017 Gentoo, almost everything in /etc/runlevels/ was just "put there" inside stage3, while recently openrc took ownership of those basic services. So if you start from a recent Gentoo then downgrade openrc, you lose those symlinks and have to manually add the right services to the right runlevels.

...that is unless this line gets removed from openrc-0.29 ebuild, then it will be able to add those services itself :D
Actually 0.40.3 is the last ebuild with that "Backup our default runlevels" routine, which disappeared in 0.41 along with a bunch of other deprecated stuff. This seems in line with the working versions Elleni reported half a year ago.

Next week I'll try to use 0.41.2, we'll see if cgroups still explode on shutdown :twisted:
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 580
Location: Earth

PostPosted: Sat Sep 07, 2019 5:51 pm    Post subject: Reply with quote

dantrell wrote:
I'll review this.

I realized GNOME 3.34 is on the horizon so I'll review it then.

Definitely not procrastinating. Nope. Not this fellow.

Shibotto wrote:
Well, it turned out it had nothing to do with UEFI, services are just missing from runlevels, the root service for this issue in particular. :lol:

I duct taped together sys-apps/openrc-0.29-r3.ebuild (which is slotted in ~) but I would need someone to test it. :twisted:

Edit: Speaking of testing, I was doing preliminary checks and found that WebkitGTK+ 2.26.0's GNOME requirements have been drastically and non-uniformly bumped.

I investigated further and found WebKit bug #199094 in which they removed the preprocessor guards.

Looking into restoring the guards for 2.26 will probably be a stopgap measure since maintaining code for WebkitGTK+ is not really something I want to do (but we'll see).

What probably needs to be done is making sure that WebkitGTK+ is completely optional even if I have to gut some code.
_________________
Dantrell B.
Back to top
View user's profile Send private message
saboya
Guru
Guru


Joined: 28 Nov 2006
Posts: 445
Location: Brazil

PostPosted: Wed Sep 11, 2019 9:49 pm    Post subject: Reply with quote

dantrell wrote:

Looking into restoring the guards for 2.26 will probably be a stopgap measure since maintaining code for WebkitGTK+ is not really something I want to do (but we'll see).


I wouldn't wish that for my worst enemy

dantrell wrote:

What probably needs to be done is making sure that WebkitGTK+ is completely optional even if I have to gut some code.


At the same time, yes please.
Back to top
View user's profile Send private message
Shibotto
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jun 2015
Posts: 122
Location: Italy

PostPosted: Fri Sep 13, 2019 2:22 pm    Post subject: Reply with quote

dantrell wrote:
dantrell wrote:
I'll review this.

I realized GNOME 3.34 is on the horizon so I'll review it then.

Oh! I didn't even notice it was that time of the year :lol:
No hurry for that flag however, libinput gets pulled in anyway :P

dantrell wrote:
Edit: Speaking of testing, I was doing preliminary checks and found that WebkitGTK+ 2.26.0's GNOME requirements have been drastically and non-uniformly bumped.

I investigated further and found WebKit bug #199094 in which they removed the preprocessor guards.

Looking into restoring the guards for 2.26 will probably be a stopgap measure since maintaining code for WebkitGTK+ is not really something I want to do (but we'll see).

What probably needs to be done is making sure that WebkitGTK+ is completely optional even if I have to gut some code.

I guess problems come with older GNOME versions not matching the new minimum required dependencies? Is it a really bad idea to just keep webkit-gtk-2.26 masked on those profiles?
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 580
Location: Earth

PostPosted: Sat Sep 14, 2019 1:13 am    Post subject: Reply with quote

Shibotto wrote:
Oh! I didn't even notice it was that time of the year :lol:

I'm a bit conflicted about trying for a 3.34.0 release or waiting for 3.34.1 because there's at least 20-25 packages they haven't updated yet which creates a bit more work for me but then again I already started so... :twisted:

Shibotto wrote:
I guess problems come with older GNOME versions not matching the new minimum required dependencies?

Yep.

If I have it right that's only includes GNOME release versions earlier than 3.22 (this time).

saboya wrote:
At the same time, yes please.

Shibotto wrote:
Is it a really bad idea to just keep webkit-gtk-2.26 masked on those profiles?

I'm looking at this from a security viewpoint.

Better a bracketed WebkitGTK+ than an outdated one and better an optional WebkitGTK+ than an outdated one.

If there's no bracketed or optional WebkitGTK+ then your point is valid for when you need an outdated WebkitGTK+ to make sure everything builds while understanding you shouldn't allow it internet access.

For now we can avoid the issue but only time will tell what WebkitGTK+ 2.28 brings.
_________________
Dantrell B.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6, 7
Page 7 of 7

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum