Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Bluetooth Kopfhörer PX210BT am Notebook als Soundausgabe
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
alexander_ro
Apprentice
Apprentice


Joined: 22 Nov 2014
Posts: 182

PostPosted: Sat Aug 10, 2019 9:06 am    Post subject: Bluetooth Kopfhörer PX210BT am Notebook als Soundausgabe Reply with quote

Hi Mädels ... Jungs ... :)

Ich versuche gerade meinen Sennheiser PX210BT an meinem Alien Notebook als Soundausgabe zu verwenden. Das Pairing mit bluetoothctl hat noch funktioniert aber leider kann man sich nicht connecten zum Kopfhörer.

Code:

[bluetooth]# devices
Device 00:16:94:09:A5:12 Sennheiser PX210BT
[bluetooth]# connect 00:16:94:09:A5:12
Attempting to connect to 00:16:94:09:A5:12
[CHG] Device 00:16:94:09:A5:12 Connected: yes
Failed to connect: org.bluez.Error.Failed
[CHG] Device 00:16:94:09:A5:12 Connected: no
[CHG] Device 00:16:94:09:A5:12 Connected: yes
[CHG] Device 00:16:94:09:A5:12 Connected: no


Leider sind die Beschreibungen die ich gefunden habe alle nicht ganz aktuell. Meist benutzen die noch das hciconfig das es nicht mehr gibt und auch die Kernel Einstellungen passen nicht mehr so ganz zu meinem 4.19.57-gentoo Kernel. Vermutlich fehlt noch irgendeine Kerneloption ich komme aber irgendwie gerade nicht drauf welche es sein könnte?

Ich hätte das gerne so gehabt das wenn sich der Kopfhörer verbindet automatisch die Soundausgabe auf den Umgeleitet wird. Gehen muss das weil ich es schon mal bei einem gesehen habe nur wie habe ich auch gerade keine Idee. Ideen oder Links sind gerne gesehen ... :)

Grüße
Alexander
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1178

PostPosted: Sat Aug 10, 2019 11:53 am    Post subject: Reply with quote

hm, manuell/mit cli hab ich nicht viel Ahnung von Bluetooth.
Bisher hab ich das nur von KDE aus verwendet, in Kombination mit pulseaudio
wird da bei verbinden eines BT Kopfhörers/Lautsprechers automatisch auf diesen umgeschaltet.

Hast du eine DE verfügbar, die BT unterstützt? und verwendest du pulseaudio oder einfaches alsa?
Back to top
View user's profile Send private message
alexander_ro
Apprentice
Apprentice


Joined: 22 Nov 2014
Posts: 182

PostPosted: Sat Aug 10, 2019 12:10 pm    Post subject: Reply with quote

Was denn für ein DE?

Ich habe es mal mit alsa probiert: "media-sound/bluez-alsa-1.4.0". Installiert sind im Moment folgende Pakete:
Code:

alien # qlist -Iv | grep pulse
media-sound/pulseaudio-12.2-r1
xfce-extra/xfce4-pulseaudio-plugin-0.4.1

alien # qlist -Iv | grep alsa
media-libs/alsa-lib-1.1.8
media-plugins/alsa-plugins-1.1.8
media-sound/alsa-utils-1.1.8
media-sound/bluez-alsa-1.4.0
alien /home/alex #


Aber das erste Problem ist der Fehler beim connect zum Kopfhörer: "Failed to connect: org.bluez.Error.Failed".
Ich vermute das liegt an einer Kerneloption. Oder kann es sein das ein Notebook keine Bluetooth Audio Geräte unterstützt?
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1178

PostPosted: Sat Aug 10, 2019 4:25 pm    Post subject: Reply with quote

naja, KDE hat auf jeden fall bluetooth support, und Gnome wahrscheinlich auch.
wie es mit anderend DEs aussieht weiß ich nicht.

Kernel optionen fehlen eher keine, da der Kernel nur Treiber zur verfügung stellt und der rest des BT stacks (bluez) im userspace läuft.
in gentoo solltest du aber das bluetooth useflag aktiviert haben.
bluez-alsa habe ich gar nicht installiert, vermutlich weil man das mit pulseaudio gar nicht braucht.

Evtl. kannst du mal net-wireless/blueman als bluetooth manager probieren, scheint wohl DE unabhängig zu sein.
Back to top
View user's profile Send private message
alexander_ro
Apprentice
Apprentice


Joined: 22 Nov 2014
Posts: 182

PostPosted: Sat Aug 10, 2019 4:45 pm    Post subject: Reply with quote

Ich benutze gerade einen Xfce.

Das USE-Flag bluetooth habe ich schon aktiviert. Das connecten zu anderen Bluetooth Geräten wie z.B. Computer oder Handy funktioniert auch. Der Kopfhörer geht zum Beispiel auch am Handy also an dem liegt es nicht.

Der net-wireless/blueman ist scheinbar noch sehr neu bei Gentoo gibt nur eine Testing Version. Ich werde den mal probieren. Das mit bluez-alsa habe ich im Gentoo Wiki gefunden und halt mal ausprobiert.

Ich dachte die Alsa Treiber sind die im Kernel. Früher musste man oft noch die Unterstützung für Geräte Profile wie z.B. Audio mit irgendwelchen Optionen aktivieren. Daher meine Vermutung mit dem Kernel Treiber.
Back to top
View user's profile Send private message
alexander_ro
Apprentice
Apprentice


Joined: 22 Nov 2014
Posts: 182

PostPosted: Sun Aug 11, 2019 7:27 am    Post subject: Reply with quote

Der Blueman sagt beim verbinden zum Kopfhörer: "Verbindung fehlgeschlagen: Resource temporarily unavailable"

<Edit>
Wie geht das eigentlich?
Bluez macht doch das pairing und den connect. Dann werden die Daten zu pullseaudio übertragen. Wird da einfach ein Disconnect automatisch ausgeführt falls Pulsaudio mit den Daten nicht klar kommt oder Spielt es einfach keinen Ton?

Der Kopfhörer sendet die Daten aptX Codiert und nach den zum Teil leider auch schon älteren Dokumenten die ich gefunden habe wird das von Pulsaudio nicht unterstützt. Sondern nur über andere Projekte die eingene Treiber bauten.
</Edit>

<EditNochMal :)>
Mit dem Tool btmon habe ich ein Tool gefunden das es noch gibt. Wenn ich über blueman zum Kopfhörer verbinden will zeigt btmon folgenden Fehlermeldung:
bluetoothd: a2dp-sink profile connect failed for 00:16:94:09:A5:12: Protocol not available

Fragt sich jetzt nur wie komme ich zu dem Protocol a2dp-sink?
</EditNochMal :)>

<Debug Meldungen>
Nach einigem probieren habe ich es noch hin bekommen dem Ding etwas mehr Infos zu entlocken.

Aug 13 20:56:22 alien bluetoothd[6048]: src/device.c:connect_profiles() /org/bluez/hci0/dev_00_16_94_09_A5_12 (all), client :1.22
Aug 13 20:56:22 alien bluetoothd[6048]: profiles/audio/a2dp.c:a2dp_sink_connect() path /org/bluez/hci0/dev_00_16_94_09_A5_12
Aug 13 20:56:22 alien bluetoothd[6048]: a2dp-sink profile connect failed for 00:16:94:09:A5:12: Protocol not available

Das in den Meldungen genannte Profil konnte ich auch um Source Code finden. Aber das mit dem Protocol das nicht verfügbar sein soll nicht. Mir ist auch nicht so recht klar was die mit Protocol meinen. Die Profile sind ja verschiedene Anwendungsbereiche wie Audio, Netzwerk, usw. aber was ist das Protocol?
</Debug Meldungen>
Back to top
View user's profile Send private message
alexander_ro
Apprentice
Apprentice


Joined: 22 Nov 2014
Posts: 182

PostPosted: Sat Aug 17, 2019 8:02 am    Post subject: Reply with quote

Das muss irgendein Grundsätzliches Problem mit dem bluetoothd sein. Ich kann auch andere Geräte nur mehr Koppeln aber nicht verbinden. Auch ein externer USB Bluetooth Adapter hilft nicht weiter. Irgendwie kaputt das ganze ... :(
Back to top
View user's profile Send private message
alexander_ro
Apprentice
Apprentice


Joined: 22 Nov 2014
Posts: 182

PostPosted: Wed Aug 28, 2019 10:10 am    Post subject: Reply with quote

Code:

Aug 28 12:06:02 alien bluetoothd[5980]: Bluetooth daemon 5.50
Aug 28 12:06:02 alien bluetoothd[5980]: Starting SDP server
Aug 28 12:06:02 alien bluetoothd[5980]: kernel lacks bnep-protocol support
Aug 28 12:06:02 alien bluetoothd[5980]: System does not support network plugin
Aug 28 12:06:02 alien bluetoothd[5980]: Bluetooth management interface 1.14 initialized
Aug 28 12:06:02 alien bluetoothd[5980]: RFCOMM server failed for Message Notification: socket(STREAM, RFCOMM): Protocol not supported (93)
Aug 28 12:06:02 alien bluetoothd[5980]: RFCOMM server failed for Message Access: socket(STREAM, RFCOMM): Protocol not supported (93)
Aug 28 12:06:02 alien bluetoothd[5980]: RFCOMM server failed for Phone Book Access: socket(STREAM, RFCOMM): Protocol not supported (93)
Aug 28 12:06:02 alien bluetoothd[5980]: RFCOMM server failed for Synchronization: socket(STREAM, RFCOMM): Protocol not supported (93)
Aug 28 12:06:02 alien bluetoothd[5980]: RFCOMM server failed for File Transfer: socket(STREAM, RFCOMM): Protocol not supported (93)
Aug 28 12:06:02 alien bluetoothd[5980]: RFCOMM server failed for Object Push: socket(STREAM, RFCOMM): Protocol not supported (93)


Code:

--- Bluetooth subsystem support
[*]   Bluetooth Classic (BR/EDR) features
<*>     RFCOMM protocol support
[*]       RFCOMM TTY support
<*>     BNEP protocol support
[*]       Multicast filter support
[*]       Protocol filter support
<*>     HIDP protocol support
[*]     Bluetooth High Speed (HS) features
[*]   Bluetooth Low Energy (LE) features
[ ]   Enable LED triggers
[ ]   Bluetooth self testing support
[*]   Export Bluetooth internals in debugfs


Hat vielleicht jemand einen Tipp wie man den fehlenden Kernel Support für bnep-protocol bekommt?
... und was die unter "network plugin" Support verstehen?

<Edit>
Muss man erst mal darauf kommen. Die obigen Fehlermeldungen verschwinden alle wenn man das als Kernel-Module macht. Der bluetoothd glaubt scheinbar wenn es kein Modul gibt kann der Kernel das nicht. Das muss halt nicht so sein da man Module auch in den Kernel integrieren kann. Was ich immer gerne mit den Modulen mache die zur jeweiligen Hardware passen. Jetzt ist halt die Frage bei was allem der noch glaubt mir fehlt das Modul obwohl es ein compiliert wurde.

Code:

<M>     RFCOMM protocol support
<M>     BNEP protocol support
<M>     HIDP protocol support

</Edit>

Irgendwie habe ich den Eindruck Bluetooth unter Linux benutzt keiner ... bin mir nicht sicher.
Back to top
View user's profile Send private message
alexander_ro
Apprentice
Apprentice


Joined: 22 Nov 2014
Posts: 182

PostPosted: Wed Aug 28, 2019 3:50 pm    Post subject: Reply with quote

Für das Paket "media-sound/pulseaudio-modules-bt-9999" wurde eine Abhängigkeit nicht mit installiert. Ohne die geht nichts was mit A2DP zu tun hat.

Code:

Das fehlte: emerge --ask media-libs/libldac


Jetzt sieht auch der Start des bluetoothd besser aus:
Code:

Aug 28 17:40:51 alien bluetoothd[6168]: Bluetooth daemon 5.50
Aug 28 17:40:51 alien bluetoothd[6168]: Starting SDP server
Aug 28 17:40:51 alien bluetoothd[6168]: Bluetooth management interface 1.14 initialized
Aug 28 17:40:51 alien pulseaudio[4382]: [pulseaudio] backend-ofono.c: Failed to register as a handsfree audio agent with ofono: org.freedesktop.DBus.Error.ServiceUnknown: The name org.ofono was not provided by any .service files
Aug 28 17:40:51 alien bluetoothd[6168]: Endpoint registered: sender=:1.33 path=/MediaEndpoint/A2DPSource/VENDOR/LDAC
Aug 28 17:40:51 alien bluetoothd[6168]: Endpoint registered: sender=:1.33 path=/MediaEndpoint/A2DPSource/VENDOR/APTXHD
Aug 28 17:40:51 alien bluetoothd[6168]: Endpoint registered: sender=:1.33 path=/MediaEndpoint/A2DPSource/VENDOR/APTX
Aug 28 17:40:51 alien bluetoothd[6168]: Endpoint registered: sender=:1.33 path=/MediaEndpoint/A2DPSource/AAC
Aug 28 17:40:51 alien bluetoothd[6168]: Endpoint registered: sender=:1.33 path=/MediaEndpoint/A2DPSource/SBC
Aug 28 17:40:51 alien bluetoothd[6168]: Endpoint registered: sender=:1.33 path=/MediaEndpoint/A2DPSink/VENDOR/APTXHD
Aug 28 17:40:51 alien bluetoothd[6168]: Endpoint registered: sender=:1.33 path=/MediaEndpoint/A2DPSink/VENDOR/APTX
Aug 28 17:40:51 alien bluetoothd[6168]: Endpoint registered: sender=:1.33 path=/MediaEndpoint/A2DPSink/AAC
Aug 28 17:40:51 alien bluetoothd[6168]: Endpoint registered: sender=:1.33 path=/MediaEndpoint/A2DPSink/SBC
Aug 28 17:41:22 alien bluetoothd[6168]: connect error: Connection refused (111)


Leider geht es immer noch nicht. In der letzten Log Zeile steht die aktuelle Fehlermeldung die jetzt kommt beim Verbinden mit dem Kopfhörer.
Ideen zur Lösung sind gerne gesehen ... :)
Back to top
View user's profile Send private message
misterjack
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1607
Location: Germany -> Saxony -> Leipzig

PostPosted: Wed Aug 28, 2019 10:55 pm    Post subject: Reply with quote

alexander_ro wrote:

Jetzt sieht auch der Start des bluetoothd besser aus:
Code:

Aug 28 17:40:51 alien pulseaudio[4382]: [pulseaudio] backend-ofono.c: Failed to register as a handsfree audio agent with ofono: org.freedesktop.DBus.Error.ServiceUnknown: The name org.ofono was not provided by any .service files


Leider geht es immer noch nicht. In der letzten Log Zeile steht die aktuelle Fehlermeldung die jetzt kommt beim Verbinden mit dem Kopfhörer.

Nicht nur in der letzten ;)

Code:
eix ofono
* net-misc/ofono
     Verfügbare Versionen:   1.16 (~)1.28 (~)1.29 {+atmodem bluetooth +cdmamodem +datafiles doc dundee examples +isimodem +phonesim +provision +qmimodem threads tools +udev upower}
     Startseite:             https://01.org/ofono
     Beschreibung:           Open Source mobile telephony (GSM/UMTS) daemon


Ist das Dingens installiert?
_________________
„Meine Meinung steht fest! Bitte verwirren Sie mich nicht mit Tatsachen.“
Back to top
View user's profile Send private message
alexander_ro
Apprentice
Apprentice


Joined: 22 Nov 2014
Posts: 182

PostPosted: Thu Aug 29, 2019 6:33 am    Post subject: Reply with quote

Ja, das Dingens ist installiert:
Code:

qlist -Iv | grep ofono
net-misc/ofono-1.16
Back to top
View user's profile Send private message
alexander_ro
Apprentice
Apprentice


Joined: 22 Nov 2014
Posts: 182

PostPosted: Tue Sep 10, 2019 2:21 pm    Post subject: Reply with quote

Jetzt habe ich noch ein USE-Flag (ofono-headset) gefunden das dazu gehören könnte. Leider verträgt sich da etwas dann nicht mehr.

Code:

emerge --ask pulseaudio

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] media-sound/pulseaudio-12.2-r2  USE="bluetooth* ofono-headset*"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-sound/pulseaudio:0

  (media-sound/pulseaudio-12.2-r2:0/0::gentoo, ebuild scheduled for merge) pulled in by
    media-sound/pulseaudio (Argument)

  (media-sound/pulseaudio-12.2-r2:0/0::gentoo, installed) pulled in by
    media-sound/pulseaudio[-bluetooth] required by (media-sound/pulseaudio-modules-bt-9999:0/0::gentoo, installed)
                           ^^^^^^^^^^                                                                                                                 


Sehe ich das richtig das das Modul von pulseaudio für bluetooth fordert das man das USE-Flag für bluetooth ausschaltet. Soll das so sein erscheint mir Merkwürdig ... das ofono für Handsfree braucht aber das USE-Flag bluetooth.
Back to top
View user's profile Send private message
misterjack
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1607
Location: Germany -> Saxony -> Leipzig

PostPosted: Tue Sep 10, 2019 2:37 pm    Post subject: Reply with quote

oder einfach media-sound/pulseaudio-modules-bt runterwerfen, dann lässt sich pulseaudio mit USE="bluetooth" emergen
_________________
„Meine Meinung steht fest! Bitte verwirren Sie mich nicht mit Tatsachen.“
Back to top
View user's profile Send private message
alexander_ro
Apprentice
Apprentice


Joined: 22 Nov 2014
Posts: 182

PostPosted: Tue Sep 10, 2019 2:39 pm    Post subject: Reply with quote

Auf jeden Fall einen Versuch wert danke ... :)
Ich dachte man braucht die beide aber vielleicht ist dem ja nicht so.

<Edit>
Hat leider so nicht funktioniert. An dem ofono USE-Flag liegt es scheinbar nicht ... :(
Code:

Sep 10 16:51:01 alien pulseaudio[4385]: [pulseaudio] backend-ofono.c: Failed to register as a handsfree audio agent with ofono: org.freedesktop.DBus.Error.ServiceUnknown: The name org.ofono was not provided by any .service files

</Edit>
Back to top
View user's profile Send private message
l3u
Advocate
Advocate


Joined: 26 Jan 2005
Posts: 2333
Location: Konradsreuth (Germany)

PostPosted: Wed Sep 11, 2019 8:36 pm    Post subject: Reply with quote

Das hier hast du schon gelesen? https://wiki.gentoo.org/wiki/Bluetooth_headset Mit der Anleitung hab ich (ohne pulesaudio, nur mit bluealsa) Soundausgabe über meinen JBL-GO+-Bluetooth-Lautsprecher hinbekommen.
Back to top
View user's profile Send private message
alexander_ro
Apprentice
Apprentice


Joined: 22 Nov 2014
Posts: 182

PostPosted: Thu Sep 12, 2019 5:49 pm    Post subject: Reply with quote

Ja das habe ich auch schon mal probiert hatte aber auch nicht funktioniert ... :(

Das größte Ärgernis ist ja nicht mal das es nicht funktioniert sondern das die Programme zwar wissen was schief läuft aber diese Information akribisch mit ins Grab nehmen ...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum