Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] After kernel update. Nvidia doesn't work anymore
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
jody
Guru
Guru


Joined: 16 Oct 2007
Posts: 511
Location: Switzerland

PostPosted: Wed Aug 14, 2019 2:45 pm    Post subject: [SOLVED] After kernel update. Nvidia doesn't work anymore Reply with quote

Hi

I have an old GPU (Quadro FX 4800) which can't use the newest nvidia drivers.
What always worked for me was to use nvidia-drivers-340.107-r1.

After installing the new kernel (linux-4.19.57-gentoo) i reinstalled the above version of nvidia-drivers, and wanted to do 'modprobe nvidia' (as described in the wiki) but there seems to be no module:
Code:
 $ sudo modprobe nvidia
modprobe: ERROR: could not insert 'nvidia': No such device


The modules for the old kernels are still around:
Code:
 locate nvidia.ko
/lib64/modules/4.14.65-gentoo/video/nvidia.ko
/lib64/modules/4.14.83-gentoo/video/nvidia.ko
/lib64/modules/4.9.95-gentoo/video/nvidia.ko
but the one for kernel 4.19.57 are missing.

How can i fix this?


Last edited by jody on Thu Aug 15, 2019 10:13 am; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22016
Location: here

PostPosted: Wed Aug 14, 2019 2:49 pm    Post subject: Reply with quote

What return uname -a?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7132
Location: Saint Amant, Acadiana

PostPosted: Wed Aug 14, 2019 2:56 pm    Post subject: Reply with quote

Did you rebuild locate database after installing drivers? Anyhow, your error is "no such device", to me it tells the module is found, but it can't find your nVidia card. Possibly because something else grabbed it. I'd look into dmesg for further clues.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
mrbassie
Guru
Guru


Joined: 31 May 2013
Posts: 547

PostPosted: Wed Aug 14, 2019 3:05 pm    Post subject: Reply with quote

Does /usr/src/linux point at the newest sources?
Back to top
View user's profile Send private message
jody
Guru
Guru


Joined: 16 Oct 2007
Posts: 511
Location: Switzerland

PostPosted: Thu Aug 15, 2019 10:13 am    Post subject: Reply with quote

Thanks for your input.
Indeed, while /usr/src/linux pointed at the correct directory, 'uname -a' showed the old 4.14 kernel as being used.

The problem was of course that i had forgotten to update grub.

So after doing
Code:
sudo grub-mkconfig -o /boot/grub/grub.cfg
and rebooting, the nvidia-drive worked and X was started.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum