Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
guayadeque compilation fails
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
peufel
n00b
n00b


Joined: 13 Aug 2019
Posts: 3

PostPosted: Tue Aug 13, 2019 11:38 am    Post subject: guayadeque compilation fails Reply with quote

Hello,

Unfortunately, I have no idea. When I try to compile
Code:
emerge -tav guayadeque


I get

Code:

/usr/lib/gcc/x86_64-pc-linux-gnu/8.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: RadioPanel.cpp:(.text+0x91c3): undefined reference
to `wxAuiManager::LoadPerspective(wxString const&, bool)'
/usr/lib/gcc/x86_64-pc-linux-gnu/8.3.0/../../../../x86_64-pc-linux-gnu/bin/ld: warning: creating a DT_TEXTREL in object
collect2: error: ld returned 1 exit status
make[2]: *** [src/CMakeFiles/guayadeque.dir/build.make:1959: src/guayadeque] Error 1
make[2]: Leaving directory '/var/tmp/portage/media-sound/guayadeque-0.4.5_p20170110/work/guayadeque-0.4.5_p20170110_build'
make[1]: *** [CMakeFiles/Makefile2:187: src/CMakeFiles/guayadeque.dir/all] Error 2
make[1]: Leaving directory '/var/tmp/portage/media-sound/guayadeque-0.4.5_p20170110/work/guayadeque-0.4.5_p20170110_build'
make: *** [Makefile:130: all] Error 2
 * ERROR: media-sound/guayadeque-0.4.5_p20170110::gentoo failed (compile phase):
 *   emake failed


I tried to rebuild wxGTK already.

Do anyone have any clue?

TIA,
peufel
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22016
Location: here

PostPosted: Tue Aug 13, 2019 12:58 pm    Post subject: Reply with quote

Welcome to gentoo forums!

For some reason CMakeList.txt is wrong, try to add this patch.
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
peufel
n00b
n00b


Joined: 13 Aug 2019
Posts: 3

PostPosted: Tue Aug 13, 2019 3:50 pm    Post subject: Reply with quote

Hi, many thanks for the patch

Before I can test it, I have to learn how to make an
overlay and build an own package, right?

So I will try this. Can you give me a little pointer?

Thanks,

peufel
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22016
Location: here

PostPosted: Tue Aug 13, 2019 4:04 pm    Post subject: Reply with quote

peufel wrote:
Before I can test it, I have to learn how to make an
overlay and build an own package, right?

No, there's no need. For apply user patch you can use /etc/portage/patches
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
peufel
n00b
n00b


Joined: 13 Aug 2019
Posts: 3

PostPosted: Tue Aug 13, 2019 6:38 pm    Post subject: Reply with quote

It works.
You make my day. Thank you very much.
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22016
Location: here

PostPosted: Tue Aug 13, 2019 6:46 pm    Post subject: Reply with quote

I submitted patch in related bug https://bugs.gentoo.org/681632
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum