Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem with nmcli and VPN
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Princess Nell
l33t
l33t


Joined: 15 Apr 2005
Posts: 785

PostPosted: Mon Jul 15, 2019 8:58 am    Post subject: Problem with nmcli and VPN Reply with quote

I have two laptops here, one of which has a fresh installation and is configured to functionally match the older machine. Both are running Mate and lightdm. Both have been configured as per https://wiki.gentoo.org/wiki/LightDM to "Unlock GNOME keyring".

On both laptops, activating a VPN connection via nm-applet works fine. On the older laptop, activating the same VPN connection with nmcli works fine, although I get this message:
Code:

(nm-vpnc-auth-dialog:7933): dbind-WARNING **: 09:28:59.817: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Connection successfully activated (D-Bus active path: /org/freedesktop/NetworkManager/ActiveConnection/8)

But on the newer setup, nmcli does not work. The message here is:
Code:

(nm-vpnc-auth-dialog:15394): dbind-WARNING **: 09:43:40.058: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Error: Connection activation failed: No valid secrets

This is the nmcli invocation:
Code:

user@host ~ $ nmcli con up VPN passwd-file /path/to/file

where the passwd file contains the vpn.secrets.Xauth password and vpn.secrets.IPSec secret.

I thought this problem might be related to the GNOME keyring, so I wiped the files under ~/.gnome2/keyrings, removed the VPN connection from NM and started from scratch, but the error persists. I even installed seahorse to take a look at the contents of the keyring and while it works, it also causes the dbind-WARNING shown above.

Any ideas what else to check?
Back to top
View user's profile Send private message
Princess Nell
l33t
l33t


Joined: 15 Apr 2005
Posts: 785

PostPosted: Thu Jul 25, 2019 11:50 am    Post subject: Reply with quote

In the Edit connections - VPN tab, Group password box, select "Store the password for all users".

I feel stupid now (but not contagious).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum