Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
rebuild of ruby-2.5.5 for some reason not working
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
Asphyxiated
n00b
n00b


Joined: 16 Nov 2011
Posts: 10
Location: Minnesota, USA

PostPosted: Tue Jun 18, 2019 9:59 pm    Post subject: rebuild of ruby-2.5.5 for some reason not working Reply with quote

here is the general stuff you ask for:

make.conf paste https://bpaste.net/show/9219aa8d9efc

emerge --info https://bpaste.net/show/8fe475680ba5 https://bpaste.net/show/1db8f1aab075

emerge -a =dev-lang/ruby-2.5.5 https://bpaste.net/show/7ce544556c5f

emerge -pqv =dev-lang/ruby-2.5.5 https://bpaste.net/show/eb75f537e103

it technically doesn't fail to compile, it just immediately fails to install and I cannot figure out why. I know that the rubytests USE flag is new but i have tried it with and without, and that goes for every single use flag available. There is only one version of ruby25 to install so I cannot try something like that.

It would be highly appreciative to know what I need to do to fix this because it is stopping me moving forward. The only thing that I can think of is that the installed version is most likely either the one that came in the stage3 tarball or it could have been generated by the gcc-8-* instead of the GCC-9.1.0 I have installed now, I highly doubt that is the problem but I can reinstall gcc-8-* if you think it might solve this issue.

Please let me know what you think.

Thanks!
_________________
Disobedience is the true foundation of liberty. The obedient must be slaves.
~ Henry David Thoreau
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21796
Location: here

PostPosted: Wed Jun 19, 2019 5:14 am    Post subject: Reply with quote

https://bugs.gentoo.org/688340
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Asphyxiated
n00b
n00b


Joined: 16 Nov 2011
Posts: 10
Location: Minnesota, USA

PostPosted: Thu Jun 20, 2019 9:17 pm    Post subject: Reply with quote

fedeliallalinea wrote:
https://bugs.gentoo.org/688340


lol yes, I started that thread, I got a workaround but the big still exists, if you have rubygems-3.0.4 installed ruby 2.5.5 will not compile, downgrade rubygems to 3.0.3 and ruby-2.5.5 installs. So the bug still exists in the rubygems-3.0.4/python-2.5.5 co-installation.
_________________
Disobedience is the true foundation of liberty. The obedient must be slaves.
~ Henry David Thoreau
Back to top
View user's profile Send private message
RayDude
Veteran
Veteran


Joined: 29 May 2004
Posts: 1507
Location: San Jose, CA

PostPosted: Mon Jul 01, 2019 3:31 pm    Post subject: Reply with quote

This is fixed with rubygems-3.0.4-r1.

If you have rubygems 3.0.4 installed you must emerge -C rubygems before trying to upgrade anything ruby related.
_________________
Some day there will only be free software.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum