Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
locale files missing, cannot be generated [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
ph0
n00b
n00b


Joined: 20 Jun 2003
Posts: 63
Location: Germany / Bayern

PostPosted: Tue May 14, 2019 7:12 am    Post subject: locale files missing, cannot be generated [solved] Reply with quote

Hi all,

I ran into an issue with my locales after performing emerge -upD @world on my desktop system. I basically want my system to run on the en_US.UTF-8 locale but also to support de_DE with UTF-8 and ISO charsets. I think my machine is falling back to the C locale right now.

What I tried so far:
- setting locale variables
- regenerate locales and env-update
- re-emerge glibc and gettext
- setting nls USE-flag and emerge -unD @world

Most programs still complain with an error when I run them:

Code:
setlocale: unsupported locale setting
setlocale: unsupported locale setting


I followed the advice given in another post and ran localedef

Code:
(reverse-i-search)`localedef': localedef -i de_DE -f ISO-8859-15 de_DE.ISO-8859-15
(reverse-i-search)`localedef': localedef -i en_US -f ISO-8859-15 en_US.ISO-8859-15
(reverse-i-search)`localedef': localedef -i en_US -f UTF-8 en_US.UTF-8
(reverse-i-search)`localedef': localedef -i de_DE -f UTF-8 de_DE.UTF-8


...which runs fine.

But locale-gen fails:

Code:
ph0-thinkpad ~ # locale-gen
 * Generating 6 locales (this might take a while) with 4 jobs
 *  (3/6) Generating de_DE.UTF-8 ...
failed to set locale!
[error] character map file `de_DE@euro' not found: No such file or directory
failed to set locale!
[error] cannot open locale definition file `UTF-8': No such file or directory     [ !! ]
 *  (2/6) Generating de_DE.ISO-8859-1 ...
failed to set locale!
[error] character map file `de_DE.UTF-8' not found: No such file or directory
failed to set locale!
[error] cannot open locale definition file `ISO-8859-1': No such file or directo  [ !! ]
 *  (4/6) Generating de_DE.ISO-8859-15@euro ...
failed to set locale!
[error] character map file `en_US' not found: No such file or directory
failed to set locale!
[error] cannot open locale definition file `ISO-8859-15': No such file or direct  [ !! ]
 *  (1/6) Generating C ...
failed to set locale!
[error] character map file `de_DE' not found: No such file or directory           [ ok ]
 * Bad entry in locale.gen: 'UTF-8 '; skipping
 *  (6/6) Generating en_US.UTF-8 ...
failed to set locale!
[error] character map file `C.UTF-8' not found: No such file or directory
failed to set locale!
[error] cannot open locale definition file `UTF-8': No such file or directory     [ !! ]
 *  (5/6) Generating en_US.ISO-8859-1 ...
failed to set locale!
[error] character map file `en_US.UTF-8' not found: No such file or directory
failed to set locale!
[error] cannot open locale definition file `ISO-8859-1': No such file or directo  [ !! ]
 * Generation complete
 * Adding locales to archive ...
incomplete set of locale files in "//usr/lib64/locale/ISO-8859-1"
incomplete set of locale files in "//usr/lib64/locale/ISO-8859-15"
incomplete set of locale files in "//usr/lib64/locale/UTF-8"                      [ !! ]


Here are the relevant config files:

Code:
ph0-thinkpad ~ # cat /etc/locale.gen | grep -v "#"

C

de_DE.UTF-8 UTF-8
de_DE ISO-8859-1
de_DE@euro ISO-8859-15
en_US.UTF-8 UTF-8
en_US ISO-8859-1


Code:

ph0-thinkpad ~ # cat /etc/env.d/02locale | grep -v "#"
LANG="en_US.utf8"
LANGUAGE="en_US"


Code:
ph0-thinkpad ~ # cat /usr/share/i18n/SUPPORTED | grep en_US
en_US.UTF-8 UTF-8
en_US ISO-8859-1

ph0-thinkpad ~ # cat /usr/share/i18n/SUPPORTED | grep de_DE
de_DE.UTF-8 UTF-8
de_DE ISO-8859-1
de_DE@euro ISO-8859-15

ph0-thinkpad ~ # ls -ll /usr/lib64/locale/
total 332
-rw-r--r-- 1 root root 408832 May 14 09:05 locale-archive


Code:
ph0-thinkpad ~ # emerge --info
setlocale: unsupported locale setting
setlocale: unsupported locale setting
Portage 2.3.62 (python 3.6.5-final-0, default/linux/amd64/17.0/desktop/plasma, gcc-8.3.0, glibc-2.28-r6, 4.19.37-gentoo x86_64)
=================================================================
System uname: Linux-4.19.37-gentoo-x86_64-Intel-R-_Core-TM-_i7-3520M_CPU_@_2.90GHz-with-gentoo-2.6
KiB Mem:    16095208 total,  13396708 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Sun, 12 May 2019 19:00:01 +0000
Head commit of repository gentoo: f22c3331b16ef435c3dc0584625ee44e0fae147b
sh bash 4.4_p23-r1
ld GNU ld (Gentoo 2.31.1 p7) 2.31.1
distcc[8652] (dcc_trace_version) distcc 3.3.2 x86_64-pc-linux-gnu; built May  8 2019 01:32:49 [disabled]
ccache version 3.6 [enabled]
app-shells/bash:          4.4_p23-r1::gentoo
dev-lang/perl:            5.26.2::gentoo
dev-lang/python:          2.7.15::gentoo, 3.4.5-r1::gentoo, 3.5.5::gentoo, 3.6.5::gentoo
dev-util/ccache:          3.6::gentoo
dev-util/cmake:           3.9.6::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/openrc:          0.41.2::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.14.1::gentoo, 1.15.1-r2::gentoo, 1.16.1-r1::gentoo
sys-devel/binutils:       2.31.1-r6::gentoo
sys-devel/gcc:            6.4.0-r1::gentoo, 8.2.0-r6::gentoo, 8.3.0-r1::gentoo
sys-devel/gcc-config:     2.0::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 4.14-r1::gentoo (virtual/os-headers)
sys-libs/glibc:           2.28-r6::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-jobs: 1
    sync-rsync-extra-opts:
    sync-rsync-verify-metamanifest: no

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=sandybridge -O3 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=sandybridge -O3 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--quiet-build=y"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.halifax.rwth-aachen.de/gentoo/ http://ftp.uni-erlangen.de/pub/mirrors/gentoo"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de en"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi activities alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam flac fortran gdbm gif glamor gpm gtk iconv ipv6 jpeg kde kipi kwallet lcms ldap libnotify libtirpc mad mng mp3 mp4 mpeg mtp multilib ncurses networkmanager nls nptl ogg opengl openmp opus pam pango pcre pdf phonon plasma png policykit ppds pulseaudio qml qt5 readline samba sdl seccomp semantic-desktop spell ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis widgets wxwidgets x264 x265 xattr xcb xcomposite xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" L10N="de en" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" NETBEANS_MODULES="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-1" POSTGRES_TARGETS="postgres9_5 postgres10" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" RUBY_TARGETS="ruby24" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Any ideas, anyone? Why am I missing the files?


Last edited by ph0 on Wed May 15, 2019 6:31 pm; edited 1 time in total
Back to top
View user's profile Send private message
mike155
Veteran
Veteran


Joined: 17 Sep 2010
Posts: 1059
Location: Frankfurt, Germany

PostPosted: Tue May 14, 2019 5:06 pm    Post subject: Reply with quote

Let's start with the 'locale-gen' error messages:
Code:
failed to set locale!
[error] character map file `de_DE@euro' not found: No such file or directory

You get this message, because locale-gen can't open the file'/usr/share/i18n/locales/de_DE@euro'.
  1. Please show us the output of
    Code:
    ls -la /usr/share/i18n/locales/de_DE@euro

  2. Re-emerge glibc
    Code:
    emerge --oneshot glibc

  3. Does '/usr/share/i18n/locales/de_DE@euro' exist now?
    Code:
    ls -la /usr/share/i18n/locales/de_DE@euro

  4. If it exists: please run 'locale-gen' and show us the output:
    Code:
    locale-gen

  5. If it does not exist: please show us the output of
    Code:
    emerge -pv sys-libs/glibc

EDIT: BTW: I just saw that you use:
Code:
CFLAGS="-march=sandybridge -O3 -pipe"

I don't know if your CFLAGS are related to the problem you reported, but the Gentoo Wiki writes:
Quote:
... Compiling with -O3 is not a guaranteed way to improve performance, and in fact, in many cases, can slow down a system due to larger binaries and increased memory usage. -O3 is also known to break several packages. Using -O3 is not recommended. ...
Back to top
View user's profile Send private message
ph0
n00b
n00b


Joined: 20 Jun 2003
Posts: 63
Location: Germany / Bayern

PostPosted: Wed May 15, 2019 4:12 pm    Post subject: Reply with quote

mike155 wrote:
Let's start with the 'locale-gen' error messages:
Code:
failed to set locale!
[error] character map file `de_DE@euro' not found: No such file or directory

You get this message, because locale-gen can't open the file'/usr/share/i18n/locales/de_DE@euro'.
  1. Please show us the output of
    Code:
    ls -la /usr/share/i18n/locales/de_DE@euro



All the files in i18n/locales exist:

Code:
ph0-thinkpad ~ # ls -la /usr/share/i18n/locales/de_DE@euro
-rw-r--r-- 1 root root 1730 May 10 19:09 /usr/share/i18n/locales/de_DE@euro


mike155 wrote:

  • Re-emerge glibc
    Code:
    emerge --oneshot glibc

  • Does '/usr/share/i18n/locales/de_DE@euro' exist now?



  • Already did re-emerge glibc and some other packages as mentioned, but just to be sure, once more with -O2:

    Code:

    ph0-thinkpad ~ # emerge glibc
    setlocale: unsupported locale setting
    setlocale: unsupported locale setting

     * IMPORTANT: 1 news items need reading for repository 'gentoo'.
     * Use eselect news read to view new items.

    Calculating dependencies... done!
    >>> Verifying ebuild manifests
    >>> Running pre-merge checks for sys-libs/glibc-2.28-r6
     * Checking general environment sanity.
    make -j4 -s glibc-test
     * Checking that IA32 emulation is enabled in the running kernel ...             [ ok ]
     * Checking gcc for __thread support ...                                         [ ok ]
     * Checking running kernel version (4.19.37-gentoo >= 3.2.0) ...                 [ ok ]
     * Checking linux-headers version (4.14.0 >= 3.2.0) ...                          [ ok ]
    >>> Emerging (1 of 1) sys-libs/glibc-2.28-r6::gentoo
    >>> Installing (1 of 1) sys-libs/glibc-2.28-r6::gentoo
    >>> Jobs: 1 of 1 complete                           Load avg: 3.34, 4.38, 3.51

     * Messages for package sys-libs/glibc-2.28-r6:

     * Applying Gentoo Glibc Patchset 2.28-9
    >>> Auto-cleaning packages...

    >>> No outdated packages were found on your system.

     * GNU info directory index is up-to-date.

     * IMPORTANT: 1 news items need reading for repository 'gentoo'.
     * Use eselect news read to view new items.

    ph0-thinkpad ~ # ls -la /usr/share/i18n/locales/de_DE@euro
    -rw-r--r-- 1 root root 1730 May 15 18:06 /usr/share/i18n/locales/de_DE@euro


    The file still exists.

    mike155 wrote:

    Code:
    ls -la /usr/share/i18n/locales/de_DE@euro

  • If it exists: please run 'locale-gen' and show us the output:
    Code:
    locale-gen

  • If it does not exist: please show us the output of
    Code:
    emerge -pv sys-libs/glibc



  • Still no luck:

    Code:

    ph0-thinkpad ~ # locale-gen
     * Generating 6 locales (this might take a while) with 4 jobs
     *  (3/6) Generating de_DE.UTF-8 ...
    failed to set locale!
    [error] character map file `de_DE@euro' not found: No such file or directory
    failed to set locale!
    [error] cannot open locale definition file `UTF-8': No such file or directory     [ !! ]
     *  (4/6) Generating de_DE.ISO-8859-15@euro ...
    failed to set locale!
    [error] character map file `en_US' not found: No such file or directory
    failed to set locale!
    [error] cannot open locale definition file `ISO-8859-15': No such file or direct  [ !! ]
     *  (2/6) Generating de_DE.ISO-8859-1 ...
    failed to set locale!
    [error] character map file `de_DE.UTF-8' not found: No such file or directory
    failed to set locale!
    [error] cannot open locale definition file `ISO-8859-1': No such file or directo  [ !! ]
     *  (1/6) Generating C ...
    failed to set locale!
    [error] character map file `de_DE' not found: No such file or directory           [ ok ]
     * Bad entry in locale.gen: 'UTF-8 '; skipping
     *  (6/6) Generating en_US.UTF-8 ...
    failed to set locale!
    [error] character map file `C.UTF-8' not found: No such file or directory
    failed to set locale!
    [error] cannot open locale definition file `UTF-8': No such file or directory     [ !! ]
     *  (5/6) Generating en_US.ISO-8859-1 ...
    failed to set locale!
    [error] character map file `en_US.UTF-8' not found: No such file or directory
    failed to set locale!
    [error] cannot open locale definition file `ISO-8859-1': No such file or directo  [ !! ]
     * Generation complete
     * Adding locales to archive ...
    incomplete set of locale files in "//usr/lib64/locale/ISO-8859-1"
    incomplete set of locale files in "//usr/lib64/locale/ISO-8859-15"
    incomplete set of locale files in "//usr/lib64/locale/UTF-8"                      [ !! ]


    ph0-thinkpad ~ # emerge -pv sys-libs/glibc
    setlocale: unsupported locale setting
    setlocale: unsupported locale setting

    These are the packages that would be merged, in order:

    Calculating dependencies... done!
    [ebuild   R    ] sys-libs/glibc-2.28-r6:2.2::gentoo  USE="multiarch (multilib) ssp -audit -caps (-cet) (-compile-locales) -doc -gd -headers-only -nscd -profile (-selinux) -suid -systemtap -test (-vanilla)" 0 KiB

    Total: 1 package (1 reinstall), Size of downloads: 0 KiB

     * IMPORTANT: 1 news items need reading for repository 'gentoo'.
     * Use eselect news read to view new items.




    Quote:

    EDIT: BTW: I just saw that you use:
    Code:
    CFLAGS="-march=sandybridge -O3 -pipe"

    I don't know if your CFLAGS are related to the problem you reported, but the Gentoo Wiki writes:


    Thanks for letting me know. This is a pretty old installation and I never had any issues related to compiling. However I changed it to -O2 anyways just to be safe.
    Back to top
    View user's profile Send private message
    mike155
    Veteran
    Veteran


    Joined: 17 Sep 2010
    Posts: 1059
    Location: Frankfurt, Germany

    PostPosted: Wed May 15, 2019 5:11 pm    Post subject: Reply with quote

    So the files are there, but locale-gen can't find them....

    Please run
    Code:
    localedef --help

    and post the paths at the end of the output. Below is the end of the output on my machine:
    Code:
    System's directory for character maps : /usr/share/i18n/charmaps
                           repertoire maps: /usr/share/i18n/repertoiremaps
                           locale path    : /usr/lib64/locale:/usr/share/i18n

    Side note: locale-gen uses 'locale path' to search for locale files (line 161 in /usr/sbin/locale-gen).
    Back to top
    View user's profile Send private message
    ph0
    n00b
    n00b


    Joined: 20 Jun 2003
    Posts: 63
    Location: Germany / Bayern

    PostPosted: Wed May 15, 2019 5:31 pm    Post subject: Reply with quote

    Mine is exactly the same as yours as far as I can tell:

    Code:

    System's directory for character maps : /usr/share/i18n/charmaps
                           repertoire maps: /usr/share/i18n/repertoiremaps
                           locale path    : /usr/lib64/locale:/usr/share/i18n


    Another thing, here's the output of `strace locale-gen 2>&1 | grep "stat("` (only the last couple of lines):

    Code:

    stat("/usr/share/i18n/locales/C", {st_mode=S_IFREG|0644, st_size=7356, ...}) = 0
    stat("/usr/share/i18n/locales/ISO-8859-1", 0x7ffd4dc39820) = -1 ENOENT (No such file or directory)
    stat("/usr/share/i18n/locales/UTF-8", 0x7ffd4dc39820) = -1 ENOENT (No such file or directory)
    stat("/usr/share/i18n/locales/ISO-8859-15", 0x7ffd4dc39820) = -1 ENOENT (No such file or directory)
    stat("/usr/share/i18n/locales/ISO-8859-1", 0x7ffd4dc39820) = -1 ENOENT (No such file or directory)
    stat("/usr/share/i18n/locales/UTF-8", 0x7ffd4dc39820) = -1 ENOENT (No such file or directory)
    fstat(3, {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
    stat("//usr/lib64/locale/ISO-8859-1", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
    stat("//usr/lib64/locale/C", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
    stat("//usr/lib64/locale/ISO-8859-15", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
    stat("//usr/lib64/locale/UTF-8", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
    stat("/dev/null", {st_mode=S_IFCHR|0666, st_rdev=makedev(1, 3), ...}) = 0


    It doesn't even try to access the en_US or de_DE files? Instead it tries to access some charmap files which are not there...
    Back to top
    View user's profile Send private message
    mike155
    Veteran
    Veteran


    Joined: 17 Sep 2010
    Posts: 1059
    Location: Frankfurt, Germany

    PostPosted: Wed May 15, 2019 5:46 pm    Post subject: Reply with quote

    Below is the output on my machine:
    Code:
    stat("/usr/share/i18n/locales/de_DE", {st_mode=S_IFREG|0644, st_size=4401, ...}) = 0
    stat("/usr/share/i18n/locales/de_DE.UTF-8", 0x7ffd008ea0c0) = -1 ENOENT (No such file or directory)
    stat("/usr/share/i18n/locales/de_DE@euro", {st_mode=S_IFREG|0644, st_size=1730, ...}) = 0
    stat("/usr/share/i18n/locales/en_US", {st_mode=S_IFREG|0644, st_size=3467, ...}) = 0
    stat("/usr/share/i18n/locales/en_US.UTF-8", 0x7ffd008ea0c0) = -1 ENOENT (No such file or directory)
    stat("/usr/share/i18n/locales/C.UTF-8", 0x7ffd008ea0c0) = -1 ENOENT (No such file or directory)
    fstat(3, {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
    stat("//usr/lib64/locale/C.utf8", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
    stat("//usr/lib64/locale/de_DE.utf8", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
    stat("//usr/lib64/locale/de_DE", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
    stat("//usr/lib64/locale/en_US", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
    stat("//usr/lib64/locale/de_DE@euro", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0
    stat("//usr/lib64/locale/en_US.utf8", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0

    See the difference? 'de_DE', 'en_US' is missing in the filenames on your machine...
    Back to top
    View user's profile Send private message
    mike155
    Veteran
    Veteran


    Joined: 17 Sep 2010
    Posts: 1059
    Location: Frankfurt, Germany

    PostPosted: Wed May 15, 2019 5:50 pm    Post subject: Reply with quote

    I can reproduce the error messages you reported if I add the line below to /etc/locale.gen:
    Code:
    C

    Remove that line from your file /etc/locale.gen and run 'locale-gen'.
    Back to top
    View user's profile Send private message
    ph0
    n00b
    n00b


    Joined: 20 Jun 2003
    Posts: 63
    Location: Germany / Bayern

    PostPosted: Wed May 15, 2019 6:30 pm    Post subject: Reply with quote

    Nice! :) Now it works. Thank you!
    Back to top
    View user's profile Send private message
    Display posts from previous:   
    Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
    Page 1 of 1

     
    Jump to:  
    You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot vote in polls in this forum