Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
SOLVED: cyrus-sasl 2.1.27-r2 depending on berkdb-6.x?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Guybrush
Tux's lil' helper
Tux's lil' helper


Joined: 06 Feb 2003
Posts: 99
Location: 48°27'N, 11°8'O

PostPosted: Tue May 14, 2019 6:40 pm    Post subject: SOLVED: cyrus-sasl 2.1.27-r2 depending on berkdb-6.x? Reply with quote

When trying to update @world wiht emerge -uDNav @world
I'm getting:

Code:
The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by dev-libs/cyrus-sasl-2.1.27-r2::gentoo[berkdb]
# required by kde-apps/kdepim-runtime-18.12.3-r1::gentoo
# required by kde-apps/kaddressbook-18.12.3-r1::gentoo
# required by kde-apps/kdepim-meta-18.12.3::gentoo
# required by @selected
# required by @world (argument)
=sys-libs/db-6.0.35-r1 ~amd64


sys-libs/db-5.3.x is installed and in the ebuild of cyrus-sasl a version of berkdb >= 4.8.30-r1 is required. So I don't understand why emerge wants me to keyword sys-libs/db-6.x


Last edited by Guybrush on Wed May 15, 2019 6:20 pm; edited 1 time in total
Back to top
View user's profile Send private message
mike155
Veteran
Veteran


Joined: 17 Sep 2010
Posts: 1059
Location: Frankfurt, Germany

PostPosted: Tue May 14, 2019 7:09 pm    Post subject: Reply with quote

It's probably NOT 'dev-libs/cyrus-sasl-2.1.27-r2' that requires 'sys-libs/db-6.0.35-r1'.

Please show us the output of:
Code:
equery d sys-libs/db
and of
Code:
emerge --info


Last edited by mike155 on Tue May 14, 2019 7:15 pm; edited 1 time in total
Back to top
View user's profile Send private message
Guybrush
Tux's lil' helper
Tux's lil' helper


Joined: 06 Feb 2003
Posts: 99
Location: 48°27'N, 11°8'O

PostPosted: Tue May 14, 2019 7:15 pm    Post subject: Reply with quote

Output of equery d sys-libs/db:
Code:
 * These packages depend on sys-libs/db:
dev-lang/perl-5.26.2 (berkdb ? sys-libs/db)
dev-lang/python-2.7.15 (berkdb ? sys-libs/db:5.3)
                       (berkdb ? sys-libs/db:5.1)
                       (berkdb ? sys-libs/db:4.8)
                       (berkdb ? sys-libs/db:4.7)
                       (berkdb ? sys-libs/db:4.6)
                       (berkdb ? sys-libs/db:4.5)
                       (berkdb ? sys-libs/db:4.4)
                       (berkdb ? sys-libs/db:4.3)
                       (berkdb ? sys-libs/db:4.2)
dev-lang/ruby-2.4.5 (berkdb ? sys-libs/db)
dev-libs/apr-util-1.6.1-r3 (berkdb ? >=sys-libs/db-4)
dev-libs/cyrus-sasl-2.1.27-r2 (berkdb ? >=sys-libs/db-4.8.30-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
dev-libs/libical-3.0.4 (berkdb ? sys-libs/db)
dev-libs/redland-1.0.17-r2 (berkdb ? sys-libs/db)
dev-python/bsddb3-6.2.4 (<sys-libs/db-6.3)
                        (sys-libs/db:6.2)
                        (sys-libs/db:6.1)
                        (sys-libs/db:5.3)
                        (sys-libs/db:5.1)
                        (sys-libs/db:4.8)
                        (sys-libs/db:4.7)
dev-vcs/subversion-1.10.4 (berkdb ? >=sys-libs/db-4.0.14)
net-nds/openldap-2.4.45 (berkdb ? <sys-libs/db-6.0)
                        (berkdb ? sys-libs/db:5.3)
                        (berkdb ? sys-libs/db:5.1)
                        (berkdb ? sys-libs/db:4.8)
                        (berkdb ? sys-libs/db:4.7)
                        (berkdb ? sys-libs/db:4.6)
                        (berkdb ? sys-libs/db:4.5)
                        (berkdb ? sys-libs/db:4.4)
sys-apps/iproute2-4.17.0-r1 (berkdb ? sys-libs/db)
sys-libs/pam-1.3.0-r2 (berkdb ? >=sys-libs/db-4.8.30-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3793
Location: Dallas area

PostPosted: Tue May 14, 2019 7:37 pm    Post subject: Reply with quote

what does equery u cyrus-sasl return?
_________________
Asus m5a99fx, FX 8320 - nouveau & radeon, oss4
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
5.0.13 zen kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
Guybrush
Tux's lil' helper
Tux's lil' helper


Joined: 06 Feb 2003
Posts: 99
Location: 48°27'N, 11°8'O

PostPosted: Tue May 14, 2019 7:41 pm    Post subject: Reply with quote

equery u cyrus-sasl output:
Code:
[ Legend : U - final flag setting for installation]
[        : I - package is installed with flag     ]
[ Colors : set, unset                             ]
 * Found these USE flags for dev-libs/cyrus-sasl-2.1.27-r2:
 U I
 + + abi_x86_32  : 32-bit (x86) libraries
 - - authdaemond : Add Courier-IMAP authdaemond unix socket support (net-mail/courier-imap, mail-mta/courier)
 + + berkdb      : Add support for sys-libs/db (Berkeley DB for MySQL)
 + + gdbm        : Add support for sys-libs/gdbm (GNU database libraries)
 + + java        : Add support for Java
 - - kerberos    : Add kerberos support
 - - ldapdb      : Enable ldapdb plugin
 - - libressl    : Use dev-libs/libressl instead of dev-libs/openssl when applicable (see also the ssl useflag)
 + + mysql       : Add mySQL Database support
 - - openldap    : Add ldap support for saslauthd
 + + pam         : Add support for PAM (Pluggable Authentication Modules) - DANGEROUS to arbitrarily flip
 - - postgres    : Add support for the postgresql database
 - - sample      : Enable sample client and server
 + + sqlite      : Add support for sqlite - embedded sql database
 - - srp         : Enable SRP authentication
 + + ssl         : Add support for SSL/TLS connections (Secure Socket Layer / Transport Layer Security)
 - - static-libs : Build static versions of dynamic libraries as well
 - - urandom     : Use /dev/urandom instead of /dev/random
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3793
Location: Dallas area

PostPosted: Tue May 14, 2019 7:47 pm    Post subject: Reply with quote

I don't see any reason for it not working with the db that you have.

what does emerge -pvuDUt @world return

and as above mike asked for "emerge --info"
_________________
Asus m5a99fx, FX 8320 - nouveau & radeon, oss4
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
5.0.13 zen kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 21551
Location: here

PostPosted: Wed May 15, 2019 5:57 am    Post subject: Reply with quote

You also can try to manually fix problem with
Code:
# emerge -1 =dev-libs/cyrus-sasl-2.1.27-r2 sys-libs/db:5.3

_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Guybrush
Tux's lil' helper
Tux's lil' helper


Joined: 06 Feb 2003
Posts: 99
Location: 48°27'N, 11°8'O

PostPosted: Wed May 15, 2019 4:25 pm    Post subject: Reply with quote

emerge --info output:
Code:
Portage 2.3.62 (python 3.6.5-final-0, default/linux/amd64/17.0/desktop/plasma/systemd, gcc-8.2.0, glibc-2.29-r2, 4.19.27-gentoo-r1 x86_64)
=================================================================
System uname: Linux-4.19.27-gentoo-r1-x86_64-Intel-R-_Core-TM-_i5-3570_CPU_@_3.40GHz-with-gentoo-2.6
KiB Mem:    16394296 total,   7310804 free
KiB Swap:   32001476 total,  32001476 free
Timestamp of repository gentoo: Tue, 14 May 2019 16:30:01 +0000
Head commit of repository gentoo: 165055e5c1363bced17eae2f10e792c58e2fb26a
sh bash 4.4_p23-r1
ld GNU ld (Gentoo 2.31.1 p7) 2.31.1
ccache version 3.6 [enabled]
app-shells/bash:          4.4_p23-r1::gentoo
dev-java/java-config:     2.2.0-r4::gentoo
dev-lang/perl:            5.26.2::gentoo
dev-lang/python:          2.7.15::gentoo, 3.6.5::gentoo
dev-util/ccache:          3.6::gentoo
dev-util/cmake:           3.9.6::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.6-r1::gentoo
sys-apps/sandbox:         2.13::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r4::gentoo
sys-devel/automake:       1.11.6-r3::gentoo, 1.13.4-r2::gentoo, 1.15.1-r2::gentoo, 1.16.1-r1::gentoo
sys-devel/binutils:       2.31.1-r6::gentoo
sys-devel/gcc:            8.2.0-r6::gentoo, 8.3.0-r1::gentoo
sys-devel/gcc-config:     2.0::gentoo
sys-devel/libtool:        2.4.6-r3::gentoo
sys-devel/make:           4.2.1-r4::gentoo
sys-kernel/linux-headers: 4.14-r1::gentoo (virtual/os-headers)
sys-libs/glibc:           2.29-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-jobs: 1
    sync-rsync-extra-opts:
    sync-rsync-verify-metamanifest: yes

my-repo
    location: /usr/portage/local
    masters: gentoo
    priority: 0

Installed sets: @steam
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA AdobeFlash-11.x Oracle-BCLA-JavaSE PUEL FraunhoferFDK"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
ENV_UNSET="DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="rsync://mirror.netcologne.de/gentoo/ http://mirror.netcologne.de/gentoo/ ftp://mirror.netcologne.de/gentoo/ http://ftp.uni-erlangen.de/pub/mirrors/gentoo ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo"
LANG="de_DE.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac accessibility acl acpi activities alsa amd64 autoipd berkdb bluetooth branding bzip2 cairo cdda cddb cdr chipcard cli client crypt css cups cupsddk cxx dbus declarative designer dhcp-tools dri dts dvb dvd dvdr eap egl embedded emboss encode exif extensions extraengine extras faac fam fax fdk ffmpeg flac fortran frei0r gd gdbm gflags gif gimp glamor google gpm gtk hbci iconv icu ipv6 ithreads java jpeg kde kdepim kipi kwallet lcms ldap libkms libnotify libtirpc lirc lm_sensors mad mdnsresponder-compat melt minizip mmx mmxext mng mp3 mp4 mpeg mtp multilib mysql ncurses networkmanager nls nptl nsplugin ogg openexr opengl openmp openssl pam pango pcre pcre16 pdf phonon pkcs11 plasma png policykit ppds printsupport pulseaudio pvr python qml qt5 rdesktop readline samba scanner script sdl seccomp semantic-desktop slp smartcard snmp soprano spell spice sql sqlite sse sse2 ssl ssse3 startup-notification suid svc svg systemd taglib tcpd templates theora threads tiff truetype udev udisks unicode upnp upower usb user-session v4l vaapi vorbis vpx webkit widgets winbind wxwidgets x264 xattr xcb xcomposite xml xscreensaver xv xvid zeroconf zlib" ABI_X86="32 64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64 pc" INPUT_DEVICES="libinput keyboard mouse" KERNEL="linux" L10N="de" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" NETBEANS_MODULES="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-1" POSTGRES_TARGETS="postgres9_5 postgres10" PYTHON_SINGLE_TARGET="python3_6" PYTHON_TARGETS="python2_7 python3_6" RUBY_TARGETS="ruby24" USERLAND="GNU" VIDEO_CARDS="radeon radeonsi amdgpu" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


and the output of emerge -pvuDUt @world:

Code:
These are the packages that would be merged, in reverse order:
Calculating dependencies... done!
[nomerge       ] media-gfx/gimp-2.10.8-r1:2::gentoo  USE="alsa mng openexr python udev -aalib (-altivec) (-aqua) -debug -doc -gnome -heif -jpeg2k -postscript -test -unwind -vector-icons -webp -wmf -xpm" CPU_FLAGS_X86="mmx sse" PYTHON_TARGETS="python2_7"
[ebuild     U  ]  dev-libs/appstream-glib-0.7.15:0/8::gentoo [0.7.9:0/8::gentoo] USE="introspection -fonts% -gtk-doc% -stemmer (-doc%)" 2.188 KiB
[nomerge       ] kde-apps/kde-meta-18.12.3:5::gentoo
[nomerge       ]  kde-apps/kde-apps-meta-18.12.3:5::gentoo  USE="accessibility -pim -sdk"
[nomerge       ]   kde-apps/kdecore-meta-18.12.3:5::gentoo  USE="handbook webengine webkit"
[ebuild     U  ]    www-client/falkon-3.1.0-r1::gentoo [3.1.0::gentoo] USE="X dbus kde -debug -libressl -test" 0 KiB
[nomerge       ] kde-apps/kde-apps-meta-18.12.3:5::gentoo  USE="accessibility -pim -sdk"
[nomerge       ]  kde-apps/kdenetwork-meta-18.12.3:5::gentoo  USE="telepathy -dropbox"
[nomerge       ]   kde-apps/plasma-telepathy-meta-18.12.3:5::gentoo  USE="-gstreamer"
[nomerge       ]    kde-apps/ktp-accounts-kcm-18.12.3:5::gentoo  USE="-debug -experimental"
[nomerge       ]     net-im/telepathy-connection-managers-2-r2::gentoo  USE="irc xmpp zeroconf -gadu -icq -meanwhile -msn -sip -sipe -steam -yahoo"
[nomerge       ]      net-voip/telepathy-gabble-0.18.4-r1::gentoo  USE="jingle -gnutls -libressl -plugins -test"
[ebuild     U  ]       net-libs/libnice-0.1.15::gentoo [0.1.13::gentoo] USE="gnutls%* introspection upnp -libressl%" ABI_X86="32 (64) (-x32)" 1.040 KiB
[nomerge       ] media-sound/clementine-1.3.1_p20190127::gentoo  USE="cdda dbus mtp pulseaudio udisks -box -debug -dropbox -googledrive -ipod -lastfm -mms -moodbar -projectm -seafile -skydrive -test -wiimote"
[ebuild     U  ]  gnome-base/gvfs-1.38.2::gentoo [1.32.2::gentoo] USE="cdda http mtp (policykit) samba systemd udev udisks zeroconf -afp -archive -bluray (-elogind) -fuse -gnome-keyring -gnome-online-accounts -google -gphoto2 -ios -nfs -test (-gtk%*)" 1.175 KiB
[nomerge       ] www-client/falkon-3.1.0-r1::gentoo [3.1.0::gentoo] USE="X dbus kde -debug -libressl -test"
[ebuild  N     ]  kde-frameworks/purpose-5.54.0:5/5.54::gentoo  USE="kaccounts -debug -test" 140 KiB
[nomerge       ] dev-python/libgnome-python-2.28.1-r1:2::gentoo  USE="-examples" PYTHON_TARGETS="python2_7"
[nomerge       ]  gnome-base/libgnome-2.32.1-r1::gentoo  USE="branding -debug"
[nomerge       ]   gnome-base/gvfs-1.38.2::gentoo [1.32.2::gentoo] USE="cdda http mtp (policykit) samba systemd udev udisks zeroconf -afp -archive -bluray (-elogind) -fuse -gnome-keyring -gnome-online-accounts -google -gphoto2 -ios -nfs -test (-gtk%*)"
[nomerge       ]    net-libs/libsoup-2.64.2:2.4::gentoo [2.58.2:2.4::gentoo] USE="introspection samba ssl vala* -debug -gssapi -test" ABI_X86="32 (64) (-x32)"
[nomerge       ]     net-libs/glib-networking-2.58.0::gentoo  USE="gnome libproxy ssl -test" ABI_X86="32 (64) (-x32)"
[nomerge       ]      net-libs/libproxy-0.4.13-r2::gentoo  USE="kde networkmanager python webkit -gnome -mono -perl -spidermonkey -test" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7"
[nomerge       ]       net-libs/webkit-gtk-2.24.1:4/37::gentoo  USE="X egl geolocation gstreamer introspection libnotify nsplugin opengl spell webgl (-aqua) -coverage -doc -gles2 -gnome-keyring -jpeg2k -test -wayland"
[ebuild     U  ]        app-misc/geoclue-2.4.13:2.0::gentoo [2.4.8:2.0::gentoo] USE="introspection zeroconf -modemmanager*" 107 KiB
[ebuild     U  ]         net-libs/libsoup-2.64.2:2.4::gentoo [2.58.2:2.4::gentoo] USE="introspection samba ssl vala* -debug -gssapi -test" ABI_X86="32 (64) (-x32)" 1.752 KiB
[nomerge       ] net-mail/imapsync-1.882::gentoo  USE="-test"
[ebuild     U  ]  virtual/perl-Digest-1.170.100_rc-r8::gentoo [1.170.100_rc-r7::gentoo] 0 KiB
[nomerge       ] net-mail/imapsync-1.882::gentoo  USE="-test"
[nomerge       ]  dev-perl/PAR-1.15.0::gentoo  USE="-test"
[ebuild     U  ]   virtual/perl-AutoLoader-5.740.0-r7::gentoo [5.740.0-r6::gentoo] 0 KiB
[nomerge       ] media-sound/pavucontrol-4.0::gentoo  USE="nls"
[ebuild     U  ]  dev-cpp/gtkmm-3.24.1:3.0::gentoo [3.24.0:3.0::gentoo] USE="X (-aqua) -doc -test -wayland" ABI_X86="32 (64) (-x32)" 12.191 KiB
[nomerge       ] media-tv/kodi-17.6-r11::gentoo  USE="alsa bluetooth css dbus dvd java lcms lirc mysql opengl pulseaudio samba (system-ffmpeg) systemd udev udisks upnp upower vaapi xslt zeroconf -airplay -bluray -caps -cec -debug -gles -libressl -libusb (-mariadb) -nfs -nonfree -sftp -test -vdpau -webserver" PYTHON_TARGETS="python2_7"
[ebuild  NS    ]  sys-fs/udisks-1.0.5-r3:0::gentoo [2.8.1:2::gentoo] USE="lvm* nls -debug -remote-access% (-selinux) (-acl%*) (-elogind%) (-introspection%*) (-systemd%*) (-vdo%)" 0 KiB
[nomerge       ] media-sound/audacity-2.2.2::gentoo  USE="alsa ffmpeg flac ladspa lame lv2 mad midi nls portmixer soundtouch vorbis vst -doc -id3tag -jack -libav -sbsms -twolame -vamp" CPU_FLAGS_X86="sse"
[nomerge       ]  media-libs/lv2-1.14.0-r1::gentoo  USE="-doc -plugins" ABI_X86="32 (64) (-x32)" PYTHON_SINGLE_TARGET="python3_6 -python2_7 -python3_5" PYTHON_TARGETS="python2_7 python3_6 -python3_5"
[nomerge       ]   dev-python/rdflib-4.2.2::gentoo  USE="berkdb mysql sqlite -doc -examples -redland -test" PYTHON_TARGETS="python2_7 python3_6 -python3_5"
[ebuild f    U  ]    dev-python/pyparsing-2.3.1::gentoo [2.2.0::gentoo] USE="-examples (-doc%)" PYTHON_TARGETS="python2_7 python3_6 (-pypy) (-pypy3) -python3_5 (-python3_7)" 605 KiB
[nomerge       ] kde-apps/kde-apps-meta-18.12.3:5::gentoo  USE="accessibility -pim -sdk"
[nomerge       ]  kde-apps/kdegraphics-meta-18.12.3:5::gentoo  USE="scanner"
[nomerge       ]   kde-apps/kamera-18.12.3:5::gentoo  USE="handbook -debug"
[ebuild     U  ]    media-libs/libgphoto2-2.5.22:0/6::gentoo [2.5.20:0/6::gentoo] USE="exif gd jpeg nls -doc -examples -serial" ABI_X86="32 (64) (-x32)" CAMERAS="adc65 agfa_cl20 aox ax203 barbie canon casio_qv clicksmart310 digigr8 digita dimagev dimera3500 directory enigma13 fuji gsmart300 hp215 iclick jamcam jd11 jl2005a jl2005c kodak_dc120 kodak_dc210 kodak_dc240 kodak_dc3200 kodak_ez200 konica konica_qm150 largan lg_gsm mars mustek panasonic_coolshot panasonic_dc1000 panasonic_dc1580 panasonic_l859 pccam300 pccam600 pentax polaroid_pdc320 polaroid_pdc640 polaroid_pdc700 ptp2 ricoh ricoh_g3 samsung sierra sipix_blink2 sipix_web2 smal sonix sony_dscf1 sony_dscf55 soundvision spca50x sq905 st2205 stv0674 stv0680 sx330z topfield toshiba_pdrm11 tp6801" 7.002 KiB
[nomerge       ] kde-apps/kdegraphics-meta-18.12.3:5::gentoo  USE="scanner"
[nomerge       ]  kde-apps/spectacle-18.12.3:5::gentoo  USE="handbook kipi -debug -share"
[ebuild     U  ]   media-plugins/kipi-plugins-5.9.1:5::gentoo [5.9.0:5::gentoo] USE="remotestorage -debug -flashexport (-mediawiki) -test (-vkontakte)" 1.434 KiB
[nomerge       ] app-portage/mirrorselect-2.2.3::gentoo  PYTHON_TARGETS="python2_7 python3_6 -python3_5"
[nomerge       ]  dev-python/ssl-fetch-0.4::gentoo  PYTHON_TARGETS="python2_7 python3_6 (-pypy) -python3_5 (-python3_7)"
[ebuild     U  ]   dev-python/pyopenssl-19.0.0::gentoo [17.5.0::gentoo] USE="-doc -examples -test" PYTHON_TARGETS="python2_7 python3_6 (-pypy) (-pypy3) -python3_5 (-python3_7)" 165 KiB
[nomerge       ] kde-apps/kdepim-meta-18.12.3:5::gentoo  USE="-bogofilter -clamav -spamassassin"
[ebuild     U  ]  kde-apps/akonadi-calendar-18.12.3-r2:5::gentoo [18.12.3-r1:5::gentoo] USE="-debug -test" 0 KiB
[ebuild     UD ] sys-boot/grub-2.02-r3:2/2.02-r3::gentoo [2.04_rc1:2/2.04_rc1::gentoo] USE="fonts mount nls sdl themes truetype -debug -device-mapper -doc -efiemu -libzfs -multislot% -static (-test)" GRUB_PLATFORMS="efi-64 pc -coreboot -efi-32 -emu -ieee1275 -loongson -multiboot -qemu -qemu-mips -uboot -xen -xen-32" 0 KiB
[ebuild     U  ] www-client/firefox-bin-66.0.5::gentoo [66.0.3::gentoo] USE="ffmpeg pulseaudio startup-notification (-selinux)" L10N="de -ach -af -an -ar -as -ast -az -bg -bn-BD -bn-IN -br -bs -ca -cs -cy -da -el -en-GB -en-ZA -eo -es-AR -es-CL -es-ES -es-MX -et -eu -fa -fi -fr -fy -ga -gd -gl -gu -he -hi -hr -hsb -hu -hy -id -is -it -ja -kk -km -kn -ko -lt -lv -mai -mk -ml -mr -ms -nb -nl -nn -or -pa -pl -pt-BR -pt-PT -rm -ro -ru -si -sk -sl -son -sq -sr -sv -ta -te -th -tr -uk -uz -vi -xh -zh-CN -zh-TW" 61.130 KiB
[ebuild     U ~] net-misc/teamviewer-14.2.8352:14::gentoo [14.2.2558:14::gentoo] 11.720 KiB
[ebuild  NS    ] sys-kernel/gentoo-sources-4.19.37:4.19.37::gentoo [4.19.27-r1:4.19.27-r1::gentoo] USE="-build -experimental -symlink" 1.132 KiB
[ebuild     U  ] sys-block/gparted-0.33.0::gentoo [0.29.0::gentoo] USE="kde (policykit) -btrfs -cryptsetup -dmraid -f2fs -fat -hfs -jfs -mdadm -ntfs -reiser4 -reiserfs -udf -wayland% -xfs" 3.826 KiB
[ebuild     U  ] www-plugins/adobe-flash-32.0.0.192:22::gentoo [32.0.0.171:22::gentoo] USE="nsplugin ppapi" ABI_X86="32 64 (-x32)" 34.812 KiB
[ebuild     U  ] sys-apps/usbutils-010-r1::gentoo [009::gentoo] USE="python" PYTHON_SINGLE_TARGET="python3_6%* -python3_5% (-python3_7)" PYTHON_TARGETS="python3_6%* -python3_5% (-python3_7) (-python2_7%*)" 302 KiB
[ebuild     U ~] net-misc/youtube-dl-2019.05.11::gentoo [2019.04.30::gentoo] PYTHON_TARGETS="python2_7 python3_6 -python3_5 -python3_7" 3.093 KiB
[ebuild     U  ] net-misc/dhcpcd-7.1.1-r3::gentoo [7.1.1-r2::gentoo] USE="embedded ipv6 udev" 0 KiB
[ebuild     U  ] www-client/google-chrome-74.0.3729.131::gentoo [74.0.3729.108-r1::gentoo] L10N="de -am -ar -bg -bn -ca -cs -da -el -en-GB -es -es-419 -et -fa -fi -fil -fr -gu -he -hi -hr -hu -id -it -ja -kn -ko -lt -lv -ml -mr -ms -nb -nl -pl -pt-BR -pt-PT -ro -ru -sk -sl -sr -sv -sw -ta -te -th -tr -uk -vi -zh-CN -zh-TW" 57.164 KiB
[ebuild     U  ] sys-apps/man-pages-5.00::gentoo [4.16::gentoo] USE="nls" L10N="de -da -fr -it -ja -nl -pl -ru -zh-CN" 1.621 KiB
[ebuild     U  ]  app-i18n/man-pages-de-2.12::gentoo [1.15::gentoo] 10.003 KiB
[nomerge       ] net-libs/webkit-gtk-2.24.1:4/37::gentoo  USE="X egl geolocation gstreamer introspection libnotify nsplugin opengl spell webgl (-aqua) -coverage -doc -gles2 -gnome-keyring -jpeg2k -test -wayland"
[nomerge       ]  media-libs/woff2-1.0.2-r1::gentoo
[ebuild     U  ]   app-arch/brotli-1.0.7:0/1::gentoo [1.0.6-r1:0/1::gentoo] USE="python -test" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7 python3_6 (-pypy) -python3_5 (-python3_7)" 23.270 KiB
[nomerge       ] net-libs/webkit-gtk-2.24.1:4/37::gentoo  USE="X egl geolocation gstreamer introspection libnotify nsplugin opengl spell webgl (-aqua) -coverage -doc -gles2 -gnome-keyring -jpeg2k -test -wayland"
[nomerge       ]  net-libs/libsoup-2.64.2:2.4::gentoo [2.58.2:2.4::gentoo] USE="introspection samba ssl vala* -debug -gssapi -test" ABI_X86="32 (64) (-x32)"
[ebuild  N     ]   net-libs/libpsl-0.21.0::gentoo  USE="icu idn man" ABI_X86="32 (64) (-x32)" 9.002 KiB
[nomerge       ] kde-apps/kdepim-meta-18.12.3:5::gentoo  USE="-bogofilter -clamav -spamassassin"
[nomerge       ]  kde-apps/libksieve-18.12.3:5::gentoo  USE="handbook -debug -test"
[nomerge       ]   dev-libs/cyrus-sasl-2.1.27-r2:2::gentoo  USE="berkdb gdbm java mysql pam sqlite ssl -authdaemond -kerberos -ldapdb -libressl -openldap -postgres -sample (-selinux) -srp -static-libs -urandom" ABI_X86="32 (64) (-x32)"
[ebuild  NS   ~]    sys-libs/db-6.0.35-r1:6.0::gentoo [5.3.28-r2:5.3::gentoo] USE="cxx java -doc -examples -tcl -test" ABI_X86="32 (64) (-x32)" 35.677 KiB
[nomerge       ] kde-plasma/plasma-meta-5.14.5:5::gentoo  USE="bluetooth browser-integration crypt display-manager gtk handbook legacy-systray networkmanager pam pm-utils pulseaudio sddm systemd wallpapers (-consolekit) (-elogind) -grub -plymouth -sdk"
[nomerge       ]  kde-plasma/plasma-pa-5.14.5:5::gentoo  USE="handbook -debug"
[nomerge       ]   kde-frameworks/plasma-5.54.0:5/5.54::gentoo  USE="X -debug -doc (-gles2) -test -wayland"
[nomerge       ]    kde-frameworks/knotifications-5.54.0:5/5.54::gentoo  USE="X dbus nls phonon -debug -doc -speech"
[nomerge       ]     media-libs/phonon-4.10.2::gentoo  USE="designer pulseaudio vlc -debug -gstreamer"
[nomerge       ]      dev-qt/designer-5.11.3:5/5.11::gentoo  USE="declarative webkit -debug -test"
[nomerge       ]       dev-qt/qtwebkit-5.212.0_pre20180120:5/5.212::gentoo  USE="X gstreamer hyphen jit nsplugin opengl printsupport qml -geolocation (-gles2) -multimedia -orientation -webp"
[nomerge       ]        media-libs/gst-plugins-base-1.14.4-r1:1.0::gentoo  USE="X alsa egl introspection nls ogg opengl orc pango theora vorbis -gbm -gles2 -ivorbis -wayland" ABI_X86="32 (64) (-x32)"
[ebuild     U  ]         media-libs/graphene-1.8.6::gentoo [1.8.2::gentoo] USE="introspection -doc -test" ABI_X86="32 (64) (-x32)" CPU_FLAGS_X86="sse2" 125 KiB
[nomerge       ] media-sound/pulseaudio-12.2-r1::gentoo  USE="X alsa alsa-plugin asyncns bluetooth caps dbus gdbm glib gtk ipv6 lirc orc qt5 ssl systemd tcpd udev webrtc-aec zeroconf -doc (-elogind) -equalizer -gconf -jack -libressl -libsamplerate -native-headset (-neon) -ofono-headset (-oss) -realtime (-selinux) -sox (-system-wide) -test" ABI_X86="32 (64) (-x32)"
[nomerge       ]  app-misc/lirc-0.10.1::gentoo  USE="X devinput gtk systemd uinput usb -audio -doc -ftdi -inputlirc -static-libs" PYTHON_SINGLE_TARGET="python3_6 -python3_5 (-python3_7)" PYTHON_TARGETS="python3_6 -python3_5 (-python3_7)"
[ebuild     U  ]   x11-libs/vte-0.54.4:2.91::gentoo [0.48.4:2.91::gentoo] USE="crypt introspection -debug -glade -vala -vanilla" 1.066 KiB
[nomerge       ] media-gfx/inkscape-0.92.3-r1::gentoo  USE="cdr dbus exif jpeg lcms nls openmp spell -dia -gnome -imagemagick -inkjar -latex -postscript -static-libs -visio -wpg" PYTHON_TARGETS="python2_7"
[nomerge       ]  dev-cpp/gtkmm-2.24.5:2.4::gentoo  USE="-doc -examples -test" ABI_X86="32 (64) (-x32)"
[ebuild     U  ]   dev-cpp/atkmm-2.28.0::gentoo [2.24.2::gentoo] USE="-doc" ABI_X86="32 (64) (-x32)" 871 KiB
[nomerge       ] media-sound/pulseaudio-12.2-r1::gentoo  USE="X alsa alsa-plugin asyncns bluetooth caps dbus gdbm glib gtk ipv6 lirc orc qt5 ssl systemd tcpd udev webrtc-aec zeroconf -doc (-elogind) -equalizer -gconf -jack -libressl -libsamplerate -native-headset (-neon) -ofono-headset (-oss) -realtime (-selinux) -sox (-system-wide) -test" ABI_X86="32 (64) (-x32)"
[nomerge       ]  media-plugins/alsa-plugins-1.1.8::gentoo  USE="ffmpeg mix pulseaudio usb_stream -arcam_av -debug -jack -libav -libsamplerate -oss -speex" ABI_X86="32 (64) (-x32)"
[nomerge       ]   media-video/ffmpeg-3.4.5:0/55.57.57::gentoo  USE="X alsa bzip2 encode fdk frei0r gpl hardcoded-tables iconv mp3 network opengl openssl postproc pulseaudio samba sdl svg theora threads truetype v4l vaapi vorbis vpx x264 xcb xvid zlib (-altivec) -amr -amrenc (-appkit) -bluray -bs2b -cdio -chromaprint -chromium -cpudetection -debug -doc -flite -fontconfig -fribidi -gcrypt -gme -gmp -gnutls -gsm -iec61883 -ieee1394 -jack -jpeg2k -kvazaar -ladspa -libass -libcaca -libdrm -libilbc -librtmp -libsoxr -libv4l -lzma (-mipsdspr1) (-mipsdspr2) (-mipsfpu) (-mmal) -modplug -nvenc -openal -opencl -openh264 -opus -oss -pic -rubberband -snappy -speex -ssh -static-libs -test -twolame -vdpau -wavpack -webp -x265 -zeromq -zimg -zvbi" ABI_X86="32 (64) (-x32)" CPU_FLAGS_X86="aes avx mmx mmxext sse sse2 sse3 sse4_1 sse4_2 ssse3 -3dnow -3dnowext -avx2 -fma3 -fma4 -xop" FFTOOLS="aviocat cws2fws ffescape ffeval ffhash fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart sidxindex trasher"
[nomerge       ]    net-fs/samba-4.8.6-r2::gentoo  USE="acl client cups fam ldap pam python system-mitkrb5 systemd winbind zeroconf -addc -addns -ads -ceph -cluster -debug (-dmapi) -gnutls -gpg -iprint -quota (-selinux) -syslog (-system-heimdal) -test" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7"
[ebuild     U  ]     dev-util/cmocka-1.1.5::gentoo [1.1.3::gentoo] USE="-doc -examples -static-libs -test" ABI_X86="32 (64) (-x32)" 80 KiB
[nomerge       ] media-gfx/inkscape-0.92.3-r1::gentoo  USE="cdr dbus exif jpeg lcms nls openmp spell -dia -gnome -imagemagick -inkjar -latex -postscript -static-libs -visio -wpg" PYTHON_TARGETS="python2_7"
[ebuild     U  ]  dev-cpp/glibmm-2.58.1:2::gentoo [2.56.1:2::gentoo] USE="-debug -doc -test" ABI_X86="32 (64) (-x32)" 6.620 KiB
[nomerge       ] app-portage/layman-2.4.2-r1::gentoo  USE="git sqlite -bazaar -cvs -darcs (-g-sorcery) -gpg -mercurial -squashfs -subversion -sync-plugin-portage -test" PYTHON_TARGETS="python2_7 python3_6 (-pypy) -python3_5"
[nomerge       ]  dev-python/ssl-fetch-0.4::gentoo  PYTHON_TARGETS="python2_7 python3_6 (-pypy) -python3_5 (-python3_7)"
[nomerge       ]   dev-python/ndg-httpsclient-0.4.0::gentoo  PYTHON_TARGETS="python2_7 python3_6 (-pypy) (-pypy3) -python3_5"
[nomerge       ]    dev-python/pyopenssl-19.0.0::gentoo [17.5.0::gentoo] USE="-doc -examples -test" PYTHON_TARGETS="python2_7 python3_6 (-pypy) (-pypy3) -python3_5 (-python3_7)"
[ebuild     U  ]     dev-python/cryptography-2.6.1::gentoo [2.2.2-r1::gentoo] USE="-idna% -libressl -test" PYTHON_TARGETS="python2_7 python3_6 (-pypy) (-pypy3) -python3_5 (-python3_7)" 481 KiB
[ebuild     U  ]      dev-python/six-1.12.0::gentoo [1.11.0::gentoo] USE="-doc -test" PYTHON_TARGETS="python2_7 python3_6 (-pypy) (-pypy3) -python3_5 (-python3_7)" 32 KiB
[nomerge       ] net-vpn/networkmanager-strongswan-1.4.4-r1::gentoo  USE="glib"
[nomerge       ]  gnome-extra/nm-applet-1.8.20::gentoo  USE="gcr introspection modemmanager (-ayatana) (-selinux) -teamd"
[ebuild     U  ]   net-misc/mobile-broadband-provider-info-20190116::gentoo [20170310::gentoo] USE="-test" 84 KiB
[ebuild     U  ] sys-kernel/linux-firmware-20190502::gentoo [20190409::gentoo] USE="-savedconfig" 180.787 KiB

Total: 40 packages (34 upgrades, 1 downgrade, 2 new, 3 in new slots), Size of downloads: 470.681 KiB

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

sys-fs/lvm2:0

  (sys-fs/lvm2-2.02.183:0/0::gentoo, ebuild scheduled for merge) conflicts with
    <sys-fs/lvm2-2.02.183 required by (sys-fs/udisks-1.0.5-r3:0/0::gentoo, ebuild scheduled for merge)
    ^            ^^^^^^^^


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by dev-libs/cyrus-sasl-2.1.27-r2::gentoo
# required by kde-apps/kdepim-runtime-18.12.3-r1::gentoo
# required by kde-apps/kaddressbook-18.12.3-r1::gentoo
# required by kde-apps/kdepim-meta-18.12.3::gentoo
# required by @selected
# required by @world (argument)
=sys-libs/db-6.0.35-r1 ~amd64

 * In order to avoid wasting time, backtracking has terminated early
 * due to the above autounmask change(s). The --autounmask-backtrack=y
 * option can be used to force further backtracking, but there is no
 * guarantee that it will produce a solution.
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3793
Location: Dallas area

PostPosted: Wed May 15, 2019 5:05 pm    Post subject: Reply with quote

add
Code:
EMERGE_DEFAULT_OPTS="--autounmask=n"

to make .conf and run emerge -pvuDU @world again

because I'm not seeing anything forcing db to run ~.
_________________
Asus m5a99fx, FX 8320 - nouveau & radeon, oss4
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
5.0.13 zen kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
Guybrush
Tux's lil' helper
Tux's lil' helper


Joined: 06 Feb 2003
Posts: 99
Location: 48°27'N, 11°8'O

PostPosted: Wed May 15, 2019 6:19 pm    Post subject: SOLVED: cyrus-sasl 2.1.27-r2 depending on berkdb-6.x? Reply with quote

This seems to fix the problem. Thanks a lot!!! :D

But I don't understand why?!?
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 3793
Location: Dallas area

PostPosted: Wed May 15, 2019 6:31 pm    Post subject: Re: SOLVED: cyrus-sasl 2.1.27-r2 depending on berkdb-6.x? Reply with quote

Guybrush wrote:
This seems to fix the problem. Thanks a lot!!! :D

But I don't understand why?!?


I'm not 100% sure, but I think it has to do with the ordering of db (high to low, instead of low to high) in various packages, along with the autounmask feature being a little stupid.

I don't normally like to run with autounmask on, because it seems to introduce more problems than it's supposed to solve.
_________________
Asus m5a99fx, FX 8320 - nouveau & radeon, oss4
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
5.0.13 zen kernel, profile 17.0 (no-pie) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
Guybrush
Tux's lil' helper
Tux's lil' helper


Joined: 06 Feb 2003
Posts: 99
Location: 48°27'N, 11°8'O

PostPosted: Wed May 15, 2019 8:00 pm    Post subject: Reply with quote

Found the problem:

I had db:6 installed (don't know why anymore) some time ago, and libical depended on libdb-6.so (because libdb.so was a link to libdb-6.so). So this seems to be the reaswon why emerge tried to reinstall sys-libs/db:6. Just removed the link of libdb.so to libdb-6.so and reinstalled sys-libs/db and libical after that.
Now everything just works as expected again.

After all, a layer 8 problem in the OSI model ;-)

Thank you all so very much for your instant support.

GENTOO (and especially it's user base) RULES!!!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum