Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Dantrell's GNOME Without Systemd Project (Part 3)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Spargeltarzan
Apprentice
Apprentice


Joined: 23 Jul 2017
Posts: 289

PostPosted: Wed May 15, 2019 7:49 am    Post subject: Reply with quote

Hello Dantrell,

Scribus fails to emerge, does it have something to do with poppler-85? Latest version available is 0.76.1.

Code:

!!! existing preserved libs:
>>> package: app-text/poppler-0.76.1
 *  - /usr/lib64/libpoppler.so.85
 *  - /usr/lib64/libpoppler.so.85.0.0
 *      used by /usr/lib64/scribus/plugins/libimportpdf.so (app-office/scribus-1.5.5_pre20190124)


Code:

ninja: build stopped: subcommand failed.
 * ERROR: app-office/scribus-1.5.5_pre20190124::gentoo failed (compile phase):
 *   ninja -v -j8 -l0 failed
 *
 * Call stack:
 *     ebuild.sh, line  124:  Called src_compile
 *   environment, line 3945:  Called cmake-utils_src_compile
 *   environment, line  972:  Called cmake-utils_src_make
 *   environment, line 1153:  Called _cmake_ninja_src_make
 *   environment, line  475:  Called eninja
 *   environment, line 1483:  Called die
 * The specific snippet of code:
 *       "$@" || die "${nonfatal_args[@]}" "${*} failed"

_________________
___________________
Regards

Spargeltarzan

Notebook: Lenovo YOGA 900-13ISK: Gentoo stable amd64, GNOME systemd, KVM/QEMU
Desktop-PC: Intel Core i7-4770K, 8GB Ram, AMD Radeon R9 280X, ZFS Storage, GNOME openrc, Dantrell, Xen
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 549
Location: Earth

PostPosted: Wed May 15, 2019 8:25 am    Post subject: Reply with quote

So I have been hard at work on another project lately but things have been relatively stable. My quiet roll-out of GNOME 3.32.2 was successful and there's only one update from my initial announcement:
  • Nautilus can thumbnail in a sandbox but the previous behaviour is still used. I initially said that it's probably time to default to the new behaviour but I forgot to rollout this change. ¯\_(ツ)_/¯
That said, besides whatever upstream broke between GNOME 3.30 and 3.32, there's 4 reported-yet-possibly-still-unresolved issues related to:
  • Suspend
  • WiFi
  • Laptop brightness
  • / mounted read-only
All 4 of these issues are things I can't reproduce and for the first 3, I'm still waiting to hear back from the users who reported them. The last one has already been determined to be related to OpenRC <0.41 but I didn't manage to pinpoint the responsible commit. I still consider this issue to be unresolved for the time being since I haven't backported the fix yet (I'll probably end up stabilizing a recent version instead).

Elleni wrote:
You certainly still appreciate the day, I joined your overlay and started testing

Like it was yesterday. :)

Elleni wrote:
But I am not able to find the correct way to launch gnome. Do you know what would be needed to launch it via vnc remote session?

I don't think GNOME has worked out-of-the-box with VNC (or Xephyr for that matter) for years.

You probably need to either disable the acceleration check and/or use the GNOME Flashback (formerly known as GNOME Fallback) session. So try:

Code:
gnome-session --disable-acceleration-check

or:
Code:
emerge --ask --oneshot gnome-base/gnome-flashback
gnome-session --session=gnome-flashback-metacity --disable-acceleration-check

Good luck. :twisted:

Spargeltarzan wrote:
Scribus fails to emerge, does it have something to do with poppler-85? Latest version available is 0.76.1.

You didn't link the full build log but I'm going guess you are running stable.

The project overlays allow ~ versions of app-text/poppler through for GNOME 3.30 and 3.32 but app-office/scribus-1.5.5_pre20190124 won't build against it (probably). Try the latest version instead:

Code:
ACCEPT_KEYWORDS="~*" emerge --ask --oneshot =app-office/scribus-1.5.5_pre20190429

_________________
Dantrell B.
Back to top
View user's profile Send private message
saboya
Guru
Guru


Joined: 28 Nov 2006
Posts: 439
Location: Brazil

PostPosted: Fri May 17, 2019 11:15 pm    Post subject: Reply with quote

Finally upgrading to 3.32, bumped into a wrong dep on gnome-extra/gnome-calculator-3.32

Code:
meson.build:29:0: ERROR:  Dependency "gtksourceview-4" not found, tried pkgconfig and cmake
Back to top
View user's profile Send private message
saboya
Guru
Guru


Joined: 28 Nov 2006
Posts: 439
Location: Brazil

PostPosted: Sat May 18, 2019 12:05 am    Post subject: Reply with quote

Except for the gnome-calculator dependency issue, everything went smoothly.

I hit a nasty issue with what I believe was an extension incompatibility that was locking me in the spotlight / search mode. After reviewing my extensions, everything seems fine. Might be placebo but feels snappier than 3.30.

As always, appreciate your effort into making this possible!
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 549
Location: Earth

PostPosted: Sat May 18, 2019 2:39 am    Post subject: Reply with quote

saboya wrote:
Finally upgrading to 3.32, bumped into a wrong dep on gnome-extra/gnome-calculator-3.32

Thanks for the heads up. I checked the source and updated the dependencies accordingly.

saboya wrote:
Might be placebo but feels snappier than 3.30.

GNOME 3.32 definitely came with real performance improvements. :)
_________________
Dantrell B.
Back to top
View user's profile Send private message
jlpoole
Guru
Guru


Joined: 01 Nov 2005
Posts: 344
Location: Salem, OR

PostPosted: Tue May 21, 2019 3:54 am    Post subject: gnome-base/gnome-settings-daemon-3.24.4-r2 fails to build Reply with quote

gnome-base/gnome-settings-daemon-3.24.4-r2 fails to build. I just went into auto-report as bug and created Bug #686396 and then was disabused that of the notion that the Gentoo Bug database is the wrong place to stage the problem. Since the information is there, I think it imprudent to repeat here and hope that someone might take a look at the bug and suggest a solution or work-around.
Back to top
View user's profile Send private message
dantrell
Guru
Guru


Joined: 01 Jun 2007
Posts: 549
Location: Earth

PostPosted: Tue May 21, 2019 6:19 am    Post subject: Reply with quote

jlpoole wrote:
Since the information is there, I think it imprudent to repeat here and hope that someone might take a look at the bug and suggest a solution or work-around.

Your build.log and environment attachments are exactly the same but no matter.

Sync up and you should be good to go.
_________________
Dantrell B.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4, 5
Page 5 of 5

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum