Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem with msfconsole
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Fulgurance
l33t
l33t


Joined: 15 Feb 2017
Posts: 703

PostPosted: Mon May 06, 2019 2:09 pm    Post subject: Problem with msfconsole Reply with quote

Hello, today i would like to test something with metasploit, but when i launch msfconsole on my console, i have this error:

Code:
 fulgurance@msi-gs73vr-6rf   ~  msfconsole                                 ✔  623  16:07:38 
/usr/lib64/ruby/gems/2.4.0/gems/backports-3.14.0/lib/backports/std_lib.rb:9:in `require': cannot load such file -- faraday (LoadError)
        from /usr/lib64/ruby/gems/2.4.0/gems/backports-3.14.0/lib/backports/std_lib.rb:9:in `require_with_backports'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:274:in `block in require'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:240:in `load_dependency'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:274:in `require'
        from /usr/lib64/ruby/gems/2.4.0/gems/sawyer-0.8.2/lib/sawyer/agent.rb:1:in `<top (required)>'
        from /usr/lib64/ruby/gems/2.4.0/gems/backports-3.14.0/lib/backports/std_lib.rb:9:in `require'
        from /usr/lib64/ruby/gems/2.4.0/gems/backports-3.14.0/lib/backports/std_lib.rb:9:in `require_with_backports'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:274:in `block in require'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:240:in `load_dependency'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:274:in `require'
        from /usr/lib64/ruby/gems/2.4.0/gems/sawyer-0.8.2/lib/sawyer.rb:17:in `block in <top (required)>'
        from /usr/lib64/ruby/gems/2.4.0/gems/sawyer-0.8.2/lib/sawyer.rb:17:in `each'
        from /usr/lib64/ruby/gems/2.4.0/gems/sawyer-0.8.2/lib/sawyer.rb:17:in `<top (required)>'
        from /usr/lib64/ruby/gems/2.4.0/gems/backports-3.14.0/lib/backports/std_lib.rb:9:in `require'
        from /usr/lib64/ruby/gems/2.4.0/gems/backports-3.14.0/lib/backports/std_lib.rb:9:in `require_with_backports'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:274:in `block in require'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:240:in `load_dependency'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:274:in `require'
        from /usr/lib64/ruby/gems/2.4.0/gems/octokit-4.14.0/lib/octokit/connection.rb:1:in `<top (required)>'
        from /usr/lib64/ruby/gems/2.4.0/gems/backports-3.14.0/lib/backports/std_lib.rb:9:in `require'
        from /usr/lib64/ruby/gems/2.4.0/gems/backports-3.14.0/lib/backports/std_lib.rb:9:in `require_with_backports'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:274:in `block in require'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:240:in `load_dependency'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:274:in `require'
        from /usr/lib64/ruby/gems/2.4.0/gems/octokit-4.14.0/lib/octokit/client.rb:1:in `<top (required)>'
        from /usr/lib64/ruby/gems/2.4.0/gems/backports-3.14.0/lib/backports/std_lib.rb:9:in `require'
        from /usr/lib64/ruby/gems/2.4.0/gems/backports-3.14.0/lib/backports/std_lib.rb:9:in `require_with_backports'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:274:in `block in require'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:240:in `load_dependency'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:274:in `require'
        from /usr/lib64/ruby/gems/2.4.0/gems/octokit-4.14.0/lib/octokit.rb:1:in `<top (required)>'
        from /usr/lib64/ruby/gems/2.4.0/gems/backports-3.14.0/lib/backports/std_lib.rb:9:in `require'
        from /usr/lib64/ruby/gems/2.4.0/gems/backports-3.14.0/lib/backports/std_lib.rb:9:in `require_with_backports'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:274:in `block in require'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:240:in `load_dependency'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:274:in `require'
        from /usr/lib64/metasploit4.17/lib/msf/util/document_generator/pull_request_finder.rb:1:in `<top (required)>'
        from /usr/lib64/ruby/gems/2.4.0/gems/backports-3.14.0/lib/backports/std_lib.rb:9:in `require'
        from /usr/lib64/ruby/gems/2.4.0/gems/backports-3.14.0/lib/backports/std_lib.rb:9:in `require_with_backports'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:274:in `block in require'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:240:in `load_dependency'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:274:in `require'
        from /usr/lib64/metasploit4.17/lib/msf/util/document_generator.rb:7:in `<top (required)>'
        from /usr/lib64/ruby/gems/2.4.0/gems/backports-3.14.0/lib/backports/std_lib.rb:9:in `require'
        from /usr/lib64/ruby/gems/2.4.0/gems/backports-3.14.0/lib/backports/std_lib.rb:9:in `require_with_backports'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:274:in `block in require'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:240:in `load_dependency'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:274:in `require'
        from /usr/lib64/metasploit4.17/lib/msf/ui/console/command_dispatcher/core.rb:23:in `<top (required)>'
        from /usr/lib64/ruby/gems/2.4.0/gems/backports-3.14.0/lib/backports/std_lib.rb:9:in `require'
        from /usr/lib64/ruby/gems/2.4.0/gems/backports-3.14.0/lib/backports/std_lib.rb:9:in `require_with_backports'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:274:in `block in require'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:240:in `load_dependency'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:274:in `require'
        from /usr/lib64/metasploit4.17/lib/msf/ui/console/command_dispatcher.rb:117:in `<top (required)>'
        from /usr/lib64/ruby/gems/2.4.0/gems/backports-3.14.0/lib/backports/std_lib.rb:9:in `require'
        from /usr/lib64/ruby/gems/2.4.0/gems/backports-3.14.0/lib/backports/std_lib.rb:9:in `require_with_backports'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:274:in `block in require'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:240:in `load_dependency'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:274:in `require'
        from /usr/lib64/metasploit4.17/lib/msf/ui/console/driver.rb:6:in `<top (required)>'
        from /usr/lib64/ruby/gems/2.4.0/gems/backports-3.14.0/lib/backports/std_lib.rb:9:in `require'
        from /usr/lib64/ruby/gems/2.4.0/gems/backports-3.14.0/lib/backports/std_lib.rb:9:in `require_with_backports'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:274:in `block in require'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:240:in `load_dependency'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:274:in `require'
        from /usr/lib64/metasploit4.17/lib/msf/ui/console.rb:11:in `<top (required)>'
        from /usr/lib64/ruby/gems/2.4.0/gems/backports-3.14.0/lib/backports/std_lib.rb:9:in `require'
        from /usr/lib64/ruby/gems/2.4.0/gems/backports-3.14.0/lib/backports/std_lib.rb:9:in `require_with_backports'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:274:in `block in require'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:240:in `load_dependency'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:274:in `require'
        from /usr/lib64/metasploit4.17/lib/msf/ui.rb:11:in `<top (required)>'
        from /usr/lib64/ruby/gems/2.4.0/gems/backports-3.14.0/lib/backports/std_lib.rb:9:in `require'
        from /usr/lib64/ruby/gems/2.4.0/gems/backports-3.14.0/lib/backports/std_lib.rb:9:in `require_with_backports'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:274:in `block in require'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:240:in `load_dependency'
        from /usr/lib64/ruby/gems/2.4.0/gems/activesupport-4.2.11.1/lib/active_support/dependencies.rb:274:in `require'
        from /usr/lib64/metasploit4.17/lib/metasploit/framework/command/console.rb:60:in `driver'
        from /usr/lib64/metasploit4.17/lib/metasploit/framework/command/console.rb:48:in `start'
        from /usr/lib64/metasploit4.17/lib/metasploit/framework/command/base.rb:82:in `start'
        from /usr/lib/metasploit/msfconsole:49:in `<main>'
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24022
Location: here

PostPosted: Mon May 06, 2019 2:25 pm    Post subject: Reply with quote

Try to install dev-ruby/faraday package
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Fulgurance
l33t
l33t


Joined: 15 Feb 2017
Posts: 703

PostPosted: Mon May 06, 2019 2:58 pm    Post subject: Reply with quote

Already installed ...
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24022
Location: here

PostPosted: Mon May 06, 2019 3:18 pm    Post subject: Reply with quote

You can provide emerge -pv dev-ruby/faraday output?
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
Fulgurance
l33t
l33t


Joined: 15 Feb 2017
Posts: 703

PostPosted: Mon May 06, 2019 6:26 pm    Post subject: Reply with quote

Code:
 fulgurance@msi-gs73vr-6rf   ~  sudo emerge -pv faraday                                   ✔  629  20:24:18 
Mot de passe : 

These are the packages that would be merged, in order:

Calculating dependencies                   ... done!     
[ebuild   R    ] dev-ruby/faraday-0.15.4::gentoo  USE="-test" RUBY_TARGETS="ruby24 (-ruby23) -ruby25 -ruby26%" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 24022
Location: here

PostPosted: Mon May 06, 2019 6:44 pm    Post subject: Reply with quote

Try to open a new bug
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
wfdawson
n00b
n00b


Joined: 05 Aug 2010
Posts: 17

PostPosted: Sun May 12, 2019 1:58 pm    Post subject: Reply with quote

I am also seeing this issue. Is a bug opened already?
Back to top
View user's profile Send private message
yigitemres
n00b
n00b


Joined: 17 Jul 2019
Posts: 2

PostPosted: Mon Jul 22, 2019 2:23 am    Post subject: Reply with quote

Adding "spec.add_runtime_dependency 'faraday'" into $MSF_ROOT/metasploit-framework.gemspec file fixes the problem. Funny thing is that this line is not exist in git repos of metasploit-framework.

Edit:

Rick Farina commit fix after 2 days of my post. (dbf6c0ffeaea1819b30e9b2e9dce34a4beb558cf)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum