Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Застрял на обновлении. Круговая зависимость. eapi 7
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
evganis
n00b
n00b


Joined: 22 Dec 2018
Posts: 2
Location: Челябинск

PostPosted: Sat Dec 22, 2018 5:16 am    Post subject: Застрял на обновлении. Круговая зависимость. eapi 7 Reply with quote

Добрый день, прошу помощи.
Некоторое время не обновлял сервак. Теперь не могу ничего обновить, требует обновить eselect-pinentry, тот в свою очередь не может обновиться так как masked by EAPI 7, Надо обновить portage. Его не могу обновить, т.к. он требует pinentry.
Есть способ разомкнуть этот круг?

Заранее благодарен

Quote:
evganis@gentoo ~ $ sudo emerge -vuDN eselect-pinentry
Password:

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy "eselect-pinentry" have been masked.
!!! One of the following masked packages is required to complete your request:
- app-eselect/eselect-pinentry-0.7::gentoo (masked by: EAPI 7)

The current version of portage supports EAPI '6'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Quote:
evganis@gentoo ~ $ sudo emerge -vuDN portage

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy "app-eselect/eselect-pinentry" have been masked.
!!! One of the following masked packages is required to complete your request:
- app-eselect/eselect-pinentry-0.7::gentoo (masked by: EAPI 7)

The current version of portage supports EAPI '6'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
(dependency required by "app-crypt/pinentry-1.1.0-r2::gentoo" [ebuild])
(dependency required by "app-crypt/gnupg-2.2.10::gentoo" [ebuild])
(dependency required by "sys-apps/portage-2.3.51-r1::gentoo[rsync-verify,-build]" [ebuild])
(dependency required by "portage" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
TigerJr
Guru
Guru


Joined: 19 Jun 2007
Posts: 487
Location: /dev/x0

PostPosted: Mon Dec 24, 2018 6:39 am    Post subject: Reply with quote

Думаю нужно откатить порты назад командой
Quote:
emerge-webrsync --revert YYYYMMDD


а вообще я сталкивался с подобной проблемой, это решение прокатит если новых пакетов неустанавливалось.

А если будешь дальше устанавливать пакеты из портов - застрянешь до полной переустановки системы(т.е. система будет работать но обновить или установить новый пакет у тебя не выйдет)

Я бы не рекомендовал обновлять порты на серверах, только критические обновления ставить, предварительно протестировать на мышах, кошках и собаках
_________________

Do not update portage without hotdog!

Xenogentooway?
Back to top
View user's profile Send private message
mvm
n00b
n00b


Joined: 05 May 2004
Posts: 16

PostPosted: Thu May 02, 2019 1:16 pm    Post subject: Reply with quote

Code:
$ emerge --sync
$ emerge -1 python
$ USE='-rsync-verify' emerge -1 portage
$ emerge -1 portage
Back to top
View user's profile Send private message
evganis
n00b
n00b


Joined: 22 Dec 2018
Posts: 2
Location: Челябинск

PostPosted: Thu May 16, 2019 11:55 am    Post subject: Reply with quote

mvm wrote:
Code:
$ emerge --sync
$ emerge -1 python
$ USE='-rsync-verify' emerge -1 portage
$ emerge -1 portage


Спасибо тебе друг огромное! Сработало на ура. Вопрос решен.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum