Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Plasma + Wine - Desktop icons for windows apps not working?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
duby2291
Guru
Guru


Joined: 17 Oct 2004
Posts: 583

PostPosted: Sun Apr 14, 2019 7:03 pm    Post subject: Plasma + Wine - Desktop icons for windows apps not working? Reply with quote

Pretty much as the title says, Native apps start fine from the desktop icon, but apps running from wine don't start the app. If I type out the full path name on a terminal though the app starts just fine. Any idea's why native apps start fine, but wine apps don't?
Back to top
View user's profile Send private message
duby2291
Guru
Guru


Joined: 17 Oct 2004
Posts: 583

PostPosted: Mon Apr 15, 2019 12:17 pm    Post subject: Reply with quote

Just an an update - I got Steam installed last night and it is displaying the same symptoms with native games and games played with Proton. Native games start just fine by simply clicking on them, but games started with Proton only start in a terminal.
Back to top
View user's profile Send private message
duby2291
Guru
Guru


Joined: 17 Oct 2004
Posts: 583

PostPosted: Mon Apr 15, 2019 4:14 pm    Post subject: Reply with quote

Here's another update - If I right-click on any .desktop file and select "Create Launcher on the Panel", it opens an error dialog (which won't allow me to highlight text in it, fucking retarded)....

"Failed to add a plugin to the panel - GDbus.Error:org.Freedesktop.DBus.Error.ServiceUnknown: The name Org.xfce.Panel was not provided by any.service files.

The thing is I'm not using xfce, I'm using plasma, but I must have installed some of xfce dependencies which is overriding Plasma dependencies maybe?
Back to top
View user's profile Send private message
duby2291
Guru
Guru


Joined: 17 Oct 2004
Posts: 583

PostPosted: Tue Apr 16, 2019 3:11 pm    Post subject: Reply with quote

So here's another update, I been puttsing around with use flags and rebuilding things and just playing around with getting my dependencies as low as possible. But this problem still persists. I have no clue at all why simply clicking on a .desktop file won't start a windows app running with wine. I'm stumped.

Anyway, I did find a sort of solution in the meantime. In Plasma, if I right click on a .desktop file and select Properties, it opens a dialog box with three tabs. Selecting the third tab called Application allows me to edit the Command field. which needs to be blanked out and replace with "wine /path/to/game/game.exe, and then the Work path field needs to be blanked out. Then double clicking on the .desktop file starts the windows app properly. I have no idea why the default configuration doesn't work, but a full path works fine.
Back to top
View user's profile Send private message
Chiitoo
Administrator
Administrator


Joined: 28 Feb 2010
Posts: 1801
Location: Here and Away Again

PostPosted: Wed Apr 17, 2019 4:42 pm    Post subject: ><)))°€ Reply with quote

Hm. Seems like I forgot to reply to this the first time I noticed it...

I would probably have suggested editing the paths, which you already have done, but what is it that the files have in them before editing it?

I might open one of them in a text editor, and copy the contents here.
_________________
Kind Regards,
~ The Noob Unlimited ~

Sore wa sore, kore wa kore.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum