Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Installare chromium [Risolto]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
aenigma
n00b
n00b


Joined: 02 Mar 2019
Posts: 66
Location: Roncaro (PV)

PostPosted: Fri Apr 12, 2019 8:23 am    Post subject: Installare chromium [Risolto] Reply with quote

Ciao a tutti, ho di nuovo bisogno d'aiuto (abbiate pazienza), ho cercato d'installare chromium e mi è venuto fuori questo:
Code:
davide@gentoo ~ $ su
Password:
gentoo /home/davide # emerge --ask chromium

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ~] net-libs/http-parser-2.9.1 [2.8.1]
[ebuild  N     ] sys-apps/baselayout-java-0.1.0
[ebuild     U ~] dev-libs/openssl-1.1.0j-r1 [1.0.2r] USE="-tls-heartbeat*"
[ebuild  N     ] dev-perl/TimeDate-2.300.0
[ebuild  N     ] virtual/perl-Digest-SHA-5.960.0
[ebuild  N     ] dev-perl/MailTools-2.190.0  USE="-examples -test"
[ebuild  N     ] dev-perl/Digest-HMAC-1.30.0-r1
[ebuild  N     ] dev-perl/Authen-SASL-2.160.0-r1  USE="-kerberos"
[ebuild  N     ] dev-perl/Error-0.170.250  USE="-test"
[ebuild  N    ~] dev-libs/libuv-1.27.0  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ~] net-dns/c-ares-1.15.0  USE="-static-libs" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] dev-util/gn-0.1463
[ebuild  N     ] media-libs/openh264-1.7.0-r1  USE="plugin -utils" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ~] net-libs/nghttp2-1.37.0  USE="cxx threads xml -debug -hpack-tools -jemalloc -libressl -static-libs -test -utils" ABI_X86="(64) -32 (-x32)"
[ebuild  N    ~] net-libs/nodejs-10.15.3  USE="icu inspector npm snapshot ssl -debug -doc -systemtap -test" CPU_FLAGS_X86="sse2" PYTHON_TARGETS="python2_7"
[ebuild  N     ] app-eselect/eselect-java-0.4.0
[ebuild  N     ] dev-vcs/git-2.21.0  USE="blksha1 curl gpg iconv nls pcre pcre-jit perl python threads webdav -cgi -cvs -doc -emacs -gnome-keyring -highlight -libressl -mediawiki -mediawiki-experimental (-ppcsha1) -subversion -test -tk -xinetd" PYTHON_TARGETS="python2_7"
[ebuild  N     ] dev-java/java-config-2.2.0-r4  USE="-test" PYTHON_TARGETS="python2_7 python3_6 -python3_5 (-python3_7)"
[ebuild  N     ] dev-java/icedtea-bin-3.10.0-r1  USE="alsa cups gtk pulseaudio webstart (-big-endian) -doc -examples -headless-awt -multilib -nsplugin (-selinux) -source" ABI_X86="(64) -32 (-x32)"
[ebuild  N     ] virtual/jdk-1.8.0-r3
[ebuild  N     ] dev-java/icedtea-sound-1.0.1  USE="doc -test"
[ebuild  N     ] virtual/jre-1.8.0-r1
[ebuild  N     ] dev-java/icedtea-web-1.6.2  USE="-doc -javascript -nsplugin -tagsoup -test"
[ebuild  N     ] www-client/chromium-73.0.3683.75  USE="closure-compile cups hangouts (pic) proprietary-codecs pulseaudio suid -component-build -custom-cflags -gnome-keyring -jumbo-build -kerberos (-neon) (-selinux) (-system-ffmpeg) (-system-icu) (-system-libvpx) (-tcmalloc) -widevine" L10N="it -am -ar -bg -bn -ca -cs -da -de -el -en-GB -es -es-419 -et -fa -fi -fil -fr -gu -he -hi -hr -hu -id -ja -kn -ko -lt -lv -ml -mr -ms -nb -nl -pl -pt-BR -pt-PT -ro -ru -sk -sl -sr -sv -sw -ta -te -th -tr -uk -vi -zh-CN -zh-TW"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

net-libs/http-parser:0

  (net-libs/http-parser-2.9.1:0/2.9.0::gentoo, ebuild scheduled for merge) pulled in by
    >=net-libs/http-parser-2.9.0:= required by (net-libs/nodejs-10.15.3:0/0::gentoo, ebuild scheduled for merge)
    ^^                     ^^^^^                                                                                                                                                         

  (net-libs/http-parser-2.8.1:0/2.8.0::gentoo, installed) pulled in by
    net-libs/http-parser:0/2.8.0= required by (dev-util/cargo-0.30.0-r1:0/0::gentoo, installed)
                        ^^^^^^^^^                                                                                                 


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by net-libs/nodejs-10.15.3::gentoo
# required by www-client/chromium-73.0.3683.75::gentoo
# required by chromium (argument)
=net-libs/http-parser-2.9.1 ~amd64
# required by net-libs/nodejs-10.15.3::gentoo
# required by www-client/chromium-73.0.3683.75::gentoo
# required by chromium (argument)
=net-libs/nghttp2-1.37.0 ~amd64
# required by net-libs/nodejs-10.15.3::gentoo
# required by www-client/chromium-73.0.3683.75::gentoo
# required by chromium (argument)
=net-dns/c-ares-1.15.0 ~amd64
# required by dev-qt/qtnetwork-5.11.3::gentoo[ssl]
# required by dev-qt/qtxmlpatterns-5.11.3::gentoo
# required by dev-qt/qtdeclarative-5.11.3::gentoo[xml]
# required by dev-qt/qtpositioning-5.11.3::gentoo[qml]
# required by kde-apps/marble-18.12.3::gentoo[geolocation]
# required by @selected
# required by @world (argument)
=dev-libs/openssl-1.1.0j-r1 ~amd64
# required by net-libs/nodejs-10.15.3::gentoo
# required by www-client/chromium-73.0.3683.75::gentoo
# required by chromium (argument)
=dev-libs/libuv-1.27.0 ~amd64

Would you like to add these changes to your config files? [Yes/No]

cosa dovrei fare? grazie in anticipo.
_________________
Gentoo MATE+LightDM+OpenRC


Last edited by aenigma on Sun Apr 14, 2019 6:39 am; edited 1 time in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22052
Location: here

PostPosted: Fri Apr 12, 2019 8:29 am    Post subject: Reply with quote

Mi spieghi perche' vuoi smascherare la versione 10.15.3 del pacchetto net-libs/nodejs?
Prova a rimuoverlo da /etc/portage/package.accept_keywords
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
aenigma
n00b
n00b


Joined: 02 Mar 2019
Posts: 66
Location: Roncaro (PV)

PostPosted: Sat Apr 13, 2019 6:41 pm    Post subject: Reply with quote

Grazie fedeliallalinea, dopo un lungo emerging ho installato chromium...ma guarda che non volevo smascherare nessuna versione di nessun pacchetto. Comunque grazie per l'aiuto.
_________________
Gentoo MATE+LightDM+OpenRC
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 22052
Location: here

PostPosted: Sat Apr 13, 2019 6:47 pm    Post subject: Reply with quote

aenigma wrote:
Grazie fedeliallalinea, dopo un lungo emerging ho installato chromium...ma guarda che non volevo smascherare nessuna versione di nessun pacchetto. Comunque grazie per l'aiuto.

Allora non capisco come mai ti sei ritrovato nodejs in package.accept_keywords
_________________
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
aenigma
n00b
n00b


Joined: 02 Mar 2019
Posts: 66
Location: Roncaro (PV)

PostPosted: Sun Apr 14, 2019 6:40 am    Post subject: Reply with quote

Sicuramente avrò combinato qualche pasticcio involontariamente. Alla prossima.
_________________
Gentoo MATE+LightDM+OpenRC
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum